Go Back   TechArena Community > Technical Support > Computer Help > Windows XP > Windows XP Support
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Network Printing Very Slow

Windows XP Support


Reply
 
Thread Tools Search this Thread
  #1  
Old 24-02-2008
Member
 
Join Date: Jan 2005
Posts: 20
Network Printing Very Slow

Hi,

I have 3 PCs at my small office running on Windows XP Home edition and are connected to a Network. I was using networked HP 2200 printer comfortably on all these PCs. Now as I had some ethernet cabling work, I connected HP as a local USB printer for temporary basis until the cabling work is done. Now it is finished and when I connect the HP 2200 printer, it takes about 15 to 20 minutes to print a page. However there is no problem accessing the web-based admin interface on the printer, I found svchost process in task manager eating up huge resources on the system.

Any idea what could be the issue? Thanks for your helps.

Reply With Quote
  #2  
Old 24-02-2008
Member
 
Join Date: Sep 2004
Posts: 74
First of all tell if the Printer is connected to your computerís USB port or the router? I am aksing this because to me it sounds like rest of computers on the network are getting the printer on your system instead of router/network. Alternatively it could be proxy problem. Better open Internet Explorer, Click Tools menu, Options, Connection tab, "Lan Settings" button.

Let me know what you saw there.
Reply With Quote
  #3  
Old 09-06-2010
Member
 
Join Date: Jun 2010
Posts: 2
A solution to extremely slow network printer problems

I have finally found a solution to extremely slow network printer problems which had me baffled for weeks. My network printers (Brother MFC-8890DW) had suddenly become excruciatingly slow to the point of almost unresponsive. It took a few minutes to 30 minutes to print any single page, if at all. I was also having the same problem at my office with some of the network printers (Brother MFC-8660DN and Brother MFC-8460N). Other network printers such as Xerox Phaser 8560 and Canon MP990 were not affected.

I had read everything on the internet and tried all of them without success. Finally, I took my laptop and the printer to a neighbor and plugged in both to his network to see if the network would make any difference. Sure enough, IT DID! It was working just fine spitting out pages promptly at high speed. I noticed that he was using an older D-Link router while I was running a D-Link DIR-655. I came home and started going through router settings to turn off all optional settings one at a time while checking to see if the printer would respond by sending a test page after each change in the router settings.

When I finally got to Advanced DNS Service (Optional, under internet settings) and turned it OFF, my network printer suddenly started working perfectly!!!

I then started turning on other router settings which I turned off earlier, again testing the printer after each change. In my case, Advanced DNS Service was the only service I needed to turn off. All other optional features such as QoS Engine, SPI (stateful packet inspection, in the firewall settings), Anti-Spoof checking, and UPnP did not block the printer even when they were all turned ON.

If you have exhausted all other options, you might want to take a deeper look into your router settings.
Reply With Quote
  #4  
Old 03-04-2011
Member
 
Join Date: Apr 2011
Posts: 1
Re: A solution to extremely slow network printer problems

Now THAT's the solution I was seeking to solve my print jobs taking 2-3 mins to start on my routered network printer!! Thank you so much. In my Linksys/Cisco router, I didn't have that specific "Advanced DNS" option. But I could solve that block using the "Port Routing" service to forward the SNMP port (printers status's protocol), and IT WORKED!! My new print jobs suddenly went instantly from the computer to the printer and started right away.

Just to help you guys seeking help: the spooler was indicating a print job was uploaded 126Kb/525Kb and always kept stuck there for 2-3 minutes before completing rapidly right after. If you have that same problem, it's that device management protocol, the SNMP, being slowed down by the router. It usually passes thourgh port 161 and tells the computer it's "Ready" or "Warming" or "Printing". Since it's blocked, symptoms are your network printer won't update it's status quickly when you turn it on, or off, or when it's still warming up.

Printer: Xerox Tektronix Phaser 740, plugged into router via RJ-45 cable.

Thanks a LOT, blueglacia!!
Reply With Quote
  #5  
Old 07-12-2011
Member
 
Join Date: Dec 2011
Posts: 1
Re: Network Printing Very Slow

Slow Network Printing -- Answer

While there are a number of equipment & network tweeks that will seemingly "solve" this problem, a large majority of these incidents are caused by one simple error.

If you have some device on your network that is acting as the DHCP server and this device has a range of IP addresses that it assigns, make sure that your print server has not been MANUALLY assigned an IP address in that range.

Either set the printer server to automatically receive an IP address or MANUALLY assign an IP address outside the DHCP servers assigned range.
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows XP > Windows XP Support
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Network Printing Very Slow"
Thread Thread Starter Forum Replies Last Post
Very Slow printing my network printer Sahkari Vista Help 2 09-06-2010 09:54 AM
Printing very slow with Samba Amy Adams Networking & Security 4 22-04-2010 01:32 PM
Slow Printing Response on Network - Vista to XP - Please Help Amitgujaran Windows Vista Network 4 26-10-2009 04:25 PM
Slow printing with Word 2007 Daley Windows Software 3 25-02-2009 01:41 PM
Vista Business - extremely SLOW printing on network printer axjul Vista Help 7 27-01-2008 08:41 PM


All times are GMT +5.5. The time now is 10:58 AM.