Go Back   TechArena Community > Technical Support > Computer Help > Windows XP > Windows XP Support
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Safely Remove Hardware problem in Windows XP

Windows XP Support


Reply
 
Thread Tools Search this Thread
  #1  
Old 26-01-2008
Member
 
Join Date: Jan 2008
Posts: 1
Safely Remove Hardware problem in Windows XP

I am having a problem with the Safely Remove Hardware applet in Windows XP. It cannot stop any USB device I connect to my PC. Whether it be a Flash Drive, my Firefly portable hard drive or my WD My Book external hard drive. It always says the device cannot be stopped. I can restart the PC and try stopping the device again and it still says the device cannot be stopped.

I have also tried using a similar application called USB Safely Remove and it does the same thing. This app is supposed to display any processes that may have the device locked, but it always says none were found. It is clearly an issue with Windows XP and not the applications. Also, I have tried these devices on other Windows XP machines and have no problems on them.

Any advice/suggestions?

Reply With Quote
  #2  
Old 26-01-2008
Member
 
Join Date: Sep 2004
Posts: 65
Re: Safely Remove Hardware problem in Windows XP

Hello mad3963.

You should try Restarting the Explorer shell and then try to remove the USB Device
Reply With Quote
  #3  
Old 22-10-2009
Member
 
Join Date: Oct 2009
Posts: 1
Re: Safely Remove Hardware problem in Windows XP

some tricks:

Right-click the notification area, and select Properties.
Under the Notification area heading on Taskbar tab, check Hide inactive icons, then click Customize button.
Find and select Safely Remove Hardware icon and select Always show
in the dropdown below the Behavior column next to it.
Click OK and Apply.
Uncheck Hide inactive icons.

start->run->cmd, then use this command inside it:
%SystemRoot%\System32\RUNDLL32.EXE shell32.dll,Control_RunDLL
this will bring up the (safely) remove hardware dialog (the one taht appears when you right click on the icon in tray and choose the only voice <<remove hardware>>there in the popup. You coukd also create a shortcut with this command to keep on the desktop...

Do you have an USB Printer (or similar device)? Seems as if it can be part of the matter:
Quote:
I have now determined that this problem on my system is related to my HP Printer which uses the USP port. After unplugging it and 2 reboots the “Safely Remove Hardware” icon appears and stays, as long as a USB device is plugged in. Once I plug my printer back up the problem starts again. Yes, I have downloaded the latest device driver from HP and it has not helped.
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows XP > Windows XP Support
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Safely Remove Hardware problem in Windows XP"
Thread Thread Starter Forum Replies Last Post
Unable to remove internal devices from safely remove hardware list? LaMarcus Hardware Peripherals 4 11-09-2011 10:18 AM
How to remove External Drive from computer if 'Safely Remove Hardware' disappears Author Operating Systems 1 13-04-2011 06:24 PM
'safely remove hardware' - in camera ? Emo Hardware Peripherals 3 25-10-2008 03:09 PM
Problem with Safely Remove Hardware feature Vicious Windows XP Support 5 15-06-2008 05:59 PM
Remove item from Safely Remove Hardware using registry? Pine Le XP Hardware 2 18-01-2007 11:07 PM


All times are GMT +5.5. The time now is 05:58 AM.