Go Back   TechArena Community > Technical Support > Computer Help > Windows XP > Windows XP Support
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



GS wavetable synth broken?

Windows XP Support


Reply
 
Thread Tools Search this Thread
  #1  
Old 20-10-2007
Alex P
 
Posts: n/a
GS wavetable synth broken?

I have a Dell XPS 410, XP MCE 2005 with Sigmatel 9227 onboard audio, and the
only MIDI option is GS Wavetable synth. I start playing a midi file, either
through Media Player or in a game, and it's fine for a while, but if I stop
the player or exit the game, then try to replay the file, I get no midi
sound, though it still appears to be playing (slider moves).

1) I have no trouble with any other audio format - .wma, .mp3, .wav, etc.
2) Nothing is muted - I know all about the sw synth "self muting" problem.
When midi is playing I can mute or adjust the synth volume with no problem.
3) DxDiag Music test plays fine using the Microsoft Synthesizer, but Midi
Mapper and Wavetable synth produce no sound - but there is no error. All
other DXDiag tests pass fine.
4) Removed ALL audio drivers in safe mode, rebooted, everything reinstalled
fine - no change; I have all the latest Sigmatel drivers.
5) If I restore the pc to a point when midi was working, it says it can't
restore because there was no change, but I always get the midi back anyway -
at least for a while. Sometimes a simple reboot works, sometimes not.
6) I can play midis fine using QuickTime's built-in synthesizer. I also
found an old file with a .mid extension that plays just fine, but it turns
out it was using an old legacy codec (Fraunhofer, I think), so it wasn't
routed through the wavetable.
7) SFC /scannow sourced from the install CD didn't help, so I've apparently
got all the files I'm supposed to.

Basically, I have 3 questions:

1) Is there anything besides the wavetable synth that can cause this problem?
2) If it is the wavetable synth, is it fixable without a repair install (or
with a repair install, for that matter)? Which specific files/drivers should
I be checking for?
3) Any clue as to what could be "breaking" the synth sound output? If I
leave the midi playing in the background it'll play all day - only stopping
and restarting is a problem.

Of course the easy answer is to get a new sound card or a new soft synth,
but it's become a matter of principle, now...



Reply With Quote
  #2  
Old 20-10-2007
theplectrum
 
Posts: n/a
Re: GS wavetable synth broken?


"Alex P" <Alex P@discussions.microsoft.com> wrote in message
news:8B8C296B-4A90-4C96-88AC-F5A9E3DD183B@microsoft.com...
>I have a Dell XPS 410, XP MCE 2005 with Sigmatel 9227 onboard audio, and
>the
> only MIDI option is GS Wavetable synth. I start playing a midi file,
> either
> through Media Player or in a game, and it's fine for a while, but if I
> stop
> the player or exit the game, then try to replay the file, I get no midi
> sound, though it still appears to be playing (slider moves).
>
> 1) I have no trouble with any other audio format - .wma, .mp3, .wav, etc.
> 2) Nothing is muted - I know all about the sw synth "self muting"
> problem.
> When midi is playing I can mute or adjust the synth volume with no
> problem.
> 3) DxDiag Music test plays fine using the Microsoft Synthesizer, but Midi
> Mapper and Wavetable synth produce no sound - but there is no error. All
> other DXDiag tests pass fine.
> 4) Removed ALL audio drivers in safe mode, rebooted, everything
> reinstalled
> fine - no change; I have all the latest Sigmatel drivers.
> 5) If I restore the pc to a point when midi was working, it says it can't
> restore because there was no change, but I always get the midi back
> anyway -
> at least for a while. Sometimes a simple reboot works, sometimes not.
> 6) I can play midis fine using QuickTime's built-in synthesizer. I also
> found an old file with a .mid extension that plays just fine, but it turns
> out it was using an old legacy codec (Fraunhofer, I think), so it wasn't
> routed through the wavetable.
> 7) SFC /scannow sourced from the install CD didn't help, so I've
> apparently
> got all the files I'm supposed to.
>
> Basically, I have 3 questions:
>
> 1) Is there anything besides the wavetable synth that can cause this
> problem?
> 2) If it is the wavetable synth, is it fixable without a repair install
> (or
> with a repair install, for that matter)? Which specific files/drivers
> should
> I be checking for?
> 3) Any clue as to what could be "breaking" the synth sound output? If I
> leave the midi playing in the background it'll play all day - only
> stopping
> and restarting is a problem.
>
> Of course the easy answer is to get a new sound card or a new soft synth,
> but it's become a matter of principle, now...
>
>
>


Corruption ?

Try replacing the Midi Mapper file and the GS Synth file from your XP
installation disk.

Cheers,
Jerry


Reply With Quote
  #3  
Old 20-10-2007
Chris Laarman
 
Posts: n/a
Re: GS wavetable synth broken?

Alex P (Alex P@discussions.microsoft.com) in
8B8C296B-4A90-4C96-88AC-F5A9E3DD183B@microsoft.com:

> I have a Dell XPS 410, XP MCE 2005 with Sigmatel 9227 onboard audio,
> and the only MIDI option is GS Wavetable synth. I start playing a
> midi file, either through Media Player or in a game, and it's fine
> for a while, but if I stop the player or exit the game, then try to
> replay the file, I get no midi sound, though it still appears to be
> playing (slider moves).
>
> 1) I have no trouble with any other audio format - .wma, .mp3, .wav,
> etc. 2) Nothing is muted - I know all about the sw synth "self
> muting" problem. When midi is playing I can mute or adjust the synth
> volume with no problem. 3) DxDiag Music test plays fine using the
> Microsoft Synthesizer, but Midi Mapper and Wavetable synth produce no
> sound - but there is no error. All other DXDiag tests pass fine.
> 4) Removed ALL audio drivers in safe mode, rebooted, everything
> reinstalled fine - no change; I have all the latest Sigmatel drivers.
> 5) If I restore the pc to a point when midi was working, it says it
> can't restore because there was no change, but I always get the midi
> back anyway - at least for a while. Sometimes a simple reboot works,
> sometimes not. 6) I can play midis fine using QuickTime's built-in
> synthesizer. I also found an old file with a .mid extension that
> plays just fine, but it turns out it was using an old legacy codec
> (Fraunhofer, I think), so it wasn't routed through the wavetable.
> 7) SFC /scannow sourced from the install CD didn't help, so I've
> apparently got all the files I'm supposed to.
>
> Basically, I have 3 questions:
>
> 1) Is there anything besides the wavetable synth that can cause this
> problem? 2) If it is the wavetable synth, is it fixable without a
> repair install (or with a repair install, for that matter)? Which
> specific files/drivers should I be checking for?
> 3) Any clue as to what could be "breaking" the synth sound output?
> If I leave the midi playing in the background it'll play all day -
> only stopping and restarting is a problem.
>
> Of course the easy answer is to get a new sound card or a new soft
> synth, but it's become a matter of principle, now...


I get the impression, that the problem has to do with the stopping: that
somehow the intended "full stop" is only a "pause", leaving both the MIDI
device and the MIDI file in use.

Jerry ("theplectrum") may be right in suggesting corrupted files. But I
would think of corrupted settings rather than corrupted files. Otherwise you
wouldn't be able to play the file again correctly.
But reinstalling may be a way to correct those settings (whatever they are).

Checking and correcting could be done by firstly performing a disk check
(with error fixing, can be done inside Windows, but requires a reboot), and
secondly a Registry check (using a third-party utility).

Just in case: the GS Wavetable is: <C:\Windows\system32\drivers\gm.dls>.

I would almost exclude the sound card from suspection. If it can accept
digital sound from a WAV file or from the output of a software synthesizer,
then it works properly (in this respect).

A workaround and comparison would be the use of another software
synthesizer, like http://www.synthfont.com/, but there are catches in using
such as the default MIDI device.

--
Chris Laarman


Reply With Quote
  #4  
Old 20-10-2007
Michael Bednarek
 
Posts: n/a
Re: GS wavetable synth broken?

On Sat, 20 Oct 2007 13:49:51 +0200, Chris Laarman wrote in
microsoft.public.windowsxp.music:

[snip]
>Just in case: the GS Wavetable is: <C:\Windows\system32\drivers\gm.dls>.


Just out of curiosity: have you tried a different DLS file?

PS: You need to manipulate the registry value at
HKLM\SOFTWARE\Microsoft\DirectMusic\GMFilePath (REG_EXPAND_SZ)
to tell Windows which DLS file you want to use; no reboot necessary
between changes, just stop/start the MIDI player.

--
Michael Bednarek http://mbednarek.com/ "POST NO BILLS"
Reply With Quote
  #5  
Old 21-10-2007
Alex P
 
Posts: n/a
RE: GS wavetable synth broken?

Wow! Thanks to all you guys for your tips. The easy ones (chkdsk, registry
check) haven't panned out, but I'm working through it.

This is a pretty slow process, since the midi keeps coming back and behaves
itself for a good while, so when (if) I get it nailed down I'll post back on
what it was. Plus I'm a recovering Win98 user, so I've got to get up to
speed on file protection and XP drivers etc. etc...

Thanks again..

Alex

PS RANT: Am I the only poor old geezer who's stuck between the Grand Theft
Auto 7.1 channel cd audio surround sound crowd and the professional midi
musician $300 sequencer crowd? Shoot, I just wanna indulge my Sierra and
Lemmings addictions....
Reply With Quote
  #6  
Old 24-10-2007
Alex P
 
Posts: n/a
RE: GS wavetable synth broken?

I think I've found the enemy, and it is I.

I installed AVG Free antivirus last month as a strictly manual backup scan
for the real-time PC-Cillin antivirus/firewall. Knowing the potential for
conflicts, I had the sense to disable AVG real-time protection and automatic
updates, and thought I made sure it wasn't in startup or running anything as
a service. Disabled or not, something was going on in there. Heaven knows
why MIDI output was the only obvious problem with this setup.

It's been uninstalled for 2 days and I've had 0 midi problems. I
reinstalled it once just for giggles and sure enough, midi was gone again.

I've learned my lesson - always check EVERYTHING that's changed, no matter
how unlikely it seems. And maybe 2 antiviruses can't get along no matter how
you set it up.

I ordered a new PCI sound card with onboard midi - just in case I'm still
wrong.

Thanks for the help, everyone - I tried most everything suggested and ended
up learning a whole lot.

Reply With Quote
  #7  
Old 24-10-2007
Chris Laarman
 
Posts: n/a
Re: GS wavetable synth broken?

Alex P (AlexP@discussions.microsoft.com) in
B2C83ED0-2CD7-47B7-A3B1-0B76FBE60E2E@microsoft.com:

> I've learned my lesson - always check EVERYTHING that's changed, no
> matter how unlikely it seems. And maybe 2 antiviruses can't get along
> no matter how you set it up.
>
> I ordered a new PCI sound card with onboard midi - just in case I'm
> still wrong.
>
> Thanks for the help, everyone - I tried most everything suggested and
> ended up learning a whole lot.


Thanks for the feedback. Yes, strange things can happen.

(I have had trouble using certain anti-virus sofware and navigating a
certain music-related web site. I have had to delete some shared DLL file in
order to get an installer to work.)

--
Chris Laarman


Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows XP > Windows XP Support
Tags: , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "GS wavetable synth broken?"
Thread Thread Starter Forum Replies Last Post
Why CPU Fan is always broken Bordoloi Hardware Peripherals 4 23-09-2011 10:40 AM
X-Fi Midi Synth Reverb and Chorus Controller not working properly Rahul Mahajan Hardware Peripherals 7 23-04-2011 10:41 PM
Disabling MS GS Wavetable Synth from Windows Gajananvihari Operating Systems 7 24-01-2011 07:40 AM
Alternative To Microsoft GS Wavetable Synth MIDI Generator for 64 bit machine pexo Windows Software 5 28-12-2010 10:15 PM
Microsoft Kernel GS Wavetable Synthesizer ShockTherapy Windows XP Support 1 21-03-2009 04:28 PM


All times are GMT +5.5. The time now is 12:42 PM.