Go Back   TechArena Community > Technical Support > Computer Help > Windows XP > Windows XP Support
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Cannot start SSDP or UPNP

Windows XP Support


Reply
 
Thread Tools Search this Thread
  #1  
Old 05-07-2007
SteveL
 
Posts: n/a
Cannot start SSDP or UPNP

Hello,

I want to enable Universal Plu and Play so I can use some upload software
that came with my new

Canon A710IS digital camera.

Going into services.msf,I cannot start Univeral Plug and Play. Because it
depends on SSDP.

SSDP Discovery Service is disabled, and when I set it to manual or Auto I
get an Access is Denied

Error Message.

Event Manager shows this message:
Event ID 7006: The ScRegSetValueExW call failed for Start with the following
error:
Access is denied.

Microsoft Help Center displays this:

Explanation
The service controller could not set a registry entry's value for a function
that it requires for

operation.

Can anyone suggest a resolution? Thanks in advance.

Reply With Quote
  #2  
Old 05-07-2007
Mark L. Ferguson
 
Posts: n/a
RE: Cannot start SSDP or UPNP

Aaron Stebner's WebLog Solving setup errors by using the SubInACL tool to
repair file and registry permissions:
http://blogs.msdn.com/astebner/archi...04/739820.aspx
--
Was this post helpful to you? Then click the "Yes" button, below.
Voting helps others who use the web interface.
Mark L. Ferguson



"SteveL" wrote:

> Hello,
>
> I want to enable Universal Plu and Play so I can use some upload software
> that came with my new
>
> Canon A710IS digital camera.
>
> Going into services.msf,I cannot start Univeral Plug and Play. Because it
> depends on SSDP.
>
> SSDP Discovery Service is disabled, and when I set it to manual or Auto I
> get an Access is Denied
>
> Error Message.
>
> Event Manager shows this message:
> Event ID 7006: The ScRegSetValueExW call failed for Start with the following
> error:
> Access is denied.
>
> Microsoft Help Center displays this:
>
> Explanation
> The service controller could not set a registry entry's value for a function
> that it requires for
>
> operation.
>
> Can anyone suggest a resolution? Thanks in advance.

Reply With Quote
  #3  
Old 06-07-2007
SteveL
 
Posts: n/a
RE: Cannot start SSDP or UPNP

Mark,

For the most part, your uggestion worked - I can now use my Canon software.

I followed the instructions for the SUBINACL tool and pasted in the
reset.cmd file and ran it. It took several minutes - was at line 85,500 when
I left and came back later it was done.

First, I still could not change SSDP from DISABLE. Nor could I start UPNP.
Then I tried to set the log in tab on SSDP from "this account" to local
system account and it hung up the machine.

I had to power off and reboot and tried to change the SSDP service again and
still got "Access is Denied". I tried again to change to log on andit hung
again.

I rebooted again and this time to my surprise SSDP was running, already set
to Automatic.

I could not start UPNP, this time getting this error message:
Error 1079 the account specified for this service is different fom the
account specified for other services rnning in the same process.

The event log show this: Eventid 7000
The Universal Plug and Play Device Host service failed to start due to the
following error:
The account specified for this service is different from the account
specified for other services running in the same process.

But I tried my Digital Camera upload anyway, and this time it DID work!

So I am deeply greatful for your help, tough I still don't understand why I
cannot start the uPNP service. The logon for UPNP is local system account. If
I change it to be NT AUTHORITY\LocalService I have no idea what to enter for
the password.

Thanks for any addtl help you can provide.

- Steve


Reply With Quote
  #4  
Old 06-07-2007
WTC
 
Posts: n/a
Re: Cannot start SSDP or UPNP

SteveL wrote:

> Hello,
>
> I want to enable Universal Plu and Play so I can use some upload
> software that came with my new
>
> Canon A710IS digital camera.
>
> Going into services.msf,I cannot start Univeral Plug and Play.
> Because it depends on SSDP.
>
> SSDP Discovery Service is disabled, and when I set it to manual or
> Auto I get an Access is Denied
>
> Error Message.
>
> Event Manager shows this message:
> Event ID 7006: The ScRegSetValueExW call failed for Start with the
> following error:
> Access is denied.


Hi SteveL,

Have you ever tried to Start the SSDP Discovery Service before?

Anyways, take a look at this KB article:

Some services may not start when you upgrade a computer to Windows XP
Service Pack 2 or to Windows Server 2003 Service Pack 1
http://support.microsoft.com/kb/926078


--
William Crawford
MS-MVP Windows Shell/User
Reply With Quote
  #5  
Old 06-07-2007
SteveL
 
Posts: n/a
RE: Cannot start SSDP or UPNP



"SteveL" wrote:

> Mark,
>
> For the most part, your uggestion worked - I can now use my Canon software.
>
> I followed the instructions for the SUBINACL tool and pasted in the
> reset.cmd file and ran it. It took several minutes - was at line 85,500 when
> I left and came back later it was done.
>
> First, I still could not change SSDP from DISABLE. Nor could I start UPNP.
> Then I tried to set the log in tab on SSDP from "this account" to local
> system account and it hung up the machine.
>
> I had to power off and reboot and tried to change the SSDP service again and
> still got "Access is Denied". I tried again to change to log on andit hung
> again.
>
> I rebooted again and this time to my surprise SSDP was running, already set
> to Automatic.
>
> I could not start UPNP, this time getting this error message:
> Error 1079 the account specified for this service is different fom the
> account specified for other services rnning in the same process.
>
> The event log show this: Eventid 7000
> The Universal Plug and Play Device Host service failed to start due to the
> following error:
> The account specified for this service is different from the account
> specified for other services running in the same process.
>
> But I tried my Digital Camera upload anyway, and this time it DID work!
>
> So I am deeply greatful for your help, tough I still don't understand why I
> cannot start the uPNP service. The logon for UPNP is local system account. If
> I change it to be NT AUTHORITY\LocalService I have no idea what to enter for
> the password.
>
> Thanks for any addtl help you can provide.
>
> - Steve
>
> FURTHER UPDATE - I now get the BSOD on NV4_DISP on bootup

am in safe mode now getting new navidia drivers
Reply With Quote
  #6  
Old 06-07-2007
Mark L. Ferguson
 
Posts: n/a
Re: Cannot start SSDP or UPNP

All of these problems seem to point at hard disk corruption. I suggest doing
"Error Checking" and then Defragmentation.

(Rightclick the drive icon, Properties, tools menu, error check.,
after restart, defrag is on start/.../system tools)

--
Mark L. Ferguson
e-mail subject line must include "QZ" or it's deleted
..
"SteveL" <SteveL@discussions.microsoft.com> wrote in message
news:BAC5E2BC-C8E1-4080-A36F-755CDC1D5173@microsoft.com...
>>
>> FURTHER UPDATE - I now get the BSOD on NV4_DISP on bootup

> am in safe mode now getting new navidia drivers



Reply With Quote
  #7  
Old 10-07-2007
SteveL
 
Posts: n/a
Re: Cannot start SSDP or UPNP



"Mark L. Ferguson" wrote:

> All of these problems seem to point at hard disk corruption. I suggest doing
> "Error Checking" and then Defragmentation.
>
> (Rightclick the drive icon, Properties, tools menu, error check.,
> after restart, defrag is on start/.../system tools)
>
> --
> Mark L. Ferguson
> e-mail subject line must include "QZ" or it's deleted
> ..
> "SteveL" <SteveL@discussions.microsoft.com> wrote in message
> news:BAC5E2BC-C8E1-4080-A36F-755CDC1D5173@microsoft.com...
> >>
> >> FURTHER UPDATE - I now get the BSOD on NV4_DISP on bootup

> > am in safe mode now getting new navidia drivers

>
>
> I have gone back to 2005 versions of NVIDIA drivers and now my system appears to be stable. Thanks for your help

Reply With Quote
  #8  
Old 10-07-2007
SteveL
 
Posts: n/a
Re: Cannot start SSDP or UPNP



"WTC" wrote:

> SteveL wrote:
>
> > Hello,
> >
> > I want to enable Universal Plu and Play so I can use some upload
> > software that came with my new
> >
> > Canon A710IS digital camera.
> >
> > Going into services.msf,I cannot start Univeral Plug and Play.
> > Because it depends on SSDP.
> >
> > SSDP Discovery Service is disabled, and when I set it to manual or
> > Auto I get an Access is Denied
> >
> > Error Message.
> >
> > Event Manager shows this message:
> > Event ID 7006: The ScRegSetValueExW call failed for Start with the
> > following error:
> > Access is denied.

>
> Hi SteveL,
>
> Have you ever tried to Start the SSDP Discovery Service before?
>
> Anyways, take a look at this KB article:
>
> Some services may not start when you upgrade a computer to Windows XP
> Service Pack 2 or to Windows Server 2003 Service Pack 1
> http://support.microsoft.com/kb/926078
>
>
> --
> William Crawford
> MS-MVP Windows Shell/User
> Thanks for the info, William. By the time I read your post I had already gotten past my orig problem and then into video driver BSOD problems, so I did not actually try to implement the solution you provided, but thanks for posting it - I may need it at some future point.


Steve

Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows XP > Windows XP Support
Tags: ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Cannot start SSDP or UPNP"
Thread Thread Starter Forum Replies Last Post
Hamachi v2.0.3.89 breaks UPnP on Windows 7 64bit start up servan$ Windows Software 3 15-03-2012 04:41 PM
How to use UPnP? HeerePanna Operating Systems 5 26-09-2010 06:30 AM
How to activate the upnp on router? Corinne Networking & Security 4 02-02-2010 09:06 PM
About port forwarding and UPnP Arlo1 Windows XP Support 1 02-01-2009 11:17 AM
UPNP Client for MCP Bloom MediaCenter 1 29-12-2007 08:49 AM


All times are GMT +5.5. The time now is 07:36 AM.