Results 1 to 3 of 3

Thread: MTP driver file missing

  1. #1
    Join Date
    Nov 2005
    Posts
    12

    MTP driver file missing

    Iím having a Windows XP desktop running with Service Pack 2. I also have a Creative Zen Vision M 30GB. My creative zen use to work fine with this computer since years, there was no problem in the connectivity. Last week I required to connect a flatbed scanner with this computer. This was the first time I connected it with my system. I think somehow it broke my Zen connectivity. Since then whenever I plug in Creative Zen, I see a notification in the system tray saying a new hardware found (like this is the first time I connected the device on this pc). But it wont show the device anywhere on the system.

    When I went to device manager I found a Yellow Mark infront of Zen is listed under portable devices. When I double click the same and go into its properties, it says "Reinstall the drivers for this device. (Code 18)To reinstall the drivers for this device, click Reinstall Driver." But as soon as I click the re-install option, I get the following error message:

    "An error occurred during the installation of the device. The system cannot find the file specified."

    Somebody please help me to get the problem fixed.

  2. #2
    Join Date
    Sep 2004
    Posts
    60
    Hello subhaash, i think before you should try anything else, better check out the following MSDN article:http://msdn2.microsoft.com/en-us/win.../bb190309.aspx

    For anyone who has this problem, there is a file located at: The file is called "fixup.zip". It evidently repairs whatever the problem is with the MTP drivers, and windows now recognizes my device.

  3. #3
    Join Date
    Apr 2009
    Posts
    1

    Re: MTP driver file missing

    Hello,
    I am also having trouble with my Zen Vision:M 30Gb. I tried to upgrade the firmware after receiving it as a replacement for a faulty unit from Creative (why do they not ensure their firmware is current???). Anyway, it erased the old firmware just fine but now does not recognise the device while attempting to use the recovery tool. I tried the direct firmware download but it failed to detect teh device too.

    At first my PC would recognise it fine but after following some of the "advice" given in the forums I have found that the device is no longer recognised. More worrying is a message I get saying that the hardware is faulty. I am trying to find "fixup.zip" but the only forum that seems to have it is down. Can anyone help?

Similar Threads

  1. Replies: 1
    Last Post: 21-03-2013, 03:52 PM
  2. LG-X130 missing driver
    By pATROCLUS in forum Portable Devices
    Replies: 6
    Last Post: 11-09-2010, 01:23 AM
  3. CD/DVD Driver missing
    By kush.impetus in forum Operating Systems
    Replies: 1
    Last Post: 26-07-2010, 01:05 PM
  4. Replies: 3
    Last Post: 03-02-2009, 03:58 PM
  5. system32 file missing how to locate this file?
    By John Joseph in forum Operating Systems
    Replies: 2
    Last Post: 01-08-2008, 07:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •