Go Back   TechArena Community > Technical Support > Computer Help > Windows XP > Windows XP Support
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Windows Management Instrumentation service problem

Windows XP Support


Reply
 
Thread Tools Search this Thread
  #1  
Old 11-02-2007
Member
 
Join Date: Oct 2004
Posts: 23
Windows Management Instrumentation service problem

I have a desktop computer running with Windows XP SP2. Everything is working fine except it seems which was also working great until two weeks ago when I ran Automatic Updates. Since then my desktop theme gets changes to Classic Mode automatically. No matter how many times I change it to XP manual theme; it gets switched to Classic mode after few minutes.

When I checked the Event Viewer, this is what found listed over there:
Quote:
Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7032
Date: 2/10/2007
Time: 9:47:17 PM
User: N/A
Computer: RUDI
Description:
The Service Control Manager tried to take a corrective action (Restart the service) after the unexpected termination of the Windows Management Instrumentation service, but this action failed with the following error: An instance of the service is already running.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Does anyone have come across this problem ever? Is there any fix for the same? Many Thanks.

Reply With Quote
  #2  
Old 12-02-2007
Member
 
Join Date: Jun 2006
Posts: 206
Re: Windows Management Instrumentation service problem

Windows Classic Theme doesn?t requires any related service to be running to make it work fine whereas on the other hand rest all XP theme needs a service running called ?Theme service?. Hence I guess the service is disabled which is automatically switching the theme to classic. Hence you should first check if the theme service running fine.
  • Go to Start > RUN > type ?services.msc? > Enter
  • In the services applet, scroll down and look for ?Theme? service.
  • Click the V next to Startup type and set it to Automatic.
  • Click Apply and exit.

Hope that helps. If still you face the problem then just try running these .reg file to fix the registry conflicts that might be causing the problem:

Windows XP Style Changes to Windows Classic
Restore Themes Functionality
Restore Luna Theme
Restore Classic Theme

Hopefully, your problem should be solved.
Reply With Quote
  #3  
Old 13-02-2007
Member
 
Join Date: Oct 2004
Posts: 23
Re: Windows Management Instrumentation service problem

Thank you very much for the help friend, i have all those things but still the same response. Also my Theme services was already running but still the problem appears. Though when i change the theme to something else, it remains there for few minutes and later gets changed to classic and when this happens it also kills my sound. I cannot hear any sound until classic theme is applied. According to the Event Viewer, problem is somewhere with WMI service. Some thing is killing the Theme service.

What now?
Reply With Quote
  #4  
Old 13-02-2007
Member
 
Join Date: Sep 2004
Posts: 69
Re: Windows Management Instrumentation service problem

Just Check out the following MS KB describing the same problem with solution.

Event Source: Service Control Manager
Event ID: 7032
The Svchost.exe process may end unexpectedly on a Windows Server 2003-based computer
http://support.microsoft.com/kb/910666

Though it is for Windows Server but could be applied for Windows XP as well.
Reply With Quote
  #5  
Old 23-01-2008
Member
 
Join Date: Jan 2008
Posts: 1
Same problem

Anyone still out there? I'm having the identical problem. I have tried all of the suggestions listed on the page in terms of registry installation from #187 and #214. Now my screen has a bluish hue to it. Any suggestions?
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows XP > Windows XP Support
Tags: ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Windows Management Instrumentation service problem"
Thread Thread Starter Forum Replies Last Post
Electronics And Instrumentation Diploma sinaskdlr Education Career and Job Discussions 1 14-06-2011 12:16 AM
Problem of lag due to the wireless management utility for Windows 7 Degrader Networking & Security 4 28-12-2010 07:33 PM
How to use Management service of Windows Bansi_WADIA Windows Software 5 07-01-2010 05:34 AM
Publishing Key Management Service (KMS) to DMS Lee Jefferies Windows Server Help 8 30-07-2008 05:12 PM
Windows Management Instrumentation can't be started CHRITOPHER Windows XP Support 2 27-03-2008 11:47 AM


All times are GMT +5.5. The time now is 04:26 PM.