Results 1 to 8 of 8

Thread: age of empires 2 tcp/ip multiplayer problem

  1. #1
    guntek Guest

    age of empires 2 tcp/ip multiplayer problem

    My friend and I have aoe2 on winxp pro machines. I have a westell 327 router
    and he has a D-Link DSL router. We have forwarded the correct ports. He can
    see my game when I create one but gets dropped when he tries to join the
    game. I cannot see any games he creates when I try to join his games.
    Firewalls are off on both winxp and routers. Any ideas.

  2. #2
    Jimmy S. Guest

    Re: age of empires 2 tcp/ip multiplayer problem

    Hi guntek,

    First step in troubleshooting your connectivity issue is to elimate
    both routers from the equation and see if you're able to connect.

    --
    Cheers, *Windows_XP_MVP_Shell/User*
    Jimmy S. http://mvp.support.microsoft.com

    Visit my MSN Zone.com and Gaming Help Site: http://mvps.org/nibblesnbits
    MS Games Help and Support Center: http://support.microsoft.com/?pr=gms
    My advice is donated "AS IS" without warranty; nor do I confer any rights.
    _________________________________________________________

    guntek Wrote:
    =================
    | My friend and I have aoe2 on winxp pro machines. I have a westell 327 router
    | and he has a D-Link DSL router. We have forwarded the correct ports. He can
    | see my game when I create one but gets dropped when he tries to join the
    | game. I cannot see any games he creates when I try to join his games.
    | Firewalls are off on both winxp and routers. Any ideas.



  3. #3
    guntek Guest

    Re: age of empires 2 tcp/ip multiplayer problem

    Hi Jimmy,
    I setup DMZ in both of them.
    This is what happens when I ran tcpview.exe (to view ports on machine).
    1) I host the game.
    2) Friend looks for game using my IP.
    3) Friend can see the game.
    4) I can see friends connection on port.
    5) Then friend tries to join the game
    6) then from tcpview.exe the connection is dropped.
    we cannot get past this point.

    the same thing happens when DMZ is enabled or disabled with port forwarding
    (all the required ports are open and forwarded).

  4. #4
    guntek Guest

    Re: age of empires 2 tcp/ip multiplayer problem

    Hi Jimmy,
    I setup DMZ in both of them.
    This is what happens when I ran tcpview.exe (to view ports on machine).
    1) I host the game.
    2) Friend looks for game using my IP.
    3) Friend can see the game.
    4) I can see friends connection on port.
    5) Then friend tries to join the game
    6) then from tcpview.exe the connection is dropped.
    we cannot get past this point.

    the same thing happens when DMZ is enabled or disabled with port forwarding
    (all the required ports are open and forwarded).

  5. #5
    Jimmy S. Guest

    Re: age of empires 2 tcp/ip multiplayer problem

    Hi guntek,

    By eliminate, I meant for both of you to disconnect from your
    routers and connect directly through your broadband modems.

    This will help determine if one or both of the routers are at fault.

    --
    Cheers, *Windows_XP_MVP_Shell/User*
    Jimmy S. http://mvp.support.microsoft.com

    Visit my MSN Zone.com and Gaming Help Site: http://mvps.org/nibblesnbits
    MS Games Help and Support Center: http://support.microsoft.com/?pr=gms
    My advice is donated "AS IS" without warranty; nor do I confer any rights.
    _________________________________________________________


    guntek Wrote:
    =================
    | Hi Jimmy,
    | I setup DMZ in both of them.
    | This is what happens when I ran tcpview.exe (to view ports on machine).
    | 1) I host the game.
    | 2) Friend looks for game using my IP.
    | 3) Friend can see the game.
    | 4) I can see friends connection on port.
    | 5) Then friend tries to join the game
    | 6) then from tcpview.exe the connection is dropped.
    | we cannot get past this point.
    |
    | the same thing happens when DMZ is enabled or disabled with port forwarding
    | (all the required ports are open and forwarded).



  6. #6
    Join Date
    Mar 2009
    Posts
    1

    Re: age of empires 2 tcp/ip multiplayer problem

    Hello, I didnt want to start a new thread because I have a similar question.
    on aoe 2, when I type in the ip adress of my friends game, It comes up with a blank game. He has the same problem with mine. But we can join other peoples games via IP. I tried using my internal and external ip's with no difference. Anybody know?

  7. #7
    Jonata Guest

    Re: age of empires 2 tcp/ip multiplayer problem

    On 6 mar, 10:38, davidsebra720 <davidsebra720.3om...@DoNotSpam.com>
    wrote:
    > Hello, I didnt want to start a new thread because I have a similar
    > question.
    > on aoe 2, when I type in the ip adress of my friends game, It comes up
    > with a blank game. He has the same problem with mine. But we can join
    > other peoples games via IP. I tried using my internal and external ip's
    > with no difference. Anybody know?
    >
    > --
    > davidsebra720
    > ------------------------------------------------------------------------
    > davidsebra720's Profile:http://forums.techarena.in/members/davidsebra720.htm
    > View this thread:http://forums.techarena.in/windows-xp-games/466717.htm
    >
    > http://forums.techarena.in


    Do you know HAMACHI? Some connections have the problem that I've
    described. Try to install Hamachi (you and your friends) create a
    virtual network (on hamachi), e play it like you are on a lan!!!

  8. #8
    Join Date
    Nov 2009
    Posts
    1

    Re: age of empires 2 tcp/ip multiplayer problem

    Quote Originally Posted by Jonata View Post
    On 6 mar, 10:38, davidsebra720 <davidsebra720.3om...@DoNotSpam.com>
    wrote:
    > Hello, I didnt want to start a new thread because I have a similar
    > question.
    > on aoe 2, when I type in the ip adress of my friends game, It comes up
    > with a blank game. He has the same problem with mine. But we can join
    > other peoples games via IP. I tried using my internal and external ip's
    > with no difference. Anybody know?
    >
    > --
    > davidsebra720
    > ------------------------------------------------------------------------
    > davidsebra720's Profile:http://forums.techarena.in/members/davidsebra720.htm
    > View this thread:http://forums.techarena.in/windows-xp-games/466717.htm
    >
    > http://forums.techarena.in


    Do you know HAMACHI? Some connections have the problem that I've
    described. Try to install Hamachi (you and your friends) create a
    virtual network (on hamachi), e play it like you are on a lan!!!
    Hy guys !

    I have try to play the game with hamachi but we cant see one another. we using routers and win xp.

    please help!

    WRG Hody

Similar Threads

  1. Replies: 5
    Last Post: 28-06-2010, 04:01 AM
  2. Age of Empires 2 multiplayer over WIN 7
    By tibe87 in forum Video Games
    Replies: 6
    Last Post: 15-04-2010, 08:46 PM
  3. Unable to join Age of Empires 3 multiplayer game
    By Ryan21 in forum Video Games
    Replies: 5
    Last Post: 21-01-2010, 08:57 PM
  4. Replies: 2
    Last Post: 14-07-2008, 06:47 PM
  5. Age of Empires multiplayer crash problem
    By JAGADI in forum Windows XP Support
    Replies: 1
    Last Post: 07-07-2008, 12:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •