Go Back   TechArena Community > Technical Support > Computer Help > Windows XP > Windows XP Support
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Slow Opening Files, Explorer Slow, Context click slow FIXED!!!

Windows XP Support


Reply
 
Thread Tools Search this Thread
  #1  
Old 17-11-2004
Dominique
 
Posts: n/a
Slow Opening Files, Explorer Slow, Context click slow FIXED!!!

OK

everybody that I've found so far that has this problem in some way or
another works on a network, and as such might have mapped drives to other
computers or servers.

What you need to do is think about whether you had any drives mapped to
servers/computers which may not be connected any more. something might have
happenned during the disconnection process which left entries in your
registry pointing in some way to these drives.

An example would be an application which was installed through a mapped
drive. The application or FILE ASSOCIATIONS (no matter what it is) might be
pointing to an exe or file on this mapped drive(which is disconnected/doesn't
exist now)

My problem was my Flash MX 2004 installation, which i copied from my desktop
pc onto my notebook through a mapped drive. It has a file association for swf
files pointing to the saflashplayer.exe on that computer. Now that computer
was shut down and removed, and that's actually where this problem began, but
it never made sense for a disconnected pc to mess things up like this.

The thing is that every time a file is opened, your pc would check all file
associations and find the current file's extension to open it. now imagine it
comes accross an extension which is opened by an application it cannot
access, and that's where the lag comes in, it times out, and skips that
filetype and opens your file.

i ran a search in my registry for \\mappedPCName and found entries under a
few file associations, changed it to point to c:\prog...\flash...\ etc etc..
and everything is working kewl now.

I'd say disconnect all mapped drives and run searches in your registry for
those computer/server names and others you may have had connected before your
troubled began.

I really hope this works for everybody here, and I'll check back here to
check your feedback.

Regards
Dominique

Reply With Quote
  #2  
Old 18-11-2004
Ramesh [MVP]
 
Posts: n/a
Re: Slow Opening Files, Explorer Slow, Context click slow FIXED!!!

Thanks for the great feedback Dominique. This should help many.

--
Ramesh, Microsoft MVP
Windows XP Shell/User
http://windowsxp.mvps.org

"Dominique" <Dominique@discussions.microsoft.com> wrote in message news:19E747B7-FD29-4EDD-B782-CFEAE205D69F@microsoft.com...
OK

everybody that I've found so far that has this problem in some way or
another works on a network, and as such might have mapped drives to other
computers or servers.

What you need to do is think about whether you had any drives mapped to
servers/computers which may not be connected any more. something might have
happenned during the disconnection process which left entries in your
registry pointing in some way to these drives.

An example would be an application which was installed through a mapped
drive. The application or FILE ASSOCIATIONS (no matter what it is) might be
pointing to an exe or file on this mapped drive(which is disconnected/doesn't
exist now)

My problem was my Flash MX 2004 installation, which i copied from my desktop
pc onto my notebook through a mapped drive. It has a file association for swf
files pointing to the saflashplayer.exe on that computer. Now that computer
was shut down and removed, and that's actually where this problem began, but
it never made sense for a disconnected pc to mess things up like this.

The thing is that every time a file is opened, your pc would check all file
associations and find the current file's extension to open it. now imagine it
comes accross an extension which is opened by an application it cannot
access, and that's where the lag comes in, it times out, and skips that
filetype and opens your file.

i ran a search in my registry for \\mappedPCName and found entries under a
few file associations, changed it to point to c:\prog...\flash...\ etc etc..
and everything is working kewl now.

I'd say disconnect all mapped drives and run searches in your registry for
those computer/server names and others you may have had connected before your
troubled began.

I really hope this works for everybody here, and I'll check back here to
check your feedback.

Regards
Dominique
Reply With Quote
  #3  
Old 20-11-2004
Malcolm
 
Posts: n/a
Re: Slow Opening Files, Explorer Slow, Context click slow FIXED!!!

On Thu, 18 Nov 2004 10:32:08 +0530, "Ramesh [MVP]"
<ramesh@nojunkmails.com@mvps.org> wrote:

>Thanks for the great feedback Dominique. This should help many.


I have the same problem, slow operation of "*.exe" files. I have two
boxes networked together with a crossover cable and have no mapped
drives, nor have there ever been any mapped drives.


Thanks

Remove "NOT" from email address to reply via email"

Later,
Malcolm
Reply With Quote
  #4  
Old 20-11-2004
Malcolm
 
Posts: n/a
Re: Slow Opening Files, Explorer Slow, Context click slow FIXED!!!

On Sat, 20 Nov 2004 02:39:34 GMT, Malcolm <malcolm34465@NOTyahoo.com>
wrote:

>On Thu, 18 Nov 2004 10:32:08 +0530, "Ramesh [MVP]"
><ramesh@nojunkmails.com@mvps.org> wrote:
>
>>Thanks for the great feedback Dominique. This should help many.

>
>I have the same problem, slow operation of "*.exe" files. I have two
>boxes networked together with a crossover cable and have no mapped
>drives, nor have there ever been any mapped drives.
>
>
>Thanks
>
>Remove "NOT" from email address to reply via email"
>
>Later,
>Malcolm



This seems to have solved my problem;
Modify Boot.ini (DEP)

Data Execution Prevention prevents complete booting or shutting down
1. The new DEP (Data Execution Prevention) technology (see special
chapter on DEP below for background information) can cause a blue
screen stop error with incompatible drivers. If your computer runs on
an AMD Athlon 64, AMD Sempron (mobile), AMD Opteron, or Intel Itanium
processor, you may want to disable hardware DEP for a test.
To disable DEP, you have to make a change to the BOOT.INI file in the
root of the partition from which the computer boots. To get Windows to
run, your only choice is now safe mode. To boot into safe mode, press
F8 a few times after the BIOS has finished its booting and Windows
begins to load. Once you have booted into safe mode, use these steps:
Right-click on My Computer and select Properties.
Click on the Advanced tab.
Click on the third button?settings for system start options.
Click on the Edit button to edit the boot.ini file.
Carefully edit the /NoExecute=OptIn string and change it to AlwaysOff.
This part at the end of the line should now read: /NoExecute=AlwaysOff
Save and close the dialog boxes by clicking on OK.
Now reboot and try to get it booted in normal mode again.
If the computer does not even run in safe mode, this probably means
that you have a different problem. If you want to try this one
nonetheless, either move the hard disk into another computer or try to
use the repair console (boot from the Windows XP installation CD and
choose the repair console). You can then use the following commands.
The BOOT.INI file is write-protected, so you have to remove the
read-only attribute first:
ATTRIB -S -H -R C:\BOOT.INI
NOTEPAD BOOT.INI
Carefully edit the /NoExecute=OptIn string and change OptIn to
AlwaysOff. This part at the end of the line should now read:
/NoExecute=AlwaysOff
Close the editor and resave the BOOT.INI file back to where it was.
ATTRIB +S +H +R C:\BOOT.INI
If you use the repair console, you may have to copy BOOT.INI to a
diskette, change it on another computer, then copy it back in place.
The second ATTRIB command is not required for booting. It is only a
protection measure, which you can also perform later, when you have
Windows up and running again.
Be careful not to change any other parts of the boot.ini file, because
a mistake can render your computer entirely unbootable.
If anybody finds this to work, I'd be very grateful for an email. Even
if you tried it, and it didn't work, please write me briefly. [1]
Of course you should now look for updated drivers, install these
whenever they appear, and then test the driver by reenabling DEP.
To change this setting back, for example, to test a new driver, you
can follow the same procedure again.
Right-click on My Computer and select Properties.
Click on the Advanced tab.
Click on the third button?settings for system start options.
Click on the Edit button to edit the boot.ini file.
Carefully edit the /NoExecute=AlwaysOff string and change it back to
OptIn. This part at the end of the line should now read:
/NoExecute=OptIn
Save and close the dialog boxes by clicking on OK.
A potential workaround, also unverified and untested, could be to set
the IDE channel to PIO mode for a test, because there are some
indications that a DMA driver is involved in this problem. This test
could reveal that it is indeed a DMA driver problem.
See also the following Microsoft Knowledge Base article.
Your computer repeatedly restarts after you install Windows XP Service
Pack 2
http://support.microsoft.com/?kbid=878474



Data Execution Prevention (DEP)
1. Service pack 2 contains a new security technology that prevents the
execution of data as a program. The purpose is to make it impossible
for malware like viruses and Trojans to exploit program errors and
other security holes, for example buffer overflows.
Not all processors support hardware DEP. Currently only the AMD Athlon
64, AMD Sempron (mobile), AMD Opteron, and the Intel Itanium server
processor support it. But at least for some Windows components there
is a software implementation of DEP that can be enabled on all
computers running Service Pack 2.
End users who are logged on as administrators can manually configure
DEP between the OptIn and OptOut policies using the Data Execution
Prevention tab inside the System Properties dialog box. The following
procedure describes how to manually configure DEP on the computer:
1. Click Start, click Control Panel, and then double-click System.
2. Click the Advanced tab. Then, under Performance, click Settings.
3. Click the Data Execution Prevention tab.
4. Click Turn off hardware DEP (software DEP enabled) to select the
Opt-in policy.
5. Click Hardware and software DEP enabled for all programs except to
select the OptOut policy.
6. Click Add and add the applications that you do not want to use DEP
with.
If you cannot boot or if DEP itself prevents you from using the dialog
described above or if you want to disable DEP entirely, please read
the chapter Boot or shutdown problems after Service Pack 2
installation above, subchapter "Data Execution Prevention prevents
complete booting or shutting down".
For a more detailed discussion of DEP, please read the following
TechNet articles.
Changes to Functionality in Microsoft Windows XP Service Pack 2
Part 3: Memory Protection Technologies
http://www.microsoft.com/technet/pro.../sp2mempr.mspx
Detailed description of the data execution prevention feature in
Windows XP SP2
http://support.microsoft.com/default...b;en-us;875352


Thanks

Remove "NOT" from email address to reply via email"

Later,
Malcolm
Reply With Quote
  #5  
Old 20-11-2004
Ramesh [MVP]
 
Posts: n/a
Re: Slow Opening Files, Explorer Slow, Context click slow FIXED!!!

Duly noted down. Still the underlying cause might be a shell extension, IMO.

--
Ramesh, Microsoft MVP
Windows XP Shell/User
http://windowsxp.mvps.org


"Malcolm" <malcolm34465@NOTyahoo.com> wrote in message news:b1etp05s3vlef6li6eb9m8ppvc9fl1okvk@4ax.com...
On Sat, 20 Nov 2004 02:39:34 GMT, Malcolm <malcolm34465@NOTyahoo.com>
wrote:

>On Thu, 18 Nov 2004 10:32:08 +0530, "Ramesh [MVP]"
><ramesh@nojunkmails.com@mvps.org> wrote:
>
>>Thanks for the great feedback Dominique. This should help many.

>
>I have the same problem, slow operation of "*.exe" files. I have two
>boxes networked together with a crossover cable and have no mapped
>drives, nor have there ever been any mapped drives.
>
>
>Thanks
>
>Remove "NOT" from email address to reply via email"
>
>Later,
>Malcolm



This seems to have solved my problem;
Modify Boot.ini (DEP)

Data Execution Prevention prevents complete booting or shutting down
1. The new DEP (Data Execution Prevention) technology (see special
chapter on DEP below for background information) can cause a blue
screen stop error with incompatible drivers. If your computer runs on
an AMD Athlon 64, AMD Sempron (mobile), AMD Opteron, or Intel Itanium
processor, you may want to disable hardware DEP for a test.
To disable DEP, you have to make a change to the BOOT.INI file in the
root of the partition from which the computer boots. To get Windows to
run, your only choice is now safe mode. To boot into safe mode, press
F8 a few times after the BIOS has finished its booting and Windows
begins to load. Once you have booted into safe mode, use these steps:
Right-click on My Computer and select Properties.
Click on the Advanced tab.
Click on the third button?settings for system start options.
Click on the Edit button to edit the boot.ini file.
Carefully edit the /NoExecute=OptIn string and change it to AlwaysOff.
This part at the end of the line should now read: /NoExecute=AlwaysOff
Save and close the dialog boxes by clicking on OK.
Now reboot and try to get it booted in normal mode again.
If the computer does not even run in safe mode, this probably means
that you have a different problem. If you want to try this one
nonetheless, either move the hard disk into another computer or try to
use the repair console (boot from the Windows XP installation CD and
choose the repair console). You can then use the following commands.
The BOOT.INI file is write-protected, so you have to remove the
read-only attribute first:
ATTRIB -S -H -R C:\BOOT.INI
NOTEPAD BOOT.INI
Carefully edit the /NoExecute=OptIn string and change OptIn to
AlwaysOff. This part at the end of the line should now read:
/NoExecute=AlwaysOff
Close the editor and resave the BOOT.INI file back to where it was.
ATTRIB +S +H +R C:\BOOT.INI
If you use the repair console, you may have to copy BOOT.INI to a
diskette, change it on another computer, then copy it back in place.
The second ATTRIB command is not required for booting. It is only a
protection measure, which you can also perform later, when you have
Windows up and running again.
Be careful not to change any other parts of the boot.ini file, because
a mistake can render your computer entirely unbootable.
If anybody finds this to work, I'd be very grateful for an email. Even
if you tried it, and it didn't work, please write me briefly. [1]
Of course you should now look for updated drivers, install these
whenever they appear, and then test the driver by reenabling DEP.
To change this setting back, for example, to test a new driver, you
can follow the same procedure again.
Right-click on My Computer and select Properties.
Click on the Advanced tab.
Click on the third button?settings for system start options.
Click on the Edit button to edit the boot.ini file.
Carefully edit the /NoExecute=AlwaysOff string and change it back to
OptIn. This part at the end of the line should now read:
/NoExecute=OptIn
Save and close the dialog boxes by clicking on OK.
A potential workaround, also unverified and untested, could be to set
the IDE channel to PIO mode for a test, because there are some
indications that a DMA driver is involved in this problem. This test
could reveal that it is indeed a DMA driver problem.
See also the following Microsoft Knowledge Base article.
Your computer repeatedly restarts after you install Windows XP Service
Pack 2
http://support.microsoft.com/?kbid=878474



Data Execution Prevention (DEP)
1. Service pack 2 contains a new security technology that prevents the
execution of data as a program. The purpose is to make it impossible
for malware like viruses and Trojans to exploit program errors and
other security holes, for example buffer overflows.
Not all processors support hardware DEP. Currently only the AMD Athlon
64, AMD Sempron (mobile), AMD Opteron, and the Intel Itanium server
processor support it. But at least for some Windows components there
is a software implementation of DEP that can be enabled on all
computers running Service Pack 2.
End users who are logged on as administrators can manually configure
DEP between the OptIn and OptOut policies using the Data Execution
Prevention tab inside the System Properties dialog box. The following
procedure describes how to manually configure DEP on the computer:
1. Click Start, click Control Panel, and then double-click System.
2. Click the Advanced tab. Then, under Performance, click Settings.
3. Click the Data Execution Prevention tab.
4. Click Turn off hardware DEP (software DEP enabled) to select the
Opt-in policy.
5. Click Hardware and software DEP enabled for all programs except to
select the OptOut policy.
6. Click Add and add the applications that you do not want to use DEP
with.
If you cannot boot or if DEP itself prevents you from using the dialog
described above or if you want to disable DEP entirely, please read
the chapter Boot or shutdown problems after Service Pack 2
installation above, subchapter "Data Execution Prevention prevents
complete booting or shutting down".
For a more detailed discussion of DEP, please read the following
TechNet articles.
Changes to Functionality in Microsoft Windows XP Service Pack 2
Part 3: Memory Protection Technologies
http://www.microsoft.com/technet/pro.../sp2mempr.mspx
Detailed description of the data execution prevention feature in
Windows XP SP2
http://support.microsoft.com/default...b;en-us;875352


Thanks

Remove "NOT" from email address to reply via email"

Later,
Malcolm
Reply With Quote
  #6  
Old 06-01-2005
=?Utf-8?B?Sm9zZXBoIENob3c=?=
 
Posts: n/a
RE: Slow Opening Files, Explorer Slow, Context click slow FIXED!!!

My problem had a different cause: I had made "My Documents" point to a
"network place". Our network disallows the use of a direct UNC path, so we
have to create a new "network place" via in Explorer:
Tools -> Map Network Drive -> Sign up for online storage or connect to ...

Then in the registry, I placed the UNC path (to that network place) in the
appropriate "User Shell Folders" key.

Undoing the above solved my problem.
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows XP > Windows XP Support
Tags: , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Slow Opening Files, Explorer Slow, Context click slow FIXED!!!"
Thread Thread Starter Forum Replies Last Post
Slow Opening of Excel Files through a Network Dee MN MS Office Support 28 18-01-2012 04:25 PM
Very slow opening of Word and Excel files gajaratna MS Office Support 2 12-10-2011 10:56 PM
Windows 7 is slow while opening Internet explorer ad word files after boot Zared Operating Systems 4 16-12-2010 01:15 AM
Slow opening MS Office files on computer Asuman Windows Software 3 27-02-2009 11:16 AM
Slow opening files shyman MS Office Support 4 28-11-2008 01:29 AM


All times are GMT +5.5. The time now is 03:47 AM.