Results 1 to 8 of 8

Thread: Workstation service will not start -- gets error 2

  1. #1
    Jim Snively Guest

    Workstation service will not start -- gets error 2

    Without the Workstation service starting the computer is almost useless. No
    networking, can't install SpywareDoctor (needs to update itself), Can't
    install Belkin Easy Transfer
    Cable for Windows 7 (requires Crypto service which depends on workstation).
    Can't even look at events.
    Can't burn CD's.

    Trying to start the workstation service service gives:

    Could not start the Workstation service on Local Computer.
    Error 2: The system could not find the file specified

    I tried sfc /scannow. It took all afternoon but did not help the issue.

    My only recourse to migrate to a new Windows machine is to hang the HDD on
    machine and burn CD's there/

    Any suggestions would be welcome.

  2. #2
    John John - MVP Guest
    Is the ServiceDll value pointing to %SystemRoot%\System32\wkssvc.dll at
    the HKLM\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters key?

    Yes it is. And the file exists there 129KB dated 6/10/2009 2:14 am.

    Try reinstalling the Client for Microsoft Networks (on the LAN adapter's
    Properties in Network Connections) if it is shown as installed uninstall
    then reinstall it.

    How to troubleshoot missing network connections icons in Windows Server
    2003 and in Windows XP

  3. #3
    Adnan Guest

    Re: Workstation service will not start -- gets error 2

    I think this is NetBEUI protocol problem. You should use the following
    steps to solve this:

    Click Start, point to Settings, click Control Panel, and then double-
    click Network.
    Click the Bindings tab, and then click All Adapters in the Show
    Bindings For box.
    Click the plus sign next to the second network adapter.
    Click NetBEUI Protocol, and then click Disable.
    Click Close, and then restart the computer.

  4. #4
    Jim Snively Guest
    Nice thought, but Control Panel has only Network Connections. Network
    Cnnections has only My Web Sites on MSN. There are 3 network adapters in
    device manager -- one NIC, one wireless NIC and 1394 Net Adapter. No

    Any further ideas.

    The adapters do not show in network connections. They do show in device
    manager. What can I to to restore them?

    Uninstalled and let windows reinstall the network adapters. The network
    connectrions did NOT repopulate. Any other ideas?

  5. #5
    John John - MVP Guest
    Try the "Advanced Troubleshooting" steps at the bottom of the same article.

    The Windows installation is damaged or missing files. Run sfc /scannow
    and see if things improve.

    I ran sfc /scannow with no messages but the problem still persists.

  6. #6
    Jim Snively Guest

    Re: Workstation service will not start -- gets error 2

    I'm finally getting around to working through the article you sreferred me
    to --

    The following glitches occur:

    1. I cannot manually start the RPC sevice -- it gets error 2: the
    requested file is not found.
    2. I cannot open the properties for the network adapters in device manager.
    Double click
    does not work nor does properties from the context (right click) menu.

  7. #7
    John John - MVP Guest

    Re: Workstation service will not start -- gets error 2

    How to perform an in-place upgrade (reinstallation) of Windows XP

  8. #8
    Jose Guest

    Re: Workstation service will not start -- gets error 2

    On Jun 22, 8:55*am, "Jim Snively" <> wrote:
    > John,
    > I ran sfc /scannow with no messages but the problem still persists.
    > Jim Snively

    But you do come away with a sense of satisfaction sometimes (and still
    have the problem).

    Error 2 is error 2: file not found.

    Did you look in the event log to see if there are any clues there?

Similar Threads

  1. Can't start the Intel PDS service Error 1053
    By Tom Wall in forum Windows Server Help
    Replies: 2
    Last Post: 04-01-2014, 09:43 AM
  2. Start service error 193 0xc1
    By Robbin M in forum Windows XP Support
    Replies: 2
    Last Post: 02-01-2014, 03:32 PM
  3. Replies: 3
    Last Post: 27-01-2010, 06:48 PM
  4. Error unable to start bluetooth service
    By KAIPO in forum Portable Devices
    Replies: 3
    Last Post: 18-08-2009, 12:59 PM
  5. The Workstation service terminated with service-specific error 225
    By Miltongomes in forum Small Business Server
    Replies: 0
    Last Post: 07-03-2007, 04:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts