Results 1 to 8 of 8

Thread: Run, cmd not working

  1. #1
    Join Date
    Oct 2005
    Posts
    93

    Run, cmd not working

    I am not able to open a command prompt window from the Run dialogue box. Also, I am not able to get auto updates for my Avg antivirus and Malwarebytes programs, Internet Explorer 7 works fine though. I want some new software to remove virus or trojan as I cant find one. I have tried scans in safe mode and with Hijack this but I am not able to see anything bad. I am running Windows XP SP3 and if anyone can help then it would be appreciated.

  2. #2
    Join Date
    Oct 2005
    Posts
    449

    Re: Run, cmd not working

    Was CMD working for you ever? What are you seeing when you run CMD? Is the command working for you? Have you checked if regedit is working or even if the Task Manager is working? Can you check if you can run Malwarebytes then are you saying that you cannot do an update? What is the problem you are having when you try to do an update? Is it running at all?

  3. #3
    Join Date
    Oct 2005
    Posts
    93

    Re: Run, cmd not working

    The command window does appear most of the time. It has done before Task Manager that works fine. Also, msconfig works anti-malware runs and scans but finds nothing on a quick scan and avg scans but finds nothing now. I have previously removed PUP Tool.AX and virus Win32/Heur and I am getting a command prompt window if I run command?

  4. #4
    Join Date
    Feb 2006
    Posts
    335
    Was regedit working? I have updated malwarebytes today only. You can try to do a update of your MBAM and do a full scan. Try to open regedit and navigate to here HKLM or HKCU\Software\Policies\Microsoft\Windows\System. After that check both HKLM and HKCU and look for a DWORD called DisableCmd. If present make sure its has value 0 and then reboot.

  5. #5
    Join Date
    May 2009
    Posts
    1
    When i ran full scan with AVG, naor.mui file got detected and deleted form C:\Documents and Settings\\Local Settings.

    Scan resulted like below.

    "C:\Documents and Settings\\Local Settings\naor.mui";"Virus found Defiler";"Moved to Virus Vault"
    "C:\RECYCLER\S-1-5-21-3939332184-3785630657-3855912810-500\Dc1.mui";"Virus found Defiler";"Moved to Virus Vault"
    "C:\RECYCLER\S-1-5-21-3939332184-3785630657-3855912810-500\Dc2.concerned";"Virus found Defiler";"Moved to Virus Vault"
    "C:\RECYCLER\S-1-5-21-3939332184-3785630657-3855912810-500\Dc3.muixxxxxxxxxxxxxxxx";"Virus found Defiler";"Moved to Virus Vault"
    "C:\RECYCLER\S-1-5-21-3939332184-3785630657-3855912810-500\Dc4.mui";"Virus found Defiler";"Moved to Virus Vault"
    "C:\RECYCLER\S-1-5-21-3939332184-3785630657-3855912810-500\Dc5.muix";"Virus found Defiler";"Moved to Virus Vault"
    "C:\RECYCLER\S-1-5-21-3939332184-3785630657-3855912810-500\Dc6.mui";"Virus found Defiler";"Moved to Virus Vault"
    "C:\RECYCLER\S-1-5-21-3939332184-3785630657-3855912810-500\Dc7.mui";"Virus found Defiler";"Moved to Virus Vault"

  6. #6
    Join Date
    May 2010
    Posts
    1
    After many hours chasing this for a customer, I finally found an answer to the IE, cmd, search functions not working.

    thanks to MPAK at msfn.org forum: This was the second time that I have seen this, and people often end up being advised to re-install to correct - How bizarre Windows can be!
    I hope some other folks stumble over this sooner than I did!

    For those who will beat the monitor wondering why pressing Start -> Run (and Search, and Help buttons also) doesn't work anymore showing stupid message "Windows cannot create a shortcut here, place it onto the Desktop instead?", or why Internet Explorer "Manage Add-ons" menu doesn't work too, here is the solution of the problem (it has cost me 4 hours!):

    The problem is you recently installed critical Windows updates (of 10 Aug 2006) but you did not install kb908531 (25.04.2006) -- that stupid update which installs Verclsid.exe tool. Install kb908531 and be happy.

  7. #7
    Join Date
    Oct 2011
    Posts
    1

    Re: Run, cmd not working

    Hi, cmd is not running on my computer. (command and regedit are running though.) I followed this thread and here is how my Drivers32.reg looks like:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32]
    "midimapper"="midimap.dll"
    "msacm.imaadpcm"="imaadp32.acm"
    "msacm.msadpcm"="msadp32.acm"
    "msacm.msg711"="msg711.acm"
    "msacm.msgsm610"="msgsm32.acm"
    "msacm.trspch"="tssoft32.acm"
    "vidc.cvid"="iccvid.dll"
    "VIDC.I420"="msh263.drv"
    "vidc.iv31"="ir32_32.dll"
    "vidc.iv32"="ir32_32.dll"
    "vidc.iv41"="ir41_32.ax"
    "VIDC.IYUV"="iyuv_32.dll"
    "vidc.mrle"="msrle32.dll"
    "vidc.msvc"="msvidc32.dll"
    "VIDC.UYVY"="msyuv.dll"
    "VIDC.YUY2"="msyuv.dll"
    "VIDC.YVU9"="tsbyuv.dll"
    "VIDC.YVYU"="msyuv.dll"
    "wavemapper"="msacm32.drv"
    "msacm.msg723"="msg723.acm"
    "vidc.M263"="msh263.drv"
    "vidc.M261"="msh261.drv"
    "msacm.msaudio1"="msaud32.acm"
    "msacm.sl_anet"="sl_anet.acm"
    "msacm.iac2"="C:\\WINDOWS\\system32\\iac25_32.ax"
    "vidc.iv50"="ir50_32.dll"
    "msacm.l3acm"="C:\\WINDOWS\\system32\\l3codeca.acm"
    "wave"="wdmaud.drv"
    "midi"="wdmaud.drv"
    "mixer"="wdmaud.drv"
    "aux"="wdmaud.drv"
    "VIDC.XVID"="xvidvfw.dll"
    "VIDC.YV12"="yv12vfw.dll"
    "msacm.ac3acm"="ac3acm.acm"
    "msacm.lameacm"="lameACM.acm"
    "VIDC.FFDS"="ff_vfw.dll"
    "MSVideo8"="VfWWDM32.dll"
    "wave1"="wdmaud.drv"
    "mixer1"="wdmaud.drv"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32\Terminal Server]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32\Terminal Server\RDP]
    "wave"="rdpsnd.dll"
    "mixer"="rdpsnd.dll"
    "MaxBandwidth"=dword:000056b9
    "wavemapper"="msacm32.drv"
    "EnableMP3Codec"=dword:00000001
    "midimapper"="midimap.dll"

    Please help me in running cmd again. Currently when I run cmd the error message says: "Windows can not find cmd."

    Thanks

  8. #8
    Join Date
    May 2011
    Posts
    526

    Re: Run, cmd not working

    Run System restore. Restore your system to old date when it was working fine. The issue can also be due to environment variable. To create a new right click on My Computer > Properties > Advance. Look below for Environment variable. Create ComSpec = %SystemRoot%\system32\cmd.exe. Set the Path = %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem. Reboot once and check back.

Similar Threads

  1. Replies: 10
    Last Post: 02-05-2012, 10:55 PM
  2. Replies: 8
    Last Post: 20-12-2011, 10:39 AM
  3. Replies: 3
    Last Post: 27-04-2011, 12:11 AM
  4. Replies: 4
    Last Post: 26-07-2009, 12:37 AM
  5. Replies: 1
    Last Post: 03-07-2008, 09:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •