Go Back   TechArena Community > Technical Support > Computer Help > Windows XP > Windows XP Support
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



The USB device can perform faster if you connect it to a High SpeedUSB 2.0 port

Windows XP Support


Reply
 
Thread Tools Search this Thread
  #1  
Old 20-01-2009
Jose
 
Posts: n/a
The USB device can perform faster if you connect it to a High SpeedUSB 2.0 port

I saw this message on my home grown system every time I turned on my
USB printer. I did not really care since I don't print much, but it
was annoying. I thought I might need a BIOS update or something. I
did some research and found maybe "bad" ideas, but then found a
solution that worked for me so I copied my notes here and in the
basics section so maybe it well help someone else. Sorry about the
formatting of my paste.

Be sure to read the whole thing since you may not see things the way I
did on my system.


Turning in a USB 2.0 device you might see a message that says this
device can perform faster if
it was connected to a high speed USB 2.0 device.

Maybe: The USB device can perform faster if you connect it to a High
Speed USB 2.0 port.
For a list of available ports, click here.


USB 1.X = 12.0 megabit per second (mbs) Full Speed
USB 2.X = 480 megabit per second, or 40 times faster than 1.1.


Right click My Computer, Properties, Hardware, Device Manager. Under
the USB Controller section
see if there is a red X.


Look in the Other device section (things with yellow question marks
and red X)

observe: Ethernet controller (with red X) who cares, I am wireless
PCI Modem (with red X) who cares, I don't use it
USB controller (with red X) here is the problem

Or maybe this: Universal Serial Bus (USB) Controller (with red X)

This means the system has the ports, but the correct driver is not
installed. XP did not
come high speed drivers, but they do come in the service packs
(SP1), so it must now be
installed manually.

More FWIW information from Microsoft:

http://www.microsoft.com/whdc/connec...faq_intro.mspx


Right click the USB Controller in the Other devices section with the
red X in the question mark,
right click Properties and if it is disabled, click Driver and Update
driver, and let it search
for a new driver and hopefully find it and install it. Things will
refresh a few times.
The question marked red X on USB Controller will go away. You may be
able to just enable it,
but I did not try this.


Now look in the Universal Serial Bus Controller section for something
that says USB Enhanced Host
Controller - Enhanced is the key word which means high speed. If it
is not there, it is just a
USB 2.0, but not high speed.

After the update, there should now be at least one USB Enhanced Host
Controller. Does this mean that
now ALL the USB 2.0 connections are high speed? The driver version
for the USB device should now all
be 5.1.2600 or later. If not, upgrade them individually to the
current version.

You may (should) reboot after this to get your other USB device
working again. My wireless connection got confused but I fixed it
easily.

Under USB Printing Support it shows my correct printer which is the
thing that was complaining every
time I turned it on. No more complaints, always was 2.0 but now I am
now enhanced.

It is possible to configure a check box in the properties on the
device to never warn you about USB errors. Probably not a good idea.


Reply With Quote
  #2  
Old 20-01-2009
Jose
 
Posts: n/a
Re: The USB device can perform faster if you connect it to a HighSpeed USB 2.0 port

On Jan 20, 8:29*am, Jose <jose_e...@yahoo.com> wrote:
> I saw this message on my home grown system every time I turned on my
> USB printer. *I did not really care since I don't print much, but it
> was annoying. *I thought I might need a BIOS update or something. *I
> did some research and found maybe "bad" ideas, but then found a
> solution that worked for me so I copied my notes here and in the
> basics section so maybe it well help someone else. *Sorry about the
> formatting of my paste.
>
> Be sure to read the whole thing since you may not see things the way I
> did on my system.
>
> Turning in a USB 2.0 device you might see a message that says this
> device can perform faster if
> * * * * it was connected to a high speed USB 2.0 device.
>
> * * * * Maybe: The USB device can perform faster if you connect it to a High
> Speed USB 2.0 port.
> * * * * For a list of available ports, click here.
>
> * * * * USB 1.X = 12.0 megabit per second (mbs) Full Speed
> * * * * USB 2.X = 480 *megabit per second, or 40 times fasterthan 1.1.
>
> * * * * Right click My Computer, Properties, Hardware, Device Manager. *Under
> the USB Controller section
> * * * * see if there is a red X.
>
> * * * * Look in the Other device section (things with yellow question marks
> and red X)
>
> * * * * * * * * observe: Ethernet controller *(with redX) *who cares, I am wireless
> * * * * * * * * * * * * *PCI Modem * * * * * *(with red X) *who cares, I don't use it
> * * * * * * * * * * * * *USB controller * ** (with red X) *here is the problem
>
> * * * * * * * * * * * * *Or maybe this: *Universal Serial Bus (USB) Controller (with red X)
>
> * * * * * * * * This means the system has the ports, but the correct driver is not
> installed. *XP did not
> * * * * * * * * come high speed drivers, but they do comein the service packs
> (SP1), so it must now be
> * * * * * * * * installed manually.
>
> * * * * * * * * More FWIW information from Microsoft:
>
> * * * * * * * *http://www.microsoft.com/whdc/connec...faq_intro.mspx
>
> * * * * Right click the USB Controller in the Other devices section with the
> red X in the question mark,
> * * * * right click Properties and if it is disabled, click Driver and Update
> driver, and let it search
> * * * * for a new driver and hopefully find it and install it. *Things will
> refresh a few times.
> * * * * The question marked red X on USB Controller will go away.*You may be
> able to just enable it,
> * * * * but I did not try this.
>
> * * * * Now look in the Universal Serial Bus Controller section for something
> that says USB Enhanced Host
> * * * * Controller - Enhanced is the key word which means high speed. *If it
> is not there, it is just a
> * * * * USB 2.0, but not high speed.
>
> * * * * After the update, there should now be at least one USB Enhanced Host
> Controller. *Does this mean that
> * * * * now ALL the USB 2.0 connections are high speed? *The driver version
> for the USB device should now all
> * * * * be 5.1.2600 or later. *If not, upgrade them individually to the
> current version.
>
> * * * * You may (should) reboot after this to get your other USB device
> working again. *My wireless connection got confused but I fixed it
> easily.
>
> * * * * Under USB Printing Support it shows my correct printer which is the
> thing that was complaining every
> * * * * time I turned it on. *No more complaints, always was 2.0 but now I am
> now enhanced.
>
> * * * * It is possible to configure a check box in the propertieson the
> device to never warn you about USB errors. *Probably not a good idea.



Some other board suddenly had this idea/solution in reply to my post:

In the BIOS under a section for USB, there's an Option for ECxx
(enhanced controller) that was disabled on my machine. Enabling it
fixed me right up.


My poor old AMI BIOS just has USB enable/disable so that does not
apply to me, but maybe someone else...
Reply With Quote
  #3  
Old 20-01-2009
Twayne
 
Posts: n/a
Re: The USB device can perform faster if you connect it to a High Speed USB 2.0 port

Since you're apparently running XP without any
service packs installed (ref to it being in SP1
and having to manually install it), I don't think
you'll get much valid help here, I'm afraid. You
really need at least SP2 and better SP3.
Sorry; that's my two cents anyway.

Luck,
\
Twayne



> I saw this message on my home grown system every
> time I
> turned on my USB printer. I did not really care
> since I
> don't print much, but it was annoying. I
> thought I might
> need a BIOS update or something. I did some
> research and
> found maybe "bad" ideas, but then found a
> solution that
> worked for me so I copied my notes here and in
> the basics
> section so maybe it well help someone else.
> Sorry about
> the formatting of my paste.
>
> Be sure to read the whole thing since you may
> not see
> things the way I did on my system.
>
>
> Turning in a USB 2.0 device you might see a
> message that
> says this device can perform faster if
> it was connected to a high speed USB 2.0 device.
>
> Maybe: The USB device can perform faster if you
> connect
> it to a High Speed USB 2.0 port.
> For a list of available ports, click here.
>
>
> USB 1.X = 12.0 megabit per second (mbs) Full
> Speed
> USB 2.X = 480 megabit per second, or 40 times
> faster
> than 1.1.
>
>
> Right click My Computer, Properties, Hardware,
> Device
> Manager. Under the USB Controller section
> see if there is a red X.
>
>
> Look in the Other device section (things with
> yellow
> question marks and red X)
>
> observe: Ethernet controller (with red X) who
> cares, I
> am wireless PCI Modem (with red X) who
> cares, I
> don't use it
> USB controller (with red X) here is the
> problem
>
> Or maybe this: Universal Serial Bus (USB)
> Controller
> (with red X)
>
> This means the system has the ports, but the
> correct
> driver is not installed. XP did not
> come high speed drivers, but they do come in the
> service
> packs (SP1), so it must now be
> installed manually.
>
> More FWIW information from Microsoft:
>
> http://www.microsoft.com/whdc/connec...faq_intro.mspx
>
>
> Right click the USB Controller in the Other
> devices
> section with the red X in the question mark,
> right click Properties and if it is disabled,
> click
> Driver and Update driver, and let it search
> for a new driver and hopefully find it and
> install it.
> Things will refresh a few times.
> The question marked red X on USB Controller will
> go away.
> You may be able to just enable it,
> but I did not try this.
>
>
> Now look in the Universal Serial Bus Controller
> section
> for something that says USB Enhanced Host
> Controller - Enhanced is the key word which
> means high
> speed. If it is not there, it is just a
> USB 2.0, but not high speed.
>
> After the update, there should now be at least
> one USB
> Enhanced Host Controller. Does this mean that
> now ALL the USB 2.0 connections are high speed?
> The
> driver version for the USB device should now all
> be 5.1.2600 or later. If not, upgrade them
> individually
> to the current version.
>
> You may (should) reboot after this to get your
> other USB
> device working again. My wireless connection
> got
> confused but I fixed it easily.
>
> Under USB Printing Support it shows my correct
> printer
> which is the thing that was complaining every
> time I turned it on. No more complaints, always
> was 2.0
> but now I am now enhanced.
>
> It is possible to configure a check box in the
> properties
> on the device to never warn you about USB
> errors.
> Probably not a good idea.




Reply With Quote
  #4  
Old 21-01-2009
Jose
 
Posts: n/a
Re: The USB device can perform faster if you connect it to a HighSpeed USB 2.0 port

On Jan 20, 11:24*am, "Twayne" <nob...@devnull.spamcop.net> wrote:
> Since you're apparently running XP without any
> service packs installed (ref to it being in SP1
> and having to manually install it), I don't think
> you'll get much valid help here, I'm afraid. *You
> really need at least SP2 and better SP3.
> * Sorry; that's my two cents anyway.
>
> Luck,
> \
> Twayne
>
> > I saw this message on my home grown system every
> > time I
> > turned on my USB printer. *I did not really care
> > since I
> > don't print much, but it was annoying. *I
> > thought I might
> > need a BIOS update or something. *I did some
> > research and
> > found maybe "bad" ideas, but then found a
> > solution that
> > worked for me so I copied my notes here and in
> > the basics
> > section so maybe it well help someone else.
> > Sorry about
> > the formatting of my paste.

>
> > Be sure to read the whole thing since you may
> > not see
> > things the way I did on my system.

>
> > Turning in a USB 2.0deviceyou might see a
> > message that
> > says thisdevicecanperformfaster if
> > it was connected to a high speed USB 2.0device.

>
> > Maybe: The USBdevicecanperformfaster if you
> > connect
> > it to a High Speed USB 2.0 port.
> > For a list of available ports, click here.

>
> > USB 1.X = 12.0 megabit per second (mbs) Full
> > Speed
> > USB 2.X = 480 *megabit per second, or 40 times
> > faster
> > than 1.1.

>
> > Right click My Computer, Properties, Hardware,
> >Device
> > Manager. *Under the USB Controller section
> > see if there is a red X.

>
> > Look in the Otherdevicesection (things with
> > yellow
> > question marks and red X)

>
> > observe: Ethernet controller *(with red X) *who
> > cares, I
> > am wireless PCI Modem * * * (with red X) *who
> > cares, I
> > don't use it
> > USB controller * * * (with red X) *here is the
> > problem

>
> > Or maybe this: *Universal Serial Bus (USB)
> > Controller
> > (with red X)

>
> > This means the system has the ports, but the
> > correct
> > driver is not installed. *XP did not
> > come high speed drivers, but they do come in the
> > service
> > packs (SP1), so it must now be
> > installed manually.

>
> > More FWIW information from Microsoft:

>
> >http://www.microsoft.com/whdc/connec...faq_intro.mspx

>
> > Right click the USB Controller in the Other
> > devices
> > section with the red X in the question mark,
> > right click Properties and if it is disabled,
> > click
> > Driver and Update driver, and let it search
> > for a new driver and hopefully find it and
> > install it.
> > Things will refresh a few times.
> > The question marked red X on USB Controller will
> > go away.
> > You may be able to just enable it,
> > but I did not try this.

>
> > Now look in the Universal Serial Bus Controller
> > section
> > for something that says USB Enhanced Host
> > Controller - Enhanced is the key word which
> > means high
> > speed. *If it is not there, it is just a
> > USB 2.0, but not high speed.

>
> > After the update, there should now be at least
> > one USB
> > Enhanced Host Controller. *Does this mean that
> > now ALL the USB 2.0 connections are high speed?
> > The
> > driver version for the USBdeviceshould now all
> > be 5.1.2600 or later. *If not, upgrade them
> > individually
> > to the current version.

>
> > You may (should) reboot after this to get your
> > other USB
> >deviceworking again. *My wireless connection
> > got
> > confused but I fixed it easily.

>
> > Under USB Printing Support it shows my correct
> > printer
> > which is the thing that was complaining every
> > time I turned it on. *No more complaints, always
> > was 2.0
> > but now I am now enhanced.

>
> > It is possible to configure a check box in the
> > properties
> > on thedeviceto never warn you about USB
> > errors.
> > Probably not a good idea.


Huh? WHy do you think I am running XP with no service packs? The
mere idea is foreign to me.

I am running XP SP3 and everything is up to date as far as I/Microsoft
know.

My reference to SP1 was from reading about this problem on the
Microsoft pages. There is a note in their stuff that says the
enhanced driver was not in straight XP, but was in SP1. The enhanced
driver does not get installed or updated automatically when you
install SP1. I don't know and really don't care why; it is their
problem and they said so.

It reads that if you want the enhanced driver, you have to update it
manually which is what worked for me. Maybe it should have gotten
updated automatically when I installed SP1, SP2, SP3 or with automatic
updates, but it did not for me. Maybe it works for you. If you buy a
system with XP installed for you they said it will probably already be
installed. My laptop is fine, but it came that way. My desktop was
not fine, but I built it from scratch.

Anyway, this has gotten rid of the annoying message on two other
homegrown XP SP3 computers around me so far, so maybe it will work for
someone else out there.

I just saw this in a lot of searches, but there was no "fix". The
fixes I read were: live with it, turn off the message, you have a bad
cable...
Reply With Quote
  #5  
Old 21-01-2009
M.I.5¾
 
Posts: n/a
Re: The USB device can perform faster if you connect it to a High Speed USB 2.0 port


"Twayne" <nobody@devnull.spamcop.net> wrote in message
news:ujz8HuxeJHA.5048@TK2MSFTNGP05.phx.gbl...
> Since you're apparently running XP without any service packs installed
> (ref to it being in SP1 and having to manually install it), I don't think
> you'll get much valid help here, I'm afraid. You really need at least SP2
> and better SP3.
> Sorry; that's my two cents anyway.
>


USB2 drivers were included in Windows XP Service Pack 2. AFAIK it is not
possible to use USB2 with any earlier version (though I believe 3rd party
drivers for some 3rd party cards will work as they provide the necessary
support).



Reply With Quote
  #6  
Old 21-01-2009
smlunatick
 
Posts: n/a
Re: The USB device can perform faster if you connect it to a HighSpeed USB 2.0 port

On Jan 21, 11:23*am, Jose <jose_e...@yahoo.com> wrote:
> On Jan 20, 11:24*am, "Twayne" <nob...@devnull.spamcop.net> wrote:
>
>
>
> > Since you're apparently running XP without any
> > service packs installed (ref to it being in SP1
> > and having to manually install it), I don't think
> > you'll get much valid help here, I'm afraid. *You
> > really need at least SP2 and better SP3.
> > * Sorry; that's my two cents anyway.

>
> > Luck,
> > \
> > Twayne

>
> > > I saw this message on my home grown system every
> > > time I
> > > turned on my USB printer. *I did not really care
> > > since I
> > > don't print much, but it was annoying. *I
> > > thought I might
> > > need a BIOS update or something. *I did some
> > > research and
> > > found maybe "bad" ideas, but then found a
> > > solution that
> > > worked for me so I copied my notes here and in
> > > the basics
> > > section so maybe it well help someone else.
> > > Sorry about
> > > the formatting of my paste.

>
> > > Be sure to read the whole thing since you may
> > > not see
> > > things the way I did on my system.

>
> > > Turning in a USB 2.0deviceyou might see a
> > > message that
> > > says thisdevicecanperformfaster if
> > > it was connected to a high speed USB 2.0device.

>
> > > Maybe: The USBdevicecanperformfaster if you
> > > connect
> > > it to a High Speed USB 2.0 port.
> > > For a list of available ports, click here.

>
> > > USB 1.X = 12.0 megabit per second (mbs) Full
> > > Speed
> > > USB 2.X = 480 *megabit per second, or 40 times
> > > faster
> > > than 1.1.

>
> > > Right click My Computer, Properties, Hardware,
> > >Device
> > > Manager. *Under the USB Controller section
> > > see if there is a red X.

>
> > > Look in the Otherdevicesection (things with
> > > yellow
> > > question marks and red X)

>
> > > observe: Ethernet controller *(with red X) *who
> > > cares, I
> > > am wireless PCI Modem * * * (with red X) *who
> > > cares, I
> > > don't use it
> > > USB controller * * * (with red X) *here is the
> > > problem

>
> > > Or maybe this: *Universal Serial Bus (USB)
> > > Controller
> > > (with red X)

>
> > > This means the system has the ports, but the
> > > correct
> > > driver is not installed. *XP did not
> > > come high speed drivers, but they do come in the
> > > service
> > > packs (SP1), so it must now be
> > > installed manually.

>
> > > More FWIW information from Microsoft:

>
> > >http://www.microsoft.com/whdc/connec...faq_intro.mspx

>
> > > Right click the USB Controller in the Other
> > > devices
> > > section with the red X in the question mark,
> > > right click Properties and if it is disabled,
> > > click
> > > Driver and Update driver, and let it search
> > > for a new driver and hopefully find it and
> > > install it.
> > > Things will refresh a few times.
> > > The question marked red X on USB Controller will
> > > go away.
> > > You may be able to just enable it,
> > > but I did not try this.

>
> > > Now look in the Universal Serial Bus Controller
> > > section
> > > for something that says USB Enhanced Host
> > > Controller - Enhanced is the key word which
> > > means high
> > > speed. *If it is not there, it is just a
> > > USB 2.0, but not high speed.

>
> > > After the update, there should now be at least
> > > one USB
> > > Enhanced Host Controller. *Does this mean that
> > > now ALL the USB 2.0 connections are high speed?
> > > The
> > > driver version for the USBdeviceshould now all
> > > be 5.1.2600 or later. *If not, upgrade them
> > > individually
> > > to the current version.

>
> > > You may (should) reboot after this to get your
> > > other USB
> > >deviceworking again. *My wireless connection
> > > got
> > > confused but I fixed it easily.

>
> > > Under USB Printing Support it shows my correct
> > > printer
> > > which is the thing that was complaining every
> > > time I turned it on. *No more complaints, always
> > > was 2.0
> > > but now I am now enhanced.

>
> > > It is possible to configure a check box in the
> > > properties
> > > on thedeviceto never warn you about USB
> > > errors.
> > > Probably not a good idea.

>
> Huh? *WHy do you think I am running XP with no service packs? *The
> mere idea is foreign to me.
>
> I am running XP SP3 and everything is up to date as far as I/Microsoft
> know.
>
> My reference to SP1 was from reading about this problem on the
> Microsoft pages. *There is a note in their stuff that says the
> enhanced driver was not in straight XP, but was in SP1. *The enhanced
> driver does not get installed or updated automatically when you
> install SP1. *I don't know and really don't care why; it is their
> problem and they said so.
>
> It reads that if you want the enhanced driver, you have to update it
> manually which is what worked for me. *Maybe it should have gotten
> updated automatically when I installed SP1, SP2, SP3 or with automatic
> updates, but it did not for me. *Maybe it works for you. *If you buy a
> system with XP installed for you they said it will probably already be
> installed. *My laptop is fine, but it came that way. *My desktop was
> not fine, but I built it from scratch.
>
> Anyway, this has gotten rid of the annoying message on two other
> homegrown XP SP3 computers around me so far, so maybe it will work for
> someone else out there.
>
> I just saw this in a lot of searches, but there was no "fix". *The
> fixes I read were: *live with it, turn off the message, you have a bad
> cable...


If the enhanced USB controller does not show up in your Device
Manager, your PC definitely does not have a USB 2 controller. USB 2
requires the USB 2 "hardware" and not just only the drivers.
Reply With Quote
  #7  
Old 21-01-2009
Anna
 
Posts: n/a
Re: The USB device can perform faster if you connect it to a High Speed USB 2.0 port


> "Twayne" <nobody@devnull.spamcop.net> wrote in message
> news:ujz8HuxeJHA.5048@TK2MSFTNGP05.phx.gbl...
>> Since you're apparently running XP without any service packs installed
>> (ref to it being in SP1 and having to manually install it), I don't think
>> you'll get much valid help here, I'm afraid. You really need at least
>> SP2 and better SP3.
>> Sorry; that's my two cents anyway.



"Jose" <jose_ease@yahoo.com> wrote in message
news:3d085583-ee0e-4bf8-a6a9-a02f0c331d5d@q35g2000vbi.googlegroups.com...
Huh? WHy do you think I am running XP with no service packs? The
mere idea is foreign to me.

I am running XP SP3 and everything is up to date as far as I/Microsoft
know.

My reference to SP1 was from reading about this problem on the
Microsoft pages. There is a note in their stuff that says the
enhanced driver was not in straight XP, but was in SP1. The enhanced
driver does not get installed or updated automatically when you
install SP1. I don't know and really don't care why; it is their
problem and they said so.

It reads that if you want the enhanced driver, you have to update it
manually which is what worked for me. Maybe it should have gotten
updated automatically when I installed SP1, SP2, SP3 or with automatic
updates, but it did not for me. Maybe it works for you. If you buy a
system with XP installed for you they said it will probably already be
installed. My laptop is fine, but it came that way. My desktop was
not fine, but I built it from scratch.

Anyway, this has gotten rid of the annoying message on two other
homegrown XP SP3 computers around me so far, so maybe it will work for
someone else out there.

I just saw this in a lot of searches, but there was no "fix". The
fixes I read were: live with it, turn off the message, you have a bad
cable...


"M.I.5¾" <no.one@no.where.NO_SPAM.co.uk> wrote in message
news:49770214$1_1@glkas0286.greenlnk.net...
> USB2 drivers were included in Windows XP Service Pack 2. AFAIK it is not
> possible to use USB2 with any earlier version (though I believe 3rd party
> drivers for some 3rd party cards will work as they provide the necessary
> support).



Actually support for the USB 2.0 interface was supposed to be provided in
SP1. However we've encountered a number of situations similar to Jose's
(even when the system contained SP2) when the "HI-SPEED USB Device Plugged
into non-HI-SPEED USB Hub" and then the "There are no HI-SPEED USB host
controllers installed on this computer" messages appeared. Yet we were
working with a motherboard that supported the USB 2.0 protocol.

We found in a number of instances that it was necessary to install an
auxiliary controller driver provided by the motherboard's manufacturer. In
some instances a BIOS upgrade resolved the problem. Anyway, (as far as I can
recall) it's not something we've run into with motherboard's manufactured
during the past (approx)four years or so. And as best as I can recall when
the problem did arise it invariably involved an NVIDIA chipset (not an Intel
one).
Anna


Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows XP > Windows XP Support
Tags: , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "The USB device can perform faster if you connect it to a High SpeedUSB 2.0 port"
Thread Thread Starter Forum Replies Last Post
USB Device can Perform Faster message on Windows xp Ihit XP Hardware 9 31-03-2012 09:42 PM
How to disable “This device can perform faster” balloon in Windows 7? Smita.bendal Operating Systems 3 15-01-2010 05:22 PM
Supressing the "this device can perform faster" message Cris Han Windows XP Support 2 12-09-2009 07:12 PM
Which RAM will perform Faster? 2x1024 or 1x2048 Maryna Motherboard Processor & RAM 4 11-11-2008 06:18 AM
High speed device to what USB port? Leo Pold XP Hardware 3 04-04-2008 11:03 PM


All times are GMT +5.5. The time now is 01:59 PM.