Go Back   TechArena Community > Technical Support > Computer Help > Windows XP > Windows XP Support
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



USB mass storage devices not working properly under XP SP3

Windows XP Support


Reply
 
Thread Tools Search this Thread
  #1  
Old 03-10-2008
Simon
 
Posts: n/a
USB mass storage devices not working properly under XP SP3

I have a Samsung digital camera with 4GB SDHC card, Sandisk SDDR-89 Imagemate
12 in 1 reader and WD 2TB mirror external drive. Operation on USB is erratic.

Imagemate installs OK but XP does not recognise the card types so all
assigned drive are listed as 'removable disk. SD cards read OK but My
Computer freezes if a CF card is inserted. Response is hopelessly slow.

Samsung digital camera hung up during plug and play. It eventually installed
and I can get into the disk but clicking on any files freezes My Computer. In
any case response is very slow.

WD external mirror drive did not install correctly during plug and play. The
drive appears but indicates no volume.

All this hardware rund fine on a Vista machine. Both my XP machines exhibit
similar problems. I have tried updating all system drivers, bios and Windows.
I have checked all the hardware and it all seems to be OK. I have removed the
USB host controllers to force reinstallation of all the devices but no
change. I have ensured that all security applications are disabled and
repeated all the steps at least 6 times so far. My PC supplier is baffled and
everything points to a major problem with XP.
Other USB devices like keyboard, mouse, printer etc are working fine. The
problem only seems to be affecting mass storage devices. None of the affected
devices use manufacturers drivers. All of them are reliant on the native XP
USB drivers. Tried rolling back to SP2 but I doubt that I am getting a clean
install.

I am out of ideas. Tried to buy some Microsoft technical support but the
online system will not accept any of my credit card numbers (how convenient).
So far I have racked up 100+ hours getting nowhere. Sandisk have told me that
Microsoft have an unresolved USB problem with SP3. Does anyone out there know
anything?

Reply With Quote
  #2  
Old 03-10-2008
Leonard Grey
 
Posts: n/a
Re: USB mass storage devices not working properly under XP SP3

I have the identical card reader, and I can confirm that it works
perfectly on Windows XP SP 3. (The ImageMate software is unneeded and I
did not install it.)

To use the device I simply plug my SDHC card into the reader and then
plug the reader into a USB port. In a second or two the SDHC card shows
up in My Computer with a drive letter. To transfer images from the SDHC
card to my computer I simply drag and drop.

Did SanDisk explain the nature of the "unresolved USB problem with SP3"?
It's hard to diagnose a problem when the description is that vague.

For best results, plug the reader into a USB port directly on the
computer (i.e., do not plug into a hub.) If that doesn't work, try a
different USB port a or a different USB cable. Make sure all connections
are tight (including making sure that the SDHC card facing the right way
and is inserted all the way.)

Just about any card reader works the same way, so try a different card
reader.
---
Leonard Grey
Errare humanum est

"A Day in the Life of a Web 2.0 Hacker" - PC Magazine
http://www.pcmag.com/article2/0,2817,2330952,00.asp

Simon wrote:
> I have a Samsung digital camera with 4GB SDHC card, Sandisk SDDR-89 Imagemate
> 12 in 1 reader and WD 2TB mirror external drive. Operation on USB is erratic.
>
> Imagemate installs OK but XP does not recognise the card types so all
> assigned drive are listed as 'removable disk. SD cards read OK but My
> Computer freezes if a CF card is inserted. Response is hopelessly slow.
>
> Samsung digital camera hung up during plug and play. It eventually installed
> and I can get into the disk but clicking on any files freezes My Computer. In
> any case response is very slow.
>
> WD external mirror drive did not install correctly during plug and play. The
> drive appears but indicates no volume.
>
> All this hardware rund fine on a Vista machine. Both my XP machines exhibit
> similar problems. I have tried updating all system drivers, bios and Windows.
> I have checked all the hardware and it all seems to be OK. I have removed the
> USB host controllers to force reinstallation of all the devices but no
> change. I have ensured that all security applications are disabled and
> repeated all the steps at least 6 times so far. My PC supplier is baffled and
> everything points to a major problem with XP.
> Other USB devices like keyboard, mouse, printer etc are working fine. The
> problem only seems to be affecting mass storage devices. None of the affected
> devices use manufacturers drivers. All of them are reliant on the native XP
> USB drivers. Tried rolling back to SP2 but I doubt that I am getting a clean
> install.
>
> I am out of ideas. Tried to buy some Microsoft technical support but the
> online system will not accept any of my credit card numbers (how convenient).
> So far I have racked up 100+ hours getting nowhere. Sandisk have told me that
> Microsoft have an unresolved USB problem with SP3. Does anyone out there know
> anything?

Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows XP > Windows XP Support
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "USB mass storage devices not working properly under XP SP3"
Thread Thread Starter Forum Replies Last Post
Will HTC One X support USB mass storage? Prem-Din Portable Devices 7 27-03-2012 12:47 PM
USB mass storage driver? Hrishia Windows XP Support 5 18-12-2011 12:54 AM
What is UEFI and new storage devices Lambodar Hardware Peripherals 5 12-11-2010 12:18 AM
USB Mass Storage Device Driver Missing/Not working? Nadeem Windows XP Support 2 21-04-2008 12:14 PM
usb mass storage inactive Victor Kam Windows XP Support 4 27-09-2007 11:58 AM


All times are GMT +5.5. The time now is 03:08 PM.