Results 1 to 4 of 4

Thread: Fixed: The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID

  1. #1
    Join Date
    Sep 2005
    Posts
    74

    Fixed: The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID

    If anyone comes across this error in their even viewer "The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID {555F3418-D99E-4E51-800A-6E89CFD8B1D7} to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19). This security permission can be modified using the Component Services administrative tool." They can try following below steps for fixing it.
    • Go into registry at: HKEY_CLASSES_ROOT\CLSID\{555F3418-D99E-4E51-800A-6E89CFD8B1D7}, copy the key:AppId:{B1B9CBB2-B198-47E2-8260-9FD629A2B2EC} and paste it into text editor.
    • Go to Start > Run > Type "dcomcnfg" without quotes. Once you get ComponentServices, Right click on DCOM Config, select Properties, change view to details, check out for matching {B1B9CBB2-B198-47E2-8260-9FD629A2B2EC}.
    • Now select its Properties >Security >Launch and Activation Permissions >Custom >Add local activation for local service account and check out if there is any account which do not have right permissions. You can refer to below article for setting right permissions.
      Event 10016 may be logged in the System log on a computer that is running Windows XP Professional x64 Edition

  2. #2
    Join Date
    Nov 2009
    Posts
    2

    Re: Fixed: The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID

    Hi
    it was worked for me.

    Thanks

  3. #3
    Join Date
    Nov 2009
    Posts
    761

    Re: Fixed: The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID

    Under Dcom Config you can find a sub node with similar name. It is 000C101C-0000-0000-C000-000000000046. You have to right click on the same and choose Properties. The process is almost same but this worked for me. Go to Security. There you can find a number of things here are disabled. When you are unable to modify the same then it means you don't have admin privileges for this thing. You have to grant a full permission to your own account and then go ahead with restarting the service. This would be more than enough to fix the problem.

  4. #4
    Join Date
    Aug 2011
    Posts
    423

    Re: Fixed: The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID

    Sometime there is a bit issue with fixing the permission. It is weird to find that the permission is simply restored back to old one when you had done nothing in the settings. I am unable to get a proper idea why this thing is saved forever. I had done some updates recently and the same issue appeared back again. What thing in the system is altering the permission thing. I am looking for a good DCOM Config management tool. Through which I can fix the permission with single click instantly.

Similar Threads

  1. Replies: 3
    Last Post: 20-03-2011, 05:40 AM
  2. Registering intel application store in local server machine
    By Virendra 89 in forum Networking & Security
    Replies: 7
    Last Post: 23-02-2011, 09:02 AM
  3. Restoring default permission of folder on Acer Aspire 5735
    By $Herbert$ in forum Operating Systems
    Replies: 4
    Last Post: 26-12-2010, 09:19 PM
  4. My server permission and security settings are messed up
    By BRIGHID in forum Networking & Security
    Replies: 5
    Last Post: 30-11-2010, 11:19 PM
  5. How to grant permission?
    By Roxy_jacob in forum Software Development
    Replies: 4
    Last Post: 16-12-2009, 01:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •