Results 1 to 2 of 2

Thread: Windows installer service cant start Error 193:0xc1 ???

  1. #1
    Join Date
    Sep 2005

    Windows installer service cant start Error 193:0xc1 ???

    I wanted to install Service pack for Visual Studio 2005 on my Windows Vista based computer. But when I start the Windows installer service it gives me error saying “Windows installer service cant start Error 193:0xc1”.

    I tried installing any other setup with .MSI but that too failed with an error “The Windows Installer Service could not be accessed.” I’m just unable to install anything with MSI.

    To find out some info about this errors and problems I went to check Event Viewer log where I found this:
    The Windows Installer service failed to start due to the following error:
    Windows Installer is not a valid Win32 application.

    I don’t have any idea what to do to get rid of these errors. Can anyone help me out please ?

  2. #2
    Join Date
    Feb 2009

    Re: Windows installer service cant start Error 193:0xc1 ???

    Go to Add/Remove Programs for windows xp or Programs and Features in Windows Vista and uninstall the Windows Installer program. Then go to the Microsoft Website and reinstall the program. You can find the link to the Windows Installer Installation program here. Or you can follow the steps mentioned here.

Similar Threads

  1. Start service error 193 0xc1
    By Robbin M in forum Windows XP Support
    Replies: 2
    Last Post: 02-01-2014, 03:32 PM
  2. Replies: 1
    Last Post: 18-04-2010, 07:08 AM
  3. Windows installer service Error 193:0xc1
    By Sanith in forum Networking & Security
    Replies: 6
    Last Post: 19-09-2009, 06:33 PM
  4. windows installer error 193:0xc1 PLZ HELP
    By taigi in forum Windows Software
    Replies: 1
    Last Post: 19-09-2009, 01:53 PM
  5. Replies: 6
    Last Post: 25-02-2008, 09:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts