Go Back   TechArena Community > Technical Support > Computer Help > Windows Vista > Windows Vista Performance
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Audiodg.exe consuming full 100% cpu

Windows Vista Performance


Reply
 
Thread Tools Search this Thread
  #1  
Old 13-06-2006
Member
 
Join Date: Oct 2005
Posts: 39
Audiodg.exe consuming full 100% cpu

My computer started freezing on its own. I cannot find the reason behind that. But something happened to my system. I checked in Task Manager and found that the audiodg.exe is consuming maximum process. The cpu usage is almost 100% percent. When I terminate that the system went back to normal, but after a few minutes it starts again. It is quiet irritating. I just installed a tool bar and this started happening. Is this a virus. I am using AVG and it did not found anything.

Reply With Quote
  #2  
Old 26-06-2006
Member
 
Join Date: Sep 2004
Posts: 142
It looks something related to your audio driver. I do not think this would be a virus. There can be some issue with the internal sound device. Do this go in Device Manager > and right click on the audio device. Click on update drivers. If this does not work then I will advice you to re-install the sound device. You can locate the drivers from motherboard manufacturer's website or from the disc that comes with every new system.
Reply With Quote
  #3  
Old 26-06-2006
Member
 
Join Date: Sep 2004
Posts: 131
re: Audiodg.exe consuming full 100% cpu

It is a windows file. It is weird to find that a audio application can use full system resource. To fix the problem right click on the small speaker icon in system tray. You can find properties box there. Click on that and go to Playback. Remove the checkmark of device which is selected. Go to Enhancement and then uncheck everything inside. Do not leave anything working. Click on OK and then see. I think updating drivers will be quiet helpful in many ways to deal with the problem.
Reply With Quote
  #4  
Old 02-07-2006
Member
 
Join Date: Sep 2004
Posts: 136
re: Audiodg.exe consuming full 100% cpu

It is a essential audio component. But some virus or spyware can enter your system and cause issue. I thin this is a virus problem. Virus are capable of infecting internal system files and then spreading to the entire system. You must scan your system in safe mode and then check whether it is proper or not. I had seen a list of associated virus which are similar to this file and they affect the system. I do not think there is some appropriate way to get rid of it. If you are antivirus is capable it will scan and clean your system.
Reply With Quote
  #5  
Old 02-07-2006
Member
 
Join Date: Sep 2004
Posts: 151
I had faced this situation while using a Creative Card. I bought a new Soundblaster Live 5.1. I have a 64bit system. I found the drivers online. After installation I notice that the system performance is completely utilized by audiodg file. It is eating high system ram and after ending it, there was no audio at all. Later on I located the 64bit edition of drivers and perform some Windows Update. The system is working quiet fine.
Reply With Quote
  #6  
Old 07-05-2007
Member
 
Join Date: May 2007
Posts: 1
Not sure if that will lower the sound quailty but at least my lowly P4 2.66Ghz doesn't skip anymore. Now audiodg.exe run less than 5% of the CPU time. From last couple of weeks I was facing too many problems with my PCs sound. Sometimes I use to get crackling sound, sometimes while listening songs my CPU usage was going very high, and many such problems. After working out on the same I came to know that the problem was created by Audiodg.exe. Finally I managed too find out a solution that solved all these sound problems. Hence I thought to share the same here considering it could help other people as well with the same problem.

Here it is :
  • Right click on the speaker / volume icon in the System Tray
  • Select Playback Devices
  • Highlight the icon with the green check mark
  • Now click Properties and go to Advanced Tab
  • Here you just need to uncheck Enable audio enhancements

That’s it. Now though I can see audiodg.exe running in the task manager but it is consuming less than 5% of my CPU instead of 50% earlier.
Reply With Quote
  #7  
Old 14-01-2009
Member
 
Join Date: Jan 2009
Posts: 1
re: Audiodg.exe consuming full 100% cpu

The audiodg proces is indeed a system process, which is used sound processing on your machine. More about the process can be read in this blog post. The solution to the CPU problem has been to me to disable the service in computer management at reboot, so it wouldn't start at system bootup. Then, when I'm back in windows, I just re-enable it. At that point in time, it won't eat your CPU anymore.I have no exact explanation to why it eats that much cpu, but I expect it to be a driver incompatibility. Probably the Realtek AC97 (in my case) drivers aren't reacting the way audiodg expects them to do.
Reply With Quote
  #8  
Old 22-05-2009
Member
 
Join Date: May 2009
Posts: 1
Re: Audiodg.exe - FIXED

Quote:
Originally Posted by HemanC View Post
right click on the speaker icon at the bottom right.
select Playback Devices
highlight the icon with the green check mark
click Properties
click the Advanced tap
uncheck Enable audio enhancements
Not sure if that will lower the sound quailty but at least my lowly P4 2.66Ghz doesn't skip anymore. Now audiodg.exe run less than 5% of the CPU time.
HemanC i did what you said and the audiodg.exe dosent eat up much of my CPU anymore but now my vent and msn voicecalls dont get any sound from it is there anyway to fix it?
Reply With Quote
  #9  
Old 19-02-2011
Member
 
Join Date: Feb 2011
Posts: 1
re: Audiodg.exe consuming full 100% cpu

Due to recent updates I was having the same problem described here. Interesting thing is it was nothing to do with audiodg.exe at all. Whether it was what came from Microsoft or not something changed my power saver options. There was low power going to the CPU. Check you settings! This may be simpler than you realized!
Reply With Quote
  #10  
Old 20-03-2011
Member
 
Join Date: Mar 2010
Posts: 3
Re: Audiodg.exe - FIXED

Did unchecking only “Enable audio enhancements” fixed your problem? It dint worked for me unless and until I disabled all enhancements for the recording audio devices as well. BTW, thanks for sharing the tip.
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows Vista > Windows Vista Performance
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Audiodg.exe consuming full 100% cpu"
Thread Thread Starter Forum Replies Last Post
How do you restart the audiodg? PKTun Windows Software 2 30-12-2011 04:07 PM
audiodg.exe process results in Memory leaks GOOL Operating Systems 3 23-12-2010 10:38 PM
Crackling sound and audiodg.exe problems Chitamacha Hardware Peripherals 6 11-09-2010 06:34 AM
audiodg.exe causes 99% of CPU usage windows_user Operating Systems 4 19-02-2009 05:09 PM
Audiodg.exe takes 40-50% CPU when playing games Khongordzol Windows Vista Performance 1 02-08-2008 10:04 PM


All times are GMT +5.5. The time now is 02:14 PM.