Go Back   TechArena Community > Technical Support > Computer Help > Windows XP > Windows Update
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



error 0x8007F0F4 when installing update KB944338

Windows Update


Reply
 
Thread Tools Search this Thread
  #1  
Old 09-04-2008
shawnr
 
Posts: n/a
error 0x8007F0F4 when installing update KB944338

Repeated attempts to install this update from MS updates result in error code
0x8007F0F4. I have not tried through WSUS yet.
KB944338.log:
C:\WINDOWS\SoftwareDistribution\Download\77a3382edfdc03e5fb59ec5858f5073e\update\update.exe (version 6.2.29.0)
1.109: Hotfix started with following command line: /si
/ParentInfo:bb999d44bb8b9647ae1f5a977943f5ed
1.109: FileVersion of C:\Program Files\internet explorer\iexplore.exe is
Greater or Equal To 7.0.0.0
1.109: Condition Check for Line 1 of PreRequisite returned FALSE
1.109: KB944338 Setup encountered an error: The version of Internet
Explorer you have installed does not match the update you are trying to
install.
1.109: The version of Internet Explorer you have installed does not match
the update you are trying to install.
1.109: Update.exe extended error code = 0xf0f4

It appears browser detection has a problem. OS xpsp2, browser 7.0
I have opened ticket with support. Anybody else seeing this?

Reply With Quote
  #2  
Old 09-04-2008
Eric
 
Posts: n/a
Hi,

What version of vbscript.DLL and Jscript.dll do you have?
Reply With Quote
  #3  
Old 09-04-2008
Cj
 
Posts: n/a
Re: error 0x8007F0F4 when installing update KB944338

am having the same issues,,,, IE7, and 5.6 for JScript and VBScript,, for
HOT FIX for KB944338,,,, have tried 3+ times,, all same results,,


"PA Bear [MS-MVP]" wrote:

> > It appears browser detection has a problem. OS xpsp2, browser 7.0
> > I have opened ticket with support. Anybody else seeing this?

>
> Please keep us posted on what PSS might have to say, Shawn.
> --
> ~PA Bear
>
> On Apr 8, 4:10 pm, shawnr <sha...@discussions.microsoft.com> wrote:
> > Repeated attempts to install this update from MS updates result in error code
> > 0x8007F0F4. I have not tried through WSUS yet.
> > KB944338.log:
> > C:\WINDOWS\SoftwareDistribution\Download\77a3382edfdc03e5fb59ec5858f5073e\u*pdate\update.exe (version 6.2.29.0)
> > 1.109: Hotfix started with following command line: /si
> > /ParentInfo:bb999d44bb8b9647ae1f5a977943f5ed
> > 1.109: FileVersion of C:\Program Files\internet explorer\iexplore.exe is
> > Greater or Equal To 7.0.0.0
> > 1.109: Condition Check for Line 1 of PreRequisite returned FALSE
> > 1.109: KB944338 Setup encountered an error: The version of Internet
> > Explorer you have installed does not match the update you are trying to
> > install.
> > 1.109: The version of Internet Explorer you have installed does not match
> > the update you are trying to install.
> > 1.109: Update.exe extended error code = 0xf0f4
> >
> > It appears browser detection has a problem. OS xpsp2, browser 7.0
> > I have opened ticket with support. Anybody else seeing this?

>

Reply With Quote
  #4  
Old 09-04-2008
PA Bear [MS MVP]
 
Posts: n/a
Re: error 0x8007F0F4 when installing update KB944338

Attach %windir%/windowsupdate.log <=this file to an email message to
ericbrod@microsoft.com.

Give the email the following subject: "error 0x8007F0F4 when installing
update KB944338"

=================================

Otherwise...

Start a free Windows Update support incident request:
https://support.microsoft.com/oas/de...spx?gprid=6527

Support for Windows Update:
http://support.microsoft.com/gp/wusupport

For home users, no-charge support is available by calling 1-866-PCSAFETY in
the United States and in Canada or by contacting your local Microsoft
subsidiary. There is no-charge for support calls that are associated with
security updates. When you call, clearly state that your problem is related
to a Security Update and cite the update's KB number (e.g., KB944338).

For more information about how to contact your local Microsoft subsidiary
for security update support issues, visit the International Support Web
site: http://support.microsoft.com/common/international.aspx

For enterprise customers, support for security updates is available through
your usual support contacts.
--
~Robear Dyer (PA Bear)
MS MVP-Windows (IE, OE, Security, Shell/User)
AumHa VSOP & Admin; DTS-L.net


Cj wrote:
> am having the same issues,,,, IE7, and 5.6 for JScript and VBScript,,
> for
> HOT FIX for KB944338,,,, have tried 3+ times,, all same results,,

<snip>

Reply With Quote
  #5  
Old 09-04-2008
Harry Johnston [MVP]
 
Posts: n/a
Re: error 0x8007F0F4 when installing update KB944338

shawnr wrote:

> both are ver 5.6.


Did you check the version of the actual DLL files, or just the installed version
of VBScript/Javascript? (Normally you'd expect them to be the same, but that
isn't true in this case.)

You can check the file version by navigating to c:\windows\system32, selecting
jscript.dll, right-clicking, selecting Properties, and going to the Version tab.
Please let us know the full version number, and also the modification date and
file size in bytes.

The reason I ask is that IE7 includes version 5.7.0.5730 of jscript.dll and
vbscript.dll, so it shouldn't be possible to have version 5.6 if IE7 is installed.

Harry.
Reply With Quote
  #6  
Old 14-04-2008
Harry Johnston [MVP]
 
Posts: n/a
Re: error 0x8007F0F4 when installing update KB944338

libit wrote:

> However this brings up the following question:
> If this fix doesn't work for people with vbscript 5.6 and is not necessary
> for people with vbscript 5.7, what's its reason to exist, if any at all ????


The patch is intended for systems with neither Internet Explorer 7 nor Windows
Script 5.7 installed. If neither of these are present, the patch works.

(The problem occurs when IE7 is present but the Windows Script 5.7 components it
includes are not; this situation shouldn't happen, and seems to have been
unanticipated.)

Harry.
Reply With Quote
  #7  
Old 14-04-2008
graft
 
Posts: n/a
Re: Windows Update - KB944338

Wi have the same Problem with over 100 computers in our company.
Installing Script 5.7 is no solution.. it's only a workaround for a single
computer.

MS must fix this Patch!

Thx

"PA Bear [MS MVP]" wrote:

> 1. Download/install Windows Script 5.7 for WinXP SP2 (only!):
> http://www.microsoft.com/downloads/d...6-524e7e844d81
>
> 2. Then make sure the machine is otherwise fully patched at WIndows Update.
> --
> ~PA Bear
>
> libit wrote:
> > this update is failing for me too. I've IE 7.0.5730.11 and
> > vbscript 5.6.0.8825.
> > So it seems that the ie7 update didn't always update vbscript, or
> > something
> > else overwrote that with vbscript 5.6 thereafter (visualStudio? )
> >
> > What's the mircosoft recommend solution for this issue?
> >
> > "PA Bear [MS MVP]" wrote:
> >
> >> Windows version? IE version?
> >> --
> >> ~Robear Dyer (PA Bear)
> >> MS MVP-IE, Mail, Security, Windows Desktop Experience - since 2002
> >> AumHa VSOP & Admin http://aumha.net
> >> DTS-L http://dts-l.net/
> >>
> >> Julea Bell wrote:
> >>> I'm unable to download and install KB944338. I go to Windows Update and
> >>> when viewing my history it shows this update failed.
> >>>
> >>> I get this when research the update site, but am unable to find anything
> >>> about it -- error 0x8007F0F4 when installing update KB944338.
> >>>
> >>> How does one get this update accomplished?
> >>>
> >>> Thanks

>
>

Reply With Quote
  #8  
Old 15-04-2008
Raillon
 
Posts: n/a
Re: Windows Update - KB944338

While I agree that it would be best for MS to fix its fix, and that
installing Windows Script 5.7 is a workaround, deploying Windows Script can
be done through automated deployment tools. An example for SMS 2003, without
sms_def.mof extended to allow IE version detection through registry key:

1. Make sure that Software Inventory is set to gather exe details in at
least C:\Program Files\Internet Explorer.

2. Make sure that Software Inventory is set to gather dll details in at
least C:\Windows\System32.

3. Set up a query-based collection to detect for iexplore.exe (at C:\Program
Files\Internet Explorer) >= version 7, with jscript.dll or vbscript.dll (at
C:\Windows\System32) with version < 5.6.0.8355. Here's the Query Language
code: select distinct SMS_R_System.Name from SMS_R_System inner join
SMS_G_System_SoftwareFile on SMS_G_System_SoftwareFile.ResourceID =
SMS_R_System.ResourceId where (SMS_G_System_SoftwareFile.FileName =
"jscript.dll" or SMS_G_System_SoftwareFile.FileName = "vbscript.dll") and
SMS_G_System_SoftwareFile.FileVersion < "5.6.0.8835" and
SMS_G_System_SoftwareFile.FilePath = "C:\\WINDOWS\\system32\\" and
SMS_R_System.Name in (select SMS_R_System.Name from SMS_R_System inner join
SMS_G_System_SoftwareFile on SMS_G_System_SoftwareFile.ResourceID =
SMS_R_System.ResourceId where SMS_G_System_SoftwareFile.FileName =
"iexplore.exe" and SMS_G_System_SoftwareFile.FileVersion >= "7" and
SMS_G_System_SoftwareFile.FilePath = "C:\\Program Files\\Internet Explorer\\")

That will show which computers fall into the IE7 vs KB944338 hole. You may
want to use a separate collection for each affected OS. Then use Software
Distribution to apply Windows Script 5.7 to all the affected computers by OS.

One of our techs also has a theory that some 3rd party installs may actually
downgrade jscript.dll and/or vbscript.dll from 5.7 to 5.6 after an IE7
install. I haven't yet been able to prove nor disprove this theory. If it's
true, then I especially would like for MS to fix KB944338's
detection/deployment logic so I don't have to leave a Windows Script 5.7
advertisement active in our SMS to cover this hole.

"graft" wrote:

> Wi have the same Problem with over 100 computers in our company.
> Installing Script 5.7 is no solution.. it's only a workaround for a single
> computer.
>
> MS must fix this Patch!
>
> Thx

Reply With Quote
  #9  
Old 15-04-2008
Harry Johnston [MVP]
 
Posts: n/a
Re: Windows Update - KB944338

graft wrote:

> Wi have the same Problem with over 100 computers in our company.
> Installing Script 5.7 is no solution.. it's only a workaround for a single
> computer.
>
> MS must fix this Patch!


There isn't actually a problem with the patch; the problem (mismatched
components) was already present on your computers, the patch just revealed it.

The cause of the problem is currently unknown, but theories include third-party
anti-malware software preventing system components from being updated during the
IE7 install and third-party installers downgrading the components afterwards.
(I favour the latter theory but more experienced experts seem to prefer the
former, so YMMV.)

Hopefully Microsoft will release an automated fix at some point, either via this
patch or an IE7 patch. But as it is likely to take some time, you may prefer to
deploy Script 5.7 either via a solution like SMS (as Raillon describes) or with
a startup script, or (failing all else) by brute force. How do you deploy
third-party software updates?

Harry.
Reply With Quote
  #10  
Old 15-04-2008
graft
 
Posts: n/a
Re: Windows Update - KB944338



"Harry Johnston [MVP]" wrote:

> graft wrote:
>
> > Wi have the same Problem with over 100 computers in our company.
> > Installing Script 5.7 is no solution.. it's only a workaround for a single
> > computer.
> >
> > MS must fix this Patch!

>
> There isn't actually a problem with the patch; the problem (mismatched
> components) was already present on your computers, the patch just revealed it.
>
> The cause of the problem is currently unknown, but theories include third-party
> anti-malware software preventing system components from being updated during the
> IE7 install and third-party installers downgrading the components afterwards.
> (I favour the latter theory but more experienced experts seem to prefer the
> former, so YMMV.)


I have found the source of my problems. I have installed Windows Script 5.6
manually on these machine due to Problems with the installation of another
software. I know since thursday last week that an newer version of Windows
Script (5.7) exist.
Was it my error? Was it the error from Windows Script 5.6 to install over an
newer Version? Is it the error in Patch KB944338?

I think it's not my error!

> Hopefully Microsoft will release an automated fix at some point, either via this
> patch or an IE7 patch. But as it is likely to take some time, you may prefer to
> deploy Script 5.7 either via a solution like SMS (as Raillon describes) or with
> a startup script, or (failing all else) by brute force. How do you deploy
> third-party software updates?
>
> Harry.
>

Reply With Quote
  #11  
Old 15-04-2008
Raillon
 
Posts: n/a
Re: Windows Update - KB944338

"graft" wrote:

>
> I have found the source of my problems. I have installed Windows Script 5.6
> manually on these machine due to Problems with the installation of another
> software. I know since thursday last week that an newer version of Windows
> Script (5.7) exist.
> Was it my error? Was it the error from Windows Script 5.6 to install over an
> newer Version? Is it the error in Patch KB944338?
>
> I think it's not my error!
>


Thank you, graft - I didn't even think about testing the installation of
Windows Script 5.6 over jscript.dll/vbscript.dll 5.7. It turns out this DOES
successfully downgrade these dlls to 5.6 - in fact, this even happens if
Windows Script 5.7 was previously directly installed.

> "Harry Johnston [MVP]" wrote:
>
> >
> > There isn't actually a problem with the patch; the problem (mismatched
> > components) was already present on your computers, the patch just revealed it.
> >
> > The cause of the problem is currently unknown, but theories include third-party
> > anti-malware software preventing system components from being updated during the
> > IE7 install and third-party installers downgrading the components afterwards.
> > (I favour the latter theory but more experienced experts seem to prefer the
> > former, so YMMV.)


graft's information and my confirmation show that jscript.dll/vbscript.dll
can indeed be downgraded from 5.7 to 5.6, so your theory is shown to be
possible, Harry. However, I do agree with graft that MS is at fault here - by
not allowing the exe to apply when IE7 and jscript.dll/vbscript.dll 5.6 are
present, and not even giving a correctly-informative error message, it leaves
the end-user in confusion as to what to do. If MS protected
jscript.dll/vbscript.dll from downgrading (at least from 5.7 when IE7 is
present), this situation could have been avoided. However, the downgrading is
not prevented, so MS should have included this possible situation in
KB944338's exe's logic. If the error message from KB944338's exe indicated
that with IE7, Windows Script should also be 5.7, and is not, then the
end-user would know what to do.

As it is, with this oversight I must leave automated detection of IE and
Windows Script version (with upgrade of Windows Script when needed) constant
in my environment, lest Windows Script be downgraded by other installs,
leaving a security hole in which KB944338 cannot be applied.
Reply With Quote
  #12  
Old 16-04-2008
Harry Johnston [MVP]
 
Posts: n/a
Re: Windows Update - KB944338

Raillon wrote:

> If MS protected
> jscript.dll/vbscript.dll from downgrading (at least from 5.7 when IE7 is
> present), this situation could have been avoided.


Yes, this is certainly a bug in the Windows Script 5.6 installer.

> [...] so MS should have included this possible situation in
> KB944338's exe's logic. If the error message from KB944338's exe indicated
> that with IE7, Windows Script should also be 5.7, and is not, then the
> end-user would know what to do.


Sure, but this situation was not anticipated.

> As it is, with this oversight I must leave automated detection of IE and
> Windows Script version (with upgrade of Windows Script when needed) constant
> in my environment, lest Windows Script be downgraded by other installs,
> leaving a security hole in which KB944338 cannot be applied.


Hopefully there will eventually be a better resolution. However, assuming the
downgrade does not happen frequently, you could use the failure of KB944338 as a
warning sign to identify those machines that need assistance.

Harry.
Reply With Quote
  #13  
Old 17-04-2008
Raillon
 
Posts: n/a
Re: Windows Update - KB944338

Harry, thank you for your continued conversation on this. A few more thoughts:

"Harry Johnston [MVP]" wrote:
> Yes, this is certainly a bug in the Windows Script 5.6 installer.


I'm not sure it's just the Windows Script 5.6 installer - it appears that
jscript.dll/vbscript.dll 5.7 can be overwritten with older versions from any
installer. I'm not absolutely sure this is a bug - it may be by design.

> Sure, but this situation was not anticipated.


Agreed - however, since we've discovered the situation, I do hope it will be
corrected. I also expect that this situation will be anticipated in future
updates where its relevant.

> ...you could use the failure of KB944338 as a
> warning sign to identify those machines that need assistance.


I do have automated notification from my WSUS, however, I am not comfortable
with relying solely on manual response - we can get overwhelmed with other
items and not be able to quickly resolve each case. Though we always check on
machines that report WSUS failures (unless we're overwhelmed), with the
automated detection/application (and re-application if needed) of Windows
Script 5.7, I am better covered, especially since - in this case - a
compliant machine can suddenly become non-compliant due to an unrelated
install.
Reply With Quote
  #14  
Old 21-04-2008
4194dave
 
Posts: n/a
RE: error 0x8007F0F4 when installing update KB944338

i am having the same problem i re-installed windows service pack 2 but that
didnt fix the problem my next option is going to be to contact my computer's
manufacturer perhaps that will be helpful to you -when i ran a diagnostic
test on this problem that is what i was told to do

"shawnr" wrote:

> Repeated attempts to install this update from MS updates result in error code
> 0x8007F0F4. I have not tried through WSUS yet.
> KB944338.log:
> C:\WINDOWS\SoftwareDistribution\Download\77a3382edfdc03e5fb59ec5858f5073e\update\update.exe (version 6.2.29.0)
> 1.109: Hotfix started with following command line: /si
> /ParentInfo:bb999d44bb8b9647ae1f5a977943f5ed
> 1.109: FileVersion of C:\Program Files\internet explorer\iexplore.exe is
> Greater or Equal To 7.0.0.0
> 1.109: Condition Check for Line 1 of PreRequisite returned FALSE
> 1.109: KB944338 Setup encountered an error: The version of Internet
> Explorer you have installed does not match the update you are trying to
> install.
> 1.109: The version of Internet Explorer you have installed does not match
> the update you are trying to install.
> 1.109: Update.exe extended error code = 0xf0f4
>
> It appears browser detection has a problem. OS xpsp2, browser 7.0
> I have opened ticket with support. Anybody else seeing this?

Reply With Quote
  #15  
Old 24-04-2008
chanceu
 
Posts: n/a
Re: error 0x8007F0F4 when installing update KB944338

You say it's impossible, but I too am running XP SP2 with IE version
7.0.5730.11, jscript.dll version 5.6.0.8831, and vbscript.dll version
5.6.0.8825.

From what I've read, I have no doubt that installing the package you
describe will fix the problem. However, I would really like an explanation
detailing how this happened. This is either something malicious or we all
installed something reverted the DLL's to 5.6 instead of leaving the newer
versions in place.


"Harry Johnston [MVP]" wrote:

> shawnr wrote:
>
> > both are ver 5.6.

>
> Did you check the version of the actual DLL files, or just the installed version
> of VBScript/Javascript? (Normally you'd expect them to be the same, but that
> isn't true in this case.)
>
> You can check the file version by navigating to c:\windows\system32, selecting
> jscript.dll, right-clicking, selecting Properties, and going to the Version tab.
> Please let us know the full version number, and also the modification date and
> file size in bytes.
>
> The reason I ask is that IE7 includes version 5.7.0.5730 of jscript.dll and
> vbscript.dll, so it shouldn't be possible to have version 5.6 if IE7 is installed.
>
> Harry.
>

Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows XP > Windows Update
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "error 0x8007F0F4 when installing update KB944338"
Thread Thread Starter Forum Replies Last Post
Error Code: 0x8007F0F4 while installing windows KB2481109 Afiq Operating Systems 3 03-04-2011 07:36 AM
Error Code: 0x8007F0F4 for Windows XP Service Pack 3 (KB936929) John Sfinias Windows Update 3 08-09-2008 10:30 PM
Error Code: 0x8007F0F4 when installing Windows XP SP3 (KB936929) NBK123 Windows Update 5 26-07-2008 06:02 PM
Cannot install SP3 - Error 0x8007F0F4 onewharf Windows Update 1 11-05-2008 10:41 PM
Error Code 0x8007F0F4 when trying to install SP3 on windows xp AM Windows Update 3 08-05-2008 12:18 PM


All times are GMT +5.5. The time now is 07:19 AM.