Go Back   TechArena Community > Technical Support > Computer Help > Windows XP > Windows Update
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Windows Update (Error 80070422)

Windows Update


Reply
 
Thread Tools Search this Thread
  #1  
Old 23-06-2007
Agavar
 
Posts: n/a
Windows Update (Error 80070422)

I have been unable to do any updates since I got my new computer with Vista
Basic. I continually get the 80070422 error. I have gone into
Administrative Tools and checked Properties under Windows Update. At first
Automatic (Delayed) was selected, and I changed that to Automatic. The
Service status was already on Started. However, I still cannot do any
updates and still get the above error message.

Reply With Quote
  #2  
Old 23-06-2007
Gistcheckin
 
Posts: n/a
Restart background intelligence service
Retry updating.
I tried this, but still get the 80070433 error when I try to update.
Your Error # changed is it 80070422 or 80070433

Check the Dependency Tab on either of the above Services - It appears
something is missing from the service (80070433 error). Try to determine
what is missing.

To register the Wuaueng.dll file, follow these steps:
1. Click Start, click Run, type regsvr32 Wuaueng.dll, and then click OK.
2. When you receive the following message, click OK:
DllRegisterServer in Wuaueng.dll succeeded.

Retry installation

0x80070422 ERROR_SERVICE_DISABLED
In almost all cases user has probably disabled BITS service incorrectly
thinking that it would improve the computer perfomance.

http://technet2.microsoft.com/window....mspx?mfr=true

You may receive an error message that contains the "0x8DDD0018" code or the
"0x80246008" code when you try to download updates from the Microsoft Windows
Update Web site or from the Microsoft Update Web site
http://support.microsoft.com/kb/910337

Method 4: Reregister DLL files that are associated with Cryptographic Services
http://support.microsoft.com/?kbid=822798

I recently upgraded to the Home Basic Vista version and am experiencing
issues as well.

I checked my update log and found Error 1603 - Permissions
http://support.microsoft.com/kb/834484

I renamed my software distribution folder and retried updating with no
success. This is with the .NetFramework update. I used the cleaning tool to
remove it, reinstalled NetFramework 1.1 and the update manually. Still
windows update reappeared twice with the same update and both times
Successful was listed after I clicked install - It detected the update yet,
it showed again with the same update and today when I checked, that update is
no longer listed.

This may possibly what is happening if you've upgraded XP to Vista system as
I have. Update "detects" but it may take a couple of times for it to do so.

Error # 80070422
http://windowshelp.microsoft.com/Win...87ff61033.mspx

0x80070422 error
http://www.updatexp.com/0x80070422.html
Reply With Quote
  #3  
Old 23-06-2007
Rootax
 
Posts: n/a
I've the same problem since a few days with my Vista Ultimate x64. All my
services are started, i restarted them, i tried to rename the
SoftwareDistribution folder, so WU creates a new one, but the problem is
still here...

"{817A12BC-6517-4ACE-9F34-E1B3DFA634A6} 2007-06-23 15:04:09:796+0200 1 148
101 {61CA813A-7585-442E-A66B-B0D15CE6BDC0} 1 80070422 SelfUpdate Failure
Software Synchronization Windows Update Client failed to detect with error
0x80070422."

Windows Defender updates are ok though.

I found that the service "Windows Modules Installer" had been stopped and disabled. I had never gone into my services and stopped it so I assume another program did. However, I do not see that listed in the dependencies for Windows Updates or visa versa? As soon as I turned it on, my updates came back on.

I have tried all of these and I still get error code 80070422. Come on
Microsoft Vista is getting worse not better. How can I fix this?
Reply With Quote
  #4  
Old 22-12-2007
Member
 
Join Date: Dec 2007
Posts: 1
Go to ?Administrator Tools? (Control Panel > Administrator tools?

Select ?Services? and Run As Administrator.

Go to the Windows Update service, and select properties.

Set startup type to automatic and press OK, then restart the service.

Go to the Windows Modules Installer service, and select properties.

Enable the service, set the Startup to automatic, and start the service.

Close the Services window and run Windows Update again.
Reply With Quote
  #5  
Old 31-05-2008
Robert Aldwinckle
 
Posts: n/a
Look for some context in your logs to figure out *which* service cannot be started? ; }

In case Gistcheckin's guess for the OP was correct. You could also try using bitsadmin
(in a cmd window) to both check the status of your BITS service and optionally repair it.

Note that another service being disabled was identified as the problem cause
by another poster to this ancient thread.

Why not just open a free support incident? =>
http://support.microsoft.com/oas/def...spx?gprid=6527
Reply With Quote
  #6  
Old 17-11-2008
trevor roberts
 
Posts: n/a
We shall alert the media.

Please see this page then post back to this
thread with the information we'd need to be able to assist you properly.

Go to Start. Type 'msconfig' > then go to 'services'. Be sure that all
Micorosoft services are checked in. Then press OK. Your problem will
disappear. I have fixed the problem so simply.
Reply With Quote
  #7  
Old 24-06-2010
Tim Sokol
 
Posts: n/a
Fixed!

I know this post is 3-years old, but THANK YOU SO MUCH! I've been picking at this problem for the last year and never had luck with any helpful links or posts until now! Thank you Thank you Thank you!
Reply With Quote
  #8  
Old 24-06-2010
Andy
 
Posts: n/a
Re: FIXED!

its never an out of date or old fix if it fixes a problem for someone down
the road:)
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows XP > Windows Update
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Windows Update (Error 80070422)"
Thread Thread Starter Forum Replies Last Post
Error Code 80070422 with Windows Live Messenger Chandramukhi Chautala Technology & Internet 5 03-05-2012 06:53 AM
Getting Error code 80070422 on Age of Empires Online game Nabhan Video Games 6 21-08-2011 03:51 PM
SLMgr 0?80070422 error for Windows 7 Activation Juan-Carlos Operating Systems 3 06-12-2009 02:30 AM
Getting Update Error 80070422 in Windows 7 Santy Operating Systems 3 09-04-2009 12:14 PM
Windows Update Error Code 80070422 and Error code 1058 CloudJames Windows Update 4 10-01-2009 11:44 AM


All times are GMT +5.5. The time now is 04:26 PM.