Go Back   TechArena Community > Technical Support > Computer Help > Windows XP > Windows Update
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Windows Server 2003 Service Pack 2 installation did not complete

Windows Update


Reply
 
Thread Tools Search this Thread
  #1  
Old 30-04-2007
starki7
 
Posts: n/a
Windows Server 2003 Service Pack 2 installation did not complete

Hi!
I'm unsuccessfully trying for some time to install SP2.
I tried installing and uninstalling UDDI services, windows update, local
install but error messages are always the same.
Any suggestion is appreciated.
Thanks, starki!

Excerpt form the svcpack.log:
....
4177.266: Copied file: C:\WINDOWS\cluster\cladmwiz.dll
4177.516: Copied file: C:\WINDOWS\system32\spool\DRIVERS\W32X86\3\pclxl.dll
4177.906: DoInstallation: Installing assemblies with source root path:
c:\windows\softwaredistribution\download\bdc57de2c7888b99d2b9253b3d4d513d\
4285.922: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x2
4292.469: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x2
4318.219: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x2
4318.688: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
4318.766: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
4320.234: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
4320.234: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
4320.234: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
4320.234: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
4320.234: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
4320.234: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x2
4320.234: Num Ticks for Copying files : 2241390
4320.234: Starting process: %SystemRoot%\uddisp.exe install
"c:\windows\softwaredistribution\download\bdc57de2c7888b99d2b9253b3d4d513d\\"
4321.094: RunInfProcesses: SpawnProcessAndWaitForItToComplete on
"%SystemRoot%\uddisp.exe install
"c:\windows\softwaredistribution\download\bdc57de2c7888b99d2b9253b3d4d513d\\"" in [ProcessesToRunAfterCopying.IS] failed: 0x2
4321.094: Return Code = 2
4321.094: DoInstallation: RunInfProcesses for ProcessesToRunAfterCopying.IS
failed.
4321.094: Service Pack 2 Setup encountered an error: An error in updating
your system has occurred.
4349.281: Unregistration of sprecovr successful
4349.594: An error in updating your system has occurred.

Select 'OK' to undo the changes that have been made.
4349.594: Starting process:
C:\WINDOWS\$NtServicePackUninstall$\spuninst\spuninst.exe /~ -q -z
6921.719: Software Update Rollback has completed with return code 0xbc2.
This rollback requires a reboot.
6921.750: Service Pack 2 installation did not complete.

Windows Server 2003 has been partially updated and may not work properly.
6921.750: Update.exe extended error code = 0xf070

Excerpt form the uddisetup.log:
....
04/29/07 15:08:24: Installing Service Pack...
04/29/07 15:08:24: Incorrect usage of uddisp.exe. Wrong number of parameters.
04/29/07 15:08:24: Unknown error during UDDI install.

Reply With Quote
  #2  
Old 30-04-2007
PA Bear
 
Posts: n/a
Re: Windows Server 2003 Service Pack 2 installation did not complete

See these related, earlier threads (similar problems when installing SP1)
from microsoft.public.windows.server.general newsgroup, to which I'm
crossposting this reply for greater exposure:

http://groups.google.com/group/micro...2125f2a0038670

http://groups.google.com/group/micro...45dc38c7d3e22b
--
~Robear Dyer (PA Bear)
MS MVP-Windows (IE, OE, Security, Shell/User)
AumHa VSOP & Admin; DTS-L.org


starki7 wrote:
> Hi!
> I'm unsuccessfully trying for some time to install SP2.
> I tried installing and uninstalling UDDI services, windows update, local
> install but error messages are always the same.
> Any suggestion is appreciated.
> Thanks, starki!
>
> Excerpt form the svcpack.log:
> ...
> 4177.266: Copied file: C:\WINDOWS\cluster\cladmwiz.dll
> 4177.516: Copied file:
> C:\WINDOWS\system32\spool\DRIVERS\W32X86\3\pclxl.dll
> 4177.906: DoInstallation: Installing assemblies with source root path:
> c:\windows\softwaredistribution\download\bdc57de2c7888b99d2b9253b3d4d513d\
> 4285.922: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x2
> 4292.469: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x2
> 4318.219: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x2
> 4318.688: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
> 4318.766: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
> 4320.234: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
> 4320.234: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
> 4320.234: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
> 4320.234: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
> 4320.234: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
> 4320.234: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x2
> 4320.234: Num Ticks for Copying files : 2241390
> 4320.234: Starting process: %SystemRoot%\uddisp.exe install
> "c:\windows\softwaredistribution\download\bdc57de2c7888b99d2b9253b3d4d513d\\"
> 4321.094: RunInfProcesses: SpawnProcessAndWaitForItToComplete on
> "%SystemRoot%\uddisp.exe install
> "c:\windows\softwaredistribution\download\bdc57de2c7888b99d2b9253b3d4d513d\\""
> in [ProcessesToRunAfterCopying.IS] failed: 0x2 4321.094: Return Code = 2
> 4321.094: DoInstallation: RunInfProcesses for
> ProcessesToRunAfterCopying.IS
> failed.
> 4321.094: Service Pack 2 Setup encountered an error: An error in updating
> your system has occurred.
> 4349.281: Unregistration of sprecovr successful
> 4349.594: An error in updating your system has occurred.
>
> Select 'OK' to undo the changes that have been made.
> 4349.594: Starting process:
> C:\WINDOWS\$NtServicePackUninstall$\spuninst\spuninst.exe /~ -q -z
> 6921.719: Software Update Rollback has completed with return code 0xbc2.
> This rollback requires a reboot.
> 6921.750: Service Pack 2 installation did not complete.
>
> Windows Server 2003 has been partially updated and may not work properly.
> 6921.750: Update.exe extended error code = 0xf070
>
> Excerpt form the uddisetup.log:
> ...
> 04/29/07 15:08:24: Installing Service Pack...
> 04/29/07 15:08:24: Incorrect usage of uddisp.exe. Wrong number of
> parameters. 04/29/07 15:08:24: Unknown error during UDDI install.


Reply With Quote
  #3  
Old 04-05-2007
starki7
 
Posts: n/a
Re: Windows Server 2003 Service Pack 2 installation did not comple

Thanks Bear!

Articles don't match my problem.
I didn't mentioned before, I've already tried to uninstall and install SP1,
and it did well.

I used Sysinternals proces monitor to find out where is the problem, and I
think the problem is that update.exe proces can't find uddisp.exe (or maybe
it finds the wrong one).
From the trace it looks like update.exe looks for uddisp.exe in the %PATH% +
%SystemRoot%\uddisp.exe, and because uddisp.exe is in the %SystemRoot% it
can't find it.

I tried to change update.inf, to change reference to the uddisp.exe, but
it's digitaly signed.

Regards, Goran

"PA Bear" wrote:

> See these related, earlier threads (similar problems when installing SP1)
> from microsoft.public.windows.server.general newsgroup, to which I'm
> crossposting this reply for greater exposure:
>
> http://groups.google.com/group/micro...2125f2a0038670
>
> http://groups.google.com/group/micro...45dc38c7d3e22b
> --
> ~Robear Dyer (PA Bear)
> MS MVP-Windows (IE, OE, Security, Shell/User)
> AumHa VSOP & Admin; DTS-L.org
>
>
> starki7 wrote:
> > Hi!
> > I'm unsuccessfully trying for some time to install SP2.
> > I tried installing and uninstalling UDDI services, windows update, local
> > install but error messages are always the same.
> > Any suggestion is appreciated.
> > Thanks, starki!
> >
> > Excerpt form the svcpack.log:
> > ...
> > 4177.266: Copied file: C:\WINDOWS\cluster\cladmwiz.dll
> > 4177.516: Copied file:
> > C:\WINDOWS\system32\spool\DRIVERS\W32X86\3\pclxl.dll
> > 4177.906: DoInstallation: Installing assemblies with source root path:
> > c:\windows\softwaredistribution\download\bdc57de2c7888b99d2b9253b3d4d513d\
> > 4285.922: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x2
> > 4292.469: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x2
> > 4318.219: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x2
> > 4318.688: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
> > 4318.766: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
> > 4320.234: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
> > 4320.234: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
> > 4320.234: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
> > 4320.234: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
> > 4320.234: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x0
> > 4320.234: PruneCatalogsFromHotfixes:RegQueryValueEx Failed: 0x2
> > 4320.234: Num Ticks for Copying files : 2241390
> > 4320.234: Starting process: %SystemRoot%\uddisp.exe install
> > "c:\windows\softwaredistribution\download\bdc57de2c7888b99d2b9253b3d4d513d\\"
> > 4321.094: RunInfProcesses: SpawnProcessAndWaitForItToComplete on
> > "%SystemRoot%\uddisp.exe install
> > "c:\windows\softwaredistribution\download\bdc57de2c7888b99d2b9253b3d4d513d\\""
> > in [ProcessesToRunAfterCopying.IS] failed: 0x2 4321.094: Return Code = 2
> > 4321.094: DoInstallation: RunInfProcesses for
> > ProcessesToRunAfterCopying.IS
> > failed.
> > 4321.094: Service Pack 2 Setup encountered an error: An error in updating
> > your system has occurred.
> > 4349.281: Unregistration of sprecovr successful
> > 4349.594: An error in updating your system has occurred.
> >
> > Select 'OK' to undo the changes that have been made.
> > 4349.594: Starting process:
> > C:\WINDOWS\$NtServicePackUninstall$\spuninst\spuninst.exe /~ -q -z
> > 6921.719: Software Update Rollback has completed with return code 0xbc2.
> > This rollback requires a reboot.
> > 6921.750: Service Pack 2 installation did not complete.
> >
> > Windows Server 2003 has been partially updated and may not work properly.
> > 6921.750: Update.exe extended error code = 0xf070
> >
> > Excerpt form the uddisetup.log:
> > ...
> > 04/29/07 15:08:24: Installing Service Pack...
> > 04/29/07 15:08:24: Incorrect usage of uddisp.exe. Wrong number of
> > parameters. 04/29/07 15:08:24: Unknown error during UDDI install.

>
>

Reply With Quote
  #4  
Old 05-05-2007
Robert Aldwinckle
 
Posts: n/a
Re: Windows Server 2003 Service Pack 2 installation did not comple

"starki7" <starki7@discussions.microsoft.com> wrote in message
news:F4C1780E-BC6B-41E3-99BB-27C6E9E978B4@microsoft.com...
> Thanks Bear!
>
> Articles don't match my problem.
> I didn't mentioned before, I've already tried to uninstall and install SP1,
> and it did well.
>
> I used Sysinternals proces monitor to find out where is the problem, and I
> think the problem is that update.exe proces can't find uddisp.exe (or maybe
> it finds the wrong one).


I suspect the log you showed us in your first post suggests at most the latter. ; )
....

>> > Excerpt form the uddisetup.log:
>> > ...
>> > 04/29/07 15:08:24: Installing Service Pack...
>> > 04/29/07 15:08:24: Incorrect usage of uddisp.exe. Wrong number of
>> > parameters. 04/29/07 15:08:24: Unknown error during UDDI install.



Are you letting ProcMon show you the writes of those log records?
Which program writes them? E.g. if they are being written by uddisp.exe
you would have definitive proof that it wasn't a case of the module not being
found... <eg>

Also, is there a verbose mode which can be invoked? That would improve
the supplementary value of your ProcMon trace. In XP verbose mode on
a service pack used to involve a registry hack I think but it may only add more
records to svcpack.log. In any case I would try to see if there is a command
line switch instead.


Good luck

Robert Aldwinckle
---


Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows XP > Windows Update
Tags: ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Windows Server 2003 Service Pack 2 installation did not complete"
Thread Thread Starter Forum Replies Last Post
Windows Vista and Windows Server 2008 service pack installation fails with error 0x80004005 - [Info] Neel23 Operating Systems 1 22-05-2009 07:59 PM
Unable to install Windows Server 2003 Service Pack 2 Rocklobstar Windows Update 0 10-07-2008 07:42 PM
Event ID 2003 after installing Windows Server 2003 Service Pack 2 GregA415 Windows Server Help 3 25-07-2007 04:44 PM
Windows Server 2003 Service Pack 1 ERROR Event ID 4374 paul.mama@sesame.co.uk Windows Update 1 19-03-2007 08:47 AM
Cannot install Windows Server 2003 Service Pack 1 Administration T sleff Windows Server Help 1 04-01-2006 09:27 PM


All times are GMT +5.5. The time now is 08:33 PM.