Go Back   TechArena Community > Technical Support > Computer Help > Windows XP > Windows Update
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



windows update error 80070424

Windows Update


Reply
 
Thread Tools Search this Thread
  #1  
Old 26-04-2007
Pete
 
Posts: n/a
windows update error 80070424

hey everybody. I got a serious problem I can't activate my windows update and
as soon as I'm trying to update manual I'm getting this error 80070424.

nowhere is mentioned what this error code means and how to solve it. So if
anyone has a solution, please give a comment

Reply With Quote
  #2  
Old 26-04-2007
TaurArian [MS-MVP]
 
Posts: n/a
Click Start, select run, type: regsvr32 wuaueng.dll

if that doesn't do the trick:-

Verify that BITS is correctly configured and started:

1. Click Start, click Run, type services.msc, and then click OK.
2. Double-click Background Intelligent Transfer Service.
3. In the Startup type box, click Manual, and then click Apply.
4. Click the Log On tab, and then verify that the service is enabled in every hardware
profile that is listed. If the service is disabled in one or more hardware profiles, click
the hardware profile, click Enable, and then click Apply.
5. Click the General tab, and then click Start.

If that's all okay, then perhaps:-

1. Click Start.
2. Choose Run.
3. In the Run box, type (pressing okay after the command) :-
Regsvr32 QMGR.DLL

also see
You cannot turn on the Automatic Updates feature on a Windows XP Service Pack 2-based
computer
http://support.microsoft.com:80/kb/916261
The Automatic Updates feature is turned off in the Security Center. Additionally, you
cannot turn on the Automatic Updates feature.
When you try to install updates from the Microsoft Windows Update Web site, you may
receive an error message that resembles the following:
0x80070424
Reply With Quote
  #3  
Old 06-09-2007
Member
 
Join Date: Sep 2007
Posts: 5
hi, i'm sorry to join this thread but you seem to know what you're talking about and i've had no response to my own post in the vista section. I have the same error on a Vista machine. I had to turn off UAC to make regsrvr32 wuaueng.dll run, but it did (still error 80070424 afterwards though..)
Regsvr32 QMGR.DLL won't run -it says the module was loaded but the entry-point dllregisterserver was not found.
BITS is also correctly configured. Any clues please? This has been bugging me for weeks now..
a

Just got off with microsoft... here is the fix:

Copy the following and past it into notepad... save the doc and rename it as
a bat file (example: update.bat) execute the bat file and reboot. Hope it
works as well for you as it did me:

Hi, I'm getting the same problem with a Wondows Vista Ultimate SP1, 64 bits.

I get the "WindowsUpdate_80070424" "WindowsUpdate_dt000" error, I've tried
the solution there above, without any success, and didn't find any one
working on the net.

Does anyone here know a fix for this problem ?
Reply With Quote
  #4  
Old 05-06-2008
sd
 
Posts: n/a
To solve the Error number: 080070424 in Windows Update follow the steps
below:-
Click on Start -> Run
and paste the command below and enter

%SYSTEMROOT%\SYSTEM32\REGSVR32.EXE %SYSTEMROOT%\SYSTEM32\WUAUENG.DLL

This line use to reregistering WUAUENG.DLL in window.

You are done! Launch your windows update again, you should be able to
perform update now.
Reply With Quote
  #5  
Old 02-07-2008
GC
 
Posts: n/a
RE: windows update error 80070424

If you have Vista and you have this problem the solution is actually very
easy...

1) click Start, then All programs, then Accessories
2) Right click on Command Promt and select run as Administrator
3) At the command prompt enter the following

%SYSTEMROOT%\SYSTEM32\REGSVR32.EXE %SYSTEMROOT%\SYSTEM32\WUAUENG.DLL

It should pop up a window saying the .dll registration succeeded and thats it!
All fixed :)
Hope this helps...

Reply With Quote
  #6  
Old 08-07-2008
CMD freak
 
Posts: n/a
Re: windows update error 80070424

this is my problem now
Regsvr32 QMGR.DLL

i have vista (i know it sux) and its telling me to check if QMGR.DLL is a
dll file or an ocx
This is the exact message vvvvvvvvvvvvvvvvvvvvvvvvv

The module "QMGR.DLL" was loaded but the entry-point DllRegistryServer was
not found.

Make sure that "QMGR.DLL" is a valid DLL or OCX file and then try again.


pleeez help
Reply With Quote
  #7  
Old 24-07-2008
ms I need help!
 
Posts: n/a
Re: windows update error 80070424

Hi

I tried following step one... failed even the other step did not work for
me. It says that...

The module "QMGR.DLL" was loaded but the entry-point DllRegisterServer was
not found.

Make sure that "QMGR.DLL" is valid DLL or OCX file and then try again

How do I check if it is valid or not?
Reply With Quote
  #8  
Old 08-08-2008
dopypuppy
 
Posts: n/a
Re: windows update error 80070424

I got this update error message 80070424 in vista
I found this on a web site and it worked for me in vista

click on Start ->type Run in search bar
click on run icon

copy and paste the complete command below and press enter

%SYSTEMROOT%\SYSTEM32\REGSVR32.EXE %SYSTEMROOT%\SYSTEM32\WUAUENG.DLL

This line is use to reregister WUAUENG.DLL in window.

that is all. Launch your windows update again, you should be able to
perform update now.

Reply With Quote
  #9  
Old 05-09-2008
Ezra
 
Posts: n/a
I have done everything what you said, but get this reported as: Module
QMGR.DLL has been charged but the access point DllRegisterServer has not been
found. Care that QMGR.DLL valid DLL- or OCX File are and try it again.

So i didn't can solve this problem.
I am using Windows Vista.

I tried all the ways to enable my Windows update but nothing is fixing it,
the Regsvr32 QMGR.DLL says it can;t load and same for the other file. And
when I tried background intelligent transfer service it did nothing as well.
This stupid error 80070424. Nowhere does it explain why it can;t update.
And I can;t find a fix from microsoft or google. HELP ME ! And now vista is
silly not allowing you to manually do a windows update GRRRRRR. Any advice?
Reply With Quote
  #10  
Old 25-01-2009
Member
 
Join Date: Jan 2009
Posts: 1
Re: windows update error 80070424

Hi,

I am still having a problem with this windows update issue (80070424).

I have tried running the following solutions in a cmd window running as administrator.

1) The large bat file solution, ran sucessfully, the only issue was proxycfg was not recognized.

2) Running "regsvr32 wuaueng.dll".

3) Running the steps to enable bits.

4) Running "Regsvr32 QMGR.DLL", this didn't run though came up with a "make sure that "OMGR.DLL" is a valid OCX file and then try again" error so this could be the issue, not sure what OMGR.DLL is.

Any way all these solutions have unfortunatly not worked for me windows update is still erroring with the same issue.

Does anyone know of any other solutions?

Cheers....
Reply With Quote
  #11  
Old 12-02-2009
Me
 
Posts: n/a
Hello everybody. All you have to do is click start Allprograms then click
accessories then right click on the cmd icon and from the context menu choose
run as administrator. When the command prompt box open type

%SYSTEMROOT%\SYSTEM32\REGSVR32.EXE %SYSTEMROOT%\SYSTEM32\WUAUENG.DLL

and presto all done. close the command prompt and attempt to use windows
update once again. Good Luck!

i use this command but i am failiar to windows update i receive this message

The module "wuaueng.dll" was loaded but the call to
DllRegisterServer failed with error code 80070005
Reply With Quote
  #12  
Old 19-03-2009
Member
 
Join Date: Mar 2009
Posts: 1
Re: windows update error 80070424

Yanno, getting a lil tired of the BS solutions. Yanno what? Presto! No it DOESNT WORK!

Im just convinced of one thing.....Windows Vista possibly the worst piece of $hi& ever put out as an OS.

So with all the nonsense "just put this CMD in or type that into Run, Im staring at my 5th reinstall.

For everybody else whose been down this road....and your having no luck....call Microsoft and have them mail you a recovery disk with SP1...and pray for a new OS soon
Reply With Quote
  #13  
Old 30-04-2009
donna
 
Posts: n/a
If you have a problem with this working in windows Vista, start the command
prompt from Start, Accessories, right click on Command Prompt, click "run as
administrator" ...then enter the above regsvr32 wuaueng.dll command.
Otherwise you will get an error 80070005, which is a permissions error.

enter your command from a command prompt started with administrative
priveleges and it will work Start , Accessories, Command Prompt, right click,
run as admin, then the command above

I Have Vista home premium 64-bit also and nothing in here that i try works.
i tried using regcure and it onlly works for 32 bit, Please help this is a
huge problem!

this works on 32bit vista only i think

Interesting - but what about 640bit Vista Ultimate installations please?
Reply With Quote
  #14  
Old 26-06-2009
Robert Aldwinckle
 
Posts: n/a
Are you Pete? ; }

<cmd_output OS="XPsp3">
E:\>set /a c =0x424
1060
E:\>net helpmsg %c%

The specified service does not exist as an installed service.
</cmd_output>

Rather than trying to guess exactly which service is "specified"
why not try some diagnosis? You can find tips for doing so
in some of my previous posts on this issue and others.

this key is work (regsvr32 wuaueng.dll)

Sorry. I have tried all of this and nothing has helped. I have Vista 64.
Please provide some other suggestions. Thanks.
Reply With Quote
  #15  
Old 19-09-2009
TaurArian
 
Posts: n/a
Re: windows update error 80070424

david, you have responded to a post that was started in 2007 !
http://www.microsoft.com/windowsxp/e...&lang=en&cr=US

As you've tried everything in the thread relating to your mystery operating
system, can only suggest you contact MS -

How to obtain assistance from MS Support

Start a free Windows Update support incident request:
https://support.microsoft.com/oas/de...spx?gprid=6527

Support for Windows Update:
http://support.microsoft.com/gp/wusupport

For more information about how to contact your local Microsoft subsidiary
for security update support issues, visit the International Support Web
site:
http://support.microsoft.com/common/international.aspx
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows XP > Windows Update
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "windows update error 80070424"
Thread Thread Starter Forum Replies Last Post
Windows Update Error Code: 80070424 veloci1992f Vista Setup and Install 14 13-05-2012 06:39 PM
Automatic Update Error 80070424 Shane Point O Windows Vista Performance 9 18-06-2011 12:15 AM
error 80070424 windows update VISTA getalexfr Windows Update 11 12-02-2010 08:14 AM
Windows Update error code 80070424 RondoDondo Windows Update 7 03-10-2009 06:29 AM
error 80070424 windows update VISTA getalexfr Vista Help 5 30-09-2009 10:58 AM


All times are GMT +5.5. The time now is 11:50 AM.