Go Back   TechArena Community > Technical Support > Computer Help > Windows XP > Windows Update
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Error Code: 0x643 when installing Visual Studio 2005 Professional

Windows Update


Reply
 
Thread Tools Search this Thread
  #1  
Old 22-03-2007
tedh
 
Posts: n/a
Error Code: 0x643 when installing Visual Studio 2005 Professional

I am running a standalone Windows 2003 server and Visual Studio 2005
Professional. When I try to run Windows Update to install SP1 for Visual
Studio I get the message Error Code: 0x643.

The SP1 updates are successfully downloaded and the initialization process
runs successfully and after this the message comes up.

Can you please advise re steps to take to resolve?

Thanks


Reply With Quote
  #2  
Old 28-03-2007
Paul
 
Posts: n/a
RE: Error Code: 0x643 when installing Visual Studio 2005 Professional

This KB Article has a fix for this: http://support.microsoft.com/kb/925336

"tedh" wrote:

> I am running a standalone Windows 2003 server and Visual Studio 2005
> Professional. When I try to run Windows Update to install SP1 for Visual
> Studio I get the message Error Code: 0x643.
>
> The SP1 updates are successfully downloaded and the initialization process
> runs successfully and after this the message comes up.
>
> Can you please advise re steps to take to resolve?
>
> Thanks
>

Reply With Quote
  #3  
Old 28-03-2007
Paul
 
Posts: n/a
RE: Error Code: 0x643 when installing Visual Studio 2005 Professional

This KB Article has a fix for this: http://support.microsoft.com/kb/925336

"tedh" wrote:

> I am running a standalone Windows 2003 server and Visual Studio 2005
> Professional. When I try to run Windows Update to install SP1 for Visual
> Studio I get the message Error Code: 0x643.
>
> The SP1 updates are successfully downloaded and the initialization process
> runs successfully and after this the message comes up.
>
> Can you please advise re steps to take to resolve?
>
> Thanks
>

Reply With Quote
  #4  
Old 28-03-2007
Paul
 
Posts: n/a
RE: Error Code: 0x643 when installing Visual Studio 2005 Professio

One other thing: I did NOT run Windows Update, but I downloaded the SP from
MSDN and then ran it from my hard drive. I don't know if this made the
difference. Let me know if this helps...

"tedh" wrote:

> Hi Paul,
>
> Thanks for the reply. I carried out the instructions in the KB article but
> when I ran windows update I got the same results as previously.
>
> The initialization process runs successfully and the hard drive light is
> very active for about 10 minutes afterwards and then Windows Update reports
> that the installation failed and when reviewing the installation history and
> clicking on the error status it reports error 0x643.
>
> Regards
> Ted
>
> "Paul" wrote:
>
> > This KB Article has a fix for this: http://support.microsoft.com/kb/925336
> >
> > "tedh" wrote:
> >
> > > I am running a standalone Windows 2003 server and Visual Studio 2005
> > > Professional. When I try to run Windows Update to install SP1 for Visual
> > > Studio I get the message Error Code: 0x643.
> > >
> > > The SP1 updates are successfully downloaded and the initialization process
> > > runs successfully and after this the message comes up.
> > >
> > > Can you please advise re steps to take to resolve?
> > >
> > > Thanks
> > >

Reply With Quote
  #5  
Old 28-03-2007
Paul
 
Posts: n/a
RE: Error Code: 0x643 when installing Visual Studio 2005 Professio

One other thing: I did NOT run Windows Update, but I downloaded the SP from
MSDN and then ran it from my hard drive. I don't know if this made the
difference. Let me know if this helps...

"tedh" wrote:

> Hi Paul,
>
> Thanks for the reply. I carried out the instructions in the KB article but
> when I ran windows update I got the same results as previously.
>
> The initialization process runs successfully and the hard drive light is
> very active for about 10 minutes afterwards and then Windows Update reports
> that the installation failed and when reviewing the installation history and
> clicking on the error status it reports error 0x643.
>
> Regards
> Ted
>
> "Paul" wrote:
>
> > This KB Article has a fix for this: http://support.microsoft.com/kb/925336
> >
> > "tedh" wrote:
> >
> > > I am running a standalone Windows 2003 server and Visual Studio 2005
> > > Professional. When I try to run Windows Update to install SP1 for Visual
> > > Studio I get the message Error Code: 0x643.
> > >
> > > The SP1 updates are successfully downloaded and the initialization process
> > > runs successfully and after this the message comes up.
> > >
> > > Can you please advise re steps to take to resolve?
> > >
> > > Thanks
> > >

Reply With Quote
  #6  
Old 28-03-2007
Art
 
Posts: n/a
RE: Error Code: 0x643 when installing Visual Studio 2005 Professional

I have the identical problem on two Win 2003 Servers & am looking for a
resolution.


"tedh" wrote:

> I am running a standalone Windows 2003 server and Visual Studio 2005
> Professional. When I try to run Windows Update to install SP1 for Visual
> Studio I get the message Error Code: 0x643.
>
> The SP1 updates are successfully downloaded and the initialization process
> runs successfully and after this the message comes up.
>
> Can you please advise re steps to take to resolve?
>
> Thanks
>

Reply With Quote
  #7  
Old 28-03-2007
Art
 
Posts: n/a
RE: Error Code: 0x643 when installing Visual Studio 2005 Professional

I have the identical problem on two Win 2003 Servers & am looking for a
resolution.


"tedh" wrote:

> I am running a standalone Windows 2003 server and Visual Studio 2005
> Professional. When I try to run Windows Update to install SP1 for Visual
> Studio I get the message Error Code: 0x643.
>
> The SP1 updates are successfully downloaded and the initialization process
> runs successfully and after this the message comes up.
>
> Can you please advise re steps to take to resolve?
>
> Thanks
>

Reply With Quote
  #8  
Old 28-03-2007
Paul
 
Posts: n/a
RE: Error Code: 0x643 when installing Visual Studio 2005 Professio

I am running Windows Server 2003 SP1 and Visual Studio Professional and had
the same problem and error message that you are experiencing and this fixed
the issue for me. I did the following:

1. Click Start, click Run, type control admintools, and then click OK.
2. Double-click Local Security Policy.
3. Click Software Restriction Policies.

Note If no software restrictions are listed, right-click Software
Restriction Policies, and then click Create New Policy.
4. Under Object Type, double-click Enforcement.
5. Click All users except local administrators, and then click OK.

I then changed
HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers
PolicyScope, and then change the setting from 0 to 1.

6. Restarted the computer.


"tedh" wrote:

> Hi Paul,
>
> Thanks for the reply. I carried out the instructions in the KB article but
> when I ran windows update I got the same results as previously.
>
> The initialization process runs successfully and the hard drive light is
> very active for about 10 minutes afterwards and then Windows Update reports
> that the installation failed and when reviewing the installation history and
> clicking on the error status it reports error 0x643.
>
> Regards
> Ted
>
> "Paul" wrote:
>
> > This KB Article has a fix for this: http://support.microsoft.com/kb/925336
> >
> > "tedh" wrote:
> >
> > > I am running a standalone Windows 2003 server and Visual Studio 2005
> > > Professional. When I try to run Windows Update to install SP1 for Visual
> > > Studio I get the message Error Code: 0x643.
> > >
> > > The SP1 updates are successfully downloaded and the initialization process
> > > runs successfully and after this the message comes up.
> > >
> > > Can you please advise re steps to take to resolve?
> > >
> > > Thanks
> > >

Reply With Quote
  #9  
Old 28-03-2007
Paul
 
Posts: n/a
RE: Error Code: 0x643 when installing Visual Studio 2005 Professio

I am running Windows Server 2003 SP1 and Visual Studio Professional and had
the same problem and error message that you are experiencing and this fixed
the issue for me. I did the following:

1. Click Start, click Run, type control admintools, and then click OK.
2. Double-click Local Security Policy.
3. Click Software Restriction Policies.

Note If no software restrictions are listed, right-click Software
Restriction Policies, and then click Create New Policy.
4. Under Object Type, double-click Enforcement.
5. Click All users except local administrators, and then click OK.

I then changed
HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers
PolicyScope, and then change the setting from 0 to 1.

6. Restarted the computer.


"tedh" wrote:

> Hi Paul,
>
> Thanks for the reply. I carried out the instructions in the KB article but
> when I ran windows update I got the same results as previously.
>
> The initialization process runs successfully and the hard drive light is
> very active for about 10 minutes afterwards and then Windows Update reports
> that the installation failed and when reviewing the installation history and
> clicking on the error status it reports error 0x643.
>
> Regards
> Ted
>
> "Paul" wrote:
>
> > This KB Article has a fix for this: http://support.microsoft.com/kb/925336
> >
> > "tedh" wrote:
> >
> > > I am running a standalone Windows 2003 server and Visual Studio 2005
> > > Professional. When I try to run Windows Update to install SP1 for Visual
> > > Studio I get the message Error Code: 0x643.
> > >
> > > The SP1 updates are successfully downloaded and the initialization process
> > > runs successfully and after this the message comes up.
> > >
> > > Can you please advise re steps to take to resolve?
> > >
> > > Thanks
> > >

Reply With Quote
  #10  
Old 28-03-2007
Art
 
Posts: n/a
RE: Error Code: 0x643 when installing Visual Studio 2005 Professio

Thank you Paul. Your procedures worked for both Win2003 Servers that I
updated.

Note that one server DID NOT have "Local Security Policy" within Control
AdminTools but I was able to find the shortcut on the other server
"c:\windows\system32\secpol.msc /s" and I ran it from Start/Run.

Thanks again.

Art

"Paul" wrote:

> I am running Windows Server 2003 SP1 and Visual Studio Professional and had
> the same problem and error message that you are experiencing and this fixed
> the issue for me. I did the following:
>
> 1. Click Start, click Run, type control admintools, and then click OK.
> 2. Double-click Local Security Policy.
> 3. Click Software Restriction Policies.
>
> Note If no software restrictions are listed, right-click Software
> Restriction Policies, and then click Create New Policy.
> 4. Under Object Type, double-click Enforcement.
> 5. Click All users except local administrators, and then click OK.
>
> I then changed
> HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers
> PolicyScope, and then change the setting from 0 to 1.
>
> 6. Restarted the computer.
>
>
> "tedh" wrote:
>
> > Hi Paul,
> >
> > Thanks for the reply. I carried out the instructions in the KB article but
> > when I ran windows update I got the same results as previously.
> >
> > The initialization process runs successfully and the hard drive light is
> > very active for about 10 minutes afterwards and then Windows Update reports
> > that the installation failed and when reviewing the installation history and
> > clicking on the error status it reports error 0x643.
> >
> > Regards
> > Ted
> >
> > "Paul" wrote:
> >
> > > This KB Article has a fix for this: http://support.microsoft.com/kb/925336
> > >
> > > "tedh" wrote:
> > >
> > > > I am running a standalone Windows 2003 server and Visual Studio 2005
> > > > Professional. When I try to run Windows Update to install SP1 for Visual
> > > > Studio I get the message Error Code: 0x643.
> > > >
> > > > The SP1 updates are successfully downloaded and the initialization process
> > > > runs successfully and after this the message comes up.
> > > >
> > > > Can you please advise re steps to take to resolve?
> > > >
> > > > Thanks
> > > >

Reply With Quote
  #11  
Old 28-03-2007
Art
 
Posts: n/a
RE: Error Code: 0x643 when installing Visual Studio 2005 Professio

Thank you Paul. Your procedures worked for both Win2003 Servers that I
updated.

Note that one server DID NOT have "Local Security Policy" within Control
AdminTools but I was able to find the shortcut on the other server
"c:\windows\system32\secpol.msc /s" and I ran it from Start/Run.

Thanks again.

Art

"Paul" wrote:

> I am running Windows Server 2003 SP1 and Visual Studio Professional and had
> the same problem and error message that you are experiencing and this fixed
> the issue for me. I did the following:
>
> 1. Click Start, click Run, type control admintools, and then click OK.
> 2. Double-click Local Security Policy.
> 3. Click Software Restriction Policies.
>
> Note If no software restrictions are listed, right-click Software
> Restriction Policies, and then click Create New Policy.
> 4. Under Object Type, double-click Enforcement.
> 5. Click All users except local administrators, and then click OK.
>
> I then changed
> HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers
> PolicyScope, and then change the setting from 0 to 1.
>
> 6. Restarted the computer.
>
>
> "tedh" wrote:
>
> > Hi Paul,
> >
> > Thanks for the reply. I carried out the instructions in the KB article but
> > when I ran windows update I got the same results as previously.
> >
> > The initialization process runs successfully and the hard drive light is
> > very active for about 10 minutes afterwards and then Windows Update reports
> > that the installation failed and when reviewing the installation history and
> > clicking on the error status it reports error 0x643.
> >
> > Regards
> > Ted
> >
> > "Paul" wrote:
> >
> > > This KB Article has a fix for this: http://support.microsoft.com/kb/925336
> > >
> > > "tedh" wrote:
> > >
> > > > I am running a standalone Windows 2003 server and Visual Studio 2005
> > > > Professional. When I try to run Windows Update to install SP1 for Visual
> > > > Studio I get the message Error Code: 0x643.
> > > >
> > > > The SP1 updates are successfully downloaded and the initialization process
> > > > runs successfully and after this the message comes up.
> > > >
> > > > Can you please advise re steps to take to resolve?
> > > >
> > > > Thanks
> > > >

Reply With Quote
  #12  
Old 28-03-2007
tedh
 
Posts: n/a
RE: Error Code: 0x643 when installing Visual Studio 2005 Professio

Hi Paul,

Thanks for the reply. I carried out the instructions in the KB article but
when I ran windows update I got the same results as previously.

The initialization process runs successfully and the hard drive light is
very active for about 10 minutes afterwards and then Windows Update reports
that the installation failed and when reviewing the installation history and
clicking on the error status it reports error 0x643.

Regards
Ted

"Paul" wrote:

> This KB Article has a fix for this: http://support.microsoft.com/kb/925336
>
> "tedh" wrote:
>
> > I am running a standalone Windows 2003 server and Visual Studio 2005
> > Professional. When I try to run Windows Update to install SP1 for Visual
> > Studio I get the message Error Code: 0x643.
> >
> > The SP1 updates are successfully downloaded and the initialization process
> > runs successfully and after this the message comes up.
> >
> > Can you please advise re steps to take to resolve?
> >
> > Thanks
> >

Reply With Quote
  #13  
Old 28-03-2007
tedh
 
Posts: n/a
RE: Error Code: 0x643 when installing Visual Studio 2005 Professio

Hi Paul,

Thanks for the reply. I carried out the instructions in the KB article but
when I ran windows update I got the same results as previously.

The initialization process runs successfully and the hard drive light is
very active for about 10 minutes afterwards and then Windows Update reports
that the installation failed and when reviewing the installation history and
clicking on the error status it reports error 0x643.

Regards
Ted

"Paul" wrote:

> This KB Article has a fix for this: http://support.microsoft.com/kb/925336
>
> "tedh" wrote:
>
> > I am running a standalone Windows 2003 server and Visual Studio 2005
> > Professional. When I try to run Windows Update to install SP1 for Visual
> > Studio I get the message Error Code: 0x643.
> >
> > The SP1 updates are successfully downloaded and the initialization process
> > runs successfully and after this the message comes up.
> >
> > Can you please advise re steps to take to resolve?
> >
> > Thanks
> >

Reply With Quote
  #14  
Old 24-01-2008
NikB
 
Posts: n/a
RE: Error Code: 0x643 when installing Visual Studio 2005 Professio

Simple solution to problem I was researching for a day or so.
Step 5 was all I needed to change and no reboot.

(Full error code is 0x80070643
Visual Studio 2005 Service Pack 1, SP1 )

Nik

"Paul" wrote:

> I am running Windows Server 2003 SP1 and Visual Studio Professional and had
> the same problem and error message that you are experiencing and this fixed
> the issue for me. I did the following:
>
> 1. Click Start, click Run, type control admintools, and then click OK.
> 2. Double-click Local Security Policy.
> 3. Click Software Restriction Policies.
>
> Note If no software restrictions are listed, right-click Software
> Restriction Policies, and then click Create New Policy.
> 4. Under Object Type, double-click Enforcement.
> 5. Click All users except local administrators, and then click OK.
>
> I then changed
> HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers
> PolicyScope, and then change the setting from 0 to 1.
>
> 6. Restarted the computer.
>
>


Reply With Quote
  #15  
Old 06-11-2008
ltreachler
 
Posts: n/a
RE: Error Code: 0x643 when installing Visual Studio 2005 Professio

This procedure worked perfectly for myself. I was having problems installing
Visual Studio 2005 SP1 (i.e. getting the 10 minute wait and then the install
error 0x643) on a Windows 2003 Server SP1 w/1 Gig of RAM. Thanks Paul.

"Paul" wrote:

> I am running Windows Server 2003 SP1 and Visual Studio Professional and had
> the same problem and error message that you are experiencing and this fixed
> the issue for me. I did the following:
>
> 1. Click Start, click Run, type control admintools, and then click OK.
> 2. Double-click Local Security Policy.
> 3. Click Software Restriction Policies.
>
> Note If no software restrictions are listed, right-click Software
> Restriction Policies, and then click Create New Policy.
> 4. Under Object Type, double-click Enforcement.
> 5. Click All users except local administrators, and then click OK.
>
> I then changed
> HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers
> PolicyScope, and then change the setting from 0 to 1.
>
> 6. Restarted the computer.
>
>
> "tedh" wrote:
>
> > Hi Paul,
> >
> > Thanks for the reply. I carried out the instructions in the KB article but
> > when I ran windows update I got the same results as previously.
> >
> > The initialization process runs successfully and the hard drive light is
> > very active for about 10 minutes afterwards and then Windows Update reports
> > that the installation failed and when reviewing the installation history and
> > clicking on the error status it reports error 0x643.
> >
> > Regards
> > Ted
> >
> > "Paul" wrote:
> >
> > > This KB Article has a fix for this: http://support.microsoft.com/kb/925336
> > >
> > > "tedh" wrote:
> > >
> > > > I am running a standalone Windows 2003 server and Visual Studio 2005
> > > > Professional. When I try to run Windows Update to install SP1 for Visual
> > > > Studio I get the message Error Code: 0x643.
> > > >
> > > > The SP1 updates are successfully downloaded and the initialization process
> > > > runs successfully and after this the message comes up.
> > > >
> > > > Can you please advise re steps to take to resolve?
> > > >
> > > > Thanks
> > > >

Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows XP > Windows Update
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Error Code: 0x643 when installing Visual Studio 2005 Professional"
Thread Thread Starter Forum Replies Last Post
Vista 64 problem installing Visual Studio 2005 Kiran123 Software Development 5 19-05-2009 09:43 PM
Error installing visual studio 2005 in server 2003-PCHELTH\ERROREP prachi Windows Software 1 17-10-2008 03:02 PM
problem installing visual studio 2005 in windows server 2003 prachi Windows Software 3 17-10-2008 09:51 AM
Error code 0x663 - Visual Studio 2005 Service Pack 1 cvstebut Windows Update 3 17-04-2007 09:24 PM
Problem Installing Visual Studio 2005 Service Pack 1 Ringo Small Business Server 1 13-02-2007 04:26 PM


All times are GMT +5.5. The time now is 10:50 PM.