Go Back   TechArena Community > Technical Support > Computer Help > Windows XP > Windows Update
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Error 800700C1

Windows Update


Reply
 
Thread Tools Search this Thread
  #1  
Old 22-08-2004
Tania
 
Posts: n/a
Error 800700C1

Well, i thought i had been stupid to accept the offer to
get the new Windows Update software, but now i see that
our big brother gave me no choice. The download process
seems to go fine, but ends with

Error 800700C1

Windows Update has encountered an error and cannot
display the requested page. You may find the following
resources helpful in resolving the problem:

This leaves me in a state where there is no choice to
search for updates. So i guess i will never have any
trouble downloading SP2, since Windows Update will never
work again.

Reply With Quote
  #2  
Old 25-09-2007
myriad360
 
Posts: n/a
I am not sure why it is doing this, searched the web and saw a lot of people
have the problem, none have had success fixing it. Can't update Windows
Vista!

http://www.afreedll.com/dll/info/smipi_dll.html
Reply With Quote
  #3  
Old 25-09-2007
Juan Perez
 
Posts: n/a
Re: Error 800700C1

Hi:

I found this information some in a forums. Take a look:

SUCCESS!

The offending file in question was SMIPI.dll

You can get it off of the vista install disk (just search for it I forget

the path) or another working system. It's under

C:\Windows\winsxs\x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.0.6000.16386_non
e_07289f4cca5f6990

yes that is a real folder name (jeesh).

You'll have to take ownership under properties>security>advanced to actually

copy over it. Once it's replaced windows update ran fine.

Had a bunch of other corrupted files that I haven't dealt with yet but this

was the cause. Suggest running sfc/scannow anyway as that might have fixed

something else.

Good Luck!
Reply With Quote
  #4  
Old 25-09-2007
myriad360
 
Posts: n/a
Re: Error 800700C1

Thanks Jaun; however, I have a Dell, therefore, no install disc, just a
recover disk with no dll file. Is there another place I can find this dll?

Thanks again.

Colb
Reply With Quote
  #5  
Old 29-09-2007
myriad360
 
Posts: n/a
Thanks, Jim. Replaced existing DLL with the above, still no difference. I
suspect the above mentioned solution to have been successful because of the
sfc/scannow command, but in my Windows, it says:

"Windows Resource Protection could not start the repair service."
Reply With Quote
  #6  
Old 29-09-2007
Jim Byrd
 
Posts: n/a
Re: Error 800700C1

Hi Myriad - Try the following in order:

Procedure 1:

- First, you will need to install or re-install the updated KB927891. See
here:
http://www.microsoft.com/technet/sec...ry/927891.mspx and here
http://support.microsoft.com/?kbid=927891 for a complete fix.

- Then install the newly released 'standalone' version of Windows Update
Agent 3.0, v. 7.0.6000.374, for 32 bit machines which is available here:
http://download.windowsupdate.com/v7...gent30-x86.exe

It may say "Install is not needed since Windows Update Agent is
already installed." If so, then run the exe with the command line switch
/wuforce , like this:

WindowsUpdateAgent30-x86.exe /wuforce

to force the install.

Now reboot. Now reboot again. (Yes, twice.)

Now go back to Windows Update - what you just did should force a
re-installation of the lastest update to the Windows Update software. Allow
this and then try your updates again.


If that doesn't fix the problem, then try

Procedure 2:


1. Go to http://wiki.djlizard.net/Dial-a-fix and download Dial-a-fix
v0.60.0.24 (2006-10-27) Here's a direct download link:
http://djlizard.net.nyud.net:8080/so...v0.60.0.24.zip and a
secondary: http://djlizard.net/software/Dial-a-fix-v0.60.0.24.zip from
that page's download section, here:
http://wiki.djlizard.net/Dial-a-fix#...C_and_articles .

2. Unzip it to a new folder at root with any name, e.g.
c:\Dial-a-fix-v0.60.0.24

3. Now double click on Dial-a-fix.exe in that folder.

4. Click on the following:
- Options/tooltips (just to get an idea of what it does in each
section.
:) )
- Both boxes under Prep
- The 'all' (top) box for Sections 2, 3 and 4 (which will automatically
be set when you check 3)
- In Section 3 click on 'Flush Software Distribution' and choose 'Yes'
to force the deletion of the folder.
- In Section 5, 'ActiveX controls/codecs', 'Programming
cores/runtimes', 'Explorer/IE/OE/shell/WMP', and 'Object linking libraries
(OLE)' only.
- Click 'Go' . (Some of the re-registrations may take what seems like
a
long time for some .dll's - Don't be impatient.)

5. Reboot. Now Reboot Again. (Yes, twice.)


Now try Windows Update again. If it still doesn't work, then re-do
Procedure 2 in Safe mode (Section 2 will be greyed out.) and then try
Windows Update again.


See if that does the trick, and, again please post back with your
experience.
Reply With Quote
  #7  
Old 05-02-2008
TruckChick81
 
Posts: n/a
Re: Error 800700C1

I found this file
"C:\Windows\winsxs\x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.0.6000.16386_non
e_07289f4cca5f6990" but I'm not sure what to do with it? Can you please
explain?
Reply With Quote
  #8  
Old 12-03-2008
blkbgn9
 
Posts: n/a
Error 800700C1

When trying to check for Windows updates I get the error code 800700C1. I
have tried all of the things suggested on other threads on this board with no
success. When I go to my internet options I get the message
"C:\Windows\system32\ADVPACK.dll is either not designed to run on Windows or
it contains an error. Try installing the program again using the original
installation media or contact your system administrator or the software
vendor for support." When I got that message I went to afreedll.com and
downloaded RegCure to check my computer for errors or missing dll files.
That did not work. I still get the same messages as before.
I also had McAfee as my security on the computer. I have since uninstalled
that to see if that was the problem, but it wasn't. I now have AVG 7.5 for
my security as well as the Windows firewall.
Any suggestions would be greatly appreciated. At this point I am ready to
throw the computer out the window
Reply With Quote
  #9  
Old 04-03-2009
Bruceahz
 
Posts: n/a
Becky - did you ever get this resolved. I've had the same problem since at
least last summer; it started after installing a MicroSoft update, and the
only suggestion from MS was to reinstall Vista!
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows XP > Windows Update
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Error 800700C1"
Thread Thread Starter Forum Replies Last Post
error code 800700C1 GanGadUtt Vista Help 2 05-02-2011 12:46 AM
error “shmget (lowmem) error: Unknown error 999” on linux -Wamil- Operating Systems 6 12-11-2010 11:37 PM
Error code 800700C1 when trying to install Vista SP1 kfetherston Operating Systems 2 22-05-2008 12:30 PM
Vista - Windows Update - Error Code 800700C1 dbollard99 Windows Update 3 22-04-2007 12:37 PM


All times are GMT +5.5. The time now is 10:33 PM.