Page 1 of 2 12 LastLast
Results 1 to 15 of 20

Thread: Error Code: 0x80070645

  1. #1
    Error Code Guest

    Error Code: 0x80070645

    I tried updating to the new Family Pack 3.5 Framework. This was the what I
    received Error Code: 0x80070645 .

    Anyone out there know how to fix this?

    Thanks for your help.

  2. #2
    error code too Guest
    I am getting this same error code when installing this update. My machine
    does have .NET Framework 3.5 SP1 (BETA) installed previously. Working on
    figuring out the root of the problem, and I will update here if I do...

    I researched this and came up with this link:
    http://support.microsoft.com/kb/923100

    I followed the intructions and I fixed the problem for me.

  3. #3
    opus44 Guest
    Hello, I got the same error. No beta installed. Windows Update says that the
    product is already downloaded and can be installed. But the install reports
    the error, mentioned in the subject, on the Windows Update Page only (no
    error code is reported by the local install. The local install only reports
    that the install was not successful - no reason mentioned).
    How to fix it?
    How to change the state: downloaded and ready to install?
    How to remove the package from my local PC? or
    How to make it work?
    BTW - I have searched MS websites the whole morning to find a solution.
    Nothing found.
    I have the same message and am totally lost. Help is appreciated.

  4. #4
    error code too Guest

    RE: Error Code: 0x80070645

    I glance at the article that OpusXX mentioned, and it looked similar to the
    solution that I figured out.

    In "add remove programs" from the control panel, be sure to check the box
    that says "display updates". I had a beta version of .NET FW 3.5 installed
    previously. I removed that update, rebooted my computer, then installed the
    ..NET FW 3.5 (most recent and NON BETA) and it all worked.

  5. #5
    nha Guest

    RE: Error Code: 0x80070645 help, someone, please?

    Hi: I received the same error code, and have tried everything shown. I did
    not have 3.5 beta installed, so, as per link someone here posted from
    microsoft, I uninstalled all net framework programs on my computer, cosed
    out, and then tried to run the indows install cleanup that the link saqid to
    download next - but no reference there to any net framework showing to clean
    up. So I turned off my machine eyt again, and tried to reinstall all net
    framework programs that I'd had on my computer and uninstalled, and found
    that I couldn't install even one of those programs. So it now appears I have
    no net frameworks on my computer, I can't install or celan up anything, and
    am just thorouly lost and confused. I will try to do the last-resort
    uninstall (if there's anything left to uninstall) referred to in the windows
    article, but I have a feeling I'm in trouble. Any suggestions from anyone?
    I'd greatly appreciate. Thanks for your time.

  6. #6
    nelsontrek Guest
    For those people still having this issue I would like to know what OS you are
    running. I have 2 people with this same error and both have XP Home SP3. I
    have tried the resolution in KB923100 and still getting errors with update
    kb951847. I will post back once I find a solution.

    To anyone still having this problem, please post with your OS details. I
    have seen this on 2 pc's and the actions from KB923100 did not resolve the
    problem. Both of these PC's are running XP Home SP3.

  7. #7
    Rainer Guest

    RE: Error Code: 0x80070645

    I followed "http://support.microsoft.com/kb/923100" which was mentioned in
    this thread.
    - uninstalled all net framework versions
    - run net framework clean up utility
    - installed net framework versions again
    - run net framework verification tool
    Now it works.
    Only problem remaining is: I can not delete the package that was causing the
    error and was downloaded from Windows Update. There is a process that blocks
    ..msp files.
    Is there any hint how to delete them?

  8. #8
    Ziomo Guest
    What do you mean with: run net framework verification tool ?

    After the new installation of .net framework - run ".net framework setup
    verification tool" to ensure, that the installation is correct and working.
    You can find this tool here -
    http://blogs.msdn.com/astebner/pages/8999004.aspx

    And what is: net framework clean up utility ?

    Right-click on My Computer & select Properties: What WinXP version is
    displayed on the resulting General tab?

    What application are you attempting to uninstall via Add/Remove Programs?

  9. #9
    Rainer Guest
    Look here -

    bloody Microsoft must fix this issue in the update itself. Some not so good
    programmer messed up and now lots of people have to deal with this bull.

    I haven't yet seen any evidence that these issues are caused by a fault in the
    update rather than existing issues on the affected computers. Be that as it
    may, it is unlikely that Microsoft will make any changes to the .NET 3.5
    installer at this point.

  10. #10
    lmoss Guest
    I am having issues installing this on a server running Windows Server 2003
    SP2 - Enterprise. I have followed the information in the knowledge base
    link. I have tried to contact Microsof to get help - to no avail.

    Anyone have any other ideas?

    I am trying to fix a problem on my dell desktop, XP. I cant seem to delete a
    program in the add/remove program menu. I get an error message saying the
    program failed to launch. Make a long story short- was told that my Windows
    SP 3 may be corrupt to reinstall it. So, I deleted it. Downloaded the .exe
    from microsoft, and when I try to install get an error message saying that
    the anticipated files are not there. Error Code: 0x80070645

    so what do I do now?

    Do I manually try to download SP1 followed by SP2 and THEN try SP 3?

  11. #11
    FredO56 Guest

    Error code 80070645

    reinstall when i try to use widows vista update it says i have 2 updates one
    is for silver light and other one is net frame work 3.5 found out it dont
    apply 2 my system i have 32 bit i have tried to remove and clean and
    reinstall but i get message that it failed any clues at the end of my rope

  12. #12
    TaurArian Guest

    Re: Error code 80070645

    "0x80070645" means "ERROR_UNKNOWN_PRODUCT" (This action is only valid for
    products that are currently installed). It could be caused by the previous
    installation failure.

    From MS support notes I collect -

    "........ suggest that we use Windows Installer Cleanup to remove existing
    ..Net
    Framework, then reinstall .Net Framework 3.5. After this, we try applying
    KB951847 again.

    Please follow these steps:
    1. Download and install Windows Installer CleanUp Utility:
    Description of the Windows Installer CleanUp Utility
    http://support.microsoft.com/?id=290301

    2. Run this tool from "Start", then remove all existing .Net Framework.

    3. Downloaded the redistributable package from:
    http://www.microsoft.com/downloads/d...displaylang=en

    4. Install .Net Framework 3.5 SP1.
    http://www.microsoft.com/downloads/d...displaylang=en

    5. If it succeeds, run Windows Update and apply all available updates."


    As for the other problem, Silverlight -

    How to manually clean up a broken Silverlight installation
    http://blogs.msdn.com/rpomeroy/archi...tallation.aspx

  13. #13
    Gordonmdlnaim Guest

    Re: Error Code: 0x80070645

    Well, this is not the first time I've had to wrestle with .NET framework
    update issues... I'm going to wait a bit on this one before I uninstall the
    whole mess and start over like the last time. Something is just not
    coordinated properly - it's the only update issue I've ever had, and here it
    is again. :(

  14. #14
    Jakob Bohm Guest

    Re: Error Code: 0x80070645

    Some time ago I also had this (or a very similar) problem on one of my
    machines with the "update to .NET framework 3.x", after much debugging I
    think I found the reason, and it WAS a Microsoft mistake (though
    reporting bugs to Microsoft is always impossible thanks to the PSS idiots):

    Even though the update description did not say so, the update downloaded
    by Windows Update/Microsoft Update actually contained two complete and
    unrelated MSI patches for two different versions of the .NET framework.
    If patch#1 is irrelevant or already installed on your computer,
    installing patch#1 fails and the stupid, stupid update package then
    skips the needed patch#2 and reports that the entire update package
    failed to install (with no reporting of the details, just a
    HRESULT-wrapped hexadecimal version of a decimal MSI error code). The
    next time WU/MU/AU checks for updates it again checks if patch#2 is
    needed and not installed, redownloads the two-patch update package, runs
    it and fails again and again and again.

    So far the only workaround I could find was to uninstall ALL versions of
    the .NET framework, reboot, use the ".NET Cleaner" to remove anything
    not removed by the uninstall programs, reboot, manually reinstall all
    the .NET frameworks and their service packs from full administrative
    downloads in whichever sequence bypasses the problem, reboot, rerun
    WU/MU, reboot, rerun WU/MU, reboot.

    The thing Microsoft could/should do is simply put the two MSI patches
    individually on WU/MU/AU (which already supports MSP files directly),
    then the fact that each patch is tried on its own and the separation of
    the detection for patch#1 and patch#2 should clean up the problem
    automagically.

  15. #15
    Robert Aldwinckle Guest

    Re: Error Code: 0x80070645

    I have found that that is not necessary if you revert to a manual install
    *and* you pay attention to the diagnostics it tries to give you if it fails.
    In fact, you may find that those same diagnostics are already present
    in the logs the install creates; then the only real significant effect of the
    manual install is that it highlights the suggested resolution for you.

    In my case it was some beta versions of the components it includes
    that it wanted me to uninstall first. YMMV.

Page 1 of 2 12 LastLast

Similar Threads

  1. Unable to install MSE error code: 0x80070645
    By Qamar in forum Windows Software
    Replies: 5
    Last Post: 01-11-2012, 11:10 PM
  2. Error Code 4400:011A and Error Code 0F00:133C
    By mkwn in forum Operating Systems
    Replies: 1
    Last Post: 14-10-2011, 12:39 PM
  3. error 0x80070645
    By Jo Wright in forum Windows Update
    Replies: 5
    Last Post: 29-10-2009, 07:08 PM
  4. Replies: 9
    Last Post: 10-04-2009, 01:51 AM
  5. Replies: 2
    Last Post: 28-06-2007, 12:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •