Go Back   TechArena Community > Software > Windows Software
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



CamStudio wont record sound from RealTek HD Audio

Windows Software


Reply
 
Thread Tools Search this Thread
  #1  
Old 12-06-2012
Member
 
Join Date: May 2012
Posts: 78
CamStudio wont record sound from RealTek HD Audio
  

I have been using CamStudio on my system running on windows 7 and everything was working fine. Since adding a new Hard Drive I donít know why CamStudio is not recording sound from RealTek HD Audio and Input. When I am clicking on "Record Audio from Speakers" then I am getting an error message saying "WaveoutGetSelectControl()failed". I donít know what that means, is there anything I can try out for getting this fixed.

Reply With Quote
  #2  
Old 12-06-2012
Member
 
Join Date: Dec 2011
Posts: 117
Re: CamStudio wont record sound from RealTek HD Audio

It seems as if your CamStudio is not able to recognize your Audio Line. I will suggest you to make a auto search and if that does not help then Force CamStudio for recognizing your Audio Line manually, if you have not tried out the same then give it a try and see if it is getting detected. If it does not help then check out if there is any latest driver for your sound card by going in to the device manager, just make sure that you are updating to one of the latest available driver.
Reply With Quote
  #3  
Old 12-06-2012
Member
 
Join Date: May 2012
Posts: 78
Re: CamStudio wont record sound from RealTek HD Audio

I have updated the sound card previously but it is not making any difference in my case. I have also tried doing auto search several times and have tried choosing different option from drop down but when I am doing so then I am getting an error message saying the below thing:
"Unable to detect recording line for speakers. Please make sure your soundcard is selected correctly in the 'Soundcard device' of 'audio options for speakers."
Is there anything else that I need to check out?? Or any solution that I can try out further to fix this?? Any further help regarding the same will be appreciative.
Reply With Quote
  #4  
Old 12-06-2012
Member
 
Join Date: Nov 2011
Posts: 342
Re: CamStudio wont record sound from RealTek HD Audio

You can very well try out the solution that has been suggested above but if that does not make any difference then you can follow the below one. This solution has been mentioned as working by one who was facing similar issue.
  • First right click on audio icon which will be at the bottom, so just right click on the same and Click 'Recording Devices'. After that Right click the white background and select 'Show Disabled Devices' and now you will see Stereo Mix'.
  • So just Double click 'Stereo Mix' and click on 'General' tab, there will be a drop down box naming Device usage' so just click on click 'Use this device (enable)'.
  • After that Click on 'Listen' tab and from the drop down box naming Playback through this device' just select 'Default Playback Device' and move back to CamStudio window> Options and click on 'Record Audio from Microphone'.
  • When you are done with the same then go to Options tab> Audio Options > Audio Options for Microphone and from the drop down box naming 'Audio Capture Device' just select 'Stereo Mix (Realtek High Definition)' and click on ok.
Just try it out and post back the result that you get for this solution.
Reply With Quote
  #5  
Old 13-06-2012
Member
 
Join Date: Dec 2011
Posts: 155
Re: CamStudio wont record sound from RealTek HD Audio

I have checked out for the "WaveoutGetSelectControl()failed" error and have found that this error occurs when Stereo Mix which is also known as Wave Out Mix is not enable. You need to follow the below steps for enabling the same in Windows Vista:
  • Just go to control panel Select "Sound">recording tab> No on the background of the tab just right click and select "show disabled devices".
  • Now you will get Stereo Mix, so right click on the same and choose enable option, while you do so make sure that you are setting the Stereo Mix as your Standard.
  • So after making these changes Start Cam Studio and then go in to Options\ Audio Options for Speaker and select "Stereomix" for Soundcard Device and enable "Record audio from speakers" by going in to Options.
Reply With Quote
Reply

  TechArena Community > Software > Windows Software
Tags: , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "CamStudio wont record sound from RealTek HD Audio"
Thread Thread Starter Forum Replies Last Post
CamStudio wont record video when audio is activated Ulrich Windows Software 5 13-06-2012 02:02 PM
No sound from audio and speaker with Realtek HD Audio in DELL XPS L502x Shoya Portable Devices 4 24-02-2012 09:05 AM
Sound Keeps Cutting Out with Realtek Audio Faithist Windows Software 5 04-04-2011 07:17 AM
Cannot record sound with Realtek audio driver Erakna Operating Systems 5 22-03-2011 07:31 AM
Sound problems with Realtek Audio BoanHed Vista Hardware Devices 1 16-07-2008 07:44 AM


All times are GMT +5.5. The time now is 06:35 AM.