Go Back   TechArena Community > Software > Windows Software
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 14-04-2012
amertayeh
 
Posts: n/a
question Outlook 2003/2007 - Always allow SSL certificate

Hello people,

I am having a problem and hope to find the answer I am seeking with you.

I am trying to configure outlook to connect to a shared mail server (with shared SSL certificate) using my domain name. Of course this will give a mismatch error; that my domain name does not match the name on the certificate (which is the hosting company name).

What I want is to force outlook to connect always without prompting the "The target principal name is incorrect" error while keeping the server names in account settings for incoming and outgoing the same.

I tried adding the certificate to the trusted root certification authorities, but that did not help since the error is name mismatch, not untrusted certificate publisher.

Thank you,
Amer
Reply With Quote
  #2  
Old 18-04-2012
Member
 
Join Date: May 2011
Posts: 482
Re: Outlook 2003/2007 - Always allow SSL certificate

Try looking on the below link. It is a bit difficult to work with that error especially when you are on shared mail server. I does not really matter with other third party service. I tried to look for appropriate solution, but there are random doubts generated which can trigger another problem also. Just have a look on the below it might be helpful.

http://support.microsoft.com/kb/328917
Reply With Quote
  #3  
Old 03-01-2014
Member
 
Join Date: Jul 2011
Posts: 394
Re: Outlook 2003/2007 - Always allow SSL certificate

To fix the issue click on View Certificate. In that you have to checkout the part where it is written issued to. You can find the name of person whom the certificate is assigned. You have to properly add details of the incoming and outgoing server here. Sometime this fail to work because there might be more than one name for the certificates. You can go in the Details tab and go in Subject Alternative Name. You can find other names here. You can try adding them also and check to connect once again. This might resolve the issue.
Reply With Quote
  #4  
Old 03-01-2014
Member
 
Join Date: May 2011
Posts: 375
Re: Outlook 2003/2007 - Always allow SSL certificate

The issue appear when certificate name mismatches. You have to understand first how this thing works. Then only you can go ahead with fixing the issue. This is a common issue to many. Because here Outlook relies on the smtp address. If the name mismatches in the certificate you will get that popup on the screen. There are certain work around to fix the issue. You can find all of them at one place in the below linked article. Click on the same and checkout all the solutions. This will surely help you to get a solution.

How to suppress the AutoDiscover mismatch warning in Outlook 2007, Outlook 2010, and Outlook 2013
Reply With Quote
Reply

  TechArena Community > Software > Windows Software
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Outlook 2003/2007 - Always allow SSL certificate"
Thread Thread Starter Forum Replies Last Post
Outlook 2003 Contacts Transfer to Outlook 2007 pushpendra Vista Setup and Install 4 15-09-2008 02:15 PM
Certificate error accessing "Outlook Web Access" on SBS 2003 troy Small Business Server 2 05-08-2008 02:35 PM
certificate problem with outlook 2007 Hardik Small Business Server 3 17-07-2008 01:41 PM
Easiest way to transfer outlook 2003 settings (XP) to Outlook 2007 onnew vista machine? techman41973@yahoo.com Vista Help 6 01-04-2008 12:01 PM
How to get Digital Certificate for Outlook 2007? AngerEyes Windows Security 4 09-03-2008 12:33 PM


All times are GMT +5.5. The time now is 08:35 AM.