Results 1 to 5 of 5

Thread: FTP on Windows 2008 Server

  1. #1
    Join Date
    Feb 2011
    Posts
    123

    FTP on Windows 2008 Server

    It seems there was some confusion in the fields of Microsoft on the proper way to install the FTP service. This seems to be rooted in the fact that it took a last minute decision to exclude the new FTP Publishing Service IIS 7 in favor of the old FTP Publishing Service, In some case, once examination the installation of the FTP selection in the Add Features of my Server Manager I seen that gaily added a fresh entry of "FTP Server" in my Windows Firewall. So later than for several minutes playing with the permissions of the user, control the policies of my Netscreen firewall, etc. I originate that if you turn off Windows Firewall totally I might connect and list records without any crisis. If Windows Firewall was on I might obtain on the list except not the files. And start breaking manual FTP active / passive and ports required for that to be operational.

  2. #2
    Join Date
    Apr 2008
    Posts
    4,644

    Re: FTP on Windows 2008 Server

    I have gone through this same issue and I would like to suggest you to following steps and so that you can solve your issue. To do this you need to have inetpub.exe and after that you can solve your issue. I think you donít have the inetpub.exe file on your Windows Server 2008. This file is normally located at: c:\windows\system32\inetsrv\inetpub.exe. So I would like to suggest you top install the inetpub.exe and after that you can solve your issue. I hope this will help you.

  3. #3
    Join Date
    May 2008
    Posts
    4,574

    Re: FTP on Windows 2008 Server

    I would like to suggest you the following steps and so that you can solve your issue. To do this you need to install the IIS 7 must be installed on your Windows 2008 Server. Once you have installed and after that go through the following steps. Now you need create root folder for FTP publishing, to do this make new folder on this location: %SystemDrive%\inetpub\ftproot and after that you need to set the permission. To create the permission open the command prompt and under that type the following and then hit the enter after command:
    ICACLS "%SystemDrive%\inetpub\ftproot" /Grant IUSR:R /T
    Now once you complete this restart your system and after that go through your issue.

  4. #4
    Join Date
    May 2008
    Posts
    4,834

    Re: FTP on Windows 2008 Server

    I think you need to change the Configure Windows Firewall Settings and so that you can solve your issue. To do this: go to the start and after that make hit on the all program. Now under the all program go to the accessories and after that make hit on the command prompt. Now under that type the following and hit enter after every command.
    netsh advfirewall firewall add rule name="FTP (non-SSL)" action=allow protocol=TCP dir=in localport=21
    netsh advfirewall set global StatefulFtp enable
    Now once finish this command and after that close the command prompt and after that go through your issue.

  5. #5
    Join Date
    May 2008
    Posts
    4,348

    Re: FTP on Windows 2008 Server

    I would like to suggest you to download the FTP for IIS 7.0 and after that you can solve your issue. to download the FTP for IIS 7.0 make click here.Now once you complete the downloading and after that install it on your system. After install this one then open the command prompt and after that type the following and then hit the enter after every command:
    msiexec /I ftp7_x86_rtw.msi
    msiexec /I ftp7_x64_rtw.msi
    Now once you complete this command and after that type exit and then hit the enter and then go through your issue.

Similar Threads

  1. Replies: 8
    Last Post: 07-03-2012, 11:02 PM
  2. Replies: 1
    Last Post: 22-05-2011, 01:34 AM
  3. Installing a function of Windows Server 2008 Server Core
    By SalVatore in forum Tips & Tweaks
    Replies: 2
    Last Post: 28-08-2010, 04:03 PM
  4. Replies: 1
    Last Post: 29-12-2009, 03:06 PM
  5. Replies: 1
    Last Post: 06-05-2009, 09:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •