Go Back   TechArena Community > Software > Windows Software
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Office 2010 won't install - MSXML 6.10.1129.0 required

Windows Software


Reply
 
Thread Tools Search this Thread
  #1  
Old 29-07-2010
Member
 
Join Date: Mar 2010
Posts: 53
Office 2010 won't install - MSXML 6.10.1129.0 required
  

Office 2010 won't install - MSXML 6.10.1129.0 required. This is the error message I am getting but the windows 7 is having latest version. I am trying to configure Microsoft office 2010 and currently my operating system is windows 7. According to me there is no requirement for this version if I am using windows 7 as operating system. The office version that I am trying to install is the RTM version of office 2010 and I have downloaded yesterday. Any help related this will be appreciated.

Reply With Quote
  #2  
Old 29-07-2010
Member
 
Join Date: May 2008
Posts: 4,338
Re: Office 2010 won't install - MSXML 6.10.1129.0 required

I am also facing this similar problem, the error message that I am getting is that setup is not able to go further because of the errors. It is asking for some component and also giving instruction for re-running the setup again. The only solution I am thinking is that to downgrade this to 6.10 since the XML parser 6.30 is not given in the listed the updates. But before doing this I need suggestion from others.
Reply With Quote
  #3  
Old 29-07-2010
Member
 
Join Date: May 2008
Posts: 4,828
Re: Office 2010 won't install - MSXML 6.10.1129.0 required

Actually the thing is that there are two parts for MSXML, the first one is core services and the second one is the parser service. According to me you are not having the core services. You need to download these core services for this Microsoft Website (Core service) . I am not confident about the solution but you can try this, there are chances that you can resolve your issue.
Reply With Quote
  #4  
Old 29-07-2010
Member
 
Join Date: Mar 2010
Posts: 53
Re: Office 2010 won't install - MSXML 6.10.1129.0 required

Sorry to say but the Microsoft XML core services 6.0 service pack is not installing. A window is appearing with the message that the setup is not completed and it is not terminated. I am getting the same error message if I am trying this thing with the Core and Parser components. I have also tried to use MSXML 6.0 SP0 and SP2 but the result is same.
Reply With Quote
  #5  
Old 29-07-2010
Member
 
Join Date: Apr 2008
Posts: 4,086
Re: Office 2010 won't install - MSXML 6.10.1129.0 required

It seems that you are facing the problem of permission issue hence you need to test the workaround that is given below. Try to do this and let me know if this thing works for you.
1. First you need to log in as administarator and then opent he regedit.
2. After that you have to go to HKCR\TypeLib\{F5078F18-C551-11D3-89B9-0000F81FE221}\6.0\0\win32
3. Then you need to right click an give yourself complete access for the key.
4. After completing this you need alter the values from %SystemRoot%\System32\msxml6.dll to c:\windows\System32\msxml6.dll and then try to reinstall
I am sure that this will solve your problem.
Reply With Quote
  #6  
Old 30-07-2010
Member
 
Join Date: Mar 2010
Posts: 53
Re: Office 2010 won't install - MSXML 6.10.1129.0 required

I have tried the things as you have suggested leaving one modification. I have done the steps of changing the _"Go to HKCR\TypeLib\{F5078F18-C551-11D3-89B9-0000F81FE221}\6.0\0\win32, but it did not worked for me, because of the key is labeled \5.0\0\win32. I have also followed the suggestion of changing the key in the v5.0. after facing number of unsuccessful attempts now the Microsoft office is installed on my computer system. Thank you for the changes you have suggested.
Reply With Quote
  #7  
Old 30-07-2010
milliirthomas
 
Posts: n/a
Re: Office 2010 won't install - MSXML 6.10.1129.0 required

Office 2010 won't install and show error MSXML 6.10.1129.0 required.The windows 7 is having latest version and this configure Microsoft office 2010 and currently operating system is windows 7. According to me there is no requirement for this version because windows 7 as operating system. This office version is install in the RTM version of office 2010
Reply With Quote
  #8  
Old 06-04-2012
Member
 
Join Date: Apr 2012
Posts: 1
Re: Office 2010 won't install - MSXML 6.10.1129.0 required

Copy the following settings into a ".reg" file and apply it to your registry.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\TypeLib\{F5078F18-C551-11D3-89B9-0000F81FE221}]

[HKEY_CLASSES_ROOT\TypeLib\{F5078F18-C551-11D3-89B9-0000F81FE221}\6.0]

[HKEY_CLASSES_ROOT\TypeLib\{F5078F18-C551-11D3-89B9-0000F81FE221}\6.0\0]

[HKEY_CLASSES_ROOT\TypeLib\{F5078F18-C551-11D3-89B9-0000F81FE221}\6.0\0\win32]
@="c:\\windows\\system32\\msxml6.dll"
Reply With Quote
Reply

  TechArena Community > Software > Windows Software
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Office 2010 won't install - MSXML 6.10.1129.0 required"
Thread Thread Starter Forum Replies Last Post
before installing Office 2010 it asks for msxml 6.10.1129 shawntae Office Setup 3 14-01-2014 10:18 AM
Install OpenOffice or LibreOffice or MS Office 2010 or MS Office 365 in Windows 8, which one? ermahgerd Windows Software 6 01-10-2012 06:22 PM
Install Ms office 7 over Ms office 2010 Abriennea Windows Software 4 17-09-2011 09:56 PM
MS office 2010: Business Contact Manager 2010 wont install? Bieber Windows Software 4 15-10-2010 09:58 PM
Can't install KIS 2010 - Dont have the required permissions Vrushabh Windows Software 6 20-07-2010 05:28 PM


All times are GMT +5.5. The time now is 09:00 AM.