Go Back   TechArena Community > Software > Windows Software
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 08-04-2010
Member
 
Join Date: Mar 2010
Posts: 54
Can't compile driver under 2.6.33 kernel

I am trying to compile the newest NV driver (190.53) after the compilation of new 2.6.33 kernel, The execution procedure getting failed to function properly and occurred the message as " It can't determine the kernel version".

I have also tried to execute --kernel-source-path, but still interacting with the same behavior. If it matters, other external modules I had to compile, like a VBox driver, occurred no any issues like that.
Reply With Quote
  #2  
Old 08-04-2010
Member
 
Join Date: Apr 2008
Posts: 4,641
Can't compile driver under 2.6.33 kernel

Hello dude,

You have executed well with the Vbox because that doesn't any patches support or anything to be execute. But in case of the NV driver, For the execution of the NV driver you need to have some patch to compile specially with 190.53 .

Alternative install the latest beta-driver and execute normally with the 2.6.33 kernel.
Thanks
Reply With Quote
  #3  
Old 08-04-2010
Member
 
Join Date: May 2008
Posts: 4,565
Can't compile driver under 2.6.33 kernel

According to me, The issue that you are talking about is not related to that bug, because the nvidia 195.36.03 driver is not supported to work with kernel 2.6.33 and it should support with kernel 2.6.33 without any patches.

It commonly has something to do with his kernel sources not being installed, selected or compiled. In particular, if you installed a latest kernel version and destroyed the old kernel version, the previous kernel version will likely still be selected that will cause issues when compiling drivers that depend on the kernel sources being installed.
Reply With Quote
  #4  
Old 08-04-2010
Member
 
Join Date: May 2008
Posts: 4,339
Can't compile driver under 2.6.33 kernel

Situating fake kernel sources during simple patch from nvidia/linux site is available?

Find out the mentioned patch and run the following without root privilege:

sh NVIDIA-Linux-x86-195.30-pkg1.run --apply-patch nvidia-2.6.33.patch.txt

Then after,you would get something like this at the end of execution of the above command :

NVIDIA-Linux-x86-195.30-pkg1-custom.run
package so original file will not be overwritten

Then after execute the command associated with the SUDO :

sudo sh NVIDIA-Linux-x86-195.30-pkg1-custom.run -N -s


NVIDIA-Linux-x86-195.30-pkg1.run contains some necessary performance improvements, so I would suggest to download this beta.
Reply With Quote
  #5  
Old 08-04-2010
Member
 
Join Date: May 2008
Posts: 4,829
Can't compile driver under 2.6.33 kernel

Hello guys,
I got the exact solution for this, Now I resolved it with a patch and nvidia-drivers-190.53-r1.

By the way, At the time of broadcom-sta execution, my kernel-2.6.33 provides me some missing files error.so I have emerging again the source and now broadcom-sta executes very fine. Perhaps now nvidia-drivers-195.xx.xx could be executed but I am unable to try it now.

Thanks
Reply With Quote
Reply

  TechArena Community > Software > Windows Software
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Can't compile driver under 2.6.33 kernel"
Thread Thread Starter Forum Replies Last Post
"Display driver NVIDIA Windows Kernel Mode Driver stopped responding" error with GeGorce GT220 driver eRMA Monitor & Video Cards 4 01-04-2012 04:56 PM
How to compile VMware in ubuntu 11.04 using kernel 2.6.38-8 Czeslaw Windows Software 10 15-09-2011 10:27 PM
Getting kernel compile error when using genkernel while installing Gentoo Ro-Man Operating Systems 5 03-06-2011 10:34 AM
Debian i686 kernel compile chetna56 Operating Systems 3 04-01-2011 06:41 AM
Compile kernel 2.6.35.7 for centos 5.5 hardyB Operating Systems 5 12-11-2010 11:12 PM


All times are GMT +5.5. The time now is 05:45 PM.