Go Back   TechArena Community > Technical Support > Computer Help > Windows Server > Windows Server Help
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Error Add roles/Add Features Windows 2008 Enterprise Server

Windows Server Help


Reply
 
Thread Tools Search this Thread
  #1  
Old 12-05-2008
Marcel
 
Posts: n/a
Error Add roles/Add Features Windows 2008 Enterprise Server

After I added de feature Windows Internal Database in my Windows 2008 I get
the following error when I try to open the add roles/features interface:

Server Manager encountered an unexpected error while collecting data about
the status of this computer.

If I look in the ventvwr I see the following error:

Log Name: Microsoft-Windows-ServerManager/Operational
Source: Microsoft-Windows-ServerManager
Date: 12-5-2008 11:40:41
Event ID: 1601
Task Category: None
Level: Error
Keywords:
User: MAINSITE\administrator
Computer: MAINFRAME.mainsite.local
Description:
Could not discover the state of the system. An unexpected exception was found:
System.Runtime.InteropServices.COMException (0x80070490): Element not found.
(Exception from HRESULT: 0x80070490)
at
System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32
errorCode, IntPtr errorInfo)
at
Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(IntPtr& session, IntPtr& package)
at
Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo()
at Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()
at
Microsoft.Windows.ServerManager.Common.Provider.Initialize(DocumentCollection
documents)
at
Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResult(Object state)

<Provider Name="Microsoft-Windows-ServerManager"
Guid="{8c474092-13e4-430e-9f06-5b60a529bf38}" />
<EventID>1601</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x1000000000000000</Keywords>
<TimeCreated SystemTime="2008-05-12T09:40:41.211Z" />
<EventRecordID>35</EventRecordID>
<Correlation />
<Execution ProcessID="6440" ThreadID="5060" />
Microsoft-Windows-ServerManager/Operational

An unexpected exception was found:
System.Runtime.InteropServices.COMException (0x80070490): Element not found.
(Exception from HRESULT: 0x80070490)
at
System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32
errorCode, IntPtr errorInfo)
at
Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(IntPtr& session, IntPtr& package)
at
Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo()
at Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()
at
Microsoft.Windows.ServerManager.Common.Provider.Initialize(DocumentCollection
documents)
at
Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResult(Object state)

Anyone seen this before and knows how to solve it?

Greetings,

Marcel

Reply With Quote
  #2  
Old 13-05-2008
Marcel
 
Posts: n/a
RE: Error Add roles/Add Features Windows 2008 Enterprise Server

I installed .NET framework too, so I don't know what caused the problem.
Is there a sort op Recovery point where I can refer to in Windows 2008?

"Marcel" wrote:

> After I added de feature Windows Internal Database in my Windows 2008 I get
> the following error when I try to open the add roles/features interface:
>
> Server Manager encountered an unexpected error while collecting data about
> the status of this computer.
>
> If I look in the ventvwr I see the following error:
>
> Log Name: Microsoft-Windows-ServerManager/Operational
> Source: Microsoft-Windows-ServerManager
> Date: 12-5-2008 11:40:41
> Event ID: 1601
> Task Category: None
> Level: Error
> Keywords:
> User: MAINSITE\administrator
> Computer: MAINFRAME.mainsite.local
> Description:
> Could not discover the state of the system. An unexpected exception was found:
> System.Runtime.InteropServices.COMException (0x80070490): Element not found.
> (Exception from HRESULT: 0x80070490)
> at
> System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32
> errorCode, IntPtr errorInfo)
> at
> Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(IntPtr& session, IntPtr& package)
> at
> Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo()
> at Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()
> at
> Microsoft.Windows.ServerManager.Common.Provider.Initialize(DocumentCollection
> documents)
> at
> Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResult(Object state)
>
> <Provider Name="Microsoft-Windows-ServerManager"
> Guid="{8c474092-13e4-430e-9f06-5b60a529bf38}" />
> <EventID>1601</EventID>
> <Version>0</Version>
> <Level>2</Level>
> <Task>0</Task>
> <Opcode>0</Opcode>
> <Keywords>0x1000000000000000</Keywords>
> <TimeCreated SystemTime="2008-05-12T09:40:41.211Z" />
> <EventRecordID>35</EventRecordID>
> <Correlation />
> <Execution ProcessID="6440" ThreadID="5060" />
> Microsoft-Windows-ServerManager/Operational
>
> An unexpected exception was found:
> System.Runtime.InteropServices.COMException (0x80070490): Element not found.
> (Exception from HRESULT: 0x80070490)
> at
> System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32
> errorCode, IntPtr errorInfo)
> at
> Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(IntPtr& session, IntPtr& package)
> at
> Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo()
> at Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()
> at
> Microsoft.Windows.ServerManager.Common.Provider.Initialize(DocumentCollection
> documents)
> at
> Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResult(Object state)
>
> Anyone seen this before and knows how to solve it?
>
> Greetings,
>
> Marcel

Reply With Quote
  #3  
Old 13-05-2008
Darrell Gorter[MSFT]
 
Posts: n/a
RE: Error Add roles/Add Features Windows 2008 Enterprise Server

Hello Marcel,
Check the c:\windows\logs\cbs\cbs.log file for error messages.
Thanks,
Darrell Gorter[MSFT]

This posting is provided "AS IS" with no warranties, and confers no rights
--------------------
| >Thread-Topic: Error Add roles/Add Features Windows 2008 Enterprise Server
| >thread-index: Aci0bAVueeOr4iV0Su2d7H11qMpCzA==
| >X-WBNR-Posting-Host: 207.46.192.207
| >From: =?Utf-8?B?TWFyY2Vs?= <Marcel@discussions.microsoft.com>
| >References: <8E21E412-A2D2-4634-8A71-DD392194C73F@microsoft.com>
| >Subject: RE: Error Add roles/Add Features Windows 2008 Enterprise Server
| >Date: Mon, 12 May 2008 13:09:02 -0700
| >Lines: 76
| >Message-ID: <759DEDE0-9E8F-4103-828C-F1697F551FF1@microsoft.com>
| >MIME-Version: 1.0
| >Content-Type: text/plain;
| > charset="Utf-8"
| >Content-Transfer-Encoding: 7bit
| >X-Newsreader: Microsoft CDO for Windows 2000
| >Content-Class: urn:content-classes:message
| >Importance: normal
| >Priority: normal
| >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.2992
| >Newsgroups: microsoft.public.windows.server.general
| >Path: TK2MSFTNGHUB02.phx.gbl
| >Xref: TK2MSFTNGHUB02.phx.gbl
microsoft.public.windows.server.general:38159
| >NNTP-Posting-Host: tk2msftibfm01.phx.gbl 10.40.244.149
| >X-Tomcat-NG: microsoft.public.windows.server.general
| >
| >I installed .NET framework too, so I don't know what caused the problem.
| >Is there a sort op Recovery point where I can refer to in Windows 2008?
| >
| >"Marcel" wrote:
| >
| >> After I added de feature Windows Internal Database in my Windows 2008
I get
| >> the following error when I try to open the add roles/features
interface:
| >>
| >> Server Manager encountered an unexpected error while collecting data
about
| >> the status of this computer.
| >>
| >> If I look in the ventvwr I see the following error:
| >>
| >> Log Name: Microsoft-Windows-ServerManager/Operational
| >> Source: Microsoft-Windows-ServerManager
| >> Date: 12-5-2008 11:40:41
| >> Event ID: 1601
| >> Task Category: None
| >> Level: Error
| >> Keywords:
| >> User: MAINSITE\administrator
| >> Computer: MAINFRAME.mainsite.local
| >> Description:
| >> Could not discover the state of the system. An unexpected exception
was found:
| >> System.Runtime.InteropServices.COMException (0x80070490): Element not
found.
| >> (Exception from HRESULT: 0x80070490)
| >> at
| >>
System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32
| >> errorCode, IntPtr errorInfo)
| >> at
| >>
Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(I
ntPtr& session, IntPtr& package)
| >> at
| >>
Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo()
| >> at Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()
| >> at
| >>
Microsoft.Windows.ServerManager.Common.Provider.Initialize(DocumentCollectio
n
| >> documents)
| >> at
| >>
Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResul
t(Object state)
| >>
| >> <Provider Name="Microsoft-Windows-ServerManager"
| >> Guid="{8c474092-13e4-430e-9f06-5b60a529bf38}" />
| >> <EventID>1601</EventID>
| >> <Version>0</Version>
| >> <Level>2</Level>
| >> <Task>0</Task>
| >> <Opcode>0</Opcode>
| >> <Keywords>0x1000000000000000</Keywords>
| >> <TimeCreated SystemTime="2008-05-12T09:40:41.211Z" />
| >> <EventRecordID>35</EventRecordID>
| >> <Correlation />
| >> <Execution ProcessID="6440" ThreadID="5060" />
| >> Microsoft-Windows-ServerManager/Operational
| >>
| >> An unexpected exception was found:
| >> System.Runtime.InteropServices.COMException (0x80070490): Element not
found.
| >> (Exception from HRESULT: 0x80070490)
| >> at
| >>
System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32
| >> errorCode, IntPtr errorInfo)
| >> at
| >>
Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(I
ntPtr& session, IntPtr& package)
| >> at
| >>
Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo()
| >> at Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()
| >> at
| >>
Microsoft.Windows.ServerManager.Common.Provider.Initialize(DocumentCollectio
n
| >> documents)
| >> at
| >>
Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResul
t(Object state)
| >>
| >> Anyone seen this before and knows how to solve it?
| >>
| >> Greetings,
| >>
| >> Marcel
| >

Reply With Quote
  #4  
Old 15-05-2008
Marcel
 
Posts: n/a
RE: Error Add roles/Add Features Windows 2008 Enterprise Server

The log reports the following error:

22:32:58, Error CBS Failed to resolve Package:
Package_for_KB947864~31bf3856ad364e35~amd64~~6.0.1.0. hr: 0x80070490

I looked it up, it's a hotfix for IE 7, but does not aply on my system if I
try to install it.
I can't find this fix in my installed programs.


""Darrell Gorter[MSFT]"" wrote:

> Hello Marcel,
> Check the c:\windows\logs\cbs\cbs.log file for error messages.
> Thanks,
> Darrell Gorter[MSFT]
>
> This posting is provided "AS IS" with no warranties, and confers no rights
> --------------------
> | >Thread-Topic: Error Add roles/Add Features Windows 2008 Enterprise Server
> | >thread-index: Aci0bAVueeOr4iV0Su2d7H11qMpCzA==
> | >X-WBNR-Posting-Host: 207.46.192.207
> | >From: =?Utf-8?B?TWFyY2Vs?= <Marcel@discussions.microsoft.com>
> | >References: <8E21E412-A2D2-4634-8A71-DD392194C73F@microsoft.com>
> | >Subject: RE: Error Add roles/Add Features Windows 2008 Enterprise Server
> | >Date: Mon, 12 May 2008 13:09:02 -0700
> | >Lines: 76
> | >Message-ID: <759DEDE0-9E8F-4103-828C-F1697F551FF1@microsoft.com>
> | >MIME-Version: 1.0
> | >Content-Type: text/plain;
> | > charset="Utf-8"
> | >Content-Transfer-Encoding: 7bit
> | >X-Newsreader: Microsoft CDO for Windows 2000
> | >Content-Class: urn:content-classes:message
> | >Importance: normal
> | >Priority: normal
> | >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.2992
> | >Newsgroups: microsoft.public.windows.server.general
> | >Path: TK2MSFTNGHUB02.phx.gbl
> | >Xref: TK2MSFTNGHUB02.phx.gbl
> microsoft.public.windows.server.general:38159
> | >NNTP-Posting-Host: tk2msftibfm01.phx.gbl 10.40.244.149
> | >X-Tomcat-NG: microsoft.public.windows.server.general
> | >
> | >I installed .NET framework too, so I don't know what caused the problem.
> | >Is there a sort op Recovery point where I can refer to in Windows 2008?
> | >
> | >"Marcel" wrote:
> | >
> | >> After I added de feature Windows Internal Database in my Windows 2008
> I get
> | >> the following error when I try to open the add roles/features
> interface:
> | >>
> | >> Server Manager encountered an unexpected error while collecting data
> about
> | >> the status of this computer.
> | >>
> | >> If I look in the ventvwr I see the following error:
> | >>
> | >> Log Name: Microsoft-Windows-ServerManager/Operational
> | >> Source: Microsoft-Windows-ServerManager
> | >> Date: 12-5-2008 11:40:41
> | >> Event ID: 1601
> | >> Task Category: None
> | >> Level: Error
> | >> Keywords:
> | >> User: MAINSITE\administrator
> | >> Computer: MAINFRAME.mainsite.local
> | >> Description:
> | >> Could not discover the state of the system. An unexpected exception
> was found:
> | >> System.Runtime.InteropServices.COMException (0x80070490): Element not
> found.
> | >> (Exception from HRESULT: 0x80070490)
> | >> at
> | >>
> System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32
> | >> errorCode, IntPtr errorInfo)
> | >> at
> | >>
> Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(I
> ntPtr& session, IntPtr& package)
> | >> at
> | >>
> Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo()
> | >> at Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()
> | >> at
> | >>
> Microsoft.Windows.ServerManager.Common.Provider.Initialize(DocumentCollectio
> n
> | >> documents)
> | >> at
> | >>
> Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResul
> t(Object state)
> | >>
> | >> <Provider Name="Microsoft-Windows-ServerManager"
> | >> Guid="{8c474092-13e4-430e-9f06-5b60a529bf38}" />
> | >> <EventID>1601</EventID>
> | >> <Version>0</Version>
> | >> <Level>2</Level>
> | >> <Task>0</Task>
> | >> <Opcode>0</Opcode>
> | >> <Keywords>0x1000000000000000</Keywords>
> | >> <TimeCreated SystemTime="2008-05-12T09:40:41.211Z" />
> | >> <EventRecordID>35</EventRecordID>
> | >> <Correlation />
> | >> <Execution ProcessID="6440" ThreadID="5060" />
> | >> Microsoft-Windows-ServerManager/Operational
> | >>
> | >> An unexpected exception was found:
> | >> System.Runtime.InteropServices.COMException (0x80070490): Element not
> found.
> | >> (Exception from HRESULT: 0x80070490)
> | >> at
> | >>
> System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32
> | >> errorCode, IntPtr errorInfo)
> | >> at
> | >>
> Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(I
> ntPtr& session, IntPtr& package)
> | >> at
> | >>
> Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo()
> | >> at Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()
> | >> at
> | >>
> Microsoft.Windows.ServerManager.Common.Provider.Initialize(DocumentCollectio
> n
> | >> documents)
> | >> at
> | >>
> Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResul
> t(Object state)
> | >>
> | >> Anyone seen this before and knows how to solve it?
> | >>
> | >> Greetings,
> | >>
> | >> Marcel
> | >
>
>

Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows Server > Windows Server Help
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Error Add roles/Add Features Windows 2008 Enterprise Server"
Thread Thread Starter Forum Replies Last Post
SBS 2008 Cannot see roles and features Zylawys Networking & Security 1 11-05-2012 11:21 AM
Migrating from Server 2000 Enterprise to Server 2008 Enterprise cengizulusahin Windows Server Help 1 28-07-2011 11:55 PM
Windows 2008 server manager errors, unable to add roles/features Gilbert Windows Server Help 5 21-09-2010 06:28 PM
Server 2008 DC FSMO roles Zaz Windows Server Help 4 27-12-2009 06:55 PM
windows server 2008 Enterprise Serial Number jiang Windows Server Help 1 18-04-2009 03:26 AM


All times are GMT +5.5. The time now is 07:52 PM.