Results 1 to 9 of 9

Thread: Remote Desktop Disconnected - error in data encryption

  1. #1
    Matt Carter Guest

    Remote Desktop Disconnected - error in data encryption

    I am on a Microsoft Windows Vista x86 SP0 system and I just created a
    Microsoft Standard Server X64 and I am remotely connecting to it. I am
    getting an error and losing network connection:

    Remote Desktop Disconnected
    Because of an error in data encryption, this session will end. Please try
    connecting to the remote computer again. OK Help.

    I click OK

    On Control Panel, System, Remote Settings, System Properties for the Remote
    tab, I have selected Allow connections from computers running any version of
    Remote Desktop (less secure), and then I changed it to Allow connections only
    from computers running Remote Desktop with Network Level Authentication (more
    secure).
    I have changed it to NLA and it doesn't matter which one I go to.
    I am not sure what is happening or why this is happening. I just built
    these yesterday and I did the updates and they are on the same switch and in
    the same server room as other systems, and they were Server 2003 Standard x64
    systems but I formatted the drives. They only got new software, everything
    else, hardware, wires, etc. all stayed the same.

  2. #2
    Matt Carter Guest

    RE: Remote Desktop Disconnected - error in data encryption

    I am not sure if this is a problem for anyone else?

    I am on a Vista SP1, my information is below. I am connecting via Remote
    Desktop Connection on a simple network connection with a Switch - Foundry
    Networks - FastIron GS 648P
    with VLAN's.
    The error:
    Remote Desktop Disconnected Because of an error in data encryption, this
    session will end. Please try connecting to the remote computer again.

    I have changed from Remote tab for System Properties on both the 2008 Server
    and Vista system to have a more secure and less secure session and it doesn't
    seem to matter. I am a domain administrator logging on with domain
    administrator credentials. I also changed to NOT use a TS Gateway server as
    we do not have one on the Remote Desktop Connection on Vista SP1
    I am connecting with a Full Screen view and 16 bit color and 56K experience
    over our 1GB connection to the switch on CAT6 cables. I do not play sounds
    on the Local Resources tab of the RDC and only allow clipboard local devices
    and resources


    H:\>systeminfo

    Host Name: VISTA
    OS Name: Microsoftr Windows VistaT Business
    OS Version: 6.0.6001 Service Pack 1 Build 6001
    OS Manufacturer: Microsoft Corporation
    OS Configuration: Member Workstation
    OS Build Type: Multiprocessor Free
    Registered Owner: ME
    Registered Organization:
    Product ID: 55041-026-9513271-71879
    Original Install Date: 5/3/2007, 8:57:48 AM
    System Boot Time: 4/11/2008, 4:04:50 PM
    System Manufacturer: Hewlett-Packard

  3. #3
    Einari Guest

    RE: Remote Desktop Disconnected - error in data encryption

    Hello,

    I have the same problem.
    After some googling I found out that VS 2005 SP1 was to blame and after I
    uninstalled it I could connect again without errors.

    So I'd like to know if there's another way of solving this.

  4. #4
    Matt Carter Guest

    RE: Remote Desktop Disconnected - error in data encryption

    Thank you for the reply Einari, the strange thing is that we are not using
    Virtual Server 2005 SP1 at all on this Microsoft Windows Vista x86 SP1
    system, we are using Remote Desktop Connection and we are connecting to a
    physical server, Microsoft Windows Server 2008 Standard x64 version 6.0
    (Build 6001: Service Pack 1) 2GB memory, HP ProLiant DL365 G1
    I have other HP ProLiant systems and I have updated the firmware and
    hardware on the systems with the latest drivers from Microsoft Update and HP
    ProLiant SmartStart CD and ProLiant Support Pack for Server 2008 Standard X64

  5. #5
    Einari Guest

    RE: Remote Desktop Disconnected - error in data encryption

    My problem was solved now.
    Solution was found here:
    http://forums.microsoft.com/TechNet/...teID=17&mode=1
    "I ran into this problem as well on my PE2950 w/ Win2k8 x64 and Broadcom
    NetXtreme II NICs. To resolve it open the Broadcom Advanced Control Suite and
    disable IPv4 Large Send Offload and your problem will be solved."

  6. #6
    Bartek Guest
    Thank you very much for posting this information. It saved me a lot of
    research, although entire day was spend on it already. Much appreciated!!
    My issue started after installing Symanted Endpoint security on my 2008
    64bit clustered servers, so for anyone experiencing any issues after updating
    their AV software, make sure to check that first.

  7. #7
    Join Date
    Mar 2009
    Posts
    1

    Re: Remote Desktop Disconnected - error in data encryption

    Thankyou VERY VERY much - after a lot of hassle and head scratching. I pretty much changed every setting on my setup to no avail, but this change in the Broadcom Control Suite fixed it straight away for me.

    My setup was Windows 2008 Hyper-V x64, trying to connect via XP SP2 using RDP 6.1 client.

    Thanks again

  8. #8
    Join Date
    Jun 2009
    Posts
    1

    Re: Remote Desktop Disconnected - error in data encryption

    Your post resolved my issue. Thank you.

    I was freaking out because connecting to this system via Dameware was painfully slow, but console access was fine. RDP kept resetting. I was getting nowhere trying to perform Windows Updates. I kept getting the same "code 80072F78". After making the change you suggested, all those issues went away. Everything is working as expected.

    Thank You.

  9. #9
    Join Date
    Jan 2010
    Posts
    1

    Re: Remote Desktop Disconnected - error in data encryption

    I am having this same problem. I tried the fix of changing the large offload settings on the nic, followed by a reboot, but no joy. This is a Server 2008 x64 with one Broadcom NIC, HyperV installed and one XP VM running. It is a remote server connected by two Cisco RV042 routers over an IPSEC tunnel. It was OK for a few months, then started acting up. Sometimes drops immediately, other times after a few minutes work.

    File shares and all the usual windows functions seem OK.

    I guess the next step is to go to the remote site and see if RDP drops out locally or only over the WAN tunnel.

Similar Threads

  1. VPN Error 629 - The port was disconnected by the remote machine
    By Santosh24 in forum Networking & Security
    Replies: 5
    Last Post: 29-12-2009, 03:01 PM
  2. RDC - because of an error in data encryption, this session will en
    By Matt Carter in forum Windows Server Help
    Replies: 1
    Last Post: 19-05-2008, 07:03 PM
  3. Remote Web Workplace Disconnected Error
    By K-Mind in forum Small Business Server
    Replies: 6
    Last Post: 28-02-2008, 01:59 AM
  4. Replies: 2
    Last Post: 22-02-2006, 02:53 PM
  5. RWW vbscript: remote desktop disconnected
    By Susan Bradley in forum Small Business Server
    Replies: 4
    Last Post: 06-07-2005, 07:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •