Go Back   TechArena Community > Technical Support > Computer Help > Windows Server > Windows Server Help
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Server 2003 post SP2 update hangs at "applying computer settings"

Windows Server Help


Reply
 
Thread Tools Search this Thread
  #1  
Old 24-09-2007
Jason Knight
 
Posts: n/a
Server 2003 post SP2 update hangs at "applying computer settings"

I've got a situation that requires some describing. We recently upgraded our
BES server from W2K to W2K3 standard. All went well during and after the
upgrade. We installed SP2, everything's fine. We install post-SP2 updates,
and everything's not fine. Upon reboot, "applying computer settings" just
hangs there eternally. Two minutes later I find a KB article on Microsoft's
support site:

http://support.microsoft.com/kb/905716

It refers to using PowerChute version 6.x which had a packaged version of
Java 1.2.1 that had a digital certificate that expired in 2005. We never had
version 6.x on this machine, we started with Powerchute 7.04 and had no
problems until post-SP2 installation. Unfortunately, we're not sure which
update broke it either, there were a good number of them.

So, we upgraded from 7.04 to 7.05, which comes with the packages jre1.4_11.
Apparently, PowerChute only works with it's packaged version and does not
like Java Runtime 6 update 2! And BES MDS services won't start without
jre1.6_02 installed! I tried editing the registry key for the MDS services
to point to the jre1.4_11 in the PowerChute jre directories and no go! Also
tried it the other way around, and edited the PowerChute registry keys to
point to jre1.6_02's jvm.dll with a no go. I setup PowerChute the way it is
on our other two servers, with NO OTHER jre installed whatsoever, and it
works fine. What can I do to make BES and PowerChute live together? Any
idea which update broke the server without having to rifle through close to
50 updates?


Reply With Quote
  #2  
Old 24-09-2007
Meinolf Weber
 
Posts: n/a
Re: Server 2003 post SP2 update hangs at "applying computer settings"

Hello Jason,

I think you have to call Symantec for BE and also APC to find a solution.

Best regards

Meinolf Weber
Disclaimer: This posting is provided "AS IS" with no warranties, and confers
no rights.

> I've got a situation that requires some describing. We recently
> upgraded our BES server from W2K to W2K3 standard. All went well
> during and after the upgrade. We installed SP2, everything's fine. We
> install post-SP2 updates, and everything's not fine. Upon reboot,
> "applying computer settings" just hangs there eternally. Two minutes
> later I find a KB article on Microsoft's support site:
>
> http://support.microsoft.com/kb/905716
>
> It refers to using PowerChute version 6.x which had a packaged version
> of Java 1.2.1 that had a digital certificate that expired in 2005. We
> never had version 6.x on this machine, we started with Powerchute 7.04
> and had no problems until post-SP2 installation. Unfortunately, we're
> not sure which update broke it either, there were a good number of
> them.
>
> So, we upgraded from 7.04 to 7.05, which comes with the packages
> jre1.4_11. Apparently, PowerChute only works with it's packaged
> version and does not like Java Runtime 6 update 2! And BES MDS
> services won't start without jre1.6_02 installed! I tried editing the
> registry key for the MDS services to point to the jre1.4_11 in the
> PowerChute jre directories and no go! Also tried it the other way
> around, and edited the PowerChute registry keys to point to
> jre1.6_02's jvm.dll with a no go. I setup PowerChute the way it is on
> our other two servers, with NO OTHER jre installed whatsoever, and it
> works fine. What can I do to make BES and PowerChute live together?
> Any idea which update broke the server without having to rifle through
> close to 50 updates?
>



Reply With Quote
  #3  
Old 25-09-2007
Meinolf Weber
 
Posts: n/a
Re: Server 2003 post SP2 update hangs at "applying computer settings"

Hello Jason,

I post here the mail content also for other to follow your problem, please
do not email, post every answer here. :-)


Thanks for the reply, but here's the deal:

1. BES = Blackberry Enterprise Server. To my knowledge Symantec Backup
Exec does not use Java in any way. To be more specific, we are using BES
4.1.3 currently. Sorry, should have been a bit more specific in the original
post. We don't currently have a support contract with RIM, so I'm contacting
T-Mobile (who provided the BES) to see what we can do with them on the issue.
However, since it appears to be a M$ patch that broke everything to begin
with, I figured I'd draw on any experience that someone may have already
had with a similar configuration.

2. APC is in the clear on this one. It's what pointed out the problem,
but their software works fine, stand alone. With no other version of the
Java runtime installed, the APC PowerChute software works flawlessly. It's
when any other version of the runtime is installed, that the problem appears.
AT THIS POINT. It was co-existing fine with several other installations
of JRE, about 3 versions of 5, and 2 versions of JRE 6 installed, PRIOR TO
THE M$ UPDATE.

I thought the short was BackupExec. With Blackberry i have no experience.



Best regards

Meinolf Weber
Disclaimer: This posting is provided "AS IS" with no warranties, and confers
no rights.

> I've got a situation that requires some describing. We recently
> upgraded our BES server from W2K to W2K3 standard. All went well
> during and after the upgrade. We installed SP2, everything's fine. We
> install post-SP2 updates, and everything's not fine. Upon reboot,
> "applying computer settings" just hangs there eternally. Two minutes
> later I find a KB article on Microsoft's support site:
>
> http://support.microsoft.com/kb/905716
>
> It refers to using PowerChute version 6.x which had a packaged version
> of Java 1.2.1 that had a digital certificate that expired in 2005. We
> never had version 6.x on this machine, we started with Powerchute 7.04
> and had no problems until post-SP2 installation. Unfortunately, we're
> not sure which update broke it either, there were a good number of
> them.
>
> So, we upgraded from 7.04 to 7.05, which comes with the packages
> jre1.4_11. Apparently, PowerChute only works with it's packaged
> version and does not like Java Runtime 6 update 2! And BES MDS
> services won't start without jre1.6_02 installed! I tried editing the
> registry key for the MDS services to point to the jre1.4_11 in the
> PowerChute jre directories and no go! Also tried it the other way
> around, and edited the PowerChute registry keys to point to
> jre1.6_02's jvm.dll with a no go. I setup PowerChute the way it is on
> our other two servers, with NO OTHER jre installed whatsoever, and it
> works fine. What can I do to make BES and PowerChute live together?
> Any idea which update broke the server without having to rifle through
> close to 50 updates?
>



Reply With Quote
  #4  
Old 26-09-2007
Meinolf Weber
 
Posts: n/a
Re: Server 2003 post SP2 update hangs at "applying computer settings"

Hello Jason,

Nice to hear that you got it.

Again, PLEASE do not email, use the NG, thats for it is made.


Right on, thanks for replying!

Got it solved. It was one of the updates that broke the functionality, and
am not sure which one it was. It was a Java conflict, and the fix was:

1. Uninstall all JRE copies of Java
2. Re-install Blackberry Enterprise Server 4.1.3 with embedded jre1.5_09
3. Set up depedencies on three Blackberry services (dispatcher, policy and
sync services) to wait on MSSQL service according to this KB article:
(http://www.blackberry.com/btsc/dynam...C&kcId=KB03806)

All is functional once again!


Best regards

Meinolf Weber
Disclaimer: This posting is provided "AS IS" with no warranties, and confers
no rights.

> I've got a situation that requires some describing. We recently
> upgraded our BES server from W2K to W2K3 standard. All went well
> during and after the upgrade. We installed SP2, everything's fine. We
> install post-SP2 updates, and everything's not fine. Upon reboot,
> "applying computer settings" just hangs there eternally. Two minutes
> later I find a KB article on Microsoft's support site:
>
> http://support.microsoft.com/kb/905716
>
> It refers to using PowerChute version 6.x which had a packaged version
> of Java 1.2.1 that had a digital certificate that expired in 2005. We
> never had version 6.x on this machine, we started with Powerchute 7.04
> and had no problems until post-SP2 installation. Unfortunately, we're
> not sure which update broke it either, there were a good number of
> them.
>
> So, we upgraded from 7.04 to 7.05, which comes with the packages
> jre1.4_11. Apparently, PowerChute only works with it's packaged
> version and does not like Java Runtime 6 update 2! And BES MDS
> services won't start without jre1.6_02 installed! I tried editing the
> registry key for the MDS services to point to the jre1.4_11 in the
> PowerChute jre directories and no go! Also tried it the other way
> around, and edited the PowerChute registry keys to point to
> jre1.6_02's jvm.dll with a no go. I setup PowerChute the way it is on
> our other two servers, with NO OTHER jre installed whatsoever, and it
> works fine. What can I do to make BES and PowerChute live together?
> Any idea which update broke the server without having to rifle through
> close to 50 updates?
>



Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows Server > Windows Server Help
Tags: , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Server 2003 post SP2 update hangs at "applying computer settings""
Thread Thread Starter Forum Replies Last Post
Windows Server 2003 hangs on "applying computer settings" Gavin Windows Server Help 11 16-11-2010 01:09 AM
Server Hangs at " Applying Computer Settings" on SBS 2003 R2/HP ML Donald Small Business Server 2 18-07-2008 12:31 AM
Following Reboot Server Hangs at "applying computer settings" CoreTin Small Business Server 2 04-10-2007 07:29 PM
Server Stuck at "Applying Personal Settings" & Clients stuck at "Applying Computer Settings" Blerim Small Business Server 3 06-10-2006 05:23 PM
Windows 2003 SBS Hangs on "Applying computer Settings" MSFT Small Business Server 6 29-07-2005 08:48 AM


All times are GMT +5.5. The time now is 12:32 PM.