Go Back   TechArena Community > Technical Support > Computer Help > Windows Server > Windows Server Help
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Group or Resource not in correct state

Windows Server Help


Reply
 
Thread Tools Search this Thread
  #1  
Old 13-04-2005
Allan West
 
Posts: n/a
Group or Resource not in correct state

I'm trying to implement a 2 node windows server 2003 cluster. I've got the
first node configured using the wizard and its created a group called Cluster
Group which contains: Cluster IP Address, Cluster Name and Disk Q: R:
resources

When i try to add the other node it gets through the wizard all the way to
the end when it states an error "0x8007139F: The group or resource is not in
the correct state to perform the requested operation."

Does anyone know what could cause this as my searches on google and on
microsoft support haven't brought up anything.

Reply With Quote
  #2  
Old 13-04-2005
Mike Rosado [MSFT]
 
Posts: n/a
RE: Group or Resource not in correct state

Hi Alan,

See if the Cluster Log on the failing node to see if it is reporting the
following:

2003-12-30 17:07:54.190 [INFO] [BC] A runtime error has occurred in file
'd:\srv03rtm\base\cluster\mgmt\cluscfg\basecluster\cbaseclusteraddnode.cpp',
line
284. Error code is 0x8007139f.

The error string is 'A problem occurred during the cluster configuration.
The
installation state of the cluster service is not correct.'.

It may be necessary to manually modify the registry for the
InstallationState on
failing node to one of the following values which are valid:

The script checks for the following values in the registry.

HKLM\SOFTWARE\Microsoft\Windows NT\Current Version\Cluster Server

with a value of "ClusterInstallationState"

The Data will be one of four, with 2 or 3 being successful:

0 = ClusterInstallStateUnknown - Cluster Service configuration unknown
1 = ClusterInstallStateFilesCopied - Files Copied but Cluster Service not
configured
2 = ClusterInstallStateConfigured - Cluster Service configured, fresh
install
3 = ClusterInstallStateUpgraded - Cluster Service configured, upgrade

--
Hope this helps,
Mike Rosado
Windows 2000 MCSE + MCDBA
Microsoft Enterprise Platform Support
Windows NT/2000/2003 Cluster Technologies

====================================================
When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.
====================================================

This posting is provided "AS IS" with no warranties, and confers no rights.
<http://www.microsoft.com/info/cpyright.htm>

-----Original Message-----
> From: <Allan West@discussions.microsoft.com>
> Subject: Group or Resource not in correct state
> Date: Wed, 13 Apr 2005 02:33:01 -0700
>
> I'm trying to implement a 2 node windows server 2003 cluster. I've got

the
> first node configured using the wizard and its created a group called

Cluster
> Group which contains: Cluster IP Address, Cluster Name and Disk Q: R:
> resources
>
> When i try to add the other node it gets through the wizard all the way

to
> the end when it states an error "0x8007139F: The group or resource is not

in
> the correct state to perform the requested operation."
>
> Does anyone know what could cause this as my searches on google and on
> microsoft support haven't brought up anything.
>


Reply With Quote
  #3  
Old 14-04-2005
Allan West
 
Posts: n/a
RE: Group or Resource not in correct state

I'm not getting that string in the file. Below is the entries from the
cluster log file

2005-04-14 11:02:17.421 [INFO] adama: [PC-Create] Disk Q: R:: Found existing
resource. (hr=00000000, {CD36919C-9F31-46B4-A29D-AC87F4E6CC93},
{48189324-673A-4FB6-9171-9C5939515EE1}, 0, 1, 1), (null)
2005-04-14 11:02:17.453 [INFO] adama: [PC-Create] Disk Q: R:: Found existing
resource. (hr=00000000, {CD36919C-9F31-46B4-A29D-AC87F4E6CC93},
{48189324-673A-4FB6-9171-9C5939515EE1}, 0, 1, 1), (null)
2005-04-14 11:02:17.484 [INFO] adama: Setting private properties on
resources... (hr=00000000, {411BCDEC-69D3-4485-8D5D-E19EE77A6DD4},
{9C7A0060-5607-4962-9643-F1FD7121A1D6}, 1, 1, 1), (null)
2005-04-14 11:02:17.515 [INFO] adama: Setting private properties on
resources... (hr=00000000, {411BCDEC-69D3-4485-8D5D-E19EE77A6DD4},
{9C7A0060-5607-4962-9643-F1FD7121A1D6}, 1, 1, 1), (null)
2005-04-14 11:02:17.578 [INFO] [PC-ResourceEntry] ClusterResourceControl(
CLUSCTL_RESOURCE_SET_PRIVATE_PROPERTIES ) failed for resource 'Disk Q: R:'.
(sc=0x00139f)
2005-04-14 11:02:17.609 [ERR ] adama: Failed to set the private properties
for the 'Disk Q: R:' resource. (hr=0x8007139f,
{9C7A0060-5607-4962-9643-F1FD7121A1D6},
{4A86EE67-C8EC-4831-896D-474610B4FC3C}, 1, 1, 1), (null)
2005-04-14 11:02:17.640 [ERR ] adama: Failed to set the private properties
for the 'Disk Q: R:' resource. (hr=0x8007139f,
{9C7A0060-5607-4962-9643-F1FD7121A1D6},
{4A86EE67-C8EC-4831-896D-474610B4FC3C}, 1, 1, 1), (null)
2005-04-14 11:02:17.671 [ERR ] adama: Failed to configure resource instance.
(hr=0x8007139f, {CD36919C-9F31-46B4-A29D-AC87F4E6CC93},
{04B5E793-3A69-43E1-9FE8-8443FEAC725E}, 0, 0, 0), (null)
2005-04-14 11:02:17.703 [ERR ] adama: Failed to configure resource instance.
(hr=0x8007139f, {CD36919C-9F31-46B4-A29D-AC87F4E6CC93},
{04B5E793-3A69-43E1-9FE8-8443FEAC725E}, 0, 0, 0), (null)
2005-04-14 11:02:17.750 [INFO] adama: Creating resources. (hr=00000000,
{CD36919C-9F31-46B4-A29D-AC87F4E6CC93},
{4F6BD1A1-9440-4D4C-A9E0-9943E7B34D30}, 0, 2, 2), (null)
2005-04-14 11:02:17.765 [INFO] adama: Creating resources. (hr=00000000,
{CD36919C-9F31-46B4-A29D-AC87F4E6CC93},
{4F6BD1A1-9440-4D4C-A9E0-9943E7B34D30}, 0, 2, 2), (null)

We've got 2 identical servers that i'm trying to set a 2 node cluster up on.
Unfortunately, whats happening is that even though I get this warning, when
i try to test failing the cluster the Drive Q: R: resource produces an error
icon and then it resorts back to the first node.

ClusterInstallationState value is 2 on each server.

Any further help would be greatly appreciated!

Regards,
Allan West


"Mike Rosado [MSFT]" wrote:

> Hi Alan,
>
> See if the Cluster Log on the failing node to see if it is reporting the
> following:
>
> 2003-12-30 17:07:54.190 [INFO] [BC] A runtime error has occurred in file
> 'd:\srv03rtm\base\cluster\mgmt\cluscfg\basecluster\cbaseclusteraddnode.cpp',
> line
> 284. Error code is 0x8007139f.
>
> The error string is 'A problem occurred during the cluster configuration.
> The
> installation state of the cluster service is not correct.'.
>
> It may be necessary to manually modify the registry for the
> InstallationState on
> failing node to one of the following values which are valid:
>
> The script checks for the following values in the registry.
>
> HKLM\SOFTWARE\Microsoft\Windows NT\Current Version\Cluster Server
>
> with a value of "ClusterInstallationState"
>
> The Data will be one of four, with 2 or 3 being successful:
>
> 0 = ClusterInstallStateUnknown - Cluster Service configuration unknown
> 1 = ClusterInstallStateFilesCopied - Files Copied but Cluster Service not
> configured
> 2 = ClusterInstallStateConfigured - Cluster Service configured, fresh
> install
> 3 = ClusterInstallStateUpgraded - Cluster Service configured, upgrade
>
> --
> Hope this helps,
> Mike Rosado
> Windows 2000 MCSE + MCDBA
> Microsoft Enterprise Platform Support
> Windows NT/2000/2003 Cluster Technologies
>
> ====================================================
> When responding to posts, please "Reply to Group" via your newsreader so
> that others may learn and benefit from your issue.
> ====================================================
>
> This posting is provided "AS IS" with no warranties, and confers no rights.
> <http://www.microsoft.com/info/cpyright.htm>
>
> -----Original Message-----
> > From: <Allan West@discussions.microsoft.com>
> > Subject: Group or Resource not in correct state
> > Date: Wed, 13 Apr 2005 02:33:01 -0700
> >
> > I'm trying to implement a 2 node windows server 2003 cluster. I've got

> the
> > first node configured using the wizard and its created a group called

> Cluster
> > Group which contains: Cluster IP Address, Cluster Name and Disk Q: R:
> > resources
> >
> > When i try to add the other node it gets through the wizard all the way

> to
> > the end when it states an error "0x8007139F: The group or resource is not

> in
> > the correct state to perform the requested operation."
> >
> > Does anyone know what could cause this as my searches on google and on
> > microsoft support haven't brought up anything.
> >

>
>

Reply With Quote
  #4  
Old 15-04-2005
Mike Rosado [MSFT]
 
Posts: n/a
RE: Group or Resource not in correct state

Allan,

The Physical Disk resource labeled "Disk Q: R:" tells me you have (1) LUN
with a Logical Partition on the same LUN for drive letter R:\. I would
recommend creating 2 inividual LUNs and presenting them to the Cluster.
Also make sure that Physical Disk and IP Address resources do not have any
dependencies whatsoever. Only Network Name resource should have a
dependency of IP Address resource. Nothing else should be place in the
Cluster Group. The R:\ drive letter LUN shoud be a Physical Disk resource
in it's own seperate group. If you have an anti-virus installed, we would
recommend configuration the Exclusion List of the anti-virus to exclude
scanning the whole Quorum disk and the local C:\%windir%\Cluster folder of
each node.

--
Hope this helps,
Mike Rosado
Windows 2000 MCSE + MCDBA
Microsoft Enterprise Platform Support
Windows NT/2000/2003 Cluster Technologies

====================================================
When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.
====================================================

This posting is provided "AS IS" with no warranties, and confers no rights.
<http://www.microsoft.com/info/cpyright.htm>

-----Original Message-----
> From: <AllanWest@discussions.microsoft.com>
> Subject: RE: Group or Resource not in correct state
> Date: Thu, 14 Apr 2005 03:28:01 -0700
>
> I'm not getting that string in the file. Below is the entries from the
> cluster log file
>
> 2005-04-14 11:02:17.421 [INFO] adama: [PC-Create] Disk Q: R:: Found

existing
> resource. (hr=00000000, {CD36919C-9F31-46B4-A29D-AC87F4E6CC93},
> {48189324-673A-4FB6-9171-9C5939515EE1}, 0, 1, 1), (null)
> 2005-04-14 11:02:17.453 [INFO] adama: [PC-Create] Disk Q: R:: Found

existing
> resource. (hr=00000000, {CD36919C-9F31-46B4-A29D-AC87F4E6CC93},
> {48189324-673A-4FB6-9171-9C5939515EE1}, 0, 1, 1), (null)
> 2005-04-14 11:02:17.484 [INFO] adama: Setting private properties on
> resources... (hr=00000000, {411BCDEC-69D3-4485-8D5D-E19EE77A6DD4},
> {9C7A0060-5607-4962-9643-F1FD7121A1D6}, 1, 1, 1), (null)
> 2005-04-14 11:02:17.515 [INFO] adama: Setting private properties on
> resources... (hr=00000000, {411BCDEC-69D3-4485-8D5D-E19EE77A6DD4},
> {9C7A0060-5607-4962-9643-F1FD7121A1D6}, 1, 1, 1), (null)
> 2005-04-14 11:02:17.578 [INFO] [PC-ResourceEntry] ClusterResourceControl(
> CLUSCTL_RESOURCE_SET_PRIVATE_PROPERTIES ) failed for resource 'Disk Q:

R:'.
> (sc=0x00139f)
> 2005-04-14 11:02:17.609 [ERR ] adama: Failed to set the private

properties
> for the 'Disk Q: R:' resource. (hr=0x8007139f,
> {9C7A0060-5607-4962-9643-F1FD7121A1D6},
> {4A86EE67-C8EC-4831-896D-474610B4FC3C}, 1, 1, 1), (null)
> 2005-04-14 11:02:17.640 [ERR ] adama: Failed to set the private

properties
> for the 'Disk Q: R:' resource. (hr=0x8007139f,
> {9C7A0060-5607-4962-9643-F1FD7121A1D6},
> {4A86EE67-C8EC-4831-896D-474610B4FC3C}, 1, 1, 1), (null)
> 2005-04-14 11:02:17.671 [ERR ] adama: Failed to configure resource

instance.
> (hr=0x8007139f, {CD36919C-9F31-46B4-A29D-AC87F4E6CC93},
> {04B5E793-3A69-43E1-9FE8-8443FEAC725E}, 0, 0, 0), (null)
> 2005-04-14 11:02:17.703 [ERR ] adama: Failed to configure resource

instance.
> (hr=0x8007139f, {CD36919C-9F31-46B4-A29D-AC87F4E6CC93},
> {04B5E793-3A69-43E1-9FE8-8443FEAC725E}, 0, 0, 0), (null)
> 2005-04-14 11:02:17.750 [INFO] adama: Creating resources. (hr=00000000,
> {CD36919C-9F31-46B4-A29D-AC87F4E6CC93},
> {4F6BD1A1-9440-4D4C-A9E0-9943E7B34D30}, 0, 2, 2), (null)
> 2005-04-14 11:02:17.765 [INFO] adama: Creating resources. (hr=00000000,
> {CD36919C-9F31-46B4-A29D-AC87F4E6CC93},
> {4F6BD1A1-9440-4D4C-A9E0-9943E7B34D30}, 0, 2, 2), (null)
>
> We've got 2 identical servers that i'm trying to set a 2 node cluster up

on.
> Unfortunately, whats happening is that even though I get this warning,

when
> i try to test failing the cluster the Drive Q: R: resource produces an

error
> icon and then it resorts back to the first node.
>
> ClusterInstallationState value is 2 on each server.
>
> Any further help would be greatly appreciated!
>
> Regards,
> Allan West
>
>
> "Mike Rosado [MSFT]" wrote:
>
> > Hi Alan,
> >
> > See if the Cluster Log on the failing node to see if it is reporting

the
> > following:
> >
> > 2003-12-30 17:07:54.190 [INFO] [BC] A runtime error has occurred in

file
> >

'd:\srv03rtm\base\cluster\mgmt\cluscfg\basecluster\cbaseclusteraddnode.cpp',
> > line
> > 284. Error code is 0x8007139f.
> >
> > The error string is 'A problem occurred during the cluster

configuration.
> > The
> > installation state of the cluster service is not correct.'.
> >
> > It may be necessary to manually modify the registry for the
> > InstallationState on
> > failing node to one of the following values which are valid:
> >
> > The script checks for the following values in the registry.
> >
> > HKLM\SOFTWARE\Microsoft\Windows NT\Current Version\Cluster Server
> >
> > with a value of "ClusterInstallationState"
> >
> > The Data will be one of four, with 2 or 3 being successful:
> >
> > 0 = ClusterInstallStateUnknown - Cluster Service configuration unknown
> > 1 = ClusterInstallStateFilesCopied - Files Copied but Cluster Service

not
> > configured
> > 2 = ClusterInstallStateConfigured - Cluster Service configured, fresh
> > install
> > 3 = ClusterInstallStateUpgraded - Cluster Service configured, upgrade
> >
> > --
> > Hope this helps,
> > Mike Rosado
> > Windows 2000 MCSE + MCDBA
> > Microsoft Enterprise Platform Support
> > Windows NT/2000/2003 Cluster Technologies
> >
> > ====================================================
> > When responding to posts, please "Reply to Group" via your newsreader so
> > that others may learn and benefit from your issue.
> > ====================================================
> >
> > This posting is provided "AS IS" with no warranties, and confers no

rights.
> > <http://www.microsoft.com/info/cpyright.htm>
> >
> > -----Original Message-----
> > > From: <Allan West@discussions.microsoft.com>
> > > Subject: Group or Resource not in correct state
> > > Date: Wed, 13 Apr 2005 02:33:01 -0700
> > >
> > > I'm trying to implement a 2 node windows server 2003 cluster. I've

got
> > the
> > > first node configured using the wizard and its created a group called

> > Cluster
> > > Group which contains: Cluster IP Address, Cluster Name and Disk Q: R:
> > > resources
> > >
> > > When i try to add the other node it gets through the wizard all the

way
> > to
> > > the end when it states an error "0x8007139F: The group or resource is

not
> > in
> > > the correct state to perform the requested operation."
> > >
> > > Does anyone know what could cause this as my searches on google and

on
> > > microsoft support haven't brought up anything.
> > >

> >
> >

>


Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows Server > Windows Server Help
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Group or Resource not in correct state"
Thread Thread Starter Forum Replies Last Post
How to calculate cost based on resource rate? I have more than 5 rates per resource boxta Microsoft Project 8 08-05-2012 12:46 PM
Cluster error 1230: Cluster resource '%1' (resource type '%2', DLL '%3') either crashed or deadlocked. The EClipse Operating Systems 4 21-08-2010 04:03 AM
VB. List the userID from group (Domain Admins set as Primary group) epremyan karapet Software Development 1 12-10-2009 07:26 PM
FTP problem - unable to make the session state request to the session state server. Benito Software Development 3 31-07-2009 01:09 PM
Nortel and India's Chhattisgarh State Enhance State - Wide Communications With WiMAX Broad-Man India BroadBand 4 26-11-2008 12:41 PM


All times are GMT +5.5. The time now is 03:27 AM.