Results 1 to 6 of 6

Thread: Enable Write Disk Caching not saving (Server 2003)

  1. #1
    daniel.dryhurst@gmail.com Guest

    Enable Write Disk Caching not saving (Server 2003)

    Hi

    I have recently built and configured a new server (HP DL360 G5
    series), with two 70GB hard disks configured as the default Raid 1 in
    the hardware.

    I have not promoted it to a domain controller and the only role set is
    that of a file server. One of the legacy applications that it is for
    requires 'Write Disk Caching' enabling.

    So I go into the device manager disk properties and click on the
    policies tab to enable it. I get a message underneath the check box
    along the lines of:

    "This device does not allow its write cache setting to be modified"

    So, I check the box anyway and then when I go back in the setting
    hasn't saved at all. I have checked the following registry setting:

    HKLM/System/CurrentControlSet/Enum/SCSI/VotreHardDisk/SerialNum/
    DeviceParameters/Disk/UserWriteCacheSetting which is set to a value of
    '1'.

    I have checked the event log and got the following information:

    Event Type: Warning
    Event Source: Disk
    Event Category: None
    Event ID: 34
    Date: 30/04/2007
    Time: 09:18:19
    User: N/A
    Computer: xxxxxxxx
    Description:
    The driver disabled the write cache on device \Device\Harddisk0\DR0.

    For more information, see Help and Support Center at
    http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 0f 00 04 00 01 00 62 00 ......b.
    0008: 00 00 00 00 22 00 04 80 ...."..
    0010: 01 00 00 00 10 00 00 c0 .......
    0018: 00 00 00 00 00 00 00 00 ........
    0020: 00 00 00 00 00 00 00 00 ........
    0028: 00 00 00 00 ....

    I have been into the BIOS and cannot see any settings related to DMA/
    Write caching etc. I have also tried the HP Array Configuration
    Utility which only has options for acceleration whch are on default
    settings. I'm really at a loss here, as far as I know these settings
    should be allowed.

    I know that it is DEFINITELY not switched on though registry indicates
    differently because on the old NT4 server a file scan takes 25 seconds
    and on the new hardware it takes upwards of 5 minutes.

    Can anyone please help me?


  2. #2
    George Valkov Guest

    Re: Enable Write Disk Caching not saving (Server 2003)

    You may try to install a UPS and if the driver knows that the power is
    backed up, it may eventually enable the write cache, but I have no
    experience with UPS or hardware disk arrays, so I am only making a guess
    here. Good Luck!

    George Valkov


    <daniel.dryhurst ?@gmail?com> wrote:
    Hi
    I have recently built and configured a new server (HP DL360 G5
    series), with two 70GB hard disks configured as the default Raid 1 in
    the hardware.

    I have not promoted it to a domain controller and the only role set is
    that of a file server. One of the legacy applications that it is for
    requires 'Write Disk Caching' enabling.

    So I go into the device manager disk properties and click on the
    policies tab to enable it. I get a message underneath the check box
    along the lines of:

    "This device does not allow its write cache setting to be modified"

    So, I check the box anyway and then when I go back in the setting
    hasn't saved at all. I have checked the following registry setting:

    HKLM/System/CurrentControlSet/Enum/SCSI/VotreHardDisk/SerialNum/
    DeviceParameters/Disk/UserWriteCacheSetting which is set to a value of
    '1'.

    I have checked the event log and got the following information:

    Event Type: Warning
    Event Source: Disk
    Event Category: None
    Event ID: 34
    Date: 30/04/2007
    Time: 09:18:19
    User: N/A
    Computer: xxxxxxxx
    Description:
    The driver disabled the write cache on device \Device\Harddisk0\DR0.

    For more information, see Help and Support Center at
    http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 0f 00 04 00 01 00 62 00 ......b.
    0008: 00 00 00 00 22 00 04 80 ...."..?
    0010: 01 00 00 00 10 00 00 c0 .......
    0018: 00 00 00 00 00 00 00 00 ........
    0020: 00 00 00 00 00 00 00 00 ........
    0028: 00 00 00 00 ....

    I have been into the BIOS and cannot see any settings related to DMA/
    Write caching etc. I have also tried the HP Array Configuration
    Utility which only has options for acceleration whch are on default
    settings. I'm really at a loss here, as far as I know these settings
    should be allowed.

    I know that it is DEFINITELY not switched on though registry indicates
    differently because on the old NT4 server a file scan takes 25 seconds
    and on the new hardware it takes upwards of 5 minutes.

    Can anyone please help me?



  3. #3
    Join Date
    Jun 2007
    Posts
    2
    In my experience, HP and Compaq hardware RAID cards will not allow write caching unless they have the appropriate battery backed cache module installed.

    Dango

  4. #4
    DevilsPGD Guest

    Re: Enable Write Disk Caching not saving (Server 2003)

    In message <Dango.2sbyfk@DoNotSpam.com> Dango
    <Dango.2sbyfk@DoNotSpam.com> wrote:

    >In my experience, HP and Compaq hardware RAID cards will not allow write
    >caching unless they have the appropriate battery backed cache module
    >installed.


    What horrible design :(

    --
    If quitters never win, and winners never quit,
    what fool came up with, "Quit while you're ahead"?

  5. #5
    Join Date
    Jun 2007
    Posts
    2
    It's actually for the user's protection... The battery backed cache will keep any data in the raid controller's memory in the event of a power outage. It also stops data being lost if the server was to bluescreen.

  6. #6
    DevilsPGD Guest

    Re: Enable Write Disk Caching not saving (Server 2003)

    In message <Dango.2sc9ji@DoNotSpam.com> Dango
    <Dango.2sc9ji@DoNotSpam.com> wrote:

    >It's actually for the user's protection... The battery backed cache will
    >keep any data in the raid controller's memory in the event of a power
    >outage. It also stops data being lost if the server was to bluescreen.


    As I said, what horrible design. Defaulting to disabling write caching
    is reasonable, preventing it outright is just plain wrong unless it can
    magically detect an external UPS.

    --
    If quitters never win, and winners never quit,
    what fool came up with, "Quit while you're ahead"?

Similar Threads

  1. How to enable SSD caching on Asus P9X79 Deluxe
    By My Name in forum Motherboard Processor & RAM
    Replies: 5
    Last Post: 23-02-2012, 09:32 AM
  2. ESX disk write caching enabled or not
    By brynhildur in forum Hardware Peripherals
    Replies: 4
    Last Post: 22-11-2010, 06:20 AM
  3. How enable L2TP VPN for windows 2003 server?
    By moh3en in forum Windows Server Help
    Replies: 3
    Last Post: 11-08-2010, 12:44 AM
  4. Drive write caching disabled in Windows 7
    By X-Man in forum Operating Systems
    Replies: 3
    Last Post: 04-05-2009, 02:31 PM
  5. disabling write caching in winxp-pro SP3 - greyed out
    By Tim in forum Windows XP Support
    Replies: 1
    Last Post: 27-04-2009, 09:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •