Results 1 to 5 of 5

Thread: Unable to join domain

  1. #1
    Richard Mueller [MVP] Guest

    Unable to join domain

    Have been unable to join a Vista Business laptop to either of two domains.
    In both cases have previously joined other clients, such as Windows 98,
    Windows 2000, and XP. Both domains functioning with these clients. Excerpt
    from NetSetup.log below (with timestamps removed).

    First domain (attempt dated 4/20 below) Windows Server 2003 with DHCP. Vista
    laptop set to get IP address automatically. Tried both wireless and wired
    connections. Can ping machines on network and access internet from the Vista
    laptop.

    Second domain (attempts dated 4/21) Windows 2000 Server without DHCP.
    Configured laptop with IP address. Again can ping other machines. Other
    machines can see the Vista laptop (under Workgroup rather than domain).

    Any help appreciated.

    NetSetup.log
    ================
    04/20/2007
    14:25:58:055 -----------------------------------------------------------------
    NetpDoDomainJoin
    NetpMachineValidToJoin: 'MYCOMPUTER'
    OS Version: 6.0
    Build number: 6000
    SKU: Windows VistaT Business
    NetpDomainJoinLicensingCheck: ulLicenseValue=1, Status: 0x0
    NetpGetLsaPrimaryDomain: status: 0x0
    NetpMachineValidToJoin: status: 0x0
    NetpJoinDomain
    Machine: MYCOMPUTER
    Domain: MyDomain1
    MachineAccountOU: (NULL)
    Account: MyDomain1\administrator
    Options: 0x27
    NetpLoadParameters: loading registry parameters...
    NetpLoadParameters: DNSNameResolutionRequired not found, defaulting to '1'
    0x2
    NetpLoadParameters: status: 0x2
    NetpValidateName: checking to see if 'MyDomain1' is valid as type 3 name
    NetpCheckDomainNameIsValid [ Exists ] for 'MyDomain1' returned 0x0
    NetpValidateName: name 'MyDomain1' is valid for type 3
    NetpDsGetDcName: trying to find DC in domain 'MyDomain1', flags: 0x40001010
    NetpDsGetDcName: status of verifying DNS A record name resolution for
    'MyServer1.MyDomain1.com': 0x0
    NetpDsGetDcName: found DC '\\MyServer1.MyDomain1.com' in the specified
    domain
    NetUseAdd to \\MyServer1.MyDomain1.com\IPC$ returned 1214
    NetpJoinDomain: status of connecting to dc '\\MyServer1.MyDomain1.com':
    0x4be
    NetpDoDomainJoin: status: 0x4be
    04/21/2007
    16:40:34:691 -----------------------------------------------------------------
    NetpDoDomainJoin
    NetpMachineValidToJoin: 'MYCOMPUTER'
    OS Version: 6.0
    Build number: 6000
    SKU: Windows VistaT Business
    NetpDomainJoinLicensingCheck: ulLicenseValue=1, Status: 0x0
    NetpGetLsaPrimaryDomain: status: 0x0
    NetpMachineValidToJoin: status: 0x0
    NetpJoinDomain
    Machine: MYCOMPUTER
    Domain: MyDomain2
    MachineAccountOU: (NULL)
    Account: MyDomain2\administrator
    Options: 0x25
    NetpLoadParameters: loading registry parameters...
    NetpLoadParameters: DNSNameResolutionRequired not found, defaulting to '1'
    0x2
    NetpLoadParameters: status: 0x2
    NetpValidateName: checking to see if 'MyDomain2' is valid as type 3 name
    NetpCheckDomainNameIsValid [ Exists ] for 'MyDomain2' returned 0x0
    NetpValidateName: name 'MyDomain2' is valid for type 3
    NetpDsGetDcName: trying to find DC in domain 'MyDomain2', flags: 0x40001010
    NetpDsGetDcName: failed to find a DC having account 'MYCOMPUTER$': 0x525,
    last error is 0x79
    NetpDsGetDcName: status of verifying DNS A record name resolution for
    'MyServer2.MyDomain2.MyCompany.net': 0x0
    NetpDsGetDcName: found DC '\\MyServer2.MyDomain2.MyCompany.net' in the
    specified domain
    NetUseAdd to \\MyServer2.MyDomain2.MyCompany.net\IPC$ returned 5
    Trying add to \\MyServer2.MyDomain2.MyCompany.net\IPC$ using NULL Session
    NetpJoinDomain: status of connecting to dc
    '\\MyServer2.MyDomain2.MyCompany.net': 0x0
    NetpGetLsaPrimaryDomain: status: 0x0
    NetpGetDnsHostName: Read NV Hostname: MYCOMPUTER
    NetpGetDnsHostName: PrimaryDnsSuffix defaulted to DNS domain name:
    MyDomain2.MyCompany.net
    NetpLsaOpenSecret: status: 0xc0000034
    NetpGetLsaPrimaryDomain: status: 0x0
    NetpLsaOpenSecret: status: 0xc0000034
    SamLookupNamesInDomain on MYCOMPUTER$ failed with 0xc0000073
    NetpJoinDomain: status of setting machine password: 0x534
    NetpJoinDomain: initiaing a rollback due to earlier errors
    NetpLsaOpenSecret: status: 0x0
    NetpJoinDomain: rollback: status of deleting secret: 0x0
    NetpJoinDomain: status of disconnecting from
    '\\MyServer2.MyDomain2.MyCompany.net': 0x0
    NetpDoDomainJoin: status: 0x534
    04/21/2007
    17:41:47:082 -----------------------------------------------------------------
    NetpDoDomainJoin
    NetpMachineValidToJoin: 'MYCOMPUTER'
    OS Version: 6.0
    Build number: 6000
    SKU: Windows VistaT Business
    NetpDomainJoinLicensingCheck: ulLicenseValue=1, Status: 0x0
    NetpGetLsaPrimaryDomain: status: 0x0
    NetpMachineValidToJoin: status: 0x0
    NetpJoinDomain
    Machine: MYCOMPUTER
    Domain: MyDomain2.MyCompany.net
    MachineAccountOU: (NULL)
    Account: MyDomain2.MyCompany.net\administrator
    Options: 0x27
    NetpLoadParameters: loading registry parameters...
    NetpLoadParameters: DNSNameResolutionRequired not found, defaulting to '1'
    0x2
    NetpLoadParameters: status: 0x2
    NetpValidateName: checking to see if 'MyDomain2.MyCompany.net' is valid as
    type 3 name
    NetpValidateName: 'MyDomain2.MyCompany.net' is not a valid NetBIOS domain
    name: 0x7b
    NetpCheckDomainNameIsValid [ Exists ] for 'MyDomain2.MyCompany.net'
    returned 0x0
    NetpValidateName: name 'MyDomain2.MyCompany.net' is valid for type 3
    NetpDsGetDcName: trying to find DC in domain 'MyDomain2.MyCompany.net',
    flags: 0x40001010
    NetpDsGetDcName: failed to find a DC having account 'MYCOMPUTER$': 0x525,
    last error is 0x79
    NetpDsGetDcName: status of verifying DNS A record name resolution for
    'MyServer2.MyDomain2.MyCompany.net': 0x0
    NetpDsGetDcName: found DC '\\MyServer2.MyDomain2.MyCompany.net' in the
    specified domain
    NetUseAdd to \\MyServer2.MyDomain2.MyCompany.net\IPC$ returned 5
    NetpJoinDomain: status of connecting to dc
    '\\MyServer2.MyDomain2.MyCompany.net': 0x5
    NetpDoDomainJoin: status: 0x5

    --
    Richard Mueller
    Microsoft MVP Scripting and ADSI
    Hilltop Lab - http://www.rlmueller.net
    --



  2. #2
    Herb Martin Guest

    Re: Unable to join domain


    "Richard Mueller [MVP]" <rlmueller-nospam@ameritech.nospam.net> wrote in
    message news:ehV6TOHhHHA.284@TK2MSFTNGP05.phx.gbl...
    > Have been unable to join a Vista Business laptop to either of two domains.
    > In both cases have previously joined other clients, such as Windows 98,
    > Windows 2000, and XP. Both domains functioning with these clients. Excerpt
    > from NetSetup.log below (with timestamps removed).
    >
    > First domain (attempt dated 4/20 below) Windows Server 2003 with DHCP.
    > Vista laptop set to get IP address automatically. Tried both wireless and
    > wired connections. Can ping machines on network and access internet from
    > the Vista laptop.
    >
    > Second domain (attempts dated 4/21) Windows 2000 Server without DHCP.
    > Configured laptop with IP address. Again can ping other machines. Other
    > machines can see the Vista laptop (under Workgroup rather than domain).


    Show us the unedited text output from the "Ipconfig /all" of the affected
    laptop.

    Ensure that the laptop uses ONLY the internal DNS which can resolve the
    DNS zone corresponding to the domain name.

    Check this DNS for access with NSLookup against the DCs records on
    every DNS server listed.

    Run NetDiag /fix and NetDiag /v checking the output for FAIL and WARN
    messages.

    Check "DCDiag /c" for FAIL and WARN on each DC separately.
    (You might be just getting unlucky by contacting the "broken" DC or
    DNS.)

    --
    Herb Martin, MCSE, MVP
    http://www.LearnQuick.Com
    (phone on web site)



  3. #3
    Dragos CAMARA Guest

    RE: Unable to join domain

    hi,
    on the first attempt you have a "The format of the specified network name is
    invalid." error so i think you have a DNS problem on that domain - did you
    renamed the domain?
    on the second attempt you have a "access denied" error so check if the user
    really have the rights .

    on vista machine try to disable IPv6 if you dont used.
    --
    Dragos CAMARA
    MCSA Windows 2003 server


    "Richard Mueller [MVP]" wrote:

    > Have been unable to join a Vista Business laptop to either of two domains.
    > In both cases have previously joined other clients, such as Windows 98,
    > Windows 2000, and XP. Both domains functioning with these clients. Excerpt
    > from NetSetup.log below (with timestamps removed).
    >
    > First domain (attempt dated 4/20 below) Windows Server 2003 with DHCP. Vista
    > laptop set to get IP address automatically. Tried both wireless and wired
    > connections. Can ping machines on network and access internet from the Vista
    > laptop.
    >
    > Second domain (attempts dated 4/21) Windows 2000 Server without DHCP.
    > Configured laptop with IP address. Again can ping other machines. Other
    > machines can see the Vista laptop (under Workgroup rather than domain).
    >
    > Any help appreciated.
    >
    > NetSetup.log
    > ================
    > 04/20/2007
    > 14:25:58:055 -----------------------------------------------------------------
    > NetpDoDomainJoin
    > NetpMachineValidToJoin: 'MYCOMPUTER'
    > OS Version: 6.0
    > Build number: 6000
    > SKU: Windows VistaT Business
    > NetpDomainJoinLicensingCheck: ulLicenseValue=1, Status: 0x0
    > NetpGetLsaPrimaryDomain: status: 0x0
    > NetpMachineValidToJoin: status: 0x0
    > NetpJoinDomain
    > Machine: MYCOMPUTER
    > Domain: MyDomain1
    > MachineAccountOU: (NULL)
    > Account: MyDomain1\administrator
    > Options: 0x27
    > NetpLoadParameters: loading registry parameters...
    > NetpLoadParameters: DNSNameResolutionRequired not found, defaulting to '1'
    > 0x2
    > NetpLoadParameters: status: 0x2
    > NetpValidateName: checking to see if 'MyDomain1' is valid as type 3 name
    > NetpCheckDomainNameIsValid [ Exists ] for 'MyDomain1' returned 0x0
    > NetpValidateName: name 'MyDomain1' is valid for type 3
    > NetpDsGetDcName: trying to find DC in domain 'MyDomain1', flags: 0x40001010
    > NetpDsGetDcName: status of verifying DNS A record name resolution for
    > 'MyServer1.MyDomain1.com': 0x0
    > NetpDsGetDcName: found DC '\\MyServer1.MyDomain1.com' in the specified
    > domain
    > NetUseAdd to \\MyServer1.MyDomain1.com\IPC$ returned 1214
    > NetpJoinDomain: status of connecting to dc '\\MyServer1.MyDomain1.com':
    > 0x4be
    > NetpDoDomainJoin: status: 0x4be
    > 04/21/2007
    > 16:40:34:691 -----------------------------------------------------------------
    > NetpDoDomainJoin
    > NetpMachineValidToJoin: 'MYCOMPUTER'
    > OS Version: 6.0
    > Build number: 6000
    > SKU: Windows VistaT Business
    > NetpDomainJoinLicensingCheck: ulLicenseValue=1, Status: 0x0
    > NetpGetLsaPrimaryDomain: status: 0x0
    > NetpMachineValidToJoin: status: 0x0
    > NetpJoinDomain
    > Machine: MYCOMPUTER
    > Domain: MyDomain2
    > MachineAccountOU: (NULL)
    > Account: MyDomain2\administrator
    > Options: 0x25
    > NetpLoadParameters: loading registry parameters...
    > NetpLoadParameters: DNSNameResolutionRequired not found, defaulting to '1'
    > 0x2
    > NetpLoadParameters: status: 0x2
    > NetpValidateName: checking to see if 'MyDomain2' is valid as type 3 name
    > NetpCheckDomainNameIsValid [ Exists ] for 'MyDomain2' returned 0x0
    > NetpValidateName: name 'MyDomain2' is valid for type 3
    > NetpDsGetDcName: trying to find DC in domain 'MyDomain2', flags: 0x40001010
    > NetpDsGetDcName: failed to find a DC having account 'MYCOMPUTER$': 0x525,
    > last error is 0x79
    > NetpDsGetDcName: status of verifying DNS A record name resolution for
    > 'MyServer2.MyDomain2.MyCompany.net': 0x0
    > NetpDsGetDcName: found DC '\\MyServer2.MyDomain2.MyCompany.net' in the
    > specified domain
    > NetUseAdd to \\MyServer2.MyDomain2.MyCompany.net\IPC$ returned 5
    > Trying add to \\MyServer2.MyDomain2.MyCompany.net\IPC$ using NULL Session
    > NetpJoinDomain: status of connecting to dc
    > '\\MyServer2.MyDomain2.MyCompany.net': 0x0
    > NetpGetLsaPrimaryDomain: status: 0x0
    > NetpGetDnsHostName: Read NV Hostname: MYCOMPUTER
    > NetpGetDnsHostName: PrimaryDnsSuffix defaulted to DNS domain name:
    > MyDomain2.MyCompany.net
    > NetpLsaOpenSecret: status: 0xc0000034
    > NetpGetLsaPrimaryDomain: status: 0x0
    > NetpLsaOpenSecret: status: 0xc0000034
    > SamLookupNamesInDomain on MYCOMPUTER$ failed with 0xc0000073
    > NetpJoinDomain: status of setting machine password: 0x534
    > NetpJoinDomain: initiaing a rollback due to earlier errors
    > NetpLsaOpenSecret: status: 0x0
    > NetpJoinDomain: rollback: status of deleting secret: 0x0
    > NetpJoinDomain: status of disconnecting from
    > '\\MyServer2.MyDomain2.MyCompany.net': 0x0
    > NetpDoDomainJoin: status: 0x534
    > 04/21/2007
    > 17:41:47:082 -----------------------------------------------------------------
    > NetpDoDomainJoin
    > NetpMachineValidToJoin: 'MYCOMPUTER'
    > OS Version: 6.0
    > Build number: 6000
    > SKU: Windows VistaT Business
    > NetpDomainJoinLicensingCheck: ulLicenseValue=1, Status: 0x0
    > NetpGetLsaPrimaryDomain: status: 0x0
    > NetpMachineValidToJoin: status: 0x0
    > NetpJoinDomain
    > Machine: MYCOMPUTER
    > Domain: MyDomain2.MyCompany.net
    > MachineAccountOU: (NULL)
    > Account: MyDomain2.MyCompany.net\administrator
    > Options: 0x27
    > NetpLoadParameters: loading registry parameters...
    > NetpLoadParameters: DNSNameResolutionRequired not found, defaulting to '1'
    > 0x2
    > NetpLoadParameters: status: 0x2
    > NetpValidateName: checking to see if 'MyDomain2.MyCompany.net' is valid as
    > type 3 name
    > NetpValidateName: 'MyDomain2.MyCompany.net' is not a valid NetBIOS domain
    > name: 0x7b
    > NetpCheckDomainNameIsValid [ Exists ] for 'MyDomain2.MyCompany.net'
    > returned 0x0
    > NetpValidateName: name 'MyDomain2.MyCompany.net' is valid for type 3
    > NetpDsGetDcName: trying to find DC in domain 'MyDomain2.MyCompany.net',
    > flags: 0x40001010
    > NetpDsGetDcName: failed to find a DC having account 'MYCOMPUTER$': 0x525,
    > last error is 0x79
    > NetpDsGetDcName: status of verifying DNS A record name resolution for
    > 'MyServer2.MyDomain2.MyCompany.net': 0x0
    > NetpDsGetDcName: found DC '\\MyServer2.MyDomain2.MyCompany.net' in the
    > specified domain
    > NetUseAdd to \\MyServer2.MyDomain2.MyCompany.net\IPC$ returned 5
    > NetpJoinDomain: status of connecting to dc
    > '\\MyServer2.MyDomain2.MyCompany.net': 0x5
    > NetpDoDomainJoin: status: 0x5
    >
    > --
    > Richard Mueller
    > Microsoft MVP Scripting and ADSI
    > Hilltop Lab - http://www.rlmueller.net
    > --
    >
    >
    >


  4. #4
    Richard Mueller [MVP] Guest

    Re: Unable to join domain


    "Herb Martin" <news@learnquick.com> wrote in message
    news:u$UNt%23JhHHA.4704@TK2MSFTNGP06.phx.gbl...
    >
    > "Richard Mueller [MVP]" <rlmueller-nospam@ameritech.nospam.net> wrote in
    > message news:ehV6TOHhHHA.284@TK2MSFTNGP05.phx.gbl...
    >> Have been unable to join a Vista Business laptop to either of two
    >> domains. In both cases have previously joined other clients, such as
    >> Windows 98, Windows 2000, and XP. Both domains functioning with these
    >> clients. Excerpt from NetSetup.log below (with timestamps removed).
    >>
    >> First domain (attempt dated 4/20 below) Windows Server 2003 with DHCP.
    >> Vista laptop set to get IP address automatically. Tried both wireless and
    >> wired connections. Can ping machines on network and access internet from
    >> the Vista laptop.
    >>
    >> Second domain (attempts dated 4/21) Windows 2000 Server without DHCP.
    >> Configured laptop with IP address. Again can ping other machines. Other
    >> machines can see the Vista laptop (under Workgroup rather than domain).

    >
    > Show us the unedited text output from the "Ipconfig /all" of the affected
    > laptop.


    See below.

    >
    > Ensure that the laptop uses ONLY the internal DNS which can resolve the
    > DNS zone corresponding to the domain name.


    I don't know what this means, so this might be a problem. DNS on the laptop
    points to the DC with DNS (when I attempt to join the domain).

    >
    > Check this DNS for access with NSLookup against the DCs records on
    > every DNS server listed.


    NSLookup does not resolve NetBIOS names, like MyComputer, only DNS names
    like MyComputer.MyDomain.com. On all other clients both types of names are
    resolved.

    >
    > Run NetDiag /fix and NetDiag /v checking the output for FAIL and WARN
    > messages.


    The only NetDiag FAIL is "Testing default gateway". I do not have a default
    gateway configured (never have). This is a standalone domain with no
    internet access. NetDiag /fix resulting in all passing.

    >
    > Check "DCDiag /c" for FAIL and WARN on each DC separately.
    > (You might be just getting unlucky by contacting the "broken" DC or
    > DNS.)


    DCDiag /c results in no FAIL and no WARN.

    Output of ipconfig /all below. This is for the network without DHCP. The
    other domain is in another state, but we ran ipconfig /all many times and
    confirmed we had an ip address in the range expected, given by DHCP. Note I
    previously modified machine and domain names, but not below. I gave the
    laptop 192.168.48.25. The DNS server is 192.168.48.1:
    =============

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : Idaho
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Wireless LAN adapter Wireless Network Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . : hilltop
    Description . . . . . . . . . . . : Dell Wireless 1490 Dual Band WLAN
    Mini-Card
    Physical Address. . . . . . . . . : 00-19-7D-5F-12-A5
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Broadcom 440x 10/100 Integrated
    Controller
    Physical Address. . . . . . . . . : 00-19-B9-51-21-DC
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . :
    fe80::a86e:9129:616d:145b%9(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.48.25(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.48.1
    DNS Servers . . . . . . . . . . . : 192.168.48.1
    Primary WINS Server . . . . . . . : 192.168.48.1
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter Local Area Connection* 6:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 02-00-54-55-4E-01
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 7:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . :
    isatap.{D7207BAD-3ECF-4D8D-8699-345E2E005CBE}
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 9:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . :
    isatap.{D7207BAD-3ECF-4D8D-8699-345E2E005CBE}
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 15:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . :
    isatap.{D7207BAD-3ECF-4D8D-8699-345E2E005CBE}
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 16:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . :
    isatap.{D7207BAD-3ECF-4D8D-8699-345E2E005CBE}
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 17:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . :
    isatap.{D7207BAD-3ECF-4D8D-8699-345E2E005CBE}
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 18:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . :
    isatap.{D7207BAD-3ECF-4D8D-8699-345E2E005CBE}
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 19:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . :
    isatap.{D7207BAD-3ECF-4D8D-8699-345E2E005CBE}
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 20:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . :
    isatap.{D7207BAD-3ECF-4D8D-8699-345E2E005CBE}
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 21:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : isatap.hilltop
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 22:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . :
    isatap.{10F32EC9-8341-42DE-8605-AB9D674A4868}
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . :
    fe80::5efe:192.168.48.25%24(Preferred)
    Default Gateway . . . . . . . . . :
    DNS Servers . . . . . . . . . . . : 192.168.48.1
    NetBIOS over Tcpip. . . . . . . . : Disabled

    --
    Richard Mueller
    Microsoft MVP Scripting and ADSI
    Hilltop Lab - http://www.rlmueller.net
    --



  5. #5
    Richard Mueller [MVP] Guest

    Re: Unable to join domain

    One attempt was to join using NetBIOS names, like MyDomain2. The other
    attempt was to join with DNS names like MyDomain2.MyCompany.net. My
    interpretation is that first the client attempts to resolve the names as
    NetBIOS names, then if that fails attempts to resolve as DNS names, which
    succeeds. In all cases, a DC is found, but an error is raised on NetUseAdd.

    I'm certain the credentials are good. I'm using the Administrator account.

    I disabled IPv6 on the Vista computer, but got the same result.

    --
    Richard Mueller
    Microsoft MVP Scripting and ADSI
    Hilltop Lab - http://www.rlmueller.net
    --

    "Dragos CAMARA" <dragos_c@remove-this.hotmail.com> wrote in message
    news:810CEEEA-D704-44A6-9BC9-23CE04B341C7@microsoft.com...
    > hi,
    > on the first attempt you have a "The format of the specified network name
    > is
    > invalid." error so i think you have a DNS problem on that domain - did you
    > renamed the domain?
    > on the second attempt you have a "access denied" error so check if the
    > user
    > really have the rights .
    >
    > on vista machine try to disable IPv6 if you dont used.
    > --
    > Dragos CAMARA
    > MCSA Windows 2003 server
    >
    >
    > "Richard Mueller [MVP]" wrote:
    >
    >> Have been unable to join a Vista Business laptop to either of two
    >> domains.
    >> In both cases have previously joined other clients, such as Windows 98,
    >> Windows 2000, and XP. Both domains functioning with these clients.
    >> Excerpt
    >> from NetSetup.log below (with timestamps removed).
    >>
    >> First domain (attempt dated 4/20 below) Windows Server 2003 with DHCP.
    >> Vista
    >> laptop set to get IP address automatically. Tried both wireless and wired
    >> connections. Can ping machines on network and access internet from the
    >> Vista
    >> laptop.
    >>
    >> Second domain (attempts dated 4/21) Windows 2000 Server without DHCP.
    >> Configured laptop with IP address. Again can ping other machines. Other
    >> machines can see the Vista laptop (under Workgroup rather than domain).
    >>
    >> Any help appreciated.
    >>
    >> NetSetup.log
    >> ================
    >> 04/20/2007
    >> 14:25:58:055 -----------------------------------------------------------------
    >> NetpDoDomainJoin
    >> NetpMachineValidToJoin: 'MYCOMPUTER'
    >> OS Version: 6.0
    >> Build number: 6000
    >> SKU: Windows VistaT Business
    >> NetpDomainJoinLicensingCheck: ulLicenseValue=1, Status: 0x0
    >> NetpGetLsaPrimaryDomain: status: 0x0
    >> NetpMachineValidToJoin: status: 0x0
    >> NetpJoinDomain
    >> Machine: MYCOMPUTER
    >> Domain: MyDomain1
    >> MachineAccountOU: (NULL)
    >> Account: MyDomain1\administrator
    >> Options: 0x27
    >> NetpLoadParameters: loading registry parameters...
    >> NetpLoadParameters: DNSNameResolutionRequired not found, defaulting to
    >> '1'
    >> 0x2
    >> NetpLoadParameters: status: 0x2
    >> NetpValidateName: checking to see if 'MyDomain1' is valid as type 3 name
    >> NetpCheckDomainNameIsValid [ Exists ] for 'MyDomain1' returned 0x0
    >> NetpValidateName: name 'MyDomain1' is valid for type 3
    >> NetpDsGetDcName: trying to find DC in domain 'MyDomain1', flags:
    >> 0x40001010
    >> NetpDsGetDcName: status of verifying DNS A record name resolution for
    >> 'MyServer1.MyDomain1.com': 0x0
    >> NetpDsGetDcName: found DC '\\MyServer1.MyDomain1.com' in the specified
    >> domain
    >> NetUseAdd to \\MyServer1.MyDomain1.com\IPC$ returned 1214
    >> NetpJoinDomain: status of connecting to dc '\\MyServer1.MyDomain1.com':
    >> 0x4be
    >> NetpDoDomainJoin: status: 0x4be
    >> 04/21/2007
    >> 16:40:34:691 -----------------------------------------------------------------
    >> NetpDoDomainJoin
    >> NetpMachineValidToJoin: 'MYCOMPUTER'
    >> OS Version: 6.0
    >> Build number: 6000
    >> SKU: Windows VistaT Business
    >> NetpDomainJoinLicensingCheck: ulLicenseValue=1, Status: 0x0
    >> NetpGetLsaPrimaryDomain: status: 0x0
    >> NetpMachineValidToJoin: status: 0x0
    >> NetpJoinDomain
    >> Machine: MYCOMPUTER
    >> Domain: MyDomain2
    >> MachineAccountOU: (NULL)
    >> Account: MyDomain2\administrator
    >> Options: 0x25
    >> NetpLoadParameters: loading registry parameters...
    >> NetpLoadParameters: DNSNameResolutionRequired not found, defaulting to
    >> '1'
    >> 0x2
    >> NetpLoadParameters: status: 0x2
    >> NetpValidateName: checking to see if 'MyDomain2' is valid as type 3 name
    >> NetpCheckDomainNameIsValid [ Exists ] for 'MyDomain2' returned 0x0
    >> NetpValidateName: name 'MyDomain2' is valid for type 3
    >> NetpDsGetDcName: trying to find DC in domain 'MyDomain2', flags:
    >> 0x40001010
    >> NetpDsGetDcName: failed to find a DC having account 'MYCOMPUTER$':
    >> 0x525,
    >> last error is 0x79
    >> NetpDsGetDcName: status of verifying DNS A record name resolution for
    >> 'MyServer2.MyDomain2.MyCompany.net': 0x0
    >> NetpDsGetDcName: found DC '\\MyServer2.MyDomain2.MyCompany.net' in the
    >> specified domain
    >> NetUseAdd to \\MyServer2.MyDomain2.MyCompany.net\IPC$ returned 5
    >> Trying add to \\MyServer2.MyDomain2.MyCompany.net\IPC$ using NULL
    >> Session
    >> NetpJoinDomain: status of connecting to dc
    >> '\\MyServer2.MyDomain2.MyCompany.net': 0x0
    >> NetpGetLsaPrimaryDomain: status: 0x0
    >> NetpGetDnsHostName: Read NV Hostname: MYCOMPUTER
    >> NetpGetDnsHostName: PrimaryDnsSuffix defaulted to DNS domain name:
    >> MyDomain2.MyCompany.net
    >> NetpLsaOpenSecret: status: 0xc0000034
    >> NetpGetLsaPrimaryDomain: status: 0x0
    >> NetpLsaOpenSecret: status: 0xc0000034
    >> SamLookupNamesInDomain on MYCOMPUTER$ failed with 0xc0000073
    >> NetpJoinDomain: status of setting machine password: 0x534
    >> NetpJoinDomain: initiaing a rollback due to earlier errors
    >> NetpLsaOpenSecret: status: 0x0
    >> NetpJoinDomain: rollback: status of deleting secret: 0x0
    >> NetpJoinDomain: status of disconnecting from
    >> '\\MyServer2.MyDomain2.MyCompany.net': 0x0
    >> NetpDoDomainJoin: status: 0x534
    >> 04/21/2007
    >> 17:41:47:082 -----------------------------------------------------------------
    >> NetpDoDomainJoin
    >> NetpMachineValidToJoin: 'MYCOMPUTER'
    >> OS Version: 6.0
    >> Build number: 6000
    >> SKU: Windows VistaT Business
    >> NetpDomainJoinLicensingCheck: ulLicenseValue=1, Status: 0x0
    >> NetpGetLsaPrimaryDomain: status: 0x0
    >> NetpMachineValidToJoin: status: 0x0
    >> NetpJoinDomain
    >> Machine: MYCOMPUTER
    >> Domain: MyDomain2.MyCompany.net
    >> MachineAccountOU: (NULL)
    >> Account: MyDomain2.MyCompany.net\administrator
    >> Options: 0x27
    >> NetpLoadParameters: loading registry parameters...
    >> NetpLoadParameters: DNSNameResolutionRequired not found, defaulting to
    >> '1'
    >> 0x2
    >> NetpLoadParameters: status: 0x2
    >> NetpValidateName: checking to see if 'MyDomain2.MyCompany.net' is valid
    >> as
    >> type 3 name
    >> NetpValidateName: 'MyDomain2.MyCompany.net' is not a valid NetBIOS
    >> domain
    >> name: 0x7b
    >> NetpCheckDomainNameIsValid [ Exists ] for 'MyDomain2.MyCompany.net'
    >> returned 0x0
    >> NetpValidateName: name 'MyDomain2.MyCompany.net' is valid for type 3
    >> NetpDsGetDcName: trying to find DC in domain 'MyDomain2.MyCompany.net',
    >> flags: 0x40001010
    >> NetpDsGetDcName: failed to find a DC having account 'MYCOMPUTER$':
    >> 0x525,
    >> last error is 0x79
    >> NetpDsGetDcName: status of verifying DNS A record name resolution for
    >> 'MyServer2.MyDomain2.MyCompany.net': 0x0
    >> NetpDsGetDcName: found DC '\\MyServer2.MyDomain2.MyCompany.net' in the
    >> specified domain
    >> NetUseAdd to \\MyServer2.MyDomain2.MyCompany.net\IPC$ returned 5
    >> NetpJoinDomain: status of connecting to dc
    >> '\\MyServer2.MyDomain2.MyCompany.net': 0x5
    >> NetpDoDomainJoin: status: 0x5
    >>
    >> --
    >> Richard Mueller
    >> Microsoft MVP Scripting and ADSI
    >> Hilltop Lab - http://www.rlmueller.net
    >> --
    >>
    >>
    >>




Similar Threads

  1. Unable to join AD domain from DMZ network
    By Jasonholt in forum Active Directory
    Replies: 4
    Last Post: 12-06-2011, 12:34 AM
  2. Unable to resolve DNS name while trying to join domain
    By tmosely in forum Windows Server Help
    Replies: 3
    Last Post: 14-12-2008, 10:51 PM
  3. Replies: 1
    Last Post: 18-08-2008, 10:17 PM
  4. Replies: 4
    Last Post: 10-02-2007, 01:41 AM
  5. Unable to join client to domain
    By Victor Kam in forum Small Business Server
    Replies: 1
    Last Post: 08-01-2007, 06:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •