Results 1 to 10 of 10

Thread: Remote Desktop Fails on Server 2K3 After Every Restart

  1. #1
    Jason H. Guest

    Remote Desktop Fails on Server 2K3 After Every Restart

    For about 6 months now, our 2K3 servers have had the same issue: Remote
    Desktop stops working after a restart (be it for patches or just
    maintenance.) Every single time, we have to log on to the machine at the
    console and restart it again. This fixes the problem - EVERY SINGLE TIME -
    and we're able to remote desktop into the servers again after this server
    restart. This issue does NOT apply to our Win2K servers. We have no problem
    connecting to those via Remote Desktop after they are restarted. Anyone have
    any idea what may be going on? Restarting a server that's hosting critical
    services can be taxing enough - have to reboot it twice is just
    frustrating...for us and our users.

  2. #2
    Pegasus \(MVP\) Guest

    Re: Remote Desktop Fails on Server 2K3 After Every Restart

    You should examine the Event Log on these servers and check specifically
    for messages about the Terminal Server service.

    What exactly is the message you see when you attempt to launch an RD
    session?

    Until you find the cause of your problem, you should implement an
    automatic second reboot. Manually create a file c:\windows\reboot.txt,
    then use the Task Scheduler to run this batch file at boot time:

    @echo off
    if not exist c:\windows\reboot.txt goto :eof
    del c:\windows\reboot.txt
    shutdown /.. /.. /..

    Select the appropriate switches to reboot the machine within
    five minutes.

  3. #3
    Jason H. Guest

    Re: Remote Desktop Fails on Server 2K3 After Every Restart

    Thanks for the prompt reply. Unfortunately, the logs show nothing relating
    to Terminal Services at the time of reboot - in fact, nothing relating to
    anything pertinent.

    I can implement the script you've provided (many thanks for that) but it's
    definitely not the ideal solution. Have you never heard of anything like
    this?

    Anyways, to answer your question, the message I get when I try to connect to
    the server is: "The computer can't connect to the remote computer. Try
    connecting again. If the problem continues, contact the owner of the remote
    computer or your network administrator."

    Thanks again for that script.

  4. #4
    Pegasus \\(MVP\\) Guest

    Re: Remote Desktop Fails on Server 2K3 After Every Restart

    When I see this message then I invariably do this:
    - I ping the RD host by its IP address to ensure that it is correct.
    - I ping the RD host by its name to ensure that it can be resolved.
    - I run telnet to check if the RD port is open, e.g.
    telnet MyServer 3389
    And no, I have never seen this phenomenon.

  5. #5
    Jason H. Guest

    Re: Remote Desktop Fails on Server 2K3 After Every Restart

    I was able to ping both ways but I haven't tried the Telnet option yet. I'll
    report back when I do. However, I did notice that after this happens, the
    Terminal Services service options are grayed out both via remote computer
    management (I can do this, I just can't remote desktop into the server) and
    sitting in front of the machine itself. Someone mentioned that it's because
    I might not have sufficient priveleges but I'm logged in as the admin. Any
    other thoughts?

    (The options for the RPC service are also grayed out but I suspected that it
    was because the TS service was in whatever state it's in now.)

  6. #6
    joshua.brown@shaw.ca Guest

    Re: Remote Desktop Fails on Server 2K3 After Every Restart

    I had a smiliar issue, or so I thought... heres the story:

    Logged into my server via RDP and Installed the latest Windows patches
    on April 19. Did a reboot (or so I thought). My RDP connection
    disconnected as usual and I waited a few minutes before I tried
    logging back in again... so after 4 or 5 minutes I try to log in
    again... no luck. Logged into the phsyical machine and noted that the
    services were still running... but still nothing listening for RDP
    connections.... did a port scan as well, no port 3389 listed. it was
    like the service didn;t exist. Everything else on the server was
    running great... web sites, services, VPN connections, etc.

    Low and behold, I looked at the logs and checked the system up since
    date and it was still showing the last date we rebooted (something
    like March 30). TS Hung before the reboot could happen and everything
    stopped there! Manually rebooting will of course fix this issue.

    not sure if this is the case with you guys, but at least its something
    to rule out. Hope thats the issue..

  7. #7
    Join Date
    Nov 2008
    Posts
    1

    Re: Remote Desktop Fails on Server 2K3 After Every Restart

    A Windows Server 2003-based computer stops responding when you shut down the computer in a remote console session

    http://support.microsoft.com/?scid=k...30045&x=16&y=8

    French keywords :
    Pas de RDP TSE après plusieurs reboot successifs.

  8. #8
    Join Date
    Oct 2010
    Posts
    1

    Re: Remote Desktop Fails on Server 2K3 After Every Restart

    I also found out the same thing as Josh. We usually assume that the server has rebooted because it kicks us off RDP but we cant see what the server is actually doing. The first thing I noticed is that PING -t continued to get responses which meant that the server was not going down at all. It turns out that the server begins to shut down various services including the service that handles RDP connections however the server hangs before it actually stops all services - so you still get PING responses, IIS is up etc.
    Solution:
    - remote reboot the server using remote command prompt:
    "c:\shutdown -r -m \\ip_address"

    - to monitor progress:
    "PING -t \\ip_address"

    (you will need to use a user account with identical credentials on the local computer as well as on the target server or or you will need to be in a domain environment for the remote reboot to work)

    at some point the ping service on the remote server stops responding then you know you have a successful reboot. After that everything works.

  9. #9
    Join Date
    Jan 2011
    Posts
    1

    Re: Remote Desktop Fails on Server 2K3 After Every Restart

    Sorry for revival old threads, but I had the same problem, and the solution for me was adding the issue group or user, to the local user group Remote Desktop Users.
    My compute/manage/Local user and groups/groups/Remote Desktop Users/Add

    Regards
    Pablo

  10. #10
    Join Date
    Mar 2012
    Posts
    1

    [SOLUTION] Re: Remote Desktop Fails on Server 2K3 After Every Restart

    Hello,

    Well, my solution anyway.

    Again, too bad about the necromancy, but,

    I had this same issue and when in doubt, install Windows Updates.

    Seriously, installing windows updates and rebooting resolved the issue.

Similar Threads

  1. Replies: 5
    Last Post: 19-04-2011, 10:37 PM
  2. Restart Windows via Remote Desktop
    By Niversen in forum Tips & Tweaks
    Replies: 1
    Last Post: 13-06-2009, 09:08 AM
  3. can't restart remote server 2003 with shutdown -i?
    By geekyguy in forum Windows Server Help
    Replies: 3
    Last Post: 24-11-2008, 08:55 PM
  4. unable to access server with remote desktop after server restart
    By inenewbl in forum Windows Server Help
    Replies: 2
    Last Post: 24-11-2008, 08:53 PM
  5. Replies: 1
    Last Post: 01-07-2008, 01:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •