Go Back   TechArena Community > Technical Support > Computer Help > Windows Server > Windows Server Help
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Maximum Number of Allowed Connections with Remote Desktop

Windows Server Help


Reply
 
Thread Tools Search this Thread
  #1  
Old 17-01-2007
Kayda
 
Posts: n/a
Maximum Number of Allowed Connections with Remote Desktop

Hi:

I'm trying to connect to a Windows 2000 server via remote desktop. My
account is a member of the administrators group on the 2000 box. I've
been connecting successfully but sometimes I get disconnected because
of a network issue or VPN problems. So my session on the server is left
open and eventually I have problems reconnecting. I usually get two
errors:

Logon Message: The system has reached its licensed logon limit

and

Terminal Services Warning: The terminal server has exceeded the maximum
number of allow connections

I searched on this on the internet and the consensus seems to be to go
in via console mode in remote desktop. But when I do that I get the
same errors, maybe because I'm going in as the same user that already
has sessions open.

Questions:
1. What are the best settings on the server to avoid this, assuming
that I can't always logoff cleanly (in fact I might want to not logoff
cleanly and leave programs open as I set the terminal service to
remember the sessions.

2. Can I set Terminal Services to timeout a session after I have
disconnected via Remote Desktop after a certain amount of time? Surely
it knows when I have disconnected my remote desktop session even if I
haven't logged out.

3. Would if be easier to go in as a non-Administrator, since the limit
in this case seems to be specific to 2 Administrative accounts logged
in at the same time. Then I should be able to have multiple sessions,
yes? In this case I don't believe I need Adminstrative rights to the
box.

Thanks!

Kayda


Reply With Quote
  #2  
Old 17-01-2007
myweb
 
Posts: n/a
Re: Maximum Number of Allowed Connections with Remote Desktop

Hello Kayda,

There are two options: a.)Remote Adminstration mode and b.)Application mode
in Terminal services of W2000. For a.) max. 2 connections and b.) depends
on the amount of licenses you bought from Microsoft


Best regards

myweb
Disclaimer: This posting is provided "AS IS" with no warranties, and confers
no rights.



> Hi:
>
> I'm trying to connect to a Windows 2000 server via remote desktop. My
> account is a member of the administrators group on the 2000 box. I've
> been connecting successfully but sometimes I get disconnected because
> of a network issue or VPN problems. So my session on the server is
> left open and eventually I have problems reconnecting. I usually get
> two errors:
>
> Logon Message: The system has reached its licensed logon limit
>
> and
>
> Terminal Services Warning: The terminal server has exceeded the
> maximum number of allow connections
>
> I searched on this on the internet and the consensus seems to be to go
> in via console mode in remote desktop. But when I do that I get the
> same errors, maybe because I'm going in as the same user that already
> has sessions open.
>
> Questions:
> 1. What are the best settings on the server to avoid this, assuming
> that I can't always logoff cleanly (in fact I might want to not logoff
> cleanly and leave programs open as I set the terminal service to
> remember the sessions.
> 2. Can I set Terminal Services to timeout a session after I have
> disconnected via Remote Desktop after a certain amount of time? Surely
> it knows when I have disconnected my remote desktop session even if I
> haven't logged out.
>
> 3. Would if be easier to go in as a non-Administrator, since the limit
> in this case seems to be specific to 2 Administrative accounts logged
> in at the same time. Then I should be able to have multiple sessions,
> yes? In this case I don't believe I need Adminstrative rights to the
> box.
>
> Thanks!
>
> Kayda
>



Reply With Quote
  #3  
Old 17-01-2007
Mark-Allen [160825]
 
Posts: n/a
Re: Maximum Number of Allowed Connections with Remote Desktop

You could also set the End Session flag on a broken connection.

Go to Administrative Tools \ Terminal Services Configuration. Select
Connections, right-click RDP protocol, select Properties, click on Sessions
tab.

Now, there is a setting "Override user settings" near the bottom. Select
"End session" for broken connection.

Test.

Hope this helps.

--
Mark-Allen Perry
160825 / 1112165
Windows Vista X64 Ultimate
RTM Build 6000.16386
ALPHA Systems
Marly, Switzerland
mark-allen @ mvps . org



"Kayda" <blairjee@gmail.com> wrote in message
news:1169023420.344005.282510@v45g2000cwv.googlegroups.com...
> Hi:
>
> I'm trying to connect to a Windows 2000 server via remote desktop. My
> account is a member of the administrators group on the 2000 box. I've
> been connecting successfully but sometimes I get disconnected because
> of a network issue or VPN problems. So my session on the server is left
> open and eventually I have problems reconnecting. I usually get two
> errors:
>
> Logon Message: The system has reached its licensed logon limit
>
> and
>
> Terminal Services Warning: The terminal server has exceeded the maximum
> number of allow connections
>
> I searched on this on the internet and the consensus seems to be to go
> in via console mode in remote desktop. But when I do that I get the
> same errors, maybe because I'm going in as the same user that already
> has sessions open.
>
> Questions:
> 1. What are the best settings on the server to avoid this, assuming
> that I can't always logoff cleanly (in fact I might want to not logoff
> cleanly and leave programs open as I set the terminal service to
> remember the sessions.
>
> 2. Can I set Terminal Services to timeout a session after I have
> disconnected via Remote Desktop after a certain amount of time? Surely
> it knows when I have disconnected my remote desktop session even if I
> haven't logged out.
>
> 3. Would if be easier to go in as a non-Administrator, since the limit
> in this case seems to be specific to 2 Administrative accounts logged
> in at the same time. Then I should be able to have multiple sessions,
> yes? In this case I don't believe I need Adminstrative rights to the
> box.
>
> Thanks!
>
> Kayda
>


Reply With Quote
  #4  
Old 18-01-2007
Patrick Squire
 
Posts: n/a
Re: Maximum Number of Allowed Connections with Remote Desktop

I have been wondering about this... In longhorn you can configure the
ammount of remote connections allowed in the Terminal services manager...is
this not the case in R2?

--
Patrick Squire
http://www.msblog.org
"Kayda" <blairjee@gmail.com> wrote in message
news:1169023420.344005.282510@v45g2000cwv.googlegroups.com...
> Hi:
>
> I'm trying to connect to a Windows 2000 server via remote desktop. My
> account is a member of the administrators group on the 2000 box. I've
> been connecting successfully but sometimes I get disconnected because
> of a network issue or VPN problems. So my session on the server is left
> open and eventually I have problems reconnecting. I usually get two
> errors:
>
> Logon Message: The system has reached its licensed logon limit
>
> and
>
> Terminal Services Warning: The terminal server has exceeded the maximum
> number of allow connections
>
> I searched on this on the internet and the consensus seems to be to go
> in via console mode in remote desktop. But when I do that I get the
> same errors, maybe because I'm going in as the same user that already
> has sessions open.
>
> Questions:
> 1. What are the best settings on the server to avoid this, assuming
> that I can't always logoff cleanly (in fact I might want to not logoff
> cleanly and leave programs open as I set the terminal service to
> remember the sessions.
>
> 2. Can I set Terminal Services to timeout a session after I have
> disconnected via Remote Desktop after a certain amount of time? Surely
> it knows when I have disconnected my remote desktop session even if I
> haven't logged out.
>
> 3. Would if be easier to go in as a non-Administrator, since the limit
> in this case seems to be specific to 2 Administrative accounts logged
> in at the same time. Then I should be able to have multiple sessions,
> yes? In this case I don't believe I need Adminstrative rights to the
> box.
>
> Thanks!
>
> Kayda
>



Reply With Quote
  #5  
Old 30-01-2007
patrick wu
 
Posts: n/a
Myweb is correct.

I think myweb's comment is perfect.

EggHeadCafe.com - .NET Developer Portal of Choice
http://www.eggheadcafe.com
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows Server > Windows Server Help
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Maximum Number of Allowed Connections with Remote Desktop"
Thread Thread Starter Forum Replies Last Post
Windows Server 2003 SBS: Error Exceeded Maximum Number of Connections Tuhina Windows Server Help 5 13-01-2011 06:45 PM
Global maximum number of connections Kickapoo Windows Software 5 25-06-2010 10:02 AM
What is the Default Maximum Number of TCP Connections on the serve TIA Windows Server Help 5 01-04-2009 08:54 PM
Event ID 402 - maximum number of connections error Darpad Small Business Server 1 29-10-2008 03:44 PM
Terminal server exeeded the maximum number of allowed connections Chad Gross Small Business Server 1 01-02-2006 07:20 AM


All times are GMT +5.5. The time now is 08:41 PM.