Results 1 to 7 of 7

Thread: Slow opening of Word and Excel documents over network

  1. #1
    Martin Connolly Guest

    Slow opening of Word and Excel documents over network

    My setup

    Windows SBS, plus about 10 PCs with XP Home in a workgroup. A single 'F
    drive' shared and mapped to the client XP Home PCs. Guest account enabled
    and permitted to the share, so that all clients can open files like in a
    simple peer-peer network. Network all works perfectly, except that randomly
    when opening a Word of Excel document, it will hang and go 'not responding'
    for about 30 seconds before then waking up and continuing as before. Happens
    about 30% if the time, on small and large documents.

    (Word and Excel 2000 BTW).

    Tried everything I could find - disabling Oplocks, NTCaching etc - and
    nothing makes a difference.

    Then, changed the network share so that it is mapped and signed on using the
    server's Administrator username and password, rather than guest. All of a
    sudden, problem is gone.

    Question is.......why?

    Why should this solve the issue?

    Also, since this does, can I make XP Home remember the password between
    boot-ups???? At the moment, we have to re-enter the Administrator password
    every morning to reconnect the F drive.

  2. #2
    Robert L [MVP - Networking] Guest

    Re: Slow opening of Word and Excel documents over network

    These search results may help,
    Slow when accessing the file located on a server You experience slow performance when you open, save, close, delete, ... When you try to open a Microsoft Word file, you may receive the following error ...

    Slow to open a file or browse because of mapping to disconnected drive ... For example, when a user tries to browse his department shared folder from Word, ...

  3. #3
    Merg to the max Guest

    Re: Slow opening of Word and Excel documents over network

    This problem can be caused by ACT!8. The preload setting needs to be
    changed from -stayrunning to -preload in:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

  4. #4
    theanswerinc Guest

    Re: Slow opening of Word and Excel documents over network

    I had the same problem, and found that the HP digital imaging monitor was
    causing the long startup time. Once I got rid of it from the startup and
    rebooted, the problem went away for my office docs.

  5. #5
    Join Date
    Jan 2009
    Posts
    1
    Thanks for the answer. I had the same issue and removing the HP Digital image center solved it.

    Thanks a lot for the answer. This seems to be working also for me.

  6. #6
    Join Date
    Mar 2010
    Posts
    1

    Re: Slow opening of Word and Excel documents over network

    We tried everything and finally decided since we are using Windows Server and it uses Internet Explorer a lot, we reset Internet Explorer to its default settings. Control panel to Internet Options. Then under Advanced, at the bottom, you can reset it to its default settings. We then did windows update, which had a bunch of updates to download and install. But, now, my computer is faster than it's ever been. I wish I had done this sooner!

  7. #7
    Join Date
    Dec 2011
    Posts
    1

    Re: Slow opening of Word and Excel documents over network

    For mapping the network share so you wouldn't have to enter username and password first you can create a logon script (.bat or someting else)

    net use h: \\server\share /user:username password



    With the slow opening of excel files it has something to do with the registry key

    1. Close any instances of MS Office
    2. Click Start, click Run, type regedit then click OK.
    3. Locate and then click to select the following registry key: HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\11.0″
    4. Nadat je de key hebt gespecifieerd in stap 3, point to New on the Edit menu, then click Key.
    5. Type Excel, then press ENTER.
    6. Select Excel, point to New on the Edit menu, and then click Key.
    7. Type Security, and then press ENTER.
    8. Select Security, point to New on the Edit menu, and then click Key.
    9. Type FileValidation, and then press ENTER.
    10. Select FileValidation, point to New on the Edit menu, then click DWORD Value.
    11. Type EnableOnLoad, then press ENTER.
    Note: The default value is 0 which disables the validation.
    12. On the File menu, click Exit to quit Registry Editor.

Similar Threads

  1. Very slow opening of Word and Excel files
    By gajaratna in forum MS Office Support
    Replies: 2
    Last Post: 12-10-2011, 10:56 PM
  2. Replies: 8
    Last Post: 11-02-2011, 10:24 AM
  3. Replies: 4
    Last Post: 07-08-2010, 03:43 PM
  4. word and excel opening up very slow
    By Hardik in forum MS Office Support
    Replies: 3
    Last Post: 03-11-2009, 01:49 AM
  5. Word and Excel Documents not opening properly
    By m3pilot in forum MS Office Support
    Replies: 2
    Last Post: 22-07-2008, 07:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •