Results 1 to 7 of 7

Thread: disk caching

  1. #1
    Guest

    disk caching

    Hello

    For testing purposes, I enabled "Enable write caching on
    the disk" in a Windows Server 2003 DC, from Disk
    Properties > Hardware tab > Properties > Plicies tab.

    When I restarted the machine, the change goes back to the
    previous settings, i.e. disabled. Is there any registry
    key to modify so that write caching remains enabled ? Or
    any other method ...

    I tried the same test on a standalone Windows Server
    2003, I did not have any problem.

    Many thanks

    Best



  2. #2
    Jason Tan Guest

    RE: disk caching

    Hi

    Thanks for posting!

    I understand that you cannot preserve the check for "Enable write caching
    on the disk". If I have misunderstood your concerns, please feel free to
    let me know.

    Based on my research, it could be the cause that some third-party queries
    and does not permit change the option when restart the machine. Therefore,
    if possible, I suggest you perform a clean boot on non-business time and
    test if the issue still persists.

    ===========================
    1. Click the "Start" and select "Run".
    2. Type msconfig in the open box, and then click "OK".
    3. On the "Services" tab, click to choose "Hide All Microsoft Services" and
    click to choose Disable All.
    4. On the Startup page, click Disable All.
    5. Click "OK" to reboot your computer.
    6. When you see the message, choose "Don't show this message or launch the
    System Configuration Utility when Windows starts" and click OK.

    The below article can also be applied to Windows 2003
    310353 How to perform a clean boot in Windows XP
    http://support.microsoft.com/?id=310353

    This option could be related to the following registry key which I traced
    on my system by Regmon tool. Please check the corresponding registry key of
    your machine. I suspect that when starting the machine the option will be
    revised back by some third party.

    HKLM\System\CurrentControlSet\Enum\IDE\DiskMaxtor_33073H3___________________
    _______YAH814Y0\334c414a38304354202020202020202020202020\Device
    Parameters\Disk\UserWriteCacheSetting

    More information for your reference:
    Regmon download
    http://www.sysinternals.com/ntw2k/source/regmon.shtml

    I look forward to your response. If there is anything that is unclear,
    please feel free to let me know.

    Thanks & Regards,

    Jason Tan

    Microsoft Online Partner Support
    Get Secure! - www.microsoft.com/security

    =====================================================

    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.

    =====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.








  3. #3
    Guest

    RE: disk caching

    Thank you Jason

    Please can I just ask you:

    Have you tested it on 2003 Domain Controller (and not
    standalone) with IDE Disk Maxtor ? For some reasons I
    assumed that it could be because it is a DC which has not
    write cache on disk.

    The Disk on which I am trying to enable "Enable write
    caching on the disk" with no success, is IDE Western
    Digital.

  4. #4
    Jason Tan Guest

    RE: disk caching

    Hi

    Thanks for your reply!

    Please excuse me that I have tested the issue on a standalone Windows
    Server 2003 other than a DC in the first place since I neglect it could be
    related to DC. To verify your concerns, I test it again on a Windows 2003
    Domain Controller on my side. The issue can be reproduced. Based on my
    further research, I would like to provide you with the following
    information.

    CAUSE
    =========
    By default, write caching is disabled on a disk that contains the Active
    Directory database (Ntds.dit). Also, write caching is disabled on a disk
    that contains the
    Active Directory log files. By doing this, you enhance the reliability of
    the Active Direcory files.

    Move the Active Directory database and the Active Directory log files off
    of a disk in which you need to enable write caching. For more information,
    see the following article:

    257420 HOW TO: Move the Ntds.dit File or Log Files
    http://support.microsoft.com/?id=257420

    WORKAROUND
    ===================
    There is a workaround to force on write caching for all drives when the
    computer is started. It involves using the Dskcache.exe tool from the
    following article in a startup script:

    811392 Obtain the Dskcache.exe Tool to Configure the "Power Protected" Write
    http://support.microsoft.com/?id=811392

    Please note that enabling write cache for drives that contain the active
    directory database or logs is not recommended since data loss can occur.
    However, here are the steps:

    1. Download Dskcache.exe from 811392 and copy it to the root of C:

    2. Create a .CMD called EnableCache.CMD on the root of C:\ that contains
    the following text:

    echo off
    c:\dskcache.exe +w
    exit

    3. Click Start, click Run, type "gpedit.msc" (without the quotation
    marks), and then press ENTER.

    4. Browse to the following:

    Local Computer Policy\Computer Configuration\Windows Settings\Scripts

    5. Double-click Startup and then click Add.

    6. Type the following in the Script Name box and click OK:

    C:\EnableCache.CMD

    7. Click OK and close the Group Policy Object Editor window.

    Now each time the computer is restarted, EnableCache.CMD runs to enable
    write cache for all disks.

    I hope my information helps. If there is anything that is unclear, please
    feel free to let me know.

    Thanks & Regards,

    Jason Tan

    Microsoft Online Partner Support
    Get Secure! - www.microsoft.com/security

    =====================================================

    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.

    =====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.



  5. #5
    Guest

    RE: disk caching

    It worked !!!

    Is this an excellent or brilliant or fan-ta-stic reply
    Jason ? you choose !

    Many many thanks !!!

  6. #6
    Jason Tan Guest

    RE: disk caching

    Hi,

    I appreciate your update. I am glad to hear that the problem has been fixed
    and you are happy. If you have any other questions or concerns, please do
    not hesitate to let me know. It is always my pleasure to be of assistance.

    Thanks & Regards,

    Jason Tan

    Microsoft Online Partner Support
    Get Secure! - www.microsoft.com/security

    =====================================================

    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.

    =====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.


  7. #7
    Join Date
    Dec 2007
    Posts
    1

    thanks

    I think that I found the answer, I got the same trouble, thanks a lot

Similar Threads

  1. ESX disk write caching enabled or not
    By brynhildur in forum Hardware Peripherals
    Replies: 4
    Last Post: 22-11-2010, 06:20 AM
  2. Caching Records in Memory with ASP.NET
    By rashmi_ay in forum Software Development
    Replies: 5
    Last Post: 16-02-2010, 02:51 PM
  3. How to improve the efficiency caching in PHP?
    By Barsha in forum Software Development
    Replies: 5
    Last Post: 13-02-2010, 02:58 AM
  4. Code for Caching
    By RMG in forum Software Development
    Replies: 3
    Last Post: 02-01-2009, 09:39 PM
  5. Enable Write Disk Caching not saving (Server 2003)
    By daniel.dryhurst@gmail.com in forum Windows Server Help
    Replies: 5
    Last Post: 18-06-2007, 11:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •