Results 1 to 5 of 5

Thread: Terminal Services not working - Port 3389 not listening

  1. #1
    mgorman@elitefoodco.com Guest
    Having read through quite a few posts, I'm hesitant to add another one
    to the pile but here it is. I've exhausted almost all the suggestions
    I have seen previously. One thing that never seems to get answered
    though is how to get port 3389 to listen appropriately. It is showing
    has the selected port in the registry. Here it is:

    Windows 2000 server, Terminal Services configured and running however
    port 3389 is not established or listening.
    Troubleshooting steps already taken:
    1.) Terminal Service is up and running in services.mgr
    2.) I have run netstat -a -n. Port 3389 is definitely NOT listening or
    established. As a double check, I have also tried to telnet to the
    machine and it fails on a connection error.
    3.) There is no firewall on the machine or on my internal network. In
    fact, this machine has worked in the past and I have a Windows 2003 SBS
    server that works.
    4.) The machine was running in Application Server Mode, but I have
    since switched it to Remote Administration mode just to check if it
    could be an issue with my License server. This had no effect.
    5.) I removed Symanted Antivirus Corporate Edition, just in case it
    was blocking port 3389.
    6.) I have insured that no filters are running on my network connection
    that might prohibit entry through this port.
    7.) I have tried changing the port that Terminal Services use.
    8.) I have tried reinstalling (through upgrade) the operating system.
    I tried reinstalling SP 4.
    9.) I have verified that port number 3389 is located in the registry.
    10.) Please DO NOT suggest checking the Remote tab in System
    properties. This is a 2000 server and the tab does not exist. In this
    same vein, unless someone can assure me differently, I do not believe
    there is a local security policy that "Enables remote desktop
    connection" in Server 2000. I've checked already. If there should be
    one, I don't have it on my system.

    This issue all started after I reinstalled the operating system as a
    result of Active Directory Issues I was having with replication. The
    reinstall did fix these problems, but since, my terminal services are
    not running properly.

    Found the solution to my particular problem. Article:
    http://support.microsoft.com/kb/270588/en-us

    CAUSE
    This problem can occur if the server has been booted by using the Last
    Known Good Configuration option more than once. When the server has
    been booted into the last known good configuration more than once, the
    ControlSet001 registry key is deleted. However, the following registry
    value is hard-coded to use the ControlSet001 registry key:
    Key: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal
    Server\VIDEO\rdpdd\

    Value name: \Device\Video0
    Value type: REG_SZ
    Value data:
    \REGISTRY\Machine\System\ControlSet001\Services\RDPDD\Device0
    Back to the top

    RESOLUTION
    WARNING: If you use Registry Editor incorrectly, you may cause serious
    problems that may require you to reinstall your operating system.
    Microsoft cannot guarantee that you can solve problems that result from
    using Registry Editor incorrectly. Use Registry Editor at your own
    risk.

    To resolve this problem, obtain the latest service pack for Windows
    2000. For additional information, click the following article number to
    view the article in the Microsoft Knowledge Base:
    260910 (http://support.microsoft.com/kb/260910/EN-US/) How to Obtain
    the Latest Windows 2000 Service Pack
    To resolve this problem: 1. Start Registry Editor (Regedt32.exe).
    2. Locate and click the following registry key:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal
    Server\VIDEO\rdpdd\
    Note If you do not have this key, use Registry Editor to create it.
    3. Do one of the following: If you did not have to create the key in
    step 2, change the following value
    Name: \Device\Video0
    Type: REG_SZ
    Value: \REGISTRY\Machine\System\ControlSet001\Services\RDPDD\Device0
    to the following:
    Name: \Device\Video0
    Type: REG_SZ
    Value:
    \REGISTRY\Machine\System\CurrentControlSet\Services\RDPDD\Device0
    If you had to create the registry key in step 2, add the following
    value:
    Subkey name: RDPDD
    Name: \Device\Video0
    Type: REG_SZ
    Value:
    \REGISTRY\Machine\System\CurrentControlSet\Services\RDPDD\Device0

    4. After you change (or create) the value, restart the computer that is
    running Terminal Services.

  2. #2
    Join Date
    May 2009
    Posts
    1
    This post was of great help. I just had a machine that was refusing to listen on port 3389 for RDP connections. I checked the registry entries you pointed to and found an error. I had the particular key you reference, but the value, which was supposed to be
    \REGISTRY\Machine\System\CurrentControlSet\Services\RDPDD\Device0
    was instead
    \REGISTRY\Machine\System\CurrentControlSet\Serviceŋ\RDPDD\Device0
    Notice the ŋ symbol? I changed that to an s and rebooted. Everything is working great now. I would never have found and fixed this without your post.

    I did a P2V in VMWARE on a Windows 2000 server which went fine. Performed anther P2V and it booted into the OS fine but I couldn't RDP TO it and couldn't figure out why.

    After performing two additional P2V's and adding/removing the terminal services via add/remove programs I could not figure it out.

  3. #3
    Ace Fekay [MCT] Guest

    Re: Terminal Services not working - Port 3389 not listening

    Found the solution to my particular problem. Article:
    http://support.microsoft.com/kb/270588/en-us

    CAUSE
    This problem can occur if the server has been booted by using the Last
    Known Good Configuration option more than once. When the server has
    been booted into the last known good configuration more than once, the
    ControlSet001 registry key is deleted. However, the following registry
    value is hard-coded to use the ControlSet001 registry key:
    Key: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Contro l\Terminal
    Server\VIDEO\rdpdd\

    Value name: \Device\Video0
    Value type: REG_SZ
    Value data:
    \REGISTRY\Machine\System\ControlSet001\Services\RD PDD\Device0
    Back to the top

    RESOLUTION
    WARNING: If you use Registry Editor incorrectly, you may cause serious
    problems that may require you to reinstall your operating system.
    Microsoft cannot guarantee that you can solve problems that result from
    using Registry Editor incorrectly. Use Registry Editor at your own
    risk.

    To resolve this problem, obtain the latest service pack for Windows
    2000. For additional information, click the following article number to
    view the article in the Microsoft Knowledge Base:
    260910 (http://support.microsoft.com/kb/260910/EN-US/) How to Obtain
    the Latest Windows 2000 Service Pack
    To resolve this problem: 1. Start Registry Editor (Regedt32.exe).
    2. Locate and click the following registry key:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Contro l\Terminal
    Server\VIDEO\rdpdd\
    Note If you do not have this key, use Registry Editor to create it.
    3. Do one of the following: If you did not have to create the key in
    step 2, change the following value
    Name: \Device\Video0
    Type: REG_SZ
    Value: \REGISTRY\Machine\System\ControlSet001\Services\RD PDD\Device0
    to the following:
    Name: \Device\Video0
    Type: REG_SZ
    Value:
    \REGISTRY\Machine\System\CurrentControlSet\Service s\RDPDD\Device0
    If you had to create the registry key in step 2, add the following
    value:
    Subkey name: RDPDD
    Name: \Device\Video0
    Type: REG_SZ
    Value:
    \REGISTRY\Machine\System\CurrentControlSet\Service s\RDPDD\Device0

    4. After you change (or create) the value, restart the computer that is
    running Terminal Services.

  4. #4
    Join Date
    Mar 2010
    Posts
    1
    Just Export below key from Working Windows 2003 Server and import it to nonworking Server.I did it successfully few minutes back.

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Contro l\Terminal
    Server\VIDEO\rdpdd\

    There is also a fDeneyTSConnections must be set to 0. This is located at LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server.

    Remote Desktop was working, then I installed McAfee, and it didn't work any longer. After digging around in the registry after reading the above, I found the above key, and that it had been set to 1.

    I had been using the MS tool PortQuery to help diagnose. It had been returning "not listening" on port 3389, until this switch was flipped.

  5. #5
    Join Date
    Dec 2010
    Posts
    2

    Re: Terminal Services not working - Port 3389 not listening

    If Terminal Services and Remote procedure call services are up, and no 3389 port listed on netstat -na then do the following (as a last option before repairing SO):

    1) Download devcon.exe from (http://support.microsoft.com/kb/311272) and run devcon.exe.

    2) An Extractor will popup, extract to "C:\devcon" or otherwise folder u like.
    3) Open a cmd prompt and navigate to the i386 folder extractor made.
    4) Type: devcon.exe -r install %windir%\inf\machine.inf root\rdpdr (All connections will be closed and machine will restart, save your work before execute that, and proceed)

    The machine will do a process, and then restart, wait until windows start, and then do an netstat -na, if the port 3389 appears listening it's all done.

    Good luck!

Similar Threads

  1. XP Port 3389 Not Listening
    By Harnoor in forum Networking & Security
    Replies: 6
    Last Post: 30-12-2010, 09:51 PM
  2. How to allow TCP port 3389 on Windows Firewall
    By DotNetUser in forum Networking & Security
    Replies: 2
    Last Post: 31-07-2009, 06:05 PM
  3. net stop terminal services not working
    By Amaresh in forum Operating Systems
    Replies: 3
    Last Post: 08-06-2009, 09:48 PM
  4. How do I open Port 3389
    By MilesAway in forum Small Business Server
    Replies: 10
    Last Post: 01-07-2008, 10:30 AM
  5. Terminal Services Manager not working
    By slimbim in forum Vista Help
    Replies: 3
    Last Post: 15-06-2007, 04:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •