Go Back   TechArena Community > Technical Support > Computer Help > Windows Server > Windows Server Help
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



default domain display at logon

Windows Server Help


Reply
 
Thread Tools Search this Thread
  #1  
Old 10-02-2006
jmhop
 
Posts: n/a
default domain display at logon

ADMT appears to set the default domain of XP workstations to log in to the
local machine. Is there a way to change this? What we would like is for the
default domain to show the target domain name. It appears to work on windows
2000 boxes

Reply With Quote
  #2  
Old 10-02-2006
Jason Tan
 
Posts: n/a
RE: default domain display at logon

Hello,

Thanks for posting!

ADMT cannot change the default logon domain of the workstations. I suggest
you wirte a script to change the default log on domain according to the
following methods:

To change the default Log on to: value edit the following local registry
key of the
machine you are logging on to:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

CachePrimaryDomain

You may write a domain logon script to achieve the goal.

More information for your reference:

315245 How to Assign a Logon Script to a Profile for a Local User
<http://support.microsoft.com/default.aspx?scid=kb;EN-US;315245>

Hope the information helps.

Best Regards,

Jason Tan

Microsoft Online Partner Support
Get Secure! - www.microsoft.com/security

=====================================================

When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.

=====================================================
This posting is provided "AS IS" with no warranties, and confers no rights.




--------------------
| Thread-Topic: default domain display at logon
| thread-index: AcYtwiRkcNfKxj7KRYOrlMtGrx/14Q==
| X-WBNR-Posting-Host: 192.35.79.70
| From: "=?Utf-8?B?am1ob3A=?=" <jmhop@discussions.microsoft.com>
| Subject: default domain display at logon
| Date: Thu, 9 Feb 2006 13:45:28 -0800
| Lines: 4
| Message-ID: <47A6AC93-5F85-4F73-985C-5420596389F7@microsoft.com>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups: microsoft.public.windows.server.migration
| NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGXA03.phx.gbl
| Xref: TK2MSFTNGXA01.phx.gbl
microsoft.public.windows.server.migration:22411
| X-Tomcat-NG: microsoft.public.windows.server.migration
|
| ADMT appears to set the default domain of XP workstations to log in to
the
| local machine. Is there a way to change this? What we would like is for
the
| default domain to show the target domain name. It appears to work on
windows
| 2000 boxes
|

Reply With Quote
  #3  
Old 10-02-2006
jmhop
 
Posts: n/a
RE: default domain display at logon

Jason -
Thanks for the reply -
we are changing the "DefaultDomainName" in Winlogon reg key - our scprit
runs prior to ADMT migrating the workstation. Windows 2000 correctly shows
the new domain, Windows XP does not. We are going to test the
CachePrimaryDomain change this morning, i will let you know.

Putting this in the logon script does not really help us, because the users
cannot log in locally (they only have domain accounts), and most do not know
which domain they even log into.

Thanks,
Jmhop


"Jason Tan (MSFT)" wrote:

> Hello,
>
> Thanks for posting!
>
> ADMT cannot change the default logon domain of the workstations. I suggest
> you wirte a script to change the default log on domain according to the
> following methods:
>
> To change the default Log on to: value edit the following local registry
> key of the
> machine you are logging on to:
>
> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
>
> CachePrimaryDomain
>
> You may write a domain logon script to achieve the goal.
>
> More information for your reference:
>
> 315245 How to Assign a Logon Script to a Profile for a Local User
> <http://support.microsoft.com/default.aspx?scid=kb;EN-US;315245>
>
> Hope the information helps.
>
> Best Regards,
>
> Jason Tan
>
> Microsoft Online Partner Support
> Get Secure! - www.microsoft.com/security
>
> =====================================================
>
> When responding to posts, please "Reply to Group" via your newsreader so
> that others may learn and benefit from your issue.
>
> =====================================================
> This posting is provided "AS IS" with no warranties, and confers no rights.
>
>
>
>
> --------------------
> | Thread-Topic: default domain display at logon
> | thread-index: AcYtwiRkcNfKxj7KRYOrlMtGrx/14Q==
> | X-WBNR-Posting-Host: 192.35.79.70
> | From: "=?Utf-8?B?am1ob3A=?=" <jmhop@discussions.microsoft.com>
> | Subject: default domain display at logon
> | Date: Thu, 9 Feb 2006 13:45:28 -0800
> | Lines: 4
> | Message-ID: <47A6AC93-5F85-4F73-985C-5420596389F7@microsoft.com>
> | MIME-Version: 1.0
> | Content-Type: text/plain;
> | charset="Utf-8"
> | Content-Transfer-Encoding: 7bit
> | X-Newsreader: Microsoft CDO for Windows 2000
> | Content-Class: urn:content-classes:message
> | Importance: normal
> | Priority: normal
> | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
> | Newsgroups: microsoft.public.windows.server.migration
> | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
> | Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGXA03.phx.gbl
> | Xref: TK2MSFTNGXA01.phx.gbl
> microsoft.public.windows.server.migration:22411
> | X-Tomcat-NG: microsoft.public.windows.server.migration
> |
> | ADMT appears to set the default domain of XP workstations to log in to
> the
> | local machine. Is there a way to change this? What we would like is for
> the
> | default domain to show the target domain name. It appears to work on
> windows
> | 2000 boxes
> |
>
>

Reply With Quote
  #4  
Old 03-03-2006
omar@marathonsolutions.com
 
Posts: n/a
Re: default domain display at logon

If you write a script to utilize the ADMT command line migration for
computers maybe you can add some additional lines of code that change
that registry key based off of the value of the target domain- that
will be in the admt migration code anyway.

The one thing that may need to be tested 1st is to see if the registry
key change needs to happen before ADMT reboots the computer or upon
start up of the workstation after the reboot.

I am working on a similar migration with ADMT so I am interested to
hear how you either fixed this issue- or just lived with it.

Omar
jmhop wrote:
> Jason -
> Thanks for the reply -
> we are changing the "DefaultDomainName" in Winlogon reg key - our scprit
> runs prior to ADMT migrating the workstation. Windows 2000 correctly shows
> the new domain, Windows XP does not. We are going to test the
> CachePrimaryDomain change this morning, i will let you know.
>
> Putting this in the logon script does not really help us, because the users
> cannot log in locally (they only have domain accounts), and most do not know
> which domain they even log into.
>
> Thanks,
> Jmhop
>
>
> "Jason Tan (MSFT)" wrote:
>
> > Hello,
> >
> > Thanks for posting!
> >
> > ADMT cannot change the default logon domain of the workstations. I suggest
> > you wirte a script to change the default log on domain according to the
> > following methods:
> >
> > To change the default Log on to: value edit the following local registry
> > key of the
> > machine you are logging on to:
> >
> > HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
> >
> > CachePrimaryDomain
> >
> > You may write a domain logon script to achieve the goal.
> >
> > More information for your reference:
> >
> > 315245 How to Assign a Logon Script to a Profile for a Local User
> > <http://support.microsoft.com/default.aspx?scid=kb;EN-US;315245>
> >
> > Hope the information helps.
> >
> > Best Regards,
> >
> > Jason Tan
> >
> > Microsoft Online Partner Support
> > Get Secure! - www.microsoft.com/security
> >
> > =====================================================
> >
> > When responding to posts, please "Reply to Group" via your newsreader so
> > that others may learn and benefit from your issue.
> >
> > =====================================================
> > This posting is provided "AS IS" with no warranties, and confers no rights.
> >
> >
> >
> >
> > --------------------
> > | Thread-Topic: default domain display at logon
> > | thread-index: AcYtwiRkcNfKxj7KRYOrlMtGrx/14Q==
> > | X-WBNR-Posting-Host: 192.35.79.70
> > | From: "=?Utf-8?B?am1ob3A=?=" <jmhop@discussions.microsoft.com>
> > | Subject: default domain display at logon
> > | Date: Thu, 9 Feb 2006 13:45:28 -0800
> > | Lines: 4
> > | Message-ID: <47A6AC93-5F85-4F73-985C-5420596389F7@microsoft.com>
> > | MIME-Version: 1.0
> > | Content-Type: text/plain;
> > | charset="Utf-8"
> > | Content-Transfer-Encoding: 7bit
> > | X-Newsreader: Microsoft CDO for Windows 2000
> > | Content-Class: urn:content-classes:message
> > | Importance: normal
> > | Priority: normal
> > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
> > | Newsgroups: microsoft.public.windows.server.migration
> > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
> > | Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGXA03.phx.gbl
> > | Xref: TK2MSFTNGXA01.phx.gbl
> > microsoft.public.windows.server.migration:22411
> > | X-Tomcat-NG: microsoft.public.windows.server.migration
> > |
> > | ADMT appears to set the default domain of XP workstations to log in to
> > the
> > | local machine. Is there a way to change this? What we would like is for
> > the
> > | default domain to show the target domain name. It appears to work on
> > windows
> > | 2000 boxes
> > |
> >
> >


Reply With Quote
  #5  
Old 03-03-2006
jmhop
 
Posts: n/a
Re: default domain display at logon

Omar -
It does matter when you change the registry. Our testing indicated that the
3 "domain" fields get updated on logon, we were able to successfully change
the default domain on the migrating workstations (via a vb app and remote
registry - long story) for win2k and winXP. we ended up changing BOTH
"CachePrimaryDomain" and "DefaultDomainName" to make all workstations happy.

jmhop


"omar@marathonsolutions.com" wrote:

> If you write a script to utilize the ADMT command line migration for
> computers maybe you can add some additional lines of code that change
> that registry key based off of the value of the target domain- that
> will be in the admt migration code anyway.
>
> The one thing that may need to be tested 1st is to see if the registry
> key change needs to happen before ADMT reboots the computer or upon
> start up of the workstation after the reboot.
>
> I am working on a similar migration with ADMT so I am interested to
> hear how you either fixed this issue- or just lived with it.
>
> Omar
> jmhop wrote:
> > Jason -
> > Thanks for the reply -
> > we are changing the "DefaultDomainName" in Winlogon reg key - our scprit
> > runs prior to ADMT migrating the workstation. Windows 2000 correctly shows
> > the new domain, Windows XP does not. We are going to test the
> > CachePrimaryDomain change this morning, i will let you know.
> >
> > Putting this in the logon script does not really help us, because the users
> > cannot log in locally (they only have domain accounts), and most do not know
> > which domain they even log into.
> >
> > Thanks,
> > Jmhop
> >
> >
> > "Jason Tan (MSFT)" wrote:
> >
> > > Hello,
> > >
> > > Thanks for posting!
> > >
> > > ADMT cannot change the default logon domain of the workstations. I suggest
> > > you wirte a script to change the default log on domain according to the
> > > following methods:
> > >
> > > To change the default Log on to: value edit the following local registry
> > > key of the
> > > machine you are logging on to:
> > >
> > > HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
> > >
> > > CachePrimaryDomain
> > >
> > > You may write a domain logon script to achieve the goal.
> > >
> > > More information for your reference:
> > >
> > > 315245 How to Assign a Logon Script to a Profile for a Local User
> > > <http://support.microsoft.com/default.aspx?scid=kb;EN-US;315245>
> > >
> > > Hope the information helps.
> > >
> > > Best Regards,
> > >
> > > Jason Tan
> > >
> > > Microsoft Online Partner Support
> > > Get Secure! - www.microsoft.com/security
> > >
> > > =====================================================
> > >
> > > When responding to posts, please "Reply to Group" via your newsreader so
> > > that others may learn and benefit from your issue.
> > >
> > > =====================================================
> > > This posting is provided "AS IS" with no warranties, and confers no rights.
> > >
> > >
> > >
> > >
> > > --------------------
> > > | Thread-Topic: default domain display at logon
> > > | thread-index: AcYtwiRkcNfKxj7KRYOrlMtGrx/14Q==
> > > | X-WBNR-Posting-Host: 192.35.79.70
> > > | From: "=?Utf-8?B?am1ob3A=?=" <jmhop@discussions.microsoft.com>
> > > | Subject: default domain display at logon
> > > | Date: Thu, 9 Feb 2006 13:45:28 -0800
> > > | Lines: 4
> > > | Message-ID: <47A6AC93-5F85-4F73-985C-5420596389F7@microsoft.com>
> > > | MIME-Version: 1.0
> > > | Content-Type: text/plain;
> > > | charset="Utf-8"
> > > | Content-Transfer-Encoding: 7bit
> > > | X-Newsreader: Microsoft CDO for Windows 2000
> > > | Content-Class: urn:content-classes:message
> > > | Importance: normal
> > > | Priority: normal
> > > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
> > > | Newsgroups: microsoft.public.windows.server.migration
> > > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
> > > | Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGXA03.phx.gbl
> > > | Xref: TK2MSFTNGXA01.phx.gbl
> > > microsoft.public.windows.server.migration:22411
> > > | X-Tomcat-NG: microsoft.public.windows.server.migration
> > > |
> > > | ADMT appears to set the default domain of XP workstations to log in to
> > > the
> > > | local machine. Is there a way to change this? What we would like is for
> > > the
> > > | default domain to show the target domain name. It appears to work on
> > > windows
> > > | 2000 boxes
> > > |
> > >
> > >

>
>

Reply With Quote
  #6  
Old 03-03-2006
Jason Tan
 
Posts: n/a
Re: default domain display at logon

Hello Jmhop,

Thank you for your reply and the detailed additional feedback on how you
were successful in resolving this issue. This information has been added
to Microsoft's database. Your solution will benefit many other users, and
we really value having you as a Microsoft customer.

If you have any other questions or concerns, please do not hesitate to
contact us. It is always our pleasure to be of assistance.

Best Regards,

Jason Tan

Microsoft Online Partner Support
Get Secure! - www.microsoft.com/security

=====================================================

When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.

=====================================================
This posting is provided "AS IS" with no warranties, and confers no rights.



--------------------
| Thread-Topic: default domain display at logon
| thread-index: AcY+K7WA3Oxnu3neQr+rfpzhHz+G9w==
| X-WBNR-Posting-Host: 192.35.79.70
| From: "=?Utf-8?B?am1ob3A=?=" <jmhop@discussions.microsoft.com>
| References: <47A6AC93-5F85-4F73-985C-5420596389F7@microsoft.com>
<PRgJ0jgLGHA.768@TK2MSFTNGXA01.phx.gbl>
<92B3BC4C-14F3-4B18-A155-692699D34BD3@microsoft.com>
<1141324963.771007.117560@p10g2000cwp.googlegroups.com>
| Subject: Re: default domain display at logon
| Date: Thu, 2 Mar 2006 11:01:27 -0800
| Lines: 123
| Message-ID: <AACA78B3-CFDD-4FF3-9E80-09B4A4FA241D@microsoft.com>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups: microsoft.public.windows.server.migration
| Path: TK2MSFTNGXA03.phx.gbl
| Xref: TK2MSFTNGXA03.phx.gbl
microsoft.public.windows.server.migration:22694
| NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| X-Tomcat-NG: microsoft.public.windows.server.migration
|
| Omar -
| It does matter when you change the registry. Our testing indicated that
the
| 3 "domain" fields get updated on logon, we were able to successfully
change
| the default domain on the migrating workstations (via a vb app and remote
| registry - long story) for win2k and winXP. we ended up changing BOTH
| "CachePrimaryDomain" and "DefaultDomainName" to make all workstations
happy.
|
| jmhop
|
|
| "omar@marathonsolutions.com" wrote:
|
| > If you write a script to utilize the ADMT command line migration for
| > computers maybe you can add some additional lines of code that change
| > that registry key based off of the value of the target domain- that
| > will be in the admt migration code anyway.
| >
| > The one thing that may need to be tested 1st is to see if the registry
| > key change needs to happen before ADMT reboots the computer or upon
| > start up of the workstation after the reboot.
| >
| > I am working on a similar migration with ADMT so I am interested to
| > hear how you either fixed this issue- or just lived with it.
| >
| > Omar
| > jmhop wrote:
| > > Jason -
| > > Thanks for the reply -
| > > we are changing the "DefaultDomainName" in Winlogon reg key - our
scprit
| > > runs prior to ADMT migrating the workstation. Windows 2000 correctly
shows
| > > the new domain, Windows XP does not. We are going to test the
| > > CachePrimaryDomain change this morning, i will let you know.
| > >
| > > Putting this in the logon script does not really help us, because the
users
| > > cannot log in locally (they only have domain accounts), and most do
not know
| > > which domain they even log into.
| > >
| > > Thanks,
| > > Jmhop
| > >
| > >
| > > "Jason Tan (MSFT)" wrote:
| > >
| > > > Hello,
| > > >
| > > > Thanks for posting!
| > > >
| > > > ADMT cannot change the default logon domain of the workstations. I
suggest
| > > > you wirte a script to change the default log on domain according to
the
| > > > following methods:
| > > >
| > > > To change the default Log on to: value edit the following local
registry
| > > > key of the
| > > > machine you are logging on to:
| > > >
| > > > HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows
NT\CurrentVersion\Winlogon
| > > >
| > > > CachePrimaryDomain
| > > >
| > > > You may write a domain logon script to achieve the goal.
| > > >
| > > > More information for your reference:
| > > >
| > > > 315245 How to Assign a Logon Script to a Profile for a Local User
| > > > <http://support.microsoft.com/default.aspx?scid=kb;EN-US;315245>
| > > >
| > > > Hope the information helps.
| > > >
| > > > Best Regards,
| > > >
| > > > Jason Tan
| > > >
| > > > Microsoft Online Partner Support
| > > > Get Secure! - www.microsoft.com/security
| > > >
| > > > =====================================================
| > > >
| > > > When responding to posts, please "Reply to Group" via your
newsreader so
| > > > that others may learn and benefit from your issue.
| > > >
| > > > =====================================================
| > > > This posting is provided "AS IS" with no warranties, and confers no
rights.
| > > >
| > > >
| > > >
| > > >
| > > > --------------------
| > > > | Thread-Topic: default domain display at logon
| > > > | thread-index: AcYtwiRkcNfKxj7KRYOrlMtGrx/14Q==
| > > > | X-WBNR-Posting-Host: 192.35.79.70
| > > > | From: "=?Utf-8?B?am1ob3A=?=" <jmhop@discussions.microsoft.com>
| > > > | Subject: default domain display at logon
| > > > | Date: Thu, 9 Feb 2006 13:45:28 -0800
| > > > | Lines: 4
| > > > | Message-ID: <47A6AC93-5F85-4F73-985C-5420596389F7@microsoft.com>
| > > > | MIME-Version: 1.0
| > > > | Content-Type: text/plain;
| > > > | charset="Utf-8"
| > > > | Content-Transfer-Encoding: 7bit
| > > > | X-Newsreader: Microsoft CDO for Windows 2000
| > > > | Content-Class: urn:content-classes:message
| > > > | Importance: normal
| > > > | Priority: normal
| > > > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| > > > | Newsgroups: microsoft.public.windows.server.migration
| > > > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| > > > | Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGXA03.phx.gbl
| > > > | Xref: TK2MSFTNGXA01.phx.gbl
| > > > microsoft.public.windows.server.migration:22411
| > > > | X-Tomcat-NG: microsoft.public.windows.server.migration
| > > > |
| > > > | ADMT appears to set the default domain of XP workstations to log
in to
| > > > the
| > > > | local machine. Is there a way to change this? What we would like
is for
| > > > the
| > > > | default domain to show the target domain name. It appears to
work on
| > > > windows
| > > > | 2000 boxes
| > > > |
| > > >
| > > >
| >
| >
|

Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows Server > Windows Server Help
Tags: ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "default domain display at logon"
Thread Thread Starter Forum Replies Last Post
Removing domain from logon box of Windows XP clients m3pilot Active Directory 4 01-06-2011 09:39 AM
Windows 7 Slow logon when logging onto domain Christofer Operating Systems 6 18-08-2010 09:46 AM
Slow logon on windows 2000 domain Nobleman Networking & Security 6 01-12-2008 08:01 PM
domain logon script does not run Onetoomany Windows Server Help 4 11-02-2008 05:37 AM
Obtaining Last Logon Time for Domain User Meng R Active Directory 1 01-09-2005 01:40 PM


All times are GMT +5.5. The time now is 02:15 AM.