Go Back   TechArena Community > Technical Support > Computer Help > Windows Server > Windows Server Help
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Remote Desktop Connection Disabled for all computers in WHS

Windows Server Help


Reply
 
Thread Tools Search this Thread
  #1  
Old 09-04-2012
Member
 
Join Date: Apr 2012
Posts: 23
Remote Desktop Connection Disabled for all computers in WHS

I am running Windows Home Server on my computer and I have been trying to get a proper connection over my remote PCs. Right now the Home server is running With Windows Home server 2011. I am switched to it very recently. Today I was checking the remote connections to my Remote PCs one after another. When I log on, I have noticed that all computers status showed up as Connection Disabled. I am quite sure that Remote Connection is activated. Double checked the Windows Firewall and everything is fine there. Can anyone tell me why Remote Computers all Have Connection Disabled?

Reply With Quote
  #2  
Old 09-04-2012
Member
 
Join Date: Mar 2011
Posts: 280
Re: Remote Desktop Connection Disabled for all computers in WHS

It is already known that Windows Home Server disables the connection from the web interface. So there is no way to get it back and you might be really out of luck now. But I have found a way to enable Remote Desktop Connection on Windows Vista computers and for that you will need following things:
  • Remote Desktop Connection or Advanced Admin Console
  • Registry Editor - Or "regedit.exe"
  • Terminal Services Hack - There are two versions: the Vista RTM version and the Vista SP1.
  • Notepad
First on the On the Client Computer extract all the files and run them as Admin. Open up firewall and make sure that port 3389 open. Otherwise it is not possible. Reboot the compute
On the Serveruse Remote Desktop Connection or Advanced Admin Console to run the registry editor. Find the following entry:
Code:
"HKEY_LOCAL_MACHINE\Software\Microsoft\Windows Home Server\Transport\Clients"
It should have a string called "MachineName"
Now open notepad, on server and add this line:
Code:
"HKEY_LOCAL_MACHINE\Software\Microsoft\Windows Home Server\Transport\Clients\{00000000-0000-0000-0000-000000000000}" /v "TerminalServicesSupport" /D "Yes" /f
Change the 0's to the correct string of letters and number as for your Vista computer.
If there are multiple computers make multiple lines indicating computer and save this file as "TermSrv.cmd" in "C:\".
Reply With Quote
  #3  
Old 09-04-2012
Member
 
Join Date: Mar 2011
Posts: 182
Re: Remote Desktop Connection Disabled for all computers in WHS

I also had the same kind of issue with 3 windows XP systems. But I have solved it by following this step:
  • First thing you have to ensure that your "Services" has starting "Remote Desktop" automatically.
  • The "remote Desktop" must "Enabled" through - "My computer"> "Properties" > "remote" tab.
  • Now go back to "My computer>"Properties> Computer Name tab. Go after the "Network ID" wizard and finally reboot the computer.
  • If you are using a Wireless router, you have to disable the DHCP and need to assign it a a static IP address outside the DHCP range of ADSL router.
Reply With Quote
  #4  
Old 09-04-2012
Member
 
Join Date: Mar 2011
Posts: 165
Re: Remote Desktop Connection Disabled for all computers in WHS

I know how to fix this problem.
  • Go to the windows Remote Settings on your comptuer
  • Under Remote Desktop , you have to change the setting to "Allow connections from computers running any version of Remote Desktop (less secure)" from already selected "Allow connections only from computers running Remote Desktop with Network Level Authentication (more secure)".
  • Click Apply and then select the Advanced tab.
  • In that you have to Uncheck the box that says "Create invitations that can only be used from computers running Windows Vista or later".
  • Here also donít forget to click on the ďApply" button.
  • Finally you have to reboot WHS and client PC for settings take affect and get the connection back. It took me several hours to find these settings in order to get the connection back. Everytime I am getting "connection disabled" message listed next to client PC's which are connected for WHS
Reply With Quote
  #5  
Old 09-04-2012
Member
 
Join Date: Mar 2011
Posts: 158
Re: Remote Desktop Connection Disabled for all computers in WHS

Are you using a Wifi router? If so, you must know that it has a built-in firewall. Disable it and then see if you can connect now. If the connection is authenticated now, then turn on the Firewall and add the rules to the firewall in order to allow the ports. I have also heard that some routers have a DMZ arrangement. I am currently using a NetGear and in my case I need to place the DMZ server to the same server IP address. I can use homeserver name to ping from any remote system.
Reply With Quote
  #6  
Old 09-04-2012
Member
 
Join Date: Mar 2011
Posts: 154
Re: Remote Desktop Connection Disabled for all computers in WHS

  • Open the Start menu of Windows Home Server and click on "Terminal Services Configuration" (Start -> Programs -> Administrative Tools).
  • A window opens with some content.
  • Click with the left mouse button on "RDP - tcp" and that opens the context menu on "Properties".
  • There click on "Start the following program when the user logs on," so that we can fill in the two lines below.
  • Under "Program path and file name" you wear% windir% \ explorer.exe. As a result, when an application is started via RDP always explorer.exe. "Start in" I "C: \" specify, but you can also specify any other directory.
  • With one click on "Apply" and "OK" to close the window. The underlying window may also be closed. We have already managed.
Reply With Quote
  #7  
Old 12-04-2012
Member
 
Join Date: Feb 2010
Posts: 428
Re: Remote Desktop Connection Disabled for all computers in WHS

In your Windows 7 system, you may have Network Level Authentication (NLA) enabled but the problem with this is Windows Home Server (the RD activex control) can't handle it. In order to disable the Network Level Authentication, you have to go through the following settings:
  • Go to Control Panel > System and Security > System
  • On the left side click on Remote settings
  • Under Remote Desktop, choose “Allow connections from computers running any version of Remote Desktop (less secure)"
  • Re-run C:\Program Files\Windows Home Server\ClientInfo.exe from command prompt (elevated).
Reply With Quote
  #8  
Old 13-04-2012
Member
 
Join Date: May 2009
Posts: 532
Re: Remote Desktop Connection Disabled for all computers in WHS

Did you try configuring Windows Home Server with a Static IP Address? The IP address is always unique assigned by router to every computer on the Home network. But it may be changed due to several reasons and it can cause problem to the network and also for connection. For that reason you have to configure the Windows Home Server always rely the same IP address. You can do it in two ways. The first method is setting up a reserved IP address in the DHCP section for your router. This means the router always provide or assign reserved IP address to the WHS. Setting up reserved IP address in the DHCP section in router is completely depends on the model of router. You need to refer manual for that. The second method is configure static IP address in the WHS itself.
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows Server > Windows Server Help
Tags: , , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Remote Desktop Connection Disabled for all computers in WHS"
Thread Thread Starter Forum Replies Last Post
How To: Remote Desktop Using Dynamic DNS, and Multiple Computers RedZot Guides & Tutorials 3 15-05-2010 02:44 PM
How to use Remote Desktop to access computers on home network? Shekhar12 Networking & Security 5 20-01-2010 09:22 PM
Remote Desktop does not work on Vista computers Terrextre Operating Systems 3 14-11-2008 12:35 PM
Remote Desktop Connection can recognize remote USB ports? Ihit Window 2000 Help 2 27-01-2008 05:15 AM
MAC and Remote Web Workplace and Remote Desktop Connection Tirana Small Business Server 2 03-01-2008 10:53 AM


All times are GMT +5.5. The time now is 12:39 AM.