Go Back   TechArena Community > Technical Support > Computer Help > Windows Server > Windows Server Help
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



DNS resolve problem with ping but not nslookup

Windows Server Help


Reply
 
Thread Tools Search this Thread
  #1  
Old 13-10-2008
Member
 
Join Date: Oct 2008
Location: FL
Posts: 2
DNS resolve problem with ping but not nslookup

After failing to update my windows XP to SP3, my PC was not able to resolve DNS with most softwares. The only one that seems to still work now is my Opera browser. Others, such as IE 6, firefox are not able to resolve the DNS.

I tried pinging google and it also fails.
C:\>ping www.google.com
Ping request could not find host www.google.com. Please check the name and try again.


But nslookup can still work
*** Can't find server name for address 192.168.0.1: Non-existent domain
*** Default servers are not available
Server: UnKnown
Address: 192.168.0.1

Non-authoritative answer:
Name: www.l.google.com
Addresses: 209.85.165.103, 209.85.165.104, 209.85.165.147, 209.85.165.99
Aliases: www.google.com


Here are the results of ipconfig /all:
Windows IP Configuration

Host Name . . . . . . . . . . . . : xxxxxx
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : hsd1.fl.comcast.net.

Ethernet adapter Local Area Connection 3:

Connection-specific DNS Suffix . : hsd1.fl.comcast.net.
Description . . . . . . . . . . . : VIA Rhine II Fast Ethernet Adapter
Physical Address. . . . . . . . . : XX-XX-XX-XX-XX-XX
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.0.10
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 192.168.0.1
Lease Obtained. . . . . . . . . . : Monday, October 13, 2008 6:39:05 AM
Lease Expires . . . . . . . . . . : Thursday, October 16, 2008 6:39:05 AM

Reply With Quote
  #2  
Old 13-10-2008
Paul Bergson [MVP-DS]
 
Posts: n/a
Re: DNS resolve problem with ping but not nslookup

Ping isn't going to work with many of the external host sites, so this is
normal. If you can do an nslookup on a site, then dns is resolving
correctly. It sounds more like the browsers you are attempting to use are
corrupted.
Reply With Quote
  #3  
Old 14-10-2008
Member
 
Join Date: Oct 2008
Location: FL
Posts: 2
From my prior experience, even if ping does not work on some external host sites, it would show another error message. The DNS would still be resolved, but the ping would time out. So I don't think that's the case. Secondly, there are other software other than the two browsers that are unable to resolve the DNS on my PC. So I don't think anything is corrupted with the browsers.
.
Reply With Quote
  #4  
Old 28-10-2008
Member
 
Join Date: Oct 2008
Posts: 1
Re: DNS resolve problem with ping but not nslookup

i'm haveing the somewhat the same problem. firefox and IE will not go out to web sites. email does not work either. but if i type googles ip in the address bar it will display the website. but if i type www.google.com it won't. very frustrating. i can ping intenal ips but no extenal DNS names. i can ping extenal IPs and i get resopnce back. any ideas?
Reply With Quote
  #5  
Old 01-11-2008
Member
 
Join Date: Nov 2008
Posts: 2
I've had the exact same issue on two computers and until I read this form it didn't occur to me it might have to do with SP3. I had just deployed SP2 & SP3 via group policy to over 40 PCs at my clients location while joining all of their computers to the new active directory network.

Basically, unless I use nslookup, DNS doesn't work. This includes Firefox, Internet Explorer, as well as internal active directory lookups to authenticate usernames and passwords against the domain. Noone could log on to the computer as a domain user - had to logon as local admin to work on it.

This means I could, say, "nslookup myserver.mydomain.local", get the IP, and then manually ping the IP and get a reply.
However, if I said "ping myserver.mydomain.local" it would say "Ping request could not find host myserver.mydomain.local. Please check the name and try again."

To me, basically this means nslookup can query because it simply opens a winsock connection on the DNS port and gets a query itself, whereas ping, IE, Firefox, and Windows itself for active directory domain authentication all cannot since they use the DNS Client service.

I had this same problem on now two computers. The first one, which I worked on earlier this week, I ended up formatting the computer to fix.
I tried specifying a static IP & DNS instead of using DHCP.
I tried uninstalling/reinstalling the network adapter.
I checked the Winsock using LSPFix to make sure there weren't any files missing or malware.
I checked hijackthis log for other malware - all clean.
I tried resetting all of the registry entries for the TCP/IP stack using "netsh int ip reset c:\resetlog.txt"

Now that I realized SP3 might be involved, I checked this second computer where the problem just surfaced - and sure enough - it still has SP2 listed in under System Properties, but SP3 is in the list of Add/Remove programs. I went ahead and uninstalled SP3 (which took like 5 seconds.. kind of wierd) and it had no affect on the problem. I'm going to try to reinstall SP3 and see if it corrects the problem.

Both machines were Acer, if that makes a difference. You never know.. it might be some of the crap software they preload on it.

SP3 Reinstallation fixed all of the DNS query issues.

It's worth noting that even though DNS didn't work, WINS and NetBIOS still did so I could still connect to our server via \\myservername (or by IP of course). (whereas \\myservername.mydomainname.local did not because that's a DNS entry)

I just connected to my server & ran the SP3 update again and it fixed all of the DNS resolution problems.
Reply With Quote
  #6  
Old 24-12-2008
Jonghyun
 
Posts: n/a
Re: DNS resolve problem with ping but not nslookup

How about stopping the DNS Client Service? I had exactly same problems and
did everything I can such as removing and reinstalling winsock , TCP/IP but
failed. And the last thing I do was to stop dns client service and it now
works fine. I don't know why. Is there someone who can explain it?
Reply With Quote
  #7  
Old 19-07-2009
tng tng is offline
Member
 
Join Date: Jul 2009
Posts: 1
Re: DNS resolve problem with ping but not nslookup

Something with AD configuration?

I got the same problem with my two new virtual redhat and suse. It was the directory LDAP client which was the problem. Now both servers are running correctly.

If using linux (redhat or suse):
look at nsswitch.conf & ldap.conf

1) put "bind_policy soft" in /etc/ldap.conf
2) nsswitch.conf must minimum have:

passwd: compat
group: compat
hosts: files dns
networks: files dns
services: files
protocols: files
rpc: files
ethers: files
netmasks: files
netgroup: files
publickey: files
bootparams: files
automount: files nis
aliases: files

3) reboot
4) check with: ping, nmap localhost.
5) now you can enable your ldap client again. (RH: authconfig ; suse: yast2 ldap). It will modify your nsswitch.conf

ref:
Reply With Quote
  #8  
Old 21-07-2009
Ace Fekay [MCT]
 
Posts: n/a
Re: DNS resolve problem with ping but not nslookup

I don't know what you're responding to, becaues we can only see your post in the Microsoft DNS newsgroup because the original or prior posts in this thread have expired in the newsgroups (they're older than 90 days), but based on the subject line, I can say that pings and nslookup problems are not related to AD, rather they are based on the client's network configuration and the client side resolver service.
Reply With Quote
  #9  
Old 07-01-2010
Member
 
Join Date: Jan 2010
Posts: 1
Re: DNS resolve problem with ping but not nslookup

What a lifesaver this thread was. After trying a thousand things that didn't work like registry edits, reinstalling TCP/IP and uninstalling/reinstalling Bonjour this did the trick. I uninstalled SP3 and reinstalled it and now the machine is fine again. I was preparing to reload the whole thing and what a pain that would have been.

Thanks a million, Tenroc2000!
Reply With Quote
  #10  
Old 12-08-2011
Member
 
Join Date: Aug 2011
Posts: 1
Re: DNS resolve problem with ping but not nslookup

I have exactly the same issue. I pretty much tried everything that I can find, but nothing was working. Thanks to "tenroc2o0o's post", once I uninstalled SP3. The problem is gone.
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows Server > Windows Server Help
Tags: , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "DNS resolve problem with ping but not nslookup"
Thread Thread Starter Forum Replies Last Post
NSLookup can resolve domain names, Ping can not resolve. Can ping IP finnce Networking & Security 3 05-02-2009 02:27 PM
Can nslookup dns but cannot ping name Colarado Networking & Security 3 30-09-2008 02:32 PM
DNS Issues affecting Ping/Nslookup Joel Windows Server Help 3 25-09-2008 12:27 AM
Ping does not resolve, nslookup does, DNS queries end up externall Mike. Windows Server Help 4 08-06-2008 07:39 AM
Ping fails to resolve name but nslookup OK AXJ Windows Server Help 5 18-04-2008 11:08 AM


All times are GMT +5.5. The time now is 03:55 AM.