Results 1 to 5 of 5

Thread: Can't start IPSec Services

  1. #1
    Join Date
    Aug 2005
    Posts
    257

    Can't start IPSec Services

    I am trying to set up a L2TP VPN on my Windows XP operating system with Service Pack 2 when I found out that the IPSec Services cannot be started? I have already tried to fo the following - sc query policyagent and it always shows me that the service has stopped? When using net start policyagent then it will give "error 10045 and the attempted operation is not supported for the type of object referenced" but sometimes it will say that the service has started successfully. Can anyone tell me how to start the IPSec Services so that the problem gets resolved.

  2. #2
    Join Date
    Dec 2005
    Posts
    945

    Re: Can't start IPSec Services

    Actually, the IPSec Services depends on the below:
    IPSEC driver
    Remote Procedure Call (RPC)
    TCP/IP Protocol Driver

    I think that the RPC will be alright and then IPSEC driver is IPSec.sys. The TCP/IP Protocol Driver is Tcpip.sys and to check if both of these are alright then open the device manager by clicking on Start and then Run and then type devmgmt.msc and click OK. After that click on view and then on Show Hidden Devices and then click the plus sign which will be next to Non-Plug and Play Drivers. Now you have to double click on the IPSEC driver and also double click on the TCP/IP Protocol Driver and check for some troubleshooting by following the below links:

    IPsec troubleshooting in Microsoft Windows 2000 Server
    http://support.microsoft.com/kb/257225

    Basic L2TP/IPSec troubleshooting in Windows 2000
    http://support.microsoft.com/kb/259335

    Basic L2TP/IPSec Troubleshooting in Windows XP
    http://support.microsoft.com/kb/314831

  3. #3
    Join Date
    Jan 2006
    Posts
    7,109

    Re: Can't start IPSec Services

    You will also need to make sure that there is no other IPSec software like for example Safenet is running on your pc, if it is, then it will conflict with the IPSec Services.

  4. #4
    Join Date
    Nov 2005
    Posts
    91

    RE: Can't start IPSec Services

    Even I am facing similar problem and I have tried to follow the solution given above but nothing is working. I have also checked that there is no other IPSec software running on my computer. When I checked in the microsoft knowledge base then I couldnt even find any information on same either. Can anyone please tell me how to get this IPSec service to start? And where can I find some information about the kind of error that I am getting? Thanks

  5. #5
    Join Date
    Jan 2006
    Posts
    3,792
    You can try to reset Internet Protocol (TCP/IP) and see if that helps. The reset command is available in the IP context of the NetShell utility. Follow these steps to use the reset command to reset TCP/IP manually:
    1. To open a command prompt, click Start and then click Run. Copy and paste (or type) the following command in the Open box and then press ENTER:
      cmd
    2. At the command prompt, copy and paste (or type) the following command and then press ENTER:
      netsh int ip reset c:\resetlog.txt
    3. Note If you do not want to specify a directory path for the log file, use the following command:
      netsh int ip reset resetlog.txt
    4. Reboot the computer.

    More information can be found here - http://support.microsoft.com/kb/299357

Similar Threads

  1. Windows services will not start
    By DataDude in forum Windows Software
    Replies: 4
    Last Post: 31-10-2009, 08:56 AM
  2. Cryptographic Services won't start
    By The Remover in forum Windows Security
    Replies: 5
    Last Post: 25-11-2008, 09:06 PM
  3. Some services do not start anymore
    By Vava in forum Vista Help
    Replies: 8
    Last Post: 29-04-2008, 07:49 AM
  4. IPSEC service will not start
    By ERWAN in forum Windows XP Support
    Replies: 1
    Last Post: 05-04-2008, 02:39 PM
  5. Exchange Services Won't Start
    By Siimile in forum Small Business Server
    Replies: 3
    Last Post: 15-08-2007, 04:12 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,675,754,977.12119 seconds with 16 queries