Results 1 to 8 of 8

Thread: HD audio bus drivers - freshly loaded IBM t60/t42 or other

  1. #1
    Join Date
    Oct 2005
    Posts
    61

    HD audio bus drivers - freshly loaded IBM t60/t42 or other

    I am having two IBM laptops. The first one is Lenovo T42 & the second one is Lenovo T60. I had formatted both the system and installed fresh drivers from the official website. I got a message on the screen saying The HDA Audio bus driver is required and not found. I am getting this common error on both. This simply means the audio is not working. I tried to run Windows Update but there was some issue with that also. How can I make this work. Thanks.

  2. #2
    Join Date
    May 2006
    Posts
    2
    Hi, the same problem comes to me and it is not done till now. I am searching the 888111US.exe for months. I am an orthopedic surgeon in China. My IBM/Lenov Thinkpad Z60t was preloaded with Microsoft Windows SP2 in Chinese version. Now, I load my thinkpad with Microsft Windows SP2 in English version, and the 888111SC.exe in Chinese Version does not work, and I can not find a thinkpad preloaded with English version Windows. I hope you can do me a favor by emailing me the 888111US.exe to finish my HD audio bus driver setup. My email is mazhensheng@hotmail.com

  3. #3
    Join Date
    Dec 2006
    Posts
    2
    Hi All, im new here. After much pain and heart ache, I was found the HDA file and needed to post it. After installation, I was able to install the SoundMax audio driver and modem on my IBM T60.

    If anyone is still requiring the 888111us.exe HDA Audio Bus Driver, use the link below to download.

    All I ask is that you share it with everyone and anyone who needs it.

    Hope this helps!

  4. #4
    Join Date
    Apr 2009
    Posts
    1
    Try searching the lenovo website for the OS hotfix (osfx31us.exe)

    Thank you so much for posting this file here. After 3 years, it's still helping people like me to resolve this same problem.
    You saved me a lots of time, Thanks again!

  5. #5
    Join Date
    Apr 2009
    Posts
    1
    im receving the error message while installing audio driver in my IMB T60 that is "The HDA Audio bus driver is required and not found".

    I saw your posts but i could not find the like to file (888111us.exe) in this forum to download and plz tel wht to do with this.

  6. #6
    Join Date
    Oct 2009
    Posts
    1
    im receving the error message while installing audio driver in my IBm T60 that is "The HDA Audio bus driver is required and not found" and also have errors in device manager for BCM2045B,NETWORK CONTROL,PCI DEVICE,SM BUS CONTROLLER.

    Kindly send what to do for the errors in these files to go.

    Thank you for your piece of advice. I did try to install the modem by running"c:\drivers\HDAMODEM\Setup.exe" but it gave error "could not find device for this driver". Pls advice on what I can do next? johnson(todemltd@gmail.com)

  7. #7
    Join Date
    Oct 2009
    Posts
    2

    Re: HD audio bus drivers - freshly loaded IBM t60/t42 or other

    i had the same problem, you can't install your audio driver first, the hd audio is connected with you modem for some reason so you have to install your modem first. i had the same problem with my t60.

  8. #8
    Join Date
    Oct 2009
    Posts
    2

    Re: HD audio bus drivers - freshly loaded IBM t60/t42 or other

    did you try to install your modem manually?

    by right clicking my computer, properties, hardware tab, device manager, click on the yellow question mark, update driver. select choose from a specific location, and browse, c:\drivers\HDAMODEM

    exactly how many errors do you have on your computer or how many drivers do you have that is not yet installed?

Similar Threads

  1. Replies: 1
    Last Post: 05-10-2011, 05:41 PM
  2. Xtremegamer Fatal1ty Pro freezes When Drivers Are Loaded
    By Raja Ram in forum Hardware Peripherals
    Replies: 5
    Last Post: 24-04-2011, 10:19 AM
  3. Freshly mounted PC that does not start
    By Sean J in forum Hardware Peripherals
    Replies: 6
    Last Post: 27-02-2009, 08:44 PM
  4. Realtek Audio Drivers
    By sk2121 in forum Motherboard Processor & RAM
    Replies: 6
    Last Post: 27-01-2009, 05:55 PM
  5. Audio drivers for Intel Sigmatel onboard audio
    By Loeb in forum Vista Hardware Devices
    Replies: 3
    Last Post: 25-07-2007, 04:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •