Go Back   TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Help
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Can't get administrator privileges

Vista Help


Reply
 
Thread Tools Search this Thread
  #1  
Old 18-06-2008
Baxterl
 
Posts: n/a
Can't get administrator privileges

Vista, SP1.

I'm using a license install tool. I jump thru the hoops and get a final
message,
"Failed to install license server. You need to be an Administrator to
perform this function."

I'm logged in as Administrator, I've set the permissions for the pertinent
folders to wide open, I've tweaked the Registry so I theoretically power up
as Administrator (http://www.interopsystems.com/commun....aspx?m=10345).

Gosh, it would be nice if Windows provided single-user security-averse users
with a single button: "Turn off all security, password, and permission stuff."

....Larry

Reply With Quote
  #2  
Old 18-06-2008
Michael Walraven
 
Posts: n/a
Re: Can't get administrator privileges

Possibly right click the tool, select 'run as administrator'
Reply With Quote
  #3  
Old 19-06-2008
Surtoff
 
Posts: n/a
Re: Can't get administrator privileges

I am glad I'm not alone with this problem! I am trying to install a printer
software program I installed in my previous PC (Windows XP) to my new PC
(Vista) but I keep getting this message: "This software cannot be installed
using the 'Run as...' command. The installation cannot continue until this is
resolved." I am also logged in as an administrator. I tried Michael's
suggestion: 'run as administrator' by openning the file and right-clicking
the option, but even so, it doesn't work!
Any other suggestions???
Reply With Quote
  #4  
Old 19-06-2008
Michael Walraven
 
Posts: n/a
Re: Can't get administrator privileges

It is quite possible that the program is simply not compatible with Vista.
Programs that install hardware drivers such as for printers may not work
because the underlying driver structure for Vista is different from XP. I
have a printer program called ClickBook that lets me do booklets for
instance that simply will not work in Vista. You may have to wait till a
Vista version for the program comes out. That said there is one more thing
you can try, that is to run the program in an emulator mode.

Right click on the program, select properties, then select the compatibility
tab, select a compatibility mode option (XP SP2).

If it is a hardware driver issue this will probably still not work but worth
a try.
Reply With Quote
  #5  
Old 19-06-2008
Luc
 
Posts: n/a
Re: Can't get administrator privileges

This could be the setup program trying to be more intelligent than is good
for it.

Not good for security, but it will probably work:
1) turn off UAC
2) install software
3) turn UAC back on.
Reply With Quote
  #6  
Old 01-02-2010
Member
 
Join Date: Jan 2010
Posts: 3
Re: Can't get administrator privileges

Hey, I'm not alone! (not that that's a good thing) I am having a problem with Administrator rights as well and have not been able to use my printer for months because the person who hijacked my computer uninstalled it and took away my right to install it.

I have tried the right click and "run as Administrator" too, and have no luck...

I have had problems with someone taking my Administrator rights and doing the uninstalling hardware and other nasty things for a long time and I haven't been able to find anyone who knew what to do.

I think I may have found a clue but I'm not sure - I noticed that there's always an entry of an Administrator who logged off on January 20th, 2008 and the computer number is 26l2233b1-13.

I'm wondering if this is related to why someone is always able to take our Administrator rights and override every configuration I make. If anyone could give me some insight on what this is, I would really appreciate it.

Thanks
Reply With Quote
  #7  
Old 13-02-2010
Member
 
Join Date: Jan 2010
Posts: 3
Re: Can't get administrator privileges

Hi,

I'm wondering if this thread is closed or just really quiet. I'm still having the same problem. I've been noticing though, that many people have this same computer number 26L2233B1-13 with the same details as mine and one even mentioned the same date I have on mine, so does anyone know how that might happen, besides the possiblity of some kind of widespread scam?

Or perhaps we are totally stumped and given up? I'm stumped! But I'm not giving up. I'll let you know what I find out -if I can. I'd apprecciate it very much if anyone reading this can save me the trouble. I'm not very advanced so it will take me longer to figure out than someone who is...

Thanx so much
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Help
Tags: , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Can't get administrator privileges"
Thread Thread Starter Forum Replies Last Post
privileges required for Administrator in ubuntu. Rege's Operating Systems 6 10-01-2012 08:18 AM
Trojan took over administrator privileges Choo-Kheng Networking & Security 4 29-05-2011 06:52 PM
Insufficient Privileges as an Administrator in Windows 7 Wamika Operating Systems 4 30-12-2010 10:41 PM
Lost administrator privileges to C Drive duckyma Operating Systems 3 21-12-2010 03:40 PM
I Do not Have Administrative Privileges in an Administrator Account Cic!cone Windows Security 2 21-09-2008 03:24 AM


All times are GMT +5.5. The time now is 09:49 AM.