Go Back   TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Help
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



How to disable Open File - Security Warning dialog box in Windows Vista?

Vista Help


Reply
 
Thread Tools Search this Thread
  #1  
Old 25-05-2008
Member
 
Join Date: Sep 2004
Posts: 136
How to disable Open File - Security Warning dialog box in Windows Vista?

On opening a website url on Deskbar configured in Windows Vista, I am getting a warning message. The message says that do you want open the file. It appears even if I open my email url. It is very annoying and I am looking to find a way to stop this completely. I am using Windows Vista, with Avast installed in the same. Does it is causing the issue. I had scanned the system and do not found any infection. The url belongs to an office site url. I had spoken to my office IT guy he said it is a safe site. So why does it is giving as a security threat on my system. How can I stop that.

Reply With Quote
  #2  
Old 25-05-2008
Member
 
Join Date: Sep 2004
Posts: 150
Re: How to disable Open File - Security Warning dialog box in Windows Vista?

It happens when your browser is not able to identify the website certificate. It count in under threat. Try to change the default web browser of your system which will make it work. The url act as a trigger to launch the website. The warning message that you receive on your desktop is related to the antivirus of is it a Vista warning. Avast might be having a section where you can unlock the url. Every antivirus offers you a exception list where you can add some specific software or file to avoid blockage. Check in the help file of Avast.
Reply With Quote
  #3  
Old 25-05-2008
Member
 
Join Date: Sep 2004
Posts: 82
That would does not work well. It looks that the warning appears because of UAC. You have to disable UAC to stop that. This is one of the useless feature I had seen in Vista. You can find UAC in control Panel. Just type that in Search Box and hit Enter. Disable UAC and then restart your PC. Now again try to open the URL. I hope the site is trusted. I use a BookManager widget on my desktop. There are number of url linked on it. It works fine in Firefox. If you have a Antivirus then it is not at all necessary to run UAC. It will work on minimal settings also.
Reply With Quote
  #4  
Old 02-10-2008
Member
 
Join Date: Oct 2008
Posts: 1
I had created a similar thread in other forums also. I want to know the reason behind the same. At some point I am not getting the right answer why this annoying thing appear again and again. I am having a dual boot system. At one side I am using old Windows XP and on the second partition installed Windows Vista. The issue is both operating system. When I open a URL there is a security warning no the screen. I had disabled UAC. In Vista I a not getting the security prompt, but what to do in Windows XP. After searching a bit while on Microsoft Forums, I found settings that can help to get rid of this issue. You have to put Internet Explorer security on minimum.
Reply With Quote
  #5  
Old 02-10-2008
Member
 
Join Date: Sep 2004
Posts: 128
I am sure that is due to IE security settings. By default this browser open up your webpages. Just to check you can completely disable the security settings and then try back. Launch Internet Explorer first and then click on Tools. In that look for Internet Options and click on Security. Now go Custom and make changes as per your need. Enable Display Mixed content located under Miscellaneous. You can put the settings to minimum so that they are not being blocked at launch.
Reply With Quote
  #6  
Old 03-10-2008
Member
 
Join Date: Sep 2004
Posts: 119
Re: How to disable Open File - Security Warning dialog box in Windows Vista?

Reducing the browser security puts your system on more risk. It is just a popup. When it appears click on No and it goes. It is actually good for your system. I do not understand what annoying stuff you find in that. Instead of disabling the security settings, better add the url to Trusted Site in Internet Explorer. To add them on in Internet Options and then click on Security. Now click on Trusted sites and then add the full url of domains that you want here. Now go to Custom Level in Security tab and enable Display Mixed content as mention above. This had worked for me to enable some basic office sites.
Reply With Quote
  #7  
Old 23-10-2008
Member
 
Join Date: Oct 2008
Posts: 1
Like a gun? Really? Nice analogy. Too bad it's valid only if you happen to be a complete retard who doesn't know the difference between a perfectly safe file you've downloaded and one that will wreck your computer. "Welcome to Microsoft, our OS is so prone to getting infested with viruses that you need to double- and triple-check every single thing you do to avoid being completely and totally fukked". Thank you MS, I feel safer already. Comparing Vista to continuously having to fight the urge to pull the trigger and end your own life would be more apt. Let me ask you something.. Did you ever download a file, chose to run it, then have that fukking pop-up make you rethink your action, resulting in you cancelling it? If you did, you're a moron, and if you didn't, then crawl back into that nerd-hole you came out of and leave normal people alone when they want an answer to something you obviously don't want to help them with. Noone asked your opinion on what people should or should not find annoying with completely useless Microsoft "features", no matter what the imaginary voices in your head tell you "everybody else" thinks.

And yeah, I created an account too just to say that, because I can't fukking stand idiots like you. For future reference, if you ever find yourself allowed into another forum, answer the question that is being asked or shut the fukk up. Noone cares about any of your personal preferences and subjective opinions on any unrelated matters.

(- AMBUUUSH! GET DOWN, MEN, FIRE AT WIIIILLLLL!!!
- Hello! You have selected the action 'pull trigger'! Pulling the trigger will release a bullet at high velocity aimed at the terrorist you are pointing your rifle at. If you are not sure whether the person is really a terrorist, you might want to reconsider your action. Innocent civilians will sometimes dress up as malicious terrorists. Killing such civilians might result in unwanted legal consequences. Are you still sure you want to pull the trigger? If yes, would you like to be warned of this exact same thing the next time you aim your gun at this specific individual or only every time you point at gun at anyone else?)
Reply With Quote
  #8  
Old 11-07-2009
Member
 
Join Date: Jul 2009
Posts: 1
Re: How to disable Open File - Security Warning dialog box in Windows Vista?

My God.. what a useless windbag you are. He is asking you how to turn it OFF. If you don't know, how about you shut your mouth? To think of all the people who will be bumping into this thread for all the years to come only to read your pointless drivel.

He did NOT WANT YOU TO "ARGUE" WITH HIM OVER WHETHER OR NOT THE "MINOR ANNOYANCE" WAS WORTH DISABLING, YOU ****ING MORON. What is wrong with people like you? Would you like to go around wagging the finger at any Windows user who wants to customize his computer the way he feels like?

Then the ending of your comment: "Sorry I'm not being helpful, but I hope in some small way this does indeed help - though not the way you might have expected."

"Not the way he might have expected?" In other words, your assumption is that you are somehow doing him some king of "favour," if only he would be smart enough to catch it, eh?
Reply With Quote
  #9  
Old 11-09-2009
Member
 
Join Date: Sep 2009
Posts: 1
Re: How to disable Open File - Security Warning dialog box in Windows Vista?

Start Menu > Run > gpedit.msc > User Configuration > Administrative Templates > Windows Components > Attachment Manager >
In the right pane, double click on 'Inclusion list for moderate risk file types' > Enabled > Under 'Inclusion list for moderate risk file types' > *.* > OK
Do the same for 'Inclusion list for low risk file types'

Try this Sub the *.* with .url

I think........... Do you know which risk class the file type is? that would be where you place it I think

I had the same problem but with media files such as .jpg, .wmv, .tiff etc.

I placed them in the moderate one and restarted the computer now when I double click on the file type I no longer get the open file security warning.

also look at the other groupings in the attachment manager click on them once will give you a description of what they do.
Reply With Quote
  #10  
Old 30-11-2009
Member
 
Join Date: Nov 2009
Posts: 1
Re: How to disable Open File - Security Warning dialog box in Windows Vista?

This article may help someone...

=== text from the website ===

To reset or change back the open or save behavior when downloading a file with IE 7 in Vista, simply run Registry Editor (type regedit in Start Search), and then navigate to the following registry key.

HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\AttachmentExecute\{0002DF01-0000-0000-C000-000000000046}

Note: {0002DF01-0000-0000-C000-000000000046} is the Class ID for the InternetExplorer.Application object.

Inside this registry key, there will be a list of value data corresponding to all the file types that you have unticked the “Always ask before opening this type of file” option check box against.

Reset Registry

Simply delete any unwanted registry values for the file type or extension that you want to reset or return the filetype to their default download behaviour.

For Windows XP, 2003, 2000 and older, there is simpler method to reset the Always Ask setting.
Reply With Quote
  #11  
Old 03-12-2009
Member
 
Join Date: Nov 2009
Location: Tennessee
Posts: 14
Re: How to disable Open File - Security Warning dialog box in Windows Vista?

If you click the "button" on the bottom left corner, then type in "auc" or "uac" it should give you some options to open up and from there, you can turn that annoyance off. Another way is by going to control panel, user accounts, and look for the option there as well. Hope this helps

Last edited by JonBoyFishhead : 03-12-2009 at 01:24 AM.
Reply With Quote
  #12  
Old 03-03-2010
Member
 
Join Date: Mar 2010
Posts: 1
Re: How to disable Open File - Security Warning dialog box in Windows Vista?

The best way I found to delete a file, or many, is to highlight the file, or files, hold down the shift key, then hit delete. That moves it beyond the trash can, and into oblivion. As to the Open File Security Warning, why should I be bothered to click on something that I believe should not be there unless it is something my anti-virus says so? It's fine for the idiots who don't know one thing about a computer, but for those of us who are more than average users, it's a pain in the posterior to jump through hoops to do these things here.
Reply With Quote
  #13  
Old 06-09-2010
Member
 
Join Date: Oct 2009
Posts: 5
Re: How to disable Open File - Security Warning dialog box in Windows Vista?

Thank you profess135 for the suggestion above but alas
HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell \AttachmentExecute
Does not exist on my system (Win 7 64 Ja)

I tried the script introduced at
webtlk.com/2010/04/12/how-to-turn-off-and-disable-do-you-want-to-run-this-file-warning-in-windows-7-and-vista/
and
windows7themes.net/disable-do-you-want-to-run-this-file-message.html

in a modified form so that multimedia files are allowed:

Quote:
[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Download]
"CheckExeSignatures"="no"
"RunInvalidSignatures"=dword:00000001
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Attachments]
"SaveZoneInformation"=dword:00000001
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
"LowRiskFileTypes"=".gif;.bmp;.jpg;.avi;.mpg;.mpeg;.mov;.mp3;.wav;"
When I run it I am asked if I really want to open the file, don't if it is not from a trusted source, and I say yes, then it says that "this is not a registry script file, the only files that can be imported to the registry editor are binary registry script" files. What is a *binary* registry script file?

I could just apply the changes manually. This is really irrational of me but I baulked at changing "CheckExeSignatures" to "no" (thought I was prepared to attempt to run the script!).

What is wrong with the above script?

Is there no way of getting rid of this annoyance using the Windows GUI?

Some filetypes (.jpg, .bmp, .gif at least) are afaik, safe, so I am not sure why there needs to be a warning for all file types.
Reply With Quote
  #14  
Old 20-12-2011
Member
 
Join Date: Dec 2011
Posts: 1
Re: How to disable Open File - Security Warning dialog box in Windows Vista?

I needed info on how to disable these annoying messages, and followed the first link Google came up with. Thank you to those who actually provided an answer!
As for FromTheRafters: it is almost 2012, and you still come over as a douchebag...
Reply With Quote
  #15  
Old 21-12-2011
Member
 
Join Date: Jun 2011
Posts: 482
Re: How to disable Open File - Security Warning dialog box in Windows Vista?

Are there any recent changes on the computer?
Have you ever tried to boot the computer into Safe mode. If not than try to do the same.
Another thing you can try is run a virus scan on the computer by using Malwarebytes and see whether you are able to fix the issue.
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Help
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "How to disable Open File - Security Warning dialog box in Windows Vista?"
Thread Thread Starter Forum Replies Last Post
How to bypass the open file security warning in vb script Quasim Software Development 5 05-07-2011 08:27 PM
Windows XP open file Security Warning Problem Guns-n-Roses Operating Systems 3 01-07-2009 11:26 AM
File Open Dialog box in Vista Pete Gomersall Windows Server Help 5 08-05-2009 09:21 AM
Stop Open File Security Warning on Windows XP rasena Windows Security 2 13-04-2009 12:33 PM
Getting Open file Security Warning ..The publisher could not be verified... karson Windows Server Help 2 22-12-2005 10:11 AM


All times are GMT +5.5. The time now is 07:48 AM.