Results 1 to 8 of 8

Thread: Add Printer Not Working - Vista Home Premium

  1. #1
    Rick_Hugh Guest

    Add Printer Not Working - Vista Home Premium

    I have an Epson Stylus c84 Inkjet that, according to the Epson support page,
    should already have drivers in Vista (I should just be able to plug in the
    printer, Vista will see it and load the appropriate driver, etc). However,
    Vista cannot find the correct driver and asks for the original driver CD, to
    which I try anyway and it still does not work.
    I contacted Epson who suggested I try and use the Add Printer feature.
    However, upon trying this, an error came up as soon as I pressed the icon:
    "Windows Cannot Open Add Printer. Operation could not be completed (error
    I did not receive the original install disc from eMachines, and they have
    been aggravating when attempting to get service from them. Any ideas? Thanks

  2. #2
    Bob Guest
    Uninstall the printer.
    Go to the eMachines or the Epson website. Download and install the latest
    Reinstall the printer.

    In between sighs...Uninstall the printer. Go to the eMachines or the Epson
    website. Download and install the latest driver. Reinstall the printer
    whether or not you find a newer driver.

    Which firewall, anti-virus or security suite is installed?

  3. #3
    Rick_Hugh Guest
    *Sigh* Ok....let me try this again:

    The driver for the printer is not the issue. Again, according to,
    a compatible printer driver for my C84 should already be on Vista.

    The issue is: When I try to use the Add Printer option, I receive an error
    that says "Windows Cannot Open Add Printer. Operation could not be completed
    (error 0x000000c1)." Why is it doing this, and what can I do to correct it?, not to sound sarcastic (because this question is going to come off
    as sounding that way), but how do I uninstall a printer that I haven't
    installed? Vista does not see it, the original driver disc doesn't work (when
    it's attempting to install the drivers, the install program just sits there),
    and the current drivers I found for my printer at Epson were for XP.

    If you're referring to the driver that Vista has for it, I don't know which
    driver Vista would use to install my printer.

    And again, why is my Add Printer command not working?

    Do you see the printer in Device Manager?

  4. #4
    Alan Morris [MSFT] Guest
    the error the UI component is reporting is bad exe format. This will also
    apply to dlls. Is sounds like x86 binaries are loading on x64 or x64
    binaries are loading on x86.

    E:\>winerror 0x000000c1

    how would I got about attempting to correct this?

    Unsure. I ran into a different issue but got this error. It turns out
    there was a x64 print driver living in the x86 driver location so when a new
    x86 client connected it failed with the 0x000000c1 error.

    Is this 64bit or 32bit?

    I assume you hit this error almost immediately

    the explorer process will load printui.dll which drives Add Printer

    You can launch Add Printer without explorer by opening a command prompt and

    rundll32 printui.dll,PrintUIEntry /il

    or for Network Add Printer
    rundll32 printui.dll,PrintUIEntry /ip

    Here is the list of files loaded and referenced by other files when starting
    Add Printer using rundll32. Any one could be the issue but I sorted the
    spooler components and placed them at the top of the list.

    ModLoad: 71670000 716b2000 C:\Windows\system32\WINSPOOL.DRV

    other stuff
    ModLoad: 004b0000 004be000 rundll32.exe
    ModLoad: 76f40000 77067000 ntdll.dll
    ModLoad: 76cb0000 76d8b000 C:\Windows\system32\kernel32.dll

  5. #5
    Dante Guest
    I spent the last few weeks with the same problem with my RX620... a driver
    that was supposed to be built into Vista, isn't the directions on the Epson
    web site are horrid. In the end I installed Windows XP/2000 drivers and it
    works fine... No help from Epson or Microsoft. who continue to say... plug
    it in and Windows will find the right driver... however it never does.

    I did try the Windows Xp/2000 drivers, but again to no avail. It appeared
    that it was trying to install the printer, but still couldn't identify it.

  6. #6
    Alan Morris [MSFT] Guest
    the remote user needs write access to the registry, the /ga machine
    connections are stored at this registry location.


    those are print driver names they do not contain printer data.

  7. #7
    Join Date
    Dec 2009
    I've tried this command from both Win7 32bit and XP computers and results are:

    rundll32 printui.dll,PrintUIEntry /c\\computer /ga /n\\server\printer01

    Win7 = locally add/remove printer OK
    Win7 = remotely doesn't work

    XP = doesn't work at all

    Can you help me please?

    I even tryed with vbs script but locally works, remotely with PSEXEC neither on XP or Win7.

    For remote user what do you mean?
    I'm running psexec with domain admin user. Is also local admin on remote machine.

    sorry but on XP machine and Win7 under that reg key there are no connections.
    XP has Connection Key but is empty.
    Win7 has no Connections key.

    Instead they have both:

    and under this key there are all the OS versions and under each one there are keys names version 2 and version 3 with the drivers underneath

  8. #8
    Alan Morris [MSFT] Guest

    Re: Add Printer Not Working - Vista Home Premium

    I do not know what psexec is.

    local admin on the remote machine was my context.

Similar Threads

  1. Vista home premium not working
    By myenglish in forum Operating Systems
    Replies: 2
    Last Post: 10-11-2011, 08:38 AM
  2. Quickcam not working on Vista Home Premium
    By Abenaki in forum Hardware Peripherals
    Replies: 6
    Last Post: 13-06-2010, 06:08 AM
  3. HP LightScribe writer not working in Vista Home Premium
    By LAMONT D in forum Vista Hardware Devices
    Replies: 3
    Last Post: 05-06-2008, 04:52 PM
  4. Replies: 3
    Last Post: 14-05-2007, 12:19 AM
  5. Upgrading Windows Vista Home Basic to Vista Home Premium
    By Sarantsatsr in forum Vista Setup and Install
    Replies: 2
    Last Post: 02-03-2007, 05:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts