Go Back   TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Help
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Cannot delete file

Vista Help


Reply
 
Thread Tools Search this Thread
  #1  
Old 24-03-2008
minnow52
 
Posts: n/a
Cannot delete file

When trying to delete a file from a folder, it says "The action can't be
completed because the file is open in another program. How do I find out what
program is running that file?

Reply With Quote
  #2  
Old 24-03-2008
Malke
 
Posts: n/a
Re: Cannot delete file

It depends on what kind of file it is. Since you didn't tell us, how can
anyone guess?

As a general troubleshooting step, you can try deleting the Mystery File in
Safe Mode.

To get into Safe Mode, restart the computer and repeatedly tap the F8 key as
the computer is starting up. This will bring you to the correct menu. Use
your arrow key and the Enter key to select Safe Mode.
Reply With Quote
  #3  
Old 24-03-2008
Bob
 
Posts: n/a
To delete the file close all open programs.
Open an admin command prompt.
Type attrib -r -a -s -h del [drive] path] [filename]
(e.g. "C:\Users\minnow52\Documents\minnow52.doc")
Press Enter.

Sorry about that. New to this. (As you can tell.)
It is an AVI movie video that is in my My Documents/Movies Folder
Reply With Quote
  #4  
Old 25-03-2008
Malke
 
Posts: n/a
First of all, I assume you really mean the file lives in
%systemdrive%\Users\your-user-account\Movies because there is no "My
Documents" in Vista. The whole Documents and Settings [My-foldername]
hierarchy doesn't exist in Vista. The Documents and Settings and subfolders
you see are virtual, junctions there only for backwards compatibility with
older software that expects those locations to exist.

You can try Bob's method or go into Safe Mode.

I will try it but how do I open an admin command prompt?
Reply With Quote
  #5  
Old 25-03-2008
Bob
 
Posts: n/a
Start>Programs>Accessories>Right click Command Prompt>Run as Administrator.

Was able to delete the 2 movie files
following your instructions just like you said. Once again thanks for your
help and I'm making sure that I put this forum into my FAVORITES.
Reply With Quote
  #6  
Old 23-04-2008
gordievsky
 
Posts: n/a
Very Useful thread. Unfortunately after trying your advise, I still
cannot delete a file with a .uif extension. I keep getting an error
message which states "the action can't be completed because the file is
open in another program."

I am pretty sure it is not open in any other programs. I tried
deleting in safe mode with no luck. I tried using a program named
"moveonboot" with no luck.

And I tried using your command prompt suggestion with no luck-- I
received an error which stated "parameter format not correct."

Any other suggestions? Did I type something incorrect into the prompt?

Have you tried a program named Unlocker
Reply With Quote
  #7  
Old 27-11-2008
Member
 
Join Date: Nov 2008
Posts: 1
Re: Cannot delete file

SITUATION: you may scroll down to the SOLUTION, but the situation will allow you to confirm the symptoms of the problem you're facing
For those who, the above given method didn't work...(yes, it didnt work for me either...)

HERE'S WHAT I DID...

I had installed MagicISO software on 20th Nov. and every single day after that I tried everything to get rid of the software itself and the .uif file.

Uninstalling The software was a no-brainer...I just used the 'Programs and Features' in Control Panel.

However, I still couldn't delete the file...

I also tried to uninstall the driver of the ROM in 'MY COMPUTER' (When we install magic disc, it creates a new ROM Device complete with a Volume Label, in my case F:)

But everytime I restarted the system the driver automatically installed and I still couldn't delete the file even after uninstalling the driver...

SOLUTION:
I tried using a feature provided by Microsoft, which until now I thought was pretty useless.

MAKE WAY FOR : "SYSTEM RESTORE"

I tried using System Restore on 26th Nov.
But the software only showed me the Restore points for the past 5 days.
Be advised however that It has a check box, which when selected shows us the restore points later than 5 days...
The system had automatically created a System Restore point before installing the MagicISO software.
All that was remaining to be doen was, choose a system restore point before 20th Nov, in my case, I chose 19th.
Sure the restoration took about 20 min, or so....but when I restarted the PC, the MAGIC ISO ROM was gone.
I went on to the .uif file and deleted it as I would delete any other file.

Thank you for reading through all this. It was quite a headache for me as well, but I wanted to be as thorough as possible. After all, nobody wants a silly 'little' file to occupy 19GB of disc space for nothing, eh?
Reply With Quote
  #8  
Old 28-11-2008
gordievsky
 
Posts: n/a
Re: Cannot delete file

Well, this probably won't help too much. But I eventually resolved this
problem. The file I was trying to delete was in use by a "virtual
drive" which basically read data files as discs.

After I realized this, and "unmounted" the file, I could delete it.
Reply With Quote
  #9  
Old 28-11-2008
Zyonix
 
Posts: n/a
Dismounting usually works. :)

If you have an error like this and it's REALLY REALLY bothering you.
Don't take too much time. Get HiJack This and use the "Delete File on
Shutdown" tool. :)

As soon as the resources stop using the file, it gets instantly
deleted. Perfecto.

well, i tried this method, but it didn't work with my mounted file.
Reply With Quote
  #10  
Old 13-06-2009
Member
 
Join Date: May 2008
Posts: 2
Re: Cannot delete file

Hi,

When I am facing this kind of issue I run Process Explorer by SysInternals (now Microsoft). http://technet.microsoft.com/fr-fr/s.../bb896653.aspxYou Open It, You click 'Find (Handle or DLL)'
You type a part of the file name which is locked and run the search.
You get the name of the faulty process. Now you can understand and close the process which locks the file.
Reply With Quote
  #11  
Old 24-11-2009
Member
 
Join Date: Nov 2009
Posts: 1
Re: Cannot delete file

I had the same problem.
I read some of the answers here and they gave me the clue I needed.

I have MagicISO disk installed, a virtual drive.

When I checked it showed the file I wanted to delete as being "mounted".
I clicked on "umount" and I could then delete the uif file.

Sorry if the techie terms aren't all correct.
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Help
Tags: , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Cannot delete file"
Thread Thread Starter Forum Replies Last Post
Error Deleting File or Folder. Cannot delete (FILE): Access denied rasena MediaCenter 3 21-03-2012 10:10 AM
cannot delete file -- cannot read from source file or disk Amitgujaran Windows XP Support 3 11-11-2010 09:55 PM
Can't delete 0 byte file, with no file type Adele2 Windows XP Support 8 15-12-2009 12:33 PM
Cannot delete file with no name disk file Shanbaag Windows Software 4 17-08-2009 03:14 AM
XP: Cannot delete file: Cannot read from the source file or disk. iexplorer0726 Operating Systems 0 10-09-2007 06:07 AM


All times are GMT +5.5. The time now is 10:55 AM.