Results 1 to 5 of 5

Thread: MSCOMCTL.OCX Runtime Problem

  1. #1
    MOBIUS Guest

    MSCOMCTL.OCX Runtime Problem

    I am having a problem with this... in certain programs I am trying to open I
    get

    "Run-time error '339':

    Component 'MSCOMCTL.OCX' or one of its dependencies not correctly
    registered: a file is missing or invalid.

    I tried registering the file through CMD prompt but that didn't work. The
    File still doesn't register or one of it's files isn't registering even
    though windows says it did. I use Vista Ultimate 32bit. Please, help me get
    this fixed. Thanks.
    --
    Help please!

  2. #2
    Andrew McLaren Guest

    Re: MSCOMCTL.OCX Runtime Problem

    Hi Mobius

    This is just a guess: but when you ran regsvr32 last time, perhaps you did
    not have the full Administrative token. Hence the registration failed, due
    to permissions problems.

    To avoid this problem, open a command prompt "as administrator". In Start
    menu, right-click the Command Prompt icon and choose "Run as Administrator"
    from the context menu. Enter any admin credentials you are prompted for.
    Then go to the Command Prompt window and run regsvr32 there. By running "as
    administrator" you get a higher level of privilege than if you are logged on
    as an administrator and merely open a normal command prompt (yes, even if
    you are the Administrator).

    You might also verify that you have only one copy of MSCOMCTL.OCX on your
    system, and that it is in a directory on the PATH, such as System32.

  3. #3
    Steve Easton Guest

    Re: MSCOMCTL.OCX Runtime Problem

    What version of Vista?
    If business or above, make sure the ActiveX installer service is
    installed and activated.
    It is not automatically installed during the install.

  4. #4
    MOBIUS Guest

    Re: MSCOMCTL.OCX Runtime Problem

    Well I did what you said... still my program won't load. Same error...

  5. #5
    Andrew McLaren Guest

    Re: MSCOMCTL.OCX Runtime Problem

    Okaaaaay ... well uh, give us a few more clues to work with. For example:

    - is there only one copy of MSCOMCTL.OCX on your system?

    - what directory is it located in?

    - what is the time and date stamp of the OCX file, and what is its version
    number? (right-click, Properties, Details)

    - was it installed by the application? If so, what is the app you're trying
    to run? Does the vendor of the app support their software on Vista?

    - or did you install the VB Runtime files separately (ie, not as part of the
    app)?

    If you have an obsolete version of the VB Common Controls, you can download
    and install the latest version from here:

    http://www.microsoft.com/downloads/d...displaylang=en

    Remember to "run as Administrator" if/when you install this package.

    If you want to get forensic, download and run the Dependency Walker,

    http://www.dependencywalker.com/

    and use it to examine MSCOMCTL.OCX on your system. Does it show any missing
    dependencies?

Similar Threads

  1. Windows 7 and MSCOMCTL.OCX problem
    By Feng in forum Operating Systems
    Replies: 5
    Last Post: 14-08-2010, 06:02 AM
  2. MSCOMCTL.OCX not compatible?
    By Gokul20 in forum Operating Systems
    Replies: 4
    Last Post: 31-03-2010, 03:58 PM
  3. What is mscomctl.ocx?
    By NSA_CIA in forum Operating Systems
    Replies: 3
    Last Post: 09-11-2009, 01:19 PM
  4. Replies: 3
    Last Post: 22-04-2009, 11:02 PM
  5. Microsoft Visual C++ Runtime Library Symantec Runtime error
    By Ranchero in forum Windows XP Support
    Replies: 8
    Last Post: 27-09-2008, 09:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •