Results 1 to 5 of 5

Thread: call to DllRegisterServer failed 0x8002801c

  1. #1
    Join Date
    Sep 2007
    Posts
    1

    call to DllRegisterServer failed 0x8002801c

    The module xxx.dll was loaded but the call to DllRegisterServer failed with an error message stating:

    "error code 0x8002801c."

    I have tried several methods that have been "The So-Called Fix" and nothing has worked as of yet i keep getting the same error message

  2. #2
    Join Date
    Sep 2004
    Posts
    42
    Just follow these few simple steps and see if it works for you.

    Click Start Menu, type CMD in the search field. When cmd.exe appears, right click the same and select "Run as Administrator." Now try executing those commands. This has worked for me many times, including Windows 7 as well. The only catch was I had to add the C:\ after the regsvr32

    ex: regsvr32 C:\windows\system32\COMCTL32.OCX

  3. #3
    Join Date
    Apr 2010
    Location
    Several places; basically in Venezuela
    Posts
    1
    no i hadn't heard that one but i tried it immediately and what do you know i finally found a fix that worked thanks so much

    You are a genius. I searched for hours for a solution until I stumbled upon your post. It worked immediately.

    top job for that reply, took me 20 minutes of digging around out there but you have saved me loads of effort

    The module xxx.dll was loaded but the call to DllRegisterServer failed with
    error code 0x8002801c

    Boy, thanks a lot. I did not even have to post anything. Your reply to another member helped enormously.

  4. #4
    Join Date
    May 2010
    Posts
    1
    This has not worked for me running windows 7.
    I am running the command as administrator in the cmd.exe

    The error returned is the module C:\Windows\system32\crxf_pdf.dll was loaded but the entry-point DllRegisterServer was not found.

    Make sure that C:\Windows\system32\crxf_pdf.dll is a valid DLL or OCX file and try again.

    What can I do to get this dll registered?

  5. #5
    Join Date
    Jul 2011
    Posts
    1

    Re: call to DllRegisterServer failed 0x8002801c

    Thanks Cal bear '66! Run as Administrator did the trick!

Similar Threads

  1. Replies: 3
    Last Post: 03-01-2014, 09:37 AM
  2. Replies: 4
    Last Post: 02-04-2011, 01:22 AM
  3. Call to DllRegisterServer failed, Error code : 0x80004005
    By Dalapathi in forum Technology & Internet
    Replies: 3
    Last Post: 13-02-2011, 07:00 PM
  4. Replies: 7
    Last Post: 04-08-2010, 09:29 PM
  5. Replies: 2
    Last Post: 14-09-2005, 03:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •