Results 1 to 10 of 10

Thread: spooler subsystem app stopped working and was closed

  1. #1
    Mentos Guest

    spooler subsystem app stopped working and was closed

    hi, i get message " spooler subsystem app stopped working and was closed"

    i go to services.msc and start "print spooler". i see the printers again but
    2 mins later, i get the same error message and i need to restart

    it was all working fine until after this morning, when i installed roxio
    easy media creator (for burning discs).

  2. #2
    Cari \(MS-MVP\) Guest

    Re: spooler subsystem app stopped working and was closed

    Do you see the same pattern if you uninstall Roxio? I have Roxio v9 on my
    Vista PC and do not see what you describe.

  3. #3
    Mentos Guest

    Re: spooler subsystem app stopped working and was closed

    hi, i have uninstalled everything related to roxio but i still get the same
    problem!!

  4. #4
    Cari \(MS-MVP\) Guest

    Re: spooler subsystem app stopped working and was closed

    Use System Restore to go back to before you installed Roxio... or a day or
    so before. If you can remember when you last printed successfully, that
    would be the one to try first.

  5. #5
    Mentos Guest

    Re: spooler subsystem app stopped working and was closed

    thanks for the suggestion, i have tried several restores before installing
    roxio - not just on that day but a day, 3 days, 5 days before. when vista
    restarts, each time, i get a

    "system did not complete successfully. your computer system's files and
    settings were not changed

    details: an unspecified error occurred during system restore"

    then the same problem persists. bummer

  6. #6
    Dan [MSFT] Guest
    The most common reason for the spooler to go down is when a bad driver gets
    installed. Because of the way printer connections work, you could have
    gotten a new driver & not really noticed it.

    Temporarily deleting all of your printers & removing their drivers from the
    system should allow the spooler to become stable again. Assuming that stops
    the spooler crashing problems, add them back one at a time until the problem
    comes back. The printer that causes it to come back is either in need of an
    updated Vista driver, or simply won't work with Vista until such time as the
    hardware vendor produces an updated driver.

    It can be difficult to remove drivers when the spooler won't stay up very
    long. If you have problems with that, see:
    http://support.microsoft.com/default...b;en-us;324757

  7. #7
    Join Date
    Aug 2009
    Posts
    2
    Hey there...I have the same problem. Been trying to troubleshoot and resolve it for 5 days now. I've been all over google and microcraps web site looking for fixes but none, absolutely none have worked. I even scrubbed my hard drive and reinstalled Vista 3 times and still get the same Spooler Subsystem App failure message each and every time. The problem, I believe, stems from a recent windows update which is causing a conflict. It wouldn't be the first time this has happened, it's Vista, after all. All I know is I need a printer and my next pc is going to be an Apple. I am out of options and need to restart my life after being holed in this room for the past 5 days pulling my hair trying to find a resolution.

    I have 2 printers and neither will print. I don't think make or model of the printer matters much. I have an HP Laserjet 1020 and an HP Officejet 4315v All-in-one.

    Idid contact HP but was politely told that I am out of warranty so no support.

    All of my Vista updates dowloaded and installed on the same I reinstalled Vista OS. I don't system restore is an option.

    The bottom line is that I have updated everything, including drivers from HP and Dell (inspiron 1501), tried every fix on google, scrubbed the hard drive, reinstalled Vista and nothing ever changes. The print closes upon start up. I can restart the print spoiler only to see it close again in less than a minute or so. I still believe this is a Vista issue and that there many others with this same problem.

    As for the cost of an Apple, if I had a probl like this with an Apple, I could just take the unit in to my local Apple store and have a tech take a look at it. You get what you pay for.

    Here are the details of the error message I receive when the Spooler SubSystem App shuts down:

    Problem signature:
    Problem Event Name: APPCRASH
    Application Name: spoolsv.exe
    Application Version: 6.0.6000.16386
    Application Timestamp: 4549b734
    Fault Module Name: ZSR.dll
    Fault Module Version: 6.20.1625.0
    Fault Module Timestamp: 462fd713
    Exception Code: c0000005
    Exception Offset: 0001f979
    OS Version: 6.0.6000.2.0.0.768.3
    Locale ID: 1033
    Additional Information 1: 8d13
    Additional Information 2: cdca9b1d21d12b77d84f02df48e34311
    Additional Information 3: 8d13
    Additional Information 4: cdca9b1d21d12b77d84f02df48e34311

    YAHOOOOOO! I finally found a fix that seems to be working. Here is a description and a link that might help others.

    Thanks! My problem was due to a corrupted spool queue. Here's how I fixed it:

    -Open up c:\windows\system32\spool\PRINTERS

    -Delete the contents of the directory (not the directory itself).

    -Retart the print spool service.

  8. #8
    Cari \(MS-MVP\) Guest

    Re: spooler subsystem app stopped working and was closed

    Use System Restore to go back to before you installed the Update.

    I hope you will appreciate the almost double the price you'll spend on that
    Apple, and make sure all your external hardware has drivers for Macs.

    BTW, if you provided details of your make and model of printer, we'd
    probably be able to assist further, but just telling us it's a printer
    leaves us in the dark. There are simply hundreds of makes and models out
    there, all with drivers NOT written by Microsoft. Did you think of
    contacting the printer manufacturer for assistance?

    Maybe this will help get you started.
    http://social.technet.microsoft.com/...6-542e1519ca3e

  9. #9
    Alan Morris [MSFT] Guest

    Re: spooler subsystem app stopped working and was closed

    Also check who releases the driver that was causing the spooler to fail.

    Fault Module Name: ZSR.dll

    I quickly checked and Zenographics releases this file which is a vendor HP
    uses to write some of the drivers for their printers. This is a known issue
    when I searched on the net. If this file causes memory corruption again,
    check if there is a fixed version available that does not perform
    improperly.

  10. #10
    Join Date
    Aug 2009
    Posts
    2

    Re: spooler subsystem app stopped working and was closed

    Thanks for the feedback Alan. I will do that.

Similar Threads

  1. Spooler SubSystem App Stopped Working And Was Closed
    By NGV BalaKrishna in forum Vista Help
    Replies: 5
    Last Post: 14-04-2015, 03:54 PM
  2. Replies: 3
    Last Post: 08-08-2009, 08:55 AM
  3. Spooler SubSystem App stopped working and has closed
    By haritable in forum Vista Help
    Replies: 1
    Last Post: 07-08-2008, 12:05 AM
  4. Replies: 2
    Last Post: 28-12-2007, 03:58 AM
  5. Replies: 5
    Last Post: 13-12-2007, 07:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •